Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gstreamer-plugins-bad-64bit-1.16.3-lp153.3.3.1 RPM for aarch64_ilp32

From OpenSuSE Leap 15.3 updates for aarch64_ilp32

Name: gstreamer-plugins-bad-64bit Distribution: openSUSE Leap 15.3
Version: 1.16.3 Vendor: openSUSE
Release: lp153.3.3.1 Build date: Tue Jun 29 11:26:49 2021
Group: Productivity/Multimedia/Other Build host: armbuild21
Size: 9384160 Source RPM: gstreamer-plugins-bad-1.16.3-lp153.3.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://gstreamer.freedesktop.org/
Summary: GStreamer Streaming-Media Framework Plug-Ins
GStreamer is a streaming media framework based on graphs of filters
that operate on media data. Applications using this library can do
anything media-related,from real-time sound processing to playing
videos. Its plug-in-based architecture means that new data types or
processing capabilities can be added simply by installing new plug-ins.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Mon Jun 07 2021 Jia Zhaocong <zcjia@suse.com>
  - Update to version 1.16.3 (bsc#1181255 CVE-2021-3185):
    - amcvideodec: fix sync meta copying not taking a reference
    - audiobuffersplit: Perform discont tracking on running time
    - audiobuffersplit: Specify in the template caps that only interleaved audio is supported
    - audiobuffersplit: Unset DISCONT flag if not discontinuous
    - autoconvert: Fix lock-less exchange or free condition
    - autoconvert: fix compiler warnings with g_atomic on recent GLib versions
    - avfvideosrc: element requests camera permissions even with capture-screen property is true
    - codecparsers: h264parser: guard against ref_pic_markings overflow
    - dtlsconnection: Avoid segmentation fault when no srtp capabilities are negotiated
    - dtls/connection: fix EOF handling with openssl 1.1.1e
    - fdkaacdec: add support for mpegversion=2
    - hls: Check nettle version to ensure AES128 support
    - ipcpipeline: Rework compiler checks
    - interlace: Increment phase_index before checking if we're at the end of the phase
    - lv2: Make it build with -fno-common
    - h264parser: Do not allocate too large size of memory for registered user data SEI
    - ladspa: fix unbounded integer properties
    - modplug: avoid division by zero
    - msdkdec: Fix GstMsdkContext leak
    - msdkenc: fix leaks on windows
    - musepackdec: Don't fail all queries if no sample rate is known yet
    - openslessink: Allow openslessink to handle 48kHz streams.
    - opencv: allow compilation against 4.2.x
    - proxysink: event_function needs to handle the event when it is disconnecetd from proxysrc
    - vulkan: Drop use of VK_RESULT_BEGIN_RANGE
    - wasapi: added missing lock release in case of error in gst_wasapi_xxx_reset
    - wasapi: Fix possible deadlock while downwards state change
    - waylandsink: Clear window when pipeline is stopped
    - webrtc: Support non-trickle ICE candidates in the SDP
    - webrtc: Unmap all non-binary buffers received via the datachannel
    - meson: build with neon 0.31
* Sat Feb 06 2021 Federico Mena Quintero <federico@suse.com>
  - Disable the kate/libtiger plugin.  Kate streams for karaoke are not
    used anymore, and the source tarball for libtiger is no longer
    available upstream. (jsc#SLE-13843)
* Wed Apr 08 2020 Michael Gorse <mgorse@suse.com>
  - Enable chromaprint plugin on SLE (jsc#SLE-11723).
* Thu Dec 12 2019 Antonio Larrosa <alarrosa@suse.com>
  - Add a BuildRequires for pkgconfig(pangocairo) since it's needed
    by the ttmlsubs and closedcaption extensions. This is not currently
    a problem in openSUSE because the dependency is pulled in by other
    packages which are not installed in SLE.
* Wed Dec 04 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.16.2:
    + wasapi:
    - Various fixes and a workaround for a specific driver bug
    - Move to CoInitializeEx for COM initialization
    - Fix runtime/build warnings
    + waylandsink: Commit the parent after creating subsurface
    + msdkdec: fix surface leak in msdkdec_handle_frame
    + tsmux: Fix copying of buffer region
    + tsdemux:
    - Handle continuity mismatch in more cases
    - Always issue a DTS even when it's equal to PTS
    + openexr: Fix build with OpenEXR 2.4 (and also OpenEXR 2.2 on
      Ubuntu 18.04)
    + ccextractor: Always forward all sticky events to the caption
      pad
    + pnmdec: Return early on ::finish() if we have no actual data to
      parse
    + ass: avoid infinite unref loop with bad data
    + fluidsynth: add sf3 to soundfont search path
  - Drop libtool and automake/conf BuildRequires and autoreconf calls
    + 0001-Require-OpenEXR-2.3.0-at-least-and-do-not-force-C-98.patch
    Fixed upstream.
* Thu Oct 10 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Fix compilation with OpenEXR 2.4.0
    + 0001-Require-OpenEXR-2.3.0-at-least-and-do-not-force-C-98.patch
    + Readd libtool and autoreconf call
  - Remove Leap 42.x support from spec file
* Tue Sep 24 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.16.1:
    + See main gstreamer package for changelog.
  - Drop upstream fixed patches:
    + fix-Werror=return-type.patch.
    + gst-bad-Fix-compilation-with-openh264-v2.0.patch.
    + gst-plugins-bad-do-not-retry-downloads-during-shutdown.patch.
  - Following the above, drop libtool BuildRequires and autoreconf
    call, no longer needed.
* Wed Sep 18 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Use openssl for HLS crypto. openssl is required by DTLS, and hls
    can use any of openssl, gcrypt or gnutls/nettle (since 1.5.1).
    Drop explicit pkgconfig(nettle) BuildRequires and pass
    hls-crypto=openssl to configure/meson.
* Mon Aug 26 2019 mvetter@suse.com
  - bsc#1144244: Remove dependency on jasper
    Jasper support was removed in 2013. OpenJPEG is used for JPEG2000.
* Mon Aug 19 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Drop pkgconfig(gtk+-3.0) and pkgconfig(gtk+-x11-3.0)
    BuildRequires and stop passing --with-gtk=3.0 to configure, only
    used for building examples, and we are already passing
    - -disable-examples to configure.
  - Drop gst-bad-revert-automake-autoconf-versions.patch: No longer
    needed for any supported version of openSUSE. Note, leaving
    libtool BuildRequires in place as fix-Werror=return-type.patch
    needs it still.
* Mon Aug 12 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Move openh264 plugin to build_orig and build it there
    unconditionally.
* Mon Jul 22 2019 Martin Liška <mliska@suse.cz>
  - Update fix-Werror=return-type.patch to upstream version.
* Wed Jul 17 2019 Rich Coe <rcoe@wi.rr.com>
  - Add gst-plugins-bad-do-not-retry-downloads-during-shutdown.patch for hang (bwo#197558)
* Mon Jul 15 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Drop pkgconfig(vdpau) BuildRequires and libgstvdpau sub-package.
    Obsolete it from the main gstreamer-plugins-bad package. Upstream
    have now dropped the package from master, and currently it only
    supports mpeg2 and poorly even that one. It will not make a
    comeback, so obsolete all versions.
* Mon Jul 15 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Add gst-bad-Fix-compilation-with-openh264-v2.0.patch: Fix build
    with openh264 version 2.0 and newer.
* Mon Jul 15 2019 Martin Liška <mliska@suse.cz>
  - Fix -Werror=return-type error in configure script
    (fix-Werror=return-type.patch).
* Sat Jul 06 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Add conditional pkgconfig(libmfx) and pkgconfig(libva-drm)
    BuildRequires: Build intel-mediasdk support.
* Mon Jul 01 2019 mgorse@suse.com
  - Re-enable musepack: depend on musepack-devel, rather than
    libmpcdec-devel; the latter is no longer sufficient as of 1.16.0.
    Add musepack plugin back into files.
* Thu Jun 27 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - Add libgstsctp-1_0-0 to baselibs.conf:
    gstreamer-plugins-bad-32bit requires it.
* Mon Jun 17 2019 mgorse@suse.com
  - Update to version 1.16.0:
    + Highlights
    - GStreamer WebRTC stack gained support for data channels for
      peer-to-peer communication based on SCTP, BUNDLE support, as
      well as support for multiple TURN servers.
    - AV1 video codec support for Matroska and QuickTime/MP4
      containers and more configuration options and supported
      input formats for the AOMedia AV1 encoder
    - Support for Closed Captions and other Ancillary Data in video
    - Support for planar (non-interleaved) raw audio
    - GstVideoAggregator, compositor and OpenGL mixer elements are
      now in -base
    - New alternate fields interlace mode where each buffer carries
      a single field
    - WebM and Matroska ContentEncryption support in the Matroska
      demuxer
    - new WebKit WPE-based web browser source element
    - Video4Linux: HEVC encoding and decoding, JPEG encoding, and
      improved dmabuf import/export
    - Hardware-accelerated Nvidia video decoder gained support for
      VP8/VP9 decoding, whilst the encoder gained support for
      H.265/HEVC encoding.
    - Many improvements to the Intel Media SDK based
      hardware-accelerated video decoder and encoder plugin (msdk):
      dmabuf import/export for zero-copy integration with other
      components; VP9 decoding; 10-bit HEVC encoding; video
      post-processing (vpp) support including deinterlacing; and
      the video decoder now handles dynamic resolution changes.
    - The ASS/SSA subtitle overlay renderer can now handle multiple
      subtitles that overlap in time and will show them on screen
      simultaneously
    - The Meson build is now feature-complete (*) and it is now the
      recommended build system on all platforms. The Autotools
      build is scheduled to be removed in the next cycle.
    - The GStreamer Rust bindings and Rust plugins module are now
      officially part of upstream GStreamer.
    - The GStreamer Editing Services gained a gesdemux element that
      allows directly playing back serialized edit list with
      playbin or (uri)decodebin
    - Many performance improvements
  - Add incomplete meson support. Currently disabled.
  - Drop gstreamer-plugins-bad-reproducible.patch: fixed upstream.
  - Disable musepack plugin and remove from files, since it
    requires a newer library than what we currently have.
  - Remove libgstcompositor.so and libgstopenglmixers.so: moved to
    - base.
  -Removed libgststereo.so from files: merged with audiofx in -good.
  - Remove libgstvcdsrc.so from files: removed upstream.
  - Add libgstclosedcaption.so to files.
  - Remove libgstbadvideo package: now in -base.
  - Package libgstcp.
* Fri May 31 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.14.5:
    + assrender: fix disappearing subtitles when seeking back in
      time.
    + decklinkvideosink: fix segfault when audiosink is closed before
      videosink.
    + decklinkvideosrc: respect pixel format property even if mode is
      set to auto.
    + d3dvideosink: Fix calculating buffer size of packed format;
      don’t leak thread object.
    + dtls: Don’t abort on non-fatal issues, make work with newer
      OpenSSL versions.
    + msdk: more robust error handling; fix intel sdk libdir path.
    + nvenc: Ensure drain all frames on finish; fix element reuse and
      clean up properly.
    + openh264dec: Fix handling of errors when doing EOS.
    + shmsrc: fixes a crash when is-live is true due a race
      condition.
    + shmsink: fix possible (racy) deadlock on shutdown.
    + siren: Fix invalid floating point operation.
    + tsdemux: Skew correction improvements: use upstream DTS if set.
    + wasapi:
    - Number of segments was always 2 (the absolute minimum) by
      accident.
    - Fix infinite loop when the device disappears.
  - Drop gst-bad-fdkaac2-fix.patch: Fixed upstream.
* Thu May 02 2019 olaf@aepfle.de
  - The license of fdk-aac is not GPL compatible, therefore this pkg
    can not possibly be built with fdk-aac by default
    To gain fdk-aac support, recompile it at home and keep it there
  - Restore code to handle faac/faad
* Thu Dec 13 2018 bjorn.lie@gmail.com
  - Add gst-bad-fdkaac2-fix.patch: fdkaac: Fixes for compatibility
    with libfdk-aac 2.0.0 (boo#1120299).
* Wed Oct 03 2018 bjorn.lie@gmail.com
  - Update to version 1.14.4:
    + Bugfix release, please see .changes in gstreamer main package.
* Wed Sep 26 2018 bjorn.lie@gmail.com
  - Update to version 1.14.3:
    + Bugfix release, please see .changes in gstreamer main package.
* Fri Aug 03 2018 bjorn.lie@gmail.com
  - Add pkgconfig(aom) BuildRequires: Build AOMedia Video 1 (AV1)
    support.
* Mon Jul 23 2018 bjorn.lie@gmail.com
  - Update to version 1.14.2:
    + Update docs.
    + find_codec_preferences: use received caps.
    + player: Avoid trying to join the player thread from itself.
    + decklink: Fix warning about HRESULT not being unsigned int.
    + pitch: Flush only if there are unprocessed samples.
    + pitch: preserve seek event seqnums.
    + pitch: fix latency reporting.
    + pitch: Fix single input buffer followed by EOS.
    + videoaggregator: Fix string leak.
    + videoaggregator: log an ERROR if we're going to return a flow
      error.
    + dvb: Fix typo in comment termination.
    + dvb: camconditionalaccess: fix wrong license headers.
    + webrtc: Fix memory leak.
    + webrtc: Clean up and fix transportsendbin.
    + webrtc: Move dtlssrtpenc state management.
    + webrtc/dtlstransport: Add more debug. Rename category.
    + webrtc: Clean up pad block allocs on dispose.
    + webrtc: Move the transportsendbin pad block removal.
    + webrtc: Fix wrong parent classes for DTLSTransport and
      ICETransport.
    + webrtc: Explicitly initialise mutex and condition.
    + webrtc: Don't deadlock on block pads on shutdown.
    + webrtcbin: copy sticky events on our ghostpads.
    + webrtcbin: rtpstorage takes a 64-bit integer for "size-time"
      property.
    + webrtcbin: implement support for FEC and RTX.
    + player: Fix duration-changed CRITICAL warning if duration did
      not actually change.
    + gst_webrtc_session_description_new: fix annotations.
    + tsdemux: Don't set invalid seqnum on segment event.
    + tsdemux: Don't query duration if program isn't active.
    + mpegtsdemux: Fix SEGMENT seqnum propagation.
    + codecparsers: mpeg2: don't mess the StartCode only packets.
    + wasapisink: fix a rounding error when calculating the buffer
      frame count.
    + wasapisink: fix missing unlock in case IAudioClient_Start
      fails.
    + wasapi: use FAILED to detect errors.
    + wasapi: Don't pass CoTaskMemFree to g_clear_pointer.
* Sat Jun 23 2018 bjorn.lie@gmail.com
  - Conditionalize pkgconfig(libopenmpt) and pkgconfig(lilv-0)
    BuildRequires: fix build for SLE 12 SP3.
* Fri Jun 22 2018 bjorn.lie@gmail.com
  - Conditionalize pkgconfig(libsrtp2) and pkgconfig(nice)
    BuildRequires: fix build for Leap 42.3.
* Fri Jun 08 2018 bjorn.lie@gmail.com
  - Add back faac-devel, there are some old apps explicitly depending
    on that plugin to to do aac encoding.
* Tue May 29 2018 bjorn.lie@gmail.com
  - Add pkgconfig(srt) BuildRequires: Build srt plugin.
* Mon May 28 2018 bjorn.lie@gmail.com
  - Drop faac-devel and faad2-devel BuildRequires: fdk-aac plugin
    fills this role for both of them.
  - No longer pass conditional --disable-dvdspu to configure, plugin
    files are all LGPL-2.1.
* Sun May 20 2018 bjorn.lie@gmail.com
  - Update to version 1.14.1:
    + GstPad: Fix race condition causing the same probe to be called
      multiple times
    + Fix occasional deadlocks on windows when outputting debug
      logging
    + Fix debug levels being applied in the wrong order
    + GIR annotation fixes for bindings
    + audiomixer, audioaggregator: fix some negotiation issues
    + gst-play-1.0: fix leaving stdin in non-blocking mode after exit
    + flvmux: wait for caps on all input pads before writing header
      even if source is live
    + flvmux: don't wake up the muxer unless there is data, fixes
      busy looping if there's no input data
    + flvmux: fix major leak of input buffers
    + rtspsrc, rtsp-server: revert to RTSP RFC handling of
      sendonly/recvonly attributes
    + rtpvrawpay: fix payloading with very large mtu sizes where
      everything fits into a single RTP packet
    + v4l2: Fix hard-coded enabled v4l2 probe on Linux/ARM
    + v4l2: Disable DMABuf for emulated formats when using libv4l2
    + v4l2: Always set colorimetry in S_FMT
    + asfdemux: Set stream-format field for H264 streams and handle
      H.264 in bytestream format
    + x265enc: Fix tagging of keyframes on output buffers
    + ladspa: Fix critical during plugin load on Windows
    + decklink: Fix COM initialisation on Windows
    + h264parse: fix re-use across pipeline stop/restart
    + mpegtsmux: fix force-keyframe event handling and PCR/PMT
      changes that would confuse some players with generated HLS
      streams
    + adaptivedemux: Support period change in live playlist
    + rfbsrc: Fix support for applevncserver and support NULL pool in
      decide_allocation
    + jpegparse: Fix APP1 marker segment parsing
    + h265parse: Make caps writable before modifying them, fixes
      criticals
    + fakevideosink: request an extra buffer if enable-last-sample is
      enabled
    + wasapisrc: Don't provide a clock based on WASAPI's clock
    + wasapi: Only use audioclient3 when low-latency, as it might
      otherwise glitch with slow CPUs or VMs
    + wasapi: Don't derive device period from latency time, should
      make it more robust against glitches
    + audiolatency: Fix wave detection in buffers and avoid bogus pts
      values while starting
    + msdk: fix plugin load on implementations with only HW support
    + msdk: dec: set framerate to the driver only if provided, not in
      0/1 case
    + msdk: Don't set extended coding options for JPEG encode
    + rtponviftimestamp: fix state change function init/reset causing
      races/crashes on shutdown
    + decklink: fix initialization failure in windows binary
    + ladspa: Fix critical warnings during plugin load on Windows and
      fix dependencies in meson build
    + gl: fix cross-compilation error with viv-fb
    + qmlglsink: make work with eglfs_kms
    + rtspclientsink: Don't deadlock in preroll on early close
    + rtspclientsink: Fix client ports for the RTCP backchannel
    + rtsp-server: Fix session timeout when streaming data to client
      over TCP
    + vaapiencode: h264: find best profile in those available, fixing
      negotiation errors
    + vaapi: remove custom GstGL context handling, use GstGL instead.
      Fixes GL Context sharing with WebkitGtk on wayland
    + gst-editing-services: various fixes
    + gst-python: bump pygobject req to 3.8;
      fix GstPad.set_query_function(); dist autogen.sh and
      configure.ac in tarball
    + g-i: pick up GstVideo-1.0.gir from local build directory in
      GstGL build
    + g-i: update constant values for bindings
    + avoid duplicate symbols in plugins across modules in static
      builds
    + ... and many, many more!
* Mon Apr 16 2018 bjorn.lie@gmail.com
  - Update to version 1.14.0:
    + Highlights:
    - WebRTC support: real-time audio/video streaming to and from
      web browsers;
    - Experimental support for the next-gen royalty-free AV1 video
      codec
    - Video4Linux: encoding support, stable element names and
      faster device probing;
    - Support for the Secure Reliable Transport (SRT) video
      streaming protocol;
    - RTP Forward Error Correction (FEC) support (ULPFEC);
    - RTSP 2.0 support in rtspsrc and gst-rtsp-server;
    - ONVIF audio backchannel support in gst-rtsp-server and
      rtspsrc;
    - playbin3 gapless playback and pre-buffering support;
    - Tee, our stream splitter/duplication element, now does
      allocation query aggregation which is important for efficient
      data handling and zero-copy;
    - QuickTime muxer has a new prefill recording mode that allows
      file import in Adobe Premiere and FinalCut Pro while the file
      is still being written;
    - rtpjitterbuffer fast-start mode and timestamp offset
      adjustment smoothing;
    - souphttpsrc connection sharing, which allows for connection
      reuse, cookie sharing, etc;
    - nvdec: new plugin for hardware-accelerated video decoding
      using the NVIDIA NVDEC API;
    - Adaptive DASH trick play support;
    - ipcpipeline: new plugin that allows splitting a pipeline
      across multiple processes;
    - Major gobject-introspection annotation improvements for large
      parts of the library API;
    - GStreamer C# bindings have been revived and seen many updates
      and fixes;
    - The externally maintained GStreamer Rust bindings had many
      usability improvements and cover most of the API now.
      Coinciding with the 1.14 release, a new release with the 1.14
      API additions is happening.
    + Updated translations.
  - Drop libgstgl-1_0-0 typelib-1_0-GstGL-1_0,
    libgstbadallocators-1_0-0 libgstbadbase-1_0-0 and
    typelib-1_0-GstBadAllocators-1_0 sub-packages, moved to
    gst-plugins-base package. Also drop libgstgl-1_0-0 and
    libgstbadbase-1_0-0 from baselibs.conf and corresponding Requires
    and post(un) handling of various dropped sub-packages.
  - Add new sub-packages libgstisoff-1_0-0, libgstwebrtc-1_0-0, and
    handle them in post(un), also add typelib-1_0-GstWebRTC-1_0 and
    add respective Requires in devel sub-package. Finaly add
    libgstisoff-1_0-0 and libgstwebrtc-1_0-0 to baselibs.conf.
  - Add pkgconfig(nice) BuildRequires: New dependency, build WebRTC
    support.
  - Add pkgconfig(lcms2) BuildRequires: Build colormanagement
    support.
  - Add pkgconfig(libopenmpt) BuildRequires: Build openmpt support.
  - Replace pkgconfig(libsrtp) with pkgconfig(libsrtp2)
    BuildRequires.
* Thu Mar 29 2018 bjorn.lie@gmail.com
  - Update to version 1.12.5:
    + Bugs fixed: bgo#794069, bgo#794353, bgo#794620, bgo#794537,
      bgo#793629, bgo#789476, bgo#789476, bgo#791910, bgo#791813,
      bgo#791772, bgo#791330, bgo#791982.
  - Drop gst-bad-vtdec-destroy-create-fix.patch and
    gst-bad-player-transfer-ownership.patch: Fixed upstream.
* Fri Mar 23 2018 fcrozat@suse.com
  - Move BuildRequires pkgconfig(dvdnav/dvdread) to BUILD_ORIG
    section. It is only needed when building BUILD_ORIG package,
    which is not the case for official builds for openSUSE Leap,
    Tumbleweed or SLE.
* Fri Mar 02 2018 bjorn.lie@gmail.com
  - Add gst-bad-revert-automake-autoconf-versions.patch: Revert the
    autoconf and automake version bump upstream did without
    consideration about us, allow to build with the automake we have
    Leap 42.3 and SLE12.
  - Following the above patch, drop the explicit automake
    BuildRequires, as libtool BuildRequires brings it in, and we can
    now build with the old version we have in Leap/SLE.
* Wed Feb 28 2018 bjorn.lie@gmail.com
  - Split out fluidsynth plugin in new sub-package
    gstreamer-plugins-bad-fluidsynth.
  - Following the above, add gstreamer-plugins-bad-fluidsynth and
    already built sub-package gstreamer-plugins-bad-chromaprint to
    baselibs.conf, build 32-bits support for these too.
  - Add conditional gstreamer-plugins-bad-fluidsynth and
    gstreamer-plugins-bad-chromaprint Requires: to -devel
    sub-package.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Wed Feb 28 2018 bwiedemann@suse.com
  - Add gstreamer-plugins-bad-reproducible.patch to avoid variations
    in gtk-doc output (boo#1048207).
  - Following the above, add automake and libtool BuildRequires and
    pass autoreconf, as the above patch touches the buildsystem.
* Thu Feb 22 2018 bjorn.lie@gmail.com
  - Move pkgconfig(mjpegtools) BuildRequires and resulting plugins to
    normal build, mjpegtools with all needed features are now
    available in openSUSE.
  - No longer pass --disable-mpegpsmux and --disable-mpegtsmux to
    configure, and move the resulting plugins to normal build. This
    was originally done due to a possible license issue, however on
    closer inspection, the plugins in question clearly states that
    one can use any of the four licenses listed, so we elect to use
    LGPL-2.1+.
  - Remove conditional for libgstwayland-1_0-0 subpackage, need due
    to it beeing in baselibs.conf, and lint bots declines this now.
* Fri Dec 29 2017 zaitor@opensuse.org
  - Add gst-bad-player-transfer-ownership.patch: player: transfer
    ownership of info properties (bgo#791982).
* Sat Dec 23 2017 zaitor@opensuse.org
  - Add gst-bad-vtdec-destroy-create-fix.patch: vtdec: destroy and
    create the GL context on start()/stop(). Removes a reference
    count loop.
  - Add python3-xml BuildRequires and switch to using plain make
    instead of make_build macro, and add conditional for
    pkgconfig(graphene-1.0), pkgconfig(wayland-client),
    pkgconfig(wayland-cursor), pkgconfig(wayland-egl),
    pkgconfig(wayland-protocols) and pkgconfig(wayland-scanner)
    BuildRequires and the .so and sub-package produced, fix build for
    old versions of openSUSE.
* Mon Dec 11 2017 zaitor@opensuse.org
  - Update to version 1.12.4:
    + openjpeg: Support building with openjpeg 2.3 (bgo#788703).
    + Bugs fixed: bgo#784593, bgo#787293, bgo#787942, bgo#789999,
      bgo#790042, bgo#790812, bgo#791258.
  - Drop gstpb-support-openjpeg-2.3.patch: Fixed upstream. Following
    this; drop autoconf, automake and libtool BuildRequires, and no
    longer pass autoreconf, no needed anymore.
* Fri Dec 08 2017 dimstar@opensuse.org
  - Move pkgconfig(libmodplug) BuildRequires, and thus libmodplug
    module, to build-orig. This move is not legally motivated, but
    rather build time optimization as it helps us eliminate a build
    cycle in openSUSE.
* Wed Nov 29 2017 dimstar@opensuse.org
  - Switch to python3:
    + Replace python-base BuildRequires with python3-base.
    + Export PYTHON=/usr/bin/python3 before calling configure.
* Mon Nov 27 2017 zaitor@opensuse.org
  - Add pkgconfig(libde265) BuildRequires in orig-addon subpackage,
    build h.265 (HVEC) decode support.
* Wed Nov 08 2017 dimstar@opensuse.org
  - Disable %glib2_gsettings_schema_post/postun scriptlets on
    suse_version >= 1330: this functionality is now covered by file
    triggers and the macros expand to %nil.
* Wed Nov 08 2017 kill_it@mail.ru
  - Enable gobject introspection bindings:
    + Add gobject-introspection-devel BuildRequires: allow the build
      system to find the needed infrastructure.
    + Pass --enable-introspection to configure: enable the
      introspection support.
    + Split out new typelib- packages:
    - typelib-1_0-GstBadAllocators-1_0
    - typelib-1_0-GstGL-1_0
    - typelib-1_0-GstInsertBin-1_0
    - typelib-1_0-GstMpegts-1_0
    - typelib-1_0-GstPlayer-1_0
* Mon Nov 06 2017 zaitor@opensuse.org
  - Move pkgconfig(mjpegtools) BuildRequires to orig-addon: mplex
    without mpeg2enc support is pointless, so keep those two in the
    same build conditional.
* Fri Oct 27 2017 idonmez@suse.com
  - Add gstpb-support-openjpeg-2.3.patch: fix build with openjpeg 2.3
    (bgo#788703).
  - Add autoconf, automake and libtool BuildRequires and call
    autoreconf, since above patch touches the build system.
* Thu Sep 28 2017 dimstar@opensuse.org
  - Split out chromaprint plugin into
    gstreamer-plugins-bad-chromaprint: the chromaprint plugin links
    against ffmpeg (indirectly) which in turn can cause cycles in
    various other builds, like webkit2).
* Mon Sep 18 2017 zaitor@opensuse.org
  - Update to version 1.12.3:
    + Bugs fixed: bgo#767462, bgo#782379, bgo#784887, bgo#785119,
      bgo#785941, bgo#785957, bgo#785987, bgo#786036, bgo#786201,
      bgo#786250, bgo#787234, bgo#787309, bgo#787442, bgo#787727.
  - Replace pkgconfig(libopenjpeg1) with pkgconfig(libopenjp2)
    BuildRequires: Build against the new branch of libopenjpeg.
* Tue Sep 05 2017 fcrozat@suse.com
  - Fix file list on SLE, libgstteletext.so is only built on
    openSUSE.
* Fri Aug 25 2017 zaitor@opensuse.org
  - Drop conditional valgrind-devel BuildRequires, this type of
    debugging is probably not done by users of binary packages.
  - Simplify spec, drop obsolete conditionals for openSUSE, keep only
    conditionals for new versions of SLE (and BUILD_ORIG).
  - Clean spec, modernize where appropriate, update macros.
  - Add explicit pkgconfig(glib-2.0), pkgconfig(gstreamer-1.0),
    pkgconfig(gmodule-export-2.0) and
    pkgconfig(gstreamer-plugins-base-1.0) BuildRequires: align with
    what configure looks for.
  - Add missing Requires to devel sub-package:
    + libgstbadallocators-1_0-0.
    + libgstbadaudio-1_0-0.
    + libgstwayland-1_0-0.
* Fri Jul 28 2017 zaitor@opensuse.org
  - Add Mesa-libGLESv3-devel, pkgconfig(egl), pkgconfig(gl) and
    pkgconfig(glesv1_cm) BuildRequires: Add missing dependencies to
    build full EGL/GL/GLES support.
* Fri Jul 28 2017 zaitor@opensuse.org
  - Add pkgconfig(libsrtp) BuildRequires: Build srtp support.
* Fri Jul 14 2017 zaitor@opensuse.org
  - Update to version 1.12.2:
    + Bugs fixed: bgo#764025, bgo#773159, bgo#782774, bgo#783028,
      bgo#783075, bgo#783244, bgo#784027, bgo#784059, bgo#784210,
      bgo#784439, bgo#784510, bgo#784755.
* Tue Jun 20 2017 zaitor@opensuse.org
  - Update to version 1.12.1:
    + Bugs fixed: bgo#783028, bgo#773681, bgo#776609, bgo#779202,
      bgo#781249, bgo#781561, bgo#782221, bgo#782352, bgo#782376,
      bgo#782693, bgo#782697, bgo#782736, bgo#782771, bgo#782801,
      bgo#782921, bgo#783066, bgo#783075, bgo#783255, bgo#783256,
      bgo#783401, bgo#783626, bgo#781204.
* Mon Jun 12 2017 zaitor@opensuse.org
  - Pass --disable-mpegpsmux, --disable-mpegtsmux and
    - -disable-resindvd to configure when building for openSUSE on the
    OBS until we can get the licensing sorted upstream. Move the
    plugins to the orig-addon package.
* Sat May 27 2017 zaitor@opensuse.org
  - Add missing libgstplayer-1_0-0 Requires to
    gstreamer-plugins-bad-devel sub package.
* Mon May 08 2017 zaitor@opensuse.org
  - Update to version 1.12.0:
    + Bugs fixed: bgo#773681, bgo#764947, bgo#780976, bgo#782046,
      bgo#782119, bgo#782078.
  - Changes from version 1.11.91:
    + Bugs fixed: bgo#729371, bgo#764011, bgo#778237, bgo#780190,
      bgo#780397, bgo#780402, bgo#780494, bgo#780569, bgo#780570,
      bgo#780897, bgo#781017, bgo#781018, bgo#781019, bgo#781022,
      bgo#781023, bgo#781024, bgo#781027, bgo#781037, bgo#781043,
      bgo#781156, bgo#781170, bgo#781179, bgo#781188, bgo#781233,
      bgo#781267, bgo#781320, bgo#781539, bgo#781725.
  - Changes from version 1.11.90:
    + Bugs fixed: bgo#736213, bgo#755782, bgo#764726, bgo#772811,
      bgo#774544, bgo#775487, bgo#776436, bgo#776997, bgo#776999,
      bgo#777847, bgo#778073, bgo#778333, bgo#778731, bgo#778825,
      bgo#779011, bgo#779067, bgo#779309, bgo#779333, bgo#779447,
      bgo#779453, bgo#779790, bgo#779831, bgo#779856, bgo#779869,
      bgo#780064, bgo#780108, bgo#780179, bgo#780180, bgo#780330,
      bgo#780367.
  - Stop passing --disable-fatal-warnings to configure, not needed on
    stable branch.
  - Package new sub package libgstbadallocators-1_0-0.
* Fri Feb 24 2017 zaitor@opensuse.org
  - Update to version 1.11.2:
    + Bugs fixed: bgo#764947, bgo#758257, bgo#773709, bgo#775665,
      bgo#776360, bgo#776490, bgo#777181, bgo#777206, bgo#777376,
      bgo#777377, bgo#777394, bgo#777652, bgo#777682, bgo#777741,
      bgo#777760, bgo#778028, bgo#778076, bgo#778142, bgo#778703,
      bgo#779064, bgo#779070, bgo#779103, bgo#779154.
* Thu Feb 23 2017 zaitor@opensuse.org
  - Update to version 1.11.1:
    + Bugs fixed: bgo#696852, bgo#711155, bgo#746018, bgo#751324,
      bgo#753003, bgo#755036, bgo#758232, bgo#760172, bgo#771992,
      bgo#772357, bgo#773473, bgo#773521, bgo#773570, bgo#773932,
      bgo#773936, bgo#774035, bgo#774112, bgo#774132, bgo#774177,
      bgo#774178, bgo#774196, bgo#774223, bgo#774357, bgo#774400,
      bgo#774463, bgo#774485, bgo#774493, bgo#774518, bgo#774530,
      bgo#774576, bgo#774629, bgo#774637, bgo#774689, bgo#774850,
      bgo#774886, bgo#775171, bgo#775248, bgo#775293, bgo#775306,
      bgo#775377, bgo#775378, bgo#775379, bgo#775409, bgo#775746,
      bgo#775791, bgo#775793, bgo#775967, bgo#776047, bgo#776076,
      bgo#776141, bgo#776317, bgo#776352, bgo#776399, bgo#776431,
      bgo#776722, bgo#776727, bgo#776787, bgo#776790, bgo#776900,
      bgo#777048, bgo#777078, bgo#777097, bgo#777121, bgo#773927,
      bgo#770990, bgo#774587, bgo#774793, bgo#775726, bgo#775288,
      bgo#772822, bgo#774527.
  - Gstreamer-plugins-bad now allows for disabling of internal
    dependency free plugins, hence we now pass conditional
    - -disable-dvdspu and --disable-siren to configure, as those are
    the last internal plugins we disable.
  - Following the above drop pre_checkin.sh,
    gstreamer-plugins-bad-patch-source.sh and
    gst-plugins-bad-x.xx.x-patched.tar.xz, we no longer need to
    generate a patched tarball.
  - Drop gstreamer-revert-bogus-automake-version.patch, gnome-common
    BuildRequires and autogen.sh call, no longer needed since we are
    not using the patched tarball.
  - Pass --disable-fatal-warnings to configure, and add fixme, needed
    now with unstable tarball.
  - Tweak fdupes macro usage, less rpmlint warnings.
  - Add missing Requires in devel subpackage.
  - Pass --disable-festival to configure, unmaintained and slated for
    removal upstream, currently causes rpmlint warnings (bgo#774508).
  - Add define ENABLE_OPENH264 and and conditional
    pkgconfig(openh264) BuildRequires, currently set to disabled (0).
    Build openh264 support. Using define so we can quickly enable it,
    should we be able to get openh264 into the distro.
  - Replace gstreamer-devel and gstreamer-plugins-base-devel with
    pkgconfig(gstreamer-video-1.0), pkgconfig(gstreamer-audio-1.0)
    and pkgconfig(gstreamer-pbutils-1.0) BuildRequires: Align with
    what configure checks for.
  - Enable conditional pkgconfig(graphene-1.0) BuildRequires for
    openSUSE 1330 (TW) and newer.
  - Enable pkgconfig(libdc1394-2) BuildRequires: Plugin now ported
    to gst-1.0.
  - Drop pkgconfig(libtimidity) BuildRequires: No longer needed nor
    used.
  - Drop bcond_with divx4linux and divx4linux-devel BuildRequires:
    Plugin no longer available.
  - Drop several disabled BuildRequires and plugins, the non-ported
    plugins have been dropped from upstream source.
  - Add pkgconfig(fdk-aac) BuildRequires in ORIG: Build fdk-aac
    support.
  - Drop obsolete libgstvdp subpackage and conditionals in place for
    it (also from baselibs.conf).
* Thu Feb 23 2017 zaitor@opensuse.org
  - Update to version 1.10.4 (CVE-2017-5848):
    + Bugs fixed: bgo#776612, bgo#777841, bgo#777957, bgo#777979,
      bgo#778297, bgo#778434, bgo#778452, bgo#778828.
  - Drop gstreamer-plugins-bad-CVE-2017-5848.patch: Fixed upstream.
  - Drop pkgconfig(libtimidity) BuildRequires: Not needed as plugin
    is not ported to 1.0 branch, and even dropped entirely in
    upcomming 1.12.0 release.
* Sat Feb 04 2017 zaitor@opensuse.org
  - Fix CVE-2017-5847 (boo#1023259):
    + Add gstreamer-plugins-bad-CVE-2017-5848.patch: psdemux: Rewrite
      PSM parsing using GstByteReader. Avoid possible buffer
      overflows and ignore invalid PSM packets better by using
      GstByteReader (bgo#777957).
* Thu Feb 02 2017 zaitor@opensuse.org
  - Add gstreamer-plugins-bad Requires in devel subpackage.
* Mon Jan 30 2017 zaitor@opensuse.org
  - Update to version 1.10.3 (CVE-2017-5838):
    + Bugs fixed: bgo#740101, bgo#775072, bgo#775292, bgo#775970,
      bgo#776072, bgo#776244, bgo#776461, bgo#776591, bgo#776722,
      bgo#776726, bgo#777143, bgo#777144, bgo#777400, bgo#777503,
      bgo#777533, bgo#777742, bgo#777930.
* Fri Dec 09 2016 olaf@aepfle.de
  - Wrap wayland support properly to fix builderrors in non-TW.
* Sat Dec 03 2016 zaitor@opensuse.org
  - Update to version 1.10.2:
    + Bugs fixed: bgo#774624, bgo#774702, bgo#774851, bgo#774896,
      bgo#775048, bgo#775120, bgo#775127, bgo#775130.
* Sun Nov 27 2016 zaitor@opensuse.org
  - Update to version 1.10.1:
    + Bugs fixed: bgo#773681, bgo#773313, bgo#774287, bgo#774328,
      bgo#774462.
* Wed Nov 02 2016 zaitor@opensuse.org
  - Update to version 1.10.0:
    + Bugs fixed: bgo#758717, bgo#762717, bgo#769382, bgo#770528,
      bgo#770587, bgo#772330, bgo#772499, bgo#772503, bgo#772698,
      bgo#772699, bgo#772704, bgo#772706, bgo#772742, bgo#773026,
      bgo#773423, bgo#773540, bgo#773635, bgo#773720, bgo#772608.
    + Updated translations.
  - Rebase gstreamer-plugins-bad-patch-source.sh.
  - Package new plugins: musepack and timecode.
  - Replace disabled pkgconfig(slv2) BuildRequires with
    pkgconfig(lilv-0), and enabled it following upstream changes.
    Drop bcond_with lv2 and move built plugin to main package, all
    dependencies are now available in openSUSE.
  - Add disabled pkgconfig(graphene-1.0) BuildRequires, new optional
    dependency, not yet available in openSUSE.
  - Add pkgconfig(webrtc-audio-processing) BuildRequires: Build
    webrtcdsp plugin.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
  - Add pkgconfig(gstreamer-allocators-1.0), pkgconfig(libdrm) and
    pkgconfig(libkms) BuildRequires: Build new kmssink plugin, mainly
    targeted for embedded systems.
* Sat Oct 08 2016 zaitor@opensuse.org
  - Fix conditional for pkgconfig(tiger) to only apply for
    Tumbleweed.
* Sun Sep 18 2016 zaitor@opensuse.org
  - Enable pkgconfig(tiger) BuildRequires for Tumbleweed.
* Fri Sep 02 2016 fezhang@suse.com
  - Disable libbs2b support when building on SLE.
* Mon Aug 22 2016 zaitor@opensuse.org
  - Update to version 1.8.3 (boo#996937):
    + Bugs fixed: bgo#767492, bgo#769376, bgo#736227, bgo#768160,
      bgo#767553, bgo#761260, bgo#763044, bgo#763081, bgo#756866,
      bgo#768771, bgo#766662, bgo#766163, bgo#768146, bgo#766663,
      bgo#767792, bgo#767492, bgo#767635.
    + Updated translations.
* Fri Aug 12 2016 zaitor@opensuse.org
  - Move libbs2b-devel BuildRequires and corresponding plugin to
    main package. There is no need for this to be in the addon one.
* Mon Jul 11 2016 fcrozat@suse.com
  - Really disable wayland support on SLE12.
* Mon Jun 20 2016 fcrozat@suse.com
  - Disable zbar support when building on SLE.
* Wed Jun 15 2016 dimstar@opensuse.org
  - Enable zbar support (needed for a new key-signing tool):
    + Add pkgconfig(zbar) BuildRequires.
* Wed Jun 15 2016 zaitor@opensuse.org
  - Drop pkgconfig(libcdaudio) BuildRequires: No longer needed, nor
    used anymore.
  - Remove obsolete clean section and a no longer meaningful
    conditional.
* Tue Jun 14 2016 zaitor@opensuse.org
  - Update to version 1.8.2:
    + bgo#756948: directsoundsrc: Audio Device not found on Windows
      (string encoding not honored).
    + bgo#764758: vulkan didn't build out of tree due to vkconfig.h.
    + bgo#765324: compositor: crashes on NULL pointer in
      _aggregate_frames().
    + bgo#765456: vtdec: Strange bug re-encoding video with GST 1.8.1
      on Mac OS 10.10.
    + bgo#765926: mpegtsmux: Set PTS on aligned buffers.
    + bgo#766190: vtdec: corrupted rendering on OSX.
    + bgo#766213: openjpeg plugin needs to be ported to libopenjp2
      v2.1.
    + bgo#766289: amc: cannot play some files on android.
    + bgo#766422: videoaggregator: rtspsrc ! compositor produces no
      output.
    + bgo#766441: OpenBSD does not use librt, but provides the needed
      functions in libc.
    + bgo#766520: gl: win32: race when handling window messages while
      creating the internal window.
    + bgo#766611: gl: buffer pool configuration error with
      caopengllayersink.
    + bgo#766638: ahc: fix possible NULL deref.
    + bgo#766732: openjpegenc: Doesn't manage MCT switch for RGB and
      YUV frames.
    + bgo#767298: amc: gst_object_unref on caps.
    + bgo#767302: ahcsrc: div by 0 warning.
* Thu Jun 02 2016 sbrabec@suse.com
  - Make baselibs.conf consistent with spec file (boo#980893).
* Tue May 24 2016 dimstar@opensuse.org
  - Drop pkgconfig(libmusicbrainz): gstreamer does not depend on it
    directly.
* Thu May 19 2016 alarrosa@suse.com
  - Update to GNOME 3.20.2 (Fate#318572)
* Thu Apr 21 2016 zaitor@opensuse.org
  - Update to version 1.8.1:
    + bgo#760473: OpenCV face detection does not work with OpenCV
      newer than 2.4.11.
    + bgo#747633: decklinkvideosrc: crash in
      ::VideoInputFrameArrived() callback with video_frame=NULL.
    + bgo#762924: interlace: negotiation fails unexpectedly.
    + bgo#763324: nvenc fails to compile with Nvidia video SDK 6.0.
    + bgo#763404: bad: video sink: Post un-handled keyboard/mouse
      events as message to application.
    + bgo#763862: mxfmux: Instead of releasing request pads on
      stop(), clear them only.
    + bgo#764148: gtkglsink doesn't fail to create on incompatible
      hardware.
    + bgo#764339: ahcsrc: g_object_class_install_property: assertion
      'pspec- > flags & G_PARAM_WRITABLE' during initialization.
    + bgo#764363: videoaggregator: Does not take into account the
      best output format that is computed.
    + bgo#764404: hlsdemux: Assertion with AES encrypted stream.
    + bgo#764448: h264parse: constrained-baseline is a subset of
      baseline.
    + bgo#764523: -lole32 is missing for libgstdirectsoundsrc.
    + bgo#764545: Crash when trying to use vulkan sink.
    + bgo#765005: mpegtsmux: memory leak caused by pad_data- >
      language.
    + bgo#765194: caopengllayersink: renders blurry content on HiDPI
      screens because contentsScale is ignored.
    + bgo#765241: glimagesink: need to clean window_id when state
      change form READY to NULL.
    + bgo#765079: srtpdec request-key is not signaled if roc is
      missing.
  - Clean up spec file, properly escape disabled plugins and macros.
    Make rpmlint report readable again. Also remove an obsolete
    source repack comment, we do it via pre_checkin.sh now.
  - No longer pass V=1 to make, stop littering buildlogs and
    debugging is done local anyway.
  - Add some missing post/postun handling.
  - Add pkgconfig(bluez), pkgconfig(x265) and libbs2b-devel
    BuildRequires and replace librtmp-devel for pkgconfig(librtmp):
    Build more supported plugins.
  - Disable a few BuildRequires that are not ported yet, no need to
    pull unused BuildRequires: SDL-devel, pkgconfig(daala),
    pkgconfig(flite), pkgconfig(libdc1394-2), libaudio-devel and
    libxvidcore-devel.
  - Split out a new libgstvdpau in an own sub-package, vdpau support
    is not needed for people not running nvidia binary driver.
  - Add fdupes BuildRequires and add macro to install section.
  - Stop passing --enable-experimental to configure, currently we are
    not building any experimental plugins, nor should we in the
    future.
* Wed Apr 13 2016 idonmez@suse.com
  - Update to GNOME 3.20  Fate#318572
  - Remove gstreamer-plugins-bad-real.patch
* Sat Mar 26 2016 zaitor@opensuse.org
  - Update to version 1.8.0:
    + Hardware-accelerated zero-copy video decoding on Android
    + New video capture source for Android using the
      android.hardware.Camera API.
    + Windows Media reverse playback support (ASF/WMV/WMA).
    + New tracing system provides support for more sophisticated
      debugging tools.
    + New high-level GstPlayer playback convenience API.
    + Initial support for the new Vulkan API, see Matthew Waters'
      blog post for more details.
    + Improved Opus audio codec support: Support for more than two
      channels; MPEG-TS demuxer/muxer can now handle Opus;
      sample-accurate encoding/decoding/transmuxing with Ogg,
      Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
      new codec utility functions for Opus header and caps handling
      in pbutils library. The Opus encoder/decoder elements were
      also moved to gst-plugins-base (from -bad), and the opus RTP
      depayloader/payloader to -good.
    + GStreamer VAAPI module now released and maintained as part of
      the GStreamer project.
    + Asset proxy support in the GStreamer Editing Services.
    + Bugs fixed: bgo#763756, bgo#763793, bgo#763877, bgo#763974,
      bgo#764066, bgo#763262.
  - Add pkgconfig(xcb) and pkgconfig(wayland-scanner) BuildRequires:
    New dependencies.
  - Add 2 new subpackages and handle them in post/un
    + libsgtbadaudio and libgstplayer.
* Wed Feb 17 2016 dimstar@opensuse.org
  - Add gstreamer-plugins-bad.appdata.xml so that the codecs can
    show up in a Software Center.
* Thu Jan 28 2016 dimstar@opensuse.org
  - Add libgstadaptivedemux-1_0-0 to baselibs.conf.
* Thu Jan 21 2016 badshah400@gmail.com
  - Update to version 1.6.3:
    + Fix regression in GL library that made glimagesink unsable on
      Android.
    + Integer arithmetic overflow in queue2 element that could break
      buffering or cause crashes due to NULL pointer dereference.
    + Fix crash in AAC/ADTS typefinder caused by reading more memory
      than is available.
    + Stop ignoring encoder errors in the VP8/VP9 encoders.
    + Deprecate GstVideoEncoder GST_VIDEO_ENCODER_FLOW_DROPPED. It's
      redudant and was never actually implemented.
    + Ensure to store the correct video info in GstVideoBufferPool.
    + Fix caps in rtspsrc when doing SRTP over interleaved TCP.
    + Fix crash in pcap parser on 0-sized packets.
    + Clear EOS flag in appsrc to allow reuse after EOS and
      flushing.
    + Ignore flushing streams in streamsynchronizer during stream
      switches to fix problems caused by this in
      gst-editing-services.
    + Ignore tags and other metadata in WAV files after the "data"
      chunk in PUSH mode to prevent them from being interpreted as
      audio.
    + Correctly use colorimetry in v4l2 only for YUV color formats.
    + Set reserved bits in MPEG TS muxer to 1s.
    + Fix calculation of SBC frame lengths.
    + Fix output of the RTP JPEG2000 depayloader to have one frame
      per buffer and crash in the OpenJPEG decoder on incomplete
      frames.
    + Update ffmpeg snapshot in gst-libav to 2.8.5.
    + Memory leak fixes in scaletempo, the raw video RTP
      depayloader, and in playsink related to audio/video filters.
    + Fixes for error handling in the OSX audio plugin.
    + Various gobject-introspection annotation fixes and additions.
    + Compiler warning fixes for latest clang compiler.
* Wed Jan 06 2016 dimstar@opensuse.org
  - Update to version 1.6.2:
    + Crashes in gst-libav with sinks that did not provide a buffer
      pool but supported video metadata were fixed. This affected
      d3dvideosink and some 3rd party sinks. Also related fixes for
      crashes when a downstream buffer pool failed allocation.
    + Big GL performance improvement on iOS by a factor of 2 by using
      Apple's sync extension.
    + Deadlocks in the DirectSound elements on Windows, and the
      behaviour of its mute property were fixed.
    + The Direct3D video sink does not crash anymore when minimizing
      the window.
    + The library soname generation on Android >= 6.0 was fixed,
      which previously caused GStreamer to fail to load there.
    + File related elements have large-file (>2GB) support on Android
      now.
    + gst-libav was updated to ffmpeg 2.8.3.
    + Deserialization of custom events in the GDP depayloader was
      fixed.
    + Missing OpenGL context initialization in the Qt/QML video sink
      was fixed in certain situations.
    + Interoperability with some broken RTSP servers using HTTP
      tunnel was improved.
    + Various compilation fixes for Windows.
    + Various smaller memory leak and other fixes in different
      places.
    + Bugs fixed: bgo#734098, bgo#738292, bgo#741608, bgo#753823,
      bgo#755106, bgo#755222, bgo#755614, bgo#756028, bgo#756951,
      bgo#757155, bgo#757264, bgo#757453, bgo#757454, bgo#757732,
      bgo#757854, bgo#757873, bgo#757895, bgo#757924, bgo#757929,
      bgo#757935, bgo#758029, bgo#758151, bgo#758204, bgo#758205,
      bgo#758276, bgo#758285, bgo#758286, bgo#758337, bgo#758344,
      bgo#758512, bgo#758620, bgo#758861, bgo#758912, bgo#758913,
      bgo#758921, bgo#759019, bgo#759380.
* Mon Dec 28 2015 joerg.lorenzen@ki.tng.de
  - Fix build for Leap 42.1.
* Thu Dec 17 2015 fcrozat@suse.com
  - Do not BuildRequires pkgconfig(wayland-egl) on SLE.
* Fri Nov 27 2015 zaitor@opensuse.org
  - Add pkgconfig(libssh2) BuildRequires: Build ssh support.
  - Add libcurl.so to BUILD_ORIG file list for openSUSE 13.1 only,
    as packman builds against Update where a new enough version is
    provided.
* Sat Oct 31 2015 zaitor@opensuse.org
  - Update to version 1.6.1:
    + Bugs fixed: bgo#756567, bgo#752132, bgo#752230, bgo#754523,
      bgo#755108, bgo#755132, bgo#755134, bgo#755239, bgo#755623,
      bgo#755680, bgo#755738, bgo#755754, bgo#755759, bgo#755824,
      bgo#755840, bgo#755850, bgo#755852, bgo#755892, bgo#755969,
      bgo#755981, bgo#756001, bgo#756065, bgo#756070, bgo#756181,
      bgo#756186, bgo#756383, bgo#756563, bgo#756578, bgo#756592,
      bgo#756617, bgo#756653, bgo#756861, bgo#756876, bgo#757251.
  - Add gstreamer-revert-bogus-automake-version.patch, upstream
    bumped automake req to high.
* Fri Oct 02 2015 zaitor@opensuse.org
  - Update to version 1.6.0:
    + For changelog, see mainpackage changes, everything is condensed
      there.
  - Rebase gstreamer-plugins-bad-patch-source.sh, add new plugins.
  - Drop gstreamer-plugins-bad-real.patch: real plugin was dropped
    from gstreamer-bad package.
  - Add new sub-package libgstadaptivedemux-1_0-0 and handle it in
    %post/postun.
* Thu Mar 26 2015 dimstar@opensuse.org
  - Change from simple %defines to %bcond_with/without, as this
    allows to be set in prjconf without the need to patch the .spec
    files.
  - Create new subpackage libgstwayland-1_0-0.
* Tue Jan 13 2015 adam@mizerski.pl
  - added BuildRequires: pkgconfig(nettle) to enable building hls plugin
* Fri Dec 26 2014 zaitor@opensuse.org
  - Update to version 1.4.5:
    + Bugs fixed: bgo#722764, bgo#729768, bgo#739152, bgo#740191,
      bgo#740201, bgo#740451, bgo#740953, bgo#741321.
  - Remove obsolete FIXME entries about pkgconfig(wayland-client)
    BuildRequires, we have had this enabled for a while.
* Mon Dec 15 2014 fcrozat@suse.com
  - Disable BuildRequires on libchromaprint, fluidsynth and openAL on
    SLE12.
* Sat Nov 15 2014 zaitor@opensuse.org
  - Enable pkgconfig(libchromaprint) BuildRequires, build
    chromaprint plugin.
* Fri Nov 14 2014 zaitor@opensuse.org
  - Update to version 1.4.4:
    + bgo#732239, bgo#733510, bgo#734156, bgo#736319, bgo#737186,
      bgo#737569, bgo#737658, bgo#737724, bgo#738067, bgo#738223,
      bgo#738230, bgo#738243, bgo#738291, bgo#738449, bgo#738519,
      bgo#738532, bgo#738674, bgo#738695, bgo#738696, bgo#739277,
      bgo#739348, bgo#739368, bgo#739374.
    + Updated translations.
* Mon Oct 27 2014 zaitor@opensuse.org
  - Add pkgconfig(fluidsynth), pkgconfig(gudev-1.0),
    pkgconfig(libusb-1.0), pkgconfig(libwebp), pkgconfig(libxml-2.0),
    pkgconfig(OpenEXR) and pkgconfig(sbc) BuildRequires, build more
    plugins.

Files

/usr/lib64/gstreamer-1.0
/usr/lib64/gstreamer-1.0/libgstaccurip.so
/usr/lib64/gstreamer-1.0/libgstadpcmdec.so
/usr/lib64/gstreamer-1.0/libgstadpcmenc.so
/usr/lib64/gstreamer-1.0/libgstaiff.so
/usr/lib64/gstreamer-1.0/libgstaom.so
/usr/lib64/gstreamer-1.0/libgstasfmux.so
/usr/lib64/gstreamer-1.0/libgstassrender.so
/usr/lib64/gstreamer-1.0/libgstaudiobuffersplit.so
/usr/lib64/gstreamer-1.0/libgstaudiofxbad.so
/usr/lib64/gstreamer-1.0/libgstaudiolatency.so
/usr/lib64/gstreamer-1.0/libgstaudiomixmatrix.so
/usr/lib64/gstreamer-1.0/libgstaudiovisualizers.so
/usr/lib64/gstreamer-1.0/libgstautoconvert.so
/usr/lib64/gstreamer-1.0/libgstbayer.so
/usr/lib64/gstreamer-1.0/libgstbluez.so
/usr/lib64/gstreamer-1.0/libgstbs2b.so
/usr/lib64/gstreamer-1.0/libgstbz2.so
/usr/lib64/gstreamer-1.0/libgstcamerabin.so
/usr/lib64/gstreamer-1.0/libgstclosedcaption.so
/usr/lib64/gstreamer-1.0/libgstcoloreffects.so
/usr/lib64/gstreamer-1.0/libgstcolormanagement.so
/usr/lib64/gstreamer-1.0/libgstcurl.so
/usr/lib64/gstreamer-1.0/libgstdashdemux.so
/usr/lib64/gstreamer-1.0/libgstdc1394.so
/usr/lib64/gstreamer-1.0/libgstdebugutilsbad.so
/usr/lib64/gstreamer-1.0/libgstdecklink.so
/usr/lib64/gstreamer-1.0/libgstdtls.so
/usr/lib64/gstreamer-1.0/libgstdvb.so
/usr/lib64/gstreamer-1.0/libgstdvbsuboverlay.so
/usr/lib64/gstreamer-1.0/libgstdvdspu.so
/usr/lib64/gstreamer-1.0/libgstfaceoverlay.so
/usr/lib64/gstreamer-1.0/libgstfbdevsink.so
/usr/lib64/gstreamer-1.0/libgstfieldanalysis.so
/usr/lib64/gstreamer-1.0/libgstfreeverb.so
/usr/lib64/gstreamer-1.0/libgstfrei0r.so
/usr/lib64/gstreamer-1.0/libgstgaudieffects.so
/usr/lib64/gstreamer-1.0/libgstgdp.so
/usr/lib64/gstreamer-1.0/libgstgeometrictransform.so
/usr/lib64/gstreamer-1.0/libgstgme.so
/usr/lib64/gstreamer-1.0/libgstgsm.so
/usr/lib64/gstreamer-1.0/libgsthls.so
/usr/lib64/gstreamer-1.0/libgstid3tag.so
/usr/lib64/gstreamer-1.0/libgstinter.so
/usr/lib64/gstreamer-1.0/libgstinterlace.so
/usr/lib64/gstreamer-1.0/libgstipcpipeline.so
/usr/lib64/gstreamer-1.0/libgstivfparse.so
/usr/lib64/gstreamer-1.0/libgstivtc.so
/usr/lib64/gstreamer-1.0/libgstjp2kdecimator.so
/usr/lib64/gstreamer-1.0/libgstjpegformat.so
/usr/lib64/gstreamer-1.0/libgstkms.so
/usr/lib64/gstreamer-1.0/libgstladspa.so
/usr/lib64/gstreamer-1.0/libgstlegacyrawparse.so
/usr/lib64/gstreamer-1.0/libgstlv2.so
/usr/lib64/gstreamer-1.0/libgstmidi.so
/usr/lib64/gstreamer-1.0/libgstmms.so
/usr/lib64/gstreamer-1.0/libgstmpeg2enc.so
/usr/lib64/gstreamer-1.0/libgstmpegpsdemux.so
/usr/lib64/gstreamer-1.0/libgstmpegpsmux.so
/usr/lib64/gstreamer-1.0/libgstmpegtsdemux.so
/usr/lib64/gstreamer-1.0/libgstmpegtsmux.so
/usr/lib64/gstreamer-1.0/libgstmplex.so
/usr/lib64/gstreamer-1.0/libgstmusepack.so
/usr/lib64/gstreamer-1.0/libgstmxf.so
/usr/lib64/gstreamer-1.0/libgstneonhttpsrc.so
/usr/lib64/gstreamer-1.0/libgstnetsim.so
/usr/lib64/gstreamer-1.0/libgstofa.so
/usr/lib64/gstreamer-1.0/libgstopenal.so
/usr/lib64/gstreamer-1.0/libgstopenexr.so
/usr/lib64/gstreamer-1.0/libgstopenjpeg.so
/usr/lib64/gstreamer-1.0/libgstopenmpt.so
/usr/lib64/gstreamer-1.0/libgstopusparse.so
/usr/lib64/gstreamer-1.0/libgstpcapparse.so
/usr/lib64/gstreamer-1.0/libgstpnm.so
/usr/lib64/gstreamer-1.0/libgstproxy.so
/usr/lib64/gstreamer-1.0/libgstremovesilence.so
/usr/lib64/gstreamer-1.0/libgstrfbsrc.so
/usr/lib64/gstreamer-1.0/libgstrsvg.so
/usr/lib64/gstreamer-1.0/libgstrtponvif.so
/usr/lib64/gstreamer-1.0/libgstsbc.so
/usr/lib64/gstreamer-1.0/libgstsdpelem.so
/usr/lib64/gstreamer-1.0/libgstsegmentclip.so
/usr/lib64/gstreamer-1.0/libgstshm.so
/usr/lib64/gstreamer-1.0/libgstsmooth.so
/usr/lib64/gstreamer-1.0/libgstsmoothstreaming.so
/usr/lib64/gstreamer-1.0/libgstsndfile.so
/usr/lib64/gstreamer-1.0/libgstsoundtouch.so
/usr/lib64/gstreamer-1.0/libgstspandsp.so
/usr/lib64/gstreamer-1.0/libgstspeed.so
/usr/lib64/gstreamer-1.0/libgstsrt.so
/usr/lib64/gstreamer-1.0/libgstsrtp.so
/usr/lib64/gstreamer-1.0/libgstsubenc.so
/usr/lib64/gstreamer-1.0/libgstteletext.so
/usr/lib64/gstreamer-1.0/libgsttimecode.so
/usr/lib64/gstreamer-1.0/libgstttmlsubs.so
/usr/lib64/gstreamer-1.0/libgstuvch264.so
/usr/lib64/gstreamer-1.0/libgstvideofiltersbad.so
/usr/lib64/gstreamer-1.0/libgstvideoframe_audiolevel.so
/usr/lib64/gstreamer-1.0/libgstvideoparsersbad.so
/usr/lib64/gstreamer-1.0/libgstvideosignal.so
/usr/lib64/gstreamer-1.0/libgstvmnc.so
/usr/lib64/gstreamer-1.0/libgstwaylandsink.so
/usr/lib64/gstreamer-1.0/libgstwebp.so
/usr/lib64/gstreamer-1.0/libgstwebrtc.so
/usr/lib64/gstreamer-1.0/libgstwebrtcdsp.so
/usr/lib64/gstreamer-1.0/libgsty4mdec.so
/usr/lib64/gstreamer-1.0/libgstyadif.so
/usr/lib64/gstreamer-1.0/libgstzbar.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 21:44:07 2021