Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

openwsman-perl-2.6.7-lp151.4.6.1 RPM for x86_64

From OpenSuSE Leap 15.1 updates for x86_64

Name: openwsman-perl Distribution: openSUSE Leap 15.1
Version: 2.6.7 Vendor: openSUSE
Release: lp151.4.6.1 Build date: Wed Sep 16 16:11:31 2020
Group: System/Management Build host: lamb74
Size: 490633 Source RPM: openwsman-2.6.7-lp151.4.6.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.openwsman.org/
Summary: Perl bindings for openwsman client API
This package provides Perl bindings to access the openwsman client API.

Provides

Requires

License

BSD-3-Clause AND GPL-2.0-only

Changelog

* Fri Aug 21 2020 Adam Majer <adam.majer@suse.de>
  - openssl_init_fix.patch: don't crash if OpenSSL SSL context fails
    to initialize. This only happened because the function signature
    used was invalid and was passing random data. (bsc#1175631)
* Tue Aug 18 2020 Klaus Kämpf <kkaempf@suse.com>
  - adapt to openssl 1.1.1 (bsc#1174541)
    add update-to-openssl-1.1.1-drop-RANDFILE.patch
* Tue Sep 17 2019 Klaus Kämpf <kkaempf@suse.com>
  - bsc1105331.patch: add CIM_NAMESPACE if it's _not_ already present
    (bsc#1105331)
* Thu Mar 14 2019 Adam Majer <adam.majer@suse.de>
  - bsc1122623.patch: (bsc#1122623, CVE-2019-3816, CVE-2019-3833)
    + treat all non-registered by provider paths as invalid
    + fix possible denial of service in path parsing
  - debug_fix.patch: fix compilation in debug mode
    Backport patches from upstream,
  - 31c355f.patch: Work with OpenSSL 1.1
  - a4a66e8.patch: disable directory listings by default (bsc#1092206)
* Thu Feb 22 2018 fcrozat@suse.com
  - Switch license to BSD-3-Clause AND GPL-2.0-only, since redirect
    plugin is under GPL 2.0 only license.
* Mon Feb 19 2018 kkaempf@suse.com
  - Update to 2.6.7
    - Features
    - Build with CMake 2.6 or later
    - Bugfixes
    - fix return value check for SSL_CTX_set_cipher_list()
    - fix pam config for local install
* Wed Dec 13 2017 kkaempf@suse.com
  - python3-openwsman
* Mon Dec 11 2017 kkaempf@suse.com
  - fix Source declarations to get a complete src.rpm
* Tue Dec 05 2017 kkaempf@suse.com
  - Build Python3 on Leap and SLE 15
  - Fix RHEL7 build
* Mon Dec 04 2017 kkaempf@suse.com
  - update to 2.6.6
    - openssl 1.1.0 compatibility
    - build python3 or python2 binding, but not both
* Fri Nov 24 2017 kkaempf@suse.com
  - update to 2.6.5
    - Fix python3 / ruby 2.5 compatibility
    - drop openwsman-2.6.2-python3.patch
* Wed Nov 08 2017 kukuk@suse.de
  - Replace obsolete pam modules with standard ones
* Tue Nov 07 2017 kkaempf@suse.com
  - update to 2.6.4
    - Bugfixes
    - setup ECDHE to allow Perfect Forward Secrecy, using the p256
      NIST prime curve (CVE-2016-2183) (mmeissner)
* Sat Sep 09 2017 kgronlund@suse.com
  - Package for python 3
  - Add openwsman-2.6.2-python3.patch
* Sun Apr 30 2017 bwiedemann@suse.com
  - use strip-nondeterminism to make build more reproducible
* Mon Jun 20 2016 kkaempf@suse.com
  - update to 2.6.3
    - Bugfixes
    - Prevent buffer overflow if digest realm too long
    - Ensure path starts with '/' in client data endpoint
    - Java bindings build fix
    - Fix SSL library, usage is not thread safe (vcrhonek)
    - Improve NetBSD and OSX builds (apjanke)
    - Install winrs with correct name and permissions
* Thu Dec 03 2015 kkaempf@suse.com
  - make winrs executable
    add-shebang-to-winrs.patch
* Wed Dec 02 2015 srinidhi.bs@microfocus.com
  - Install winrs with executable permissions
* Wed Oct 07 2015 kkaempf@suse.com
  - Update to 2.6.2
    - Features
    - Install winrs.rb (Windows Remote Shell) to /usr/bin
    - New package: winrs
    - Bugfixes
    - Make iniparser thread-safe (Emil Bartczak)
    - Fix excessive RPM rebuilds (Olaf Hering)
    - Fix selector extraction from URI query (Markus Kolb)
    - Fix RPM building on older distributions
    - Fix RPM building on Fedora 22
* Mon Oct 05 2015 kkaempf@suse.com
  - Fix build for older distributions.
    Add struct-epr.diff
* Fri Aug 28 2015 kkaempf@suse.com
  - Update to 2.6.1
    - Features
    - Add curlopt_nosignal option to openwsman_client.conf to prevent
      CURL crashes in multithreaded client applications
    - Limit EnvelopeSize to 32767 if wsman:MaxEnvelopeSize not set in
      request (WS-Man 1.2 compatibility) (Prabhakar Pujeri)
    - Bugfixes
    - fix memory leaks (Vitezslav Crhonek)
    - honor client:agent from openwsman_client.conf
    - fix possible crash in dictionary_get()
* Tue Jun 16 2015 kkaempf@suse.com
  - fix SLE 10 & 11 builds
* Thu Jun 11 2015 kkaempf@suse.com
  - Update to 2.6.0
    - Features
    - Implement DSP 0226 Section 6.3 wsman:Locale
      (wsmc_set_locale, wsmc_get_locale)
    - set transport timeout for c++ binding (prabhakar_pujeri@dell.com)
    - print CIMError code in HTTP header (prabhakar_pujeri@dell.com)
* Wed Jun 03 2015 kkaempf@suse.com
  - Update to 2.5.2
    - Features
    - build native Python package (Ahmad Jagot)
    - Cleanup
    - remove (unused) 'min_threads' config option (Vitezslav Crhonek)
* Wed Jun 03 2015 kkaempf@suse.com
  - Update to 2.5.1
    - Features
    - adds RFC1866 support in allowing ; as a separator for
      resource uri query parameters (selectors).
    - print a warning if a resource URI (wrongly) uses ',' as
      query parameter separator.
* Wed May 20 2015 kkaempf@suse.com
  - Update to 2.5.0
    - Drop 'openwsmand' service name, use 'openwsman' only
      (was never properly supported by systemd anyways)
    - Features
    - Rewrite selector and property handling to keep
      them in order (#49)
      Selectors and properties can now handle EndpointReferences
      as values. This increases compatibility with Intel AMT 7.0
      and later.
    - ABI change, .so version 3
    - Ruby: Add EndPointReference#to_s
* Wed May 20 2015 kkaempf@suse.com
  - Update to 2.4.15
    - Features
    - Ruby: Add Fault#to_s
    - Ruby: Enable ClientOptions#properties=
    - Cim: New config option "cim_client_cql' to select CQL query
      identifier ('CQL' - default, 'DMTF:CQL' - standards-compliant)
    - Bugfixes
    - Fix segfault in wsmc_add_property
    - Fix memleak in xpath handling
    - Fix typo in parsing max_connections_per_thread (vcrhonek)
    - Ruby: ClientOptions#properties=
* Tue Feb 24 2015 kkaempf@suse.com
  - Update to 2.4.14
    - Features
    - Improved C++ bindings (Peter Hatina)
    - Bugfixes
    - Build fixes for Fedora21, RHEL7, and CentOS7
    - option parser accepts '-?' and '--help' as valid
* Wed Jan 21 2015 kkaempf@suse.com
  - Fix Fedora 21, RHEL 7, and CentOS 7 build
* Thu Jan 15 2015 kkaempf@suse.com
  - Update to 2.4.13
    - Features
    - Support Ruby 2.2
    - Bugfixes
    - Parsing of vendor namespaces (#48, #38)
    - Client getters memory leaks (#47)
    - Keep order of 'invoke' parameters (#49)
* Wed Oct 29 2014 kkaempf@suse.com
  - check SSL version
* Tue Oct 28 2014 kkaempf@suse.com
  - Update to 2.4.12
    - Features
    - New config option 'ssl_disable_protocols'. Pre-set to disable
      SSLv2 and v3 in SSL mode
    - Ruby: support Ruby 2.1 threading API
    - Bugfixes
    - Fix memory corruption due to a malloc made with the wrong size
    - iniparser: dictionary_set' must return a value (David Holm)
  - drop fix-memory-corruption.patch, upstream

Files

/usr/lib/perl5/vendor_perl/5.26.1/openwsman.pm
/usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi/openwsman.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 10:07:50 2021