Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ocaml-x11-4.05.0-lp151.5.3.1 RPM for x86_64

From OpenSuSE Leap 15.1 updates for x86_64

Name: ocaml-x11 Distribution: openSUSE Leap 15.1
Version: 4.05.0 Vendor: openSUSE
Release: lp151.5.3.1 Build date: Sat Dec 7 00:18:52 2019
Group: Development/Languages/OCaml Build host: build34
Size: 2182 Source RPM: ocaml-4.05.0-lp151.5.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.ocaml.org
Summary: X11 support for OCaml
OCaml is a high-level, strongly-typed, functional and object-oriented
programming language from the ML family of languages.

This package contains X11 support for OCaml.

Provides

Requires

License

SUSE-LGPL-2.0-with-linking-exception

Changelog

* Tue Sep 24 2019 ohering@suse.de
  - Provide various macros to unify dune $cmd usage
* Mon Sep 23 2019 ohering@suse.de
  - Disable LTO for all packages that use ocaml_preserve_bytecode
* Wed Apr 24 2019 ohering@suse.de
  - Disable LTO (bsc#1133269)
* Mon Jul 02 2018 guillaume.gardet@opensuse.org
  - Tag license files with %license, not %doc
  - Backport patch to fix build on aarch64: 'AArch64 GOT fixed'
    https://github.com/ocaml/ocaml/pull/1330:
    * ocaml-fix_aarch64_build.patch
    (bsc#1151745)
* Tue Apr 24 2018 kstreitova@suse.com
  - update ocaml-4.05.0-CVE-2018-9838.patch that causes "undefined
    reference to `caml_umul_overflow`" build failure. Replace this
    function that is not available in ocaml 4.05 (added in ocaml
    4.06) with the present caml_ba_multov() that is basically the
    same [bnc#1088591] [CVE-2018-9838]
* Fri Apr 13 2018 kstreitova@suse.com
  - add ocaml-4.05.0-CVE-2018-9838.patch to fix integer overflows
    when unmarshaling a bigarray. Malicious or corrupted marshaled
    data can result in a bigarray with impossibly large dimensions
    that cause overflow when computing the in-memory size of the
    bigarray. Disaster ensues when the data is read in a too small
    memory area [bnc#1088591] [CVE-2018-9838]
* Wed Apr 04 2018 kstreitova@suse.com
  - run spec-cleaner
  - update URL to www.ocaml.org
  - the language is officially called OCaml and not Objective Caml,
    rename it in summaries and descriptions
  - tweak summaries and descriptions
  - remove definition of %{_rpmconfigdir} macro - it should be
    defined on all distros by default now
* Wed Apr 04 2018 ohering@suse.de
  - Remove info and html documentation because it is not as free
    as it should be. Drop ocaml-docs package. (bsc#1080640)
  - adjust ocaml-3.09-emacs_localcompile.patch and
    ocaml-3.08.3-gcc4.patch for autosetup
* Thu Aug 10 2017 ohering@suse.de
  - Provide ocaml(ocaml_base_version) for camlp4
* Tue Jul 25 2017 ohering@suse.de
  - Use Group: Development/Languages/OCaml
* Mon Jul 17 2017 ohering@suse.de
  - update version 4.05.0
    * http://caml.inria.fr/pub/distrib/ocaml-4.05/notes/Changes
  - build with -no-cplugins (CVE-2017-9772)
* Mon Jul 17 2017 ohering@suse.de
  - Remove autodeps for pre openSUSE 12.1 releases
* Tue Jun 06 2017 ohering@suse.de
  - Clear _find_debuginfo_dwz_opts to avoid file conflicts due
    to identical contents in .dwz sections
* Wed May 31 2017 ohering@suse.de
  - Install libasmrun_pic to fix build with gcc7
* Thu Jun 30 2016 ohering@suse.de
  - Correct .TH macro creation in ocamldoc (ocaml#7281)
    ocamldoc-man-th.patch
* Thu Jun 16 2016 ohering@suse.de
  - Install ocamltags in emacs site-lisp, do not add a shebang anymore
* Mon Jun 13 2016 ohering@suse.de
  - Provide various macros to unify oasis ocaml setup.ml $cmd usage
* Tue Jun 07 2016 ohering@suse.de
  - ocaml-compiler-libs requires ncurses-devel for some bytecode
    compilation
* Fri May 27 2016 ohering@suse.de
  - Add Provides/Requires for ocamlfind() from META files
* Wed May 18 2016 ohering@suse.de
  - update version 4.03.0 (fate#320836)
    * http://caml.inria.fr/pub/distrib/ocaml-4.03/notes/Changes
    drop ocaml-ppc64.patch
    drop ocaml-ppc64le.patch
    drop ocaml-arch-rlimit-stacksize.patch
    drop ocaml-4.02.3-bufferoverflow_infoleak.patch
* Wed May 04 2016 kstreitova@suse.com
  - add ocaml-4.02.3-bufferoverflow_infoleak.patch to prevent buffer
    overflow and information leak [bsc#977990], [CVE-2015-8869]
  - use spec-cleaner to clean the specfile
* Wed Nov 11 2015 ohering@suse.de
  - Increase rlimit stack size on ppc64
    ocaml-arch-rlimit-stacksize.patch
* Tue Nov 10 2015 ohering@suse.de
  - Add hardcoded Provides for pre 12.1 repos
* Wed Sep 16 2015 ohering@suse.de
  - update version 4.02.3
    * http://caml.inria.fr/pub/distrib/ocaml-4.02/notes/Changes
* Tue Aug 04 2015 kstreitova@suse.com
  - use spec-cleaner
* Tue Jun 23 2015 ohering@suse.de
  - update version 4.02.2
    * http://caml.inria.fr/pub/distrib/ocaml-4.02/notes/Changes
* Thu Oct 23 2014 ohering@suse.de
  - Recognize macros provided by prjconf to disable ocamlopt and
    run testsuite
* Thu Oct 23 2014 ohering@suse.de
  - New subpackage ocaml-rpm-macros
* Wed Oct 22 2014 ohering@suse.de
  - update version 4.02.1
    * http://caml.inria.fr/pub/distrib/ocaml-4.02/notes/Changes
* Mon Oct 20 2014 ohering@suse.de
  - Update ppc64/ppc64le patch (bnc#901836)

Files

/usr/lib64/ocaml/graphicsX11.cmi
/usr/lib64/ocaml/graphicsX11.mli


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 10:07:50 2021