Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libglue2-32bit-1.0.12+v1.git.1650454062.1fbde71c-1.1 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: libglue2-32bit Distribution: openSUSE Tumbleweed
Version: 1.0.12+v1.git.1650454062.1fbde71c Vendor: openSUSE
Release: 1.1 Build date: Wed May 11 04:39:53 2022
Group: Productivity/Clustering/HA Build host: lamb05
Size: 306356 Source RPM: cluster-glue-1.0.12+v1.git.1650454062.1fbde71c-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/ClusterLabs/cluster-glue.git
Summary: Reusable cluster libraries
A collection of libraries that are useful for writing cluster managers
such as Pacemaker.

Provides

Requires

License

GPL-2.0-only AND LGPL-2.1-or-later

Changelog

* Mon May 02 2022 varkoly@suse.com
  - Update to version 1.0.12+v1.git.1650454062.1fbde71c:
    * bugfix for comment in external/ec2
    * Update external/ec2 to support IMDSv2
    * ec2: add the action parameter to the getinfo_xml function
    * drac3_command: check for truncated url
    * wti_mpc: fix metadata mib-version description
    * net-snmp "remote_port" is unused and deprecated since decades
    * fix for spurious compiler warning -Werror=stringop-overflow=
    * ipmilan_test: fix for -Werror=uninitialized
    * fix for -Werror=sizeof-pointer-memaccess
    * spec: drop /man1/ from file list, no longer used
* Thu Dec 23 2021 XinLiang <XLiang@suse.com>
  - hb_report.in: Add a warning for hb_report command is deprecated, guide user to use "crm report" directly (jsc#SLE-22499)
* Thu May 27 2021 varkoly@suse.com
  - Update to version 1.0.12+v1.git.1622055853.1753f5e0:
    * ec2: add the action parameter to the getinfo_xml function
    * drac3_command: check for truncated url
    * wti_mpc: fix metadata mib-version description
    * net-snmp "remote_port" is unused and deprecated since decades
    * fix for spurious compiler warning -Werror=stringop-overflow=
    * ipmilan_test: fix for -Werror=uninitialized
    * fix for -Werror=sizeof-pointer-memaccess
    * spec: drop /man1/ from file list, no longer used
    * use git describe to generate ./.tarball-version
    * fix config.status: QUIET_MAKE_OPTS: command not found
    * automake: use AM_CPPFLAGS; INCLUDES was deprecated years ago
    * reflect python3 in configure.ac and shebangs
    * Fix Werror: format-overflow, format-truncation, stringop-truncation
    * Stop using glib2 "deprecated symbols"
    * Fix typo: bounary -> boundary
    * Current Pacemaker does not use ha_logd
    * Use pkgconfig to configure libxml-2.0 xml2-config to be removed from Debian packaging
    * Move ha_logger manpage to section 8 Fixes lintian warning for /usr/sbin binaries.
    * Adjust file paths for Debian Fix --with-rundir option for configure
    * Fix interpreter for perl scripts Policy 10.4 states that Perl scripts must use /usr/bin/perl directly and not via /usr/bin/env
    * Fix FTBFS with openipmi 2.0.25 selector_t deprecated in new openipmi version
    * Add manpage to systemd service documentation
    * Fix spelling errors reported by lintian
    * Convert scripts to python3
    * Fix cl_times on x32
    * Fix build on hurd #650820
    * Fix build on FreeBSD #650820
    * Remove .hgsigs from source
    * Remove .hgignore from source
    * Remove .hgtags from source
    * Fix spelling of output and improve grammar
    * libtoolize_check
  - Remove applied patch:
    0001-Port-scripts-to-Python-3.patch
  - Enhance BuildRequires: asciidoc is required to build man pages.
* Mon Apr 27 2020 xarbulu@suse.com
  - Update to version 1.0.12+v1.git.1587474580.a5fda2bc:
    * Fix EC2 stonith plugin (bsc#1169784)
* Wed Jun 12 2019 kgronlund@suse.com
  - Update to version 1.0.12+v1.git.1560323319.fd5a3bef:
    * ibmhmc: Create /var/run/heartbeat/rsctmp if it doesn't exist (bsc#1131545)
* Mon Jun 10 2019 kgronlund@suse.com
  - Create /var/run/heartbeat/rsctmp directory (bsc#1131545)
* Thu Aug 16 2018 kgronlund@suse.com
  - Update to version 1.0.12+v1.git.1534346580.be86a9f2:
    * Fix: stonith:ibmhmc: Add "managedsyspat" and "password" as supported parameters (bsc#1098758)
  - Remove obsolete patch:
    * Remove 0001-Medium-external-ec2-Mitigate-fence-race-bsc-1088656.patch
* Wed Apr 11 2018 kgronlund@suse.com
  - Update to version 1.0.12+v1.git.1523280117.43b22d15:
    * High: external/ec2: Avoid unicode errors and improve performance (bsc#1088656)
  - Medium: external/ec2: Mitigate fence race (bsc#1088656)
    * Add 0001-Medium-external-ec2-Mitigate-fence-race-bsc-1088656.patch
* Fri Feb 23 2018 ygao@suse.com
  - Build: Ship cibsecret by pacemaker instead of cluster-glue (bsc#1082456)
* Fri Feb 02 2018 ygao@suse.com
  - spec: Still use 90 as the consistent gid for the group "haclient" among the cluster

Files

/usr/lib/libpils.so.2
/usr/lib/libpils.so.2.0.0
/usr/lib/libplumb.so.2
/usr/lib/libplumb.so.2.1.0
/usr/lib/libplumbgpl.so.2
/usr/lib/libplumbgpl.so.2.0.0
/usr/lib/libstonith.so.1
/usr/lib/libstonith.so.1.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 30 23:58:49 2022