Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python311-six-1.16.0-4.5 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: python311-six Distribution: openSUSE Tumbleweed
Version: 1.16.0 Vendor: openSUSE
Release: 4.5 Build date: Tue Jan 2 21:56:50 2024
Group: Development/Libraries/Python Build host: reproducible
Size: 96023 Source RPM: python-six-1.16.0-4.5.src.rpm
Packager: https://bugs.opensuse.org
Url: http://pypi.python.org/pypi/six/
Summary: Python 2 and 3 compatibility utilities
Six is a Python 2 and 3 compatibility library. It provides utility
functions for smoothing over the differences between the Python
versions with the goal of writing Python code that is compatible on
both Python versions. See the documentation for more information on
what is provided.

Provides

Requires

License

MIT

Changelog

* Tue Jan 02 2024 Dirk Müller <dmueller@suse.com>
  - require setuptools
* Sun Apr 23 2023 Matej Cepl <mcepl@suse.com>
  - Switch documentation to be within the main package.
* Fri Apr 21 2023 Dirk Müller <dmueller@suse.com>
  - add sle15_python_module_pythons (jsc#PED-68)
* Thu Jun 17 2021 Benjamin Greiner <code@bnavigator.de>
  - provide python3*dist(six): work around boo#1186870
* Sun May 09 2021 Dirk Müller <dmueller@suse.com>
  - update to 1.16.0:
  - Port _SixMetaPathImporter to Python 3.10.
* Fri Oct 23 2020 Benjamin Greiner <code@bnavigator.de>
  - Use %pycache_only %python_sitelib instead of %python3_sitelib
    * fixes gh#openSUSE/python-rpm-macros#64#issuecomment-715373348
* Tue Jun 02 2020 Dirk Mueller <dmueller@suse.com>
  - update to 1.15.0:
    - Pull request #331: Optimize `six.ensure_str` and `six.ensure_binary`.
* Tue Mar 10 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Do not cause buildcycle with previous change but rather
    install the egg-info prepared metadata from the tarball
* Mon Mar 09 2020 Dirk Mueller <dmueller@suse.com>
  - use setuptools for building to support pip 10.x (bsc#1166139)
* Tue Jan 21 2020 Ondřej Súkup <mimi.vx@gmail.com>
  - update to 1.14.0
    * Add `six.assertNotRegex`
    * `six.moves._dummy_thread` now points to the `_thread` module on
      Python 3.9+. Python 3.7 and later requires threading and deprecated the
      `_dummy_thread` module
    * Remove support for Python 2.6 and Python 3.2
    * `six.wraps` now ignores missing attributes

Files

/usr/lib/python3.11/site-packages/__pycache__/six.cpython-311.opt-1.pyc
/usr/lib/python3.11/site-packages/__pycache__/six.cpython-311.pyc
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/INSTALLER
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/LICENSE
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/METADATA
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/RECORD
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/REQUESTED
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/WHEEL
/usr/lib/python3.11/site-packages/six-1.16.0.dist-info/top_level.txt
/usr/lib/python3.11/site-packages/six.py
/usr/share/doc/packages/python311-six
/usr/share/doc/packages/python311-six/CHANGES
/usr/share/doc/packages/python311-six/README.rst
/usr/share/licenses/python311-six
/usr/share/licenses/python311-six/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri May 17 23:57:33 2024