Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

rabbitmq-server-plugins-3.8.3-lp152.2.3.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 updates for aarch64

Name: rabbitmq-server-plugins Distribution: openSUSE Leap 15.2
Version: 3.8.3 Vendor: openSUSE
Release: lp152.2.3.1 Build date: Wed Sep 29 18:16:19 2021
Group: System/Daemons Build host: obs-arm-10
Size: 3543658 Source RPM: rabbitmq-server-3.8.3-lp152.2.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.rabbitmq.com/
Summary: Plugins for the RabbitMQ server
RabbitMQ is an implementation of an AMQP broker. AMQP is an emerging
standard for messaging.

This package includes some plugins for the RabbitMQ server.

Provides

Requires

License

MPL-1.1

Changelog

* Thu Aug 26 2021 Danilo Spinella <danilo.spinella@suse.com>
  - Fix CVE-2021-32718 improper neutralization of script-related HTML tags in a
    web page (basic XSS) in management UI (CVE-2021-32718, bsc#1187818)
    * fix-CVE-2021-32718.patch
  - Fix CVE-2021-32719 improper neutralization of script-related HTML tags in a
    web page (basic XSS) in federation management plugin (CVE-2021-32719, bsc#1187819)
    * fix-CVE-2021-32719.patch
  - Fix CVE-2021-22116 improper input validation may lead to DoS
    (CVE-2021-22116, bsc#1186203)
    * fix-CVE-2021-22116.patch
  - Use /run instead of /var/run in tmpfiles.d configuration, fix bsc#1185075
* Thu Mar 12 2020 Gabriele Santomaggio <gsantomaggio@suse.de>
  - Update to 3.8.3
  - RabbitMQ 3.8.3 is a maintenance release.
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.8.3
  - RabbitMQ 3.8.3 is a maintenance release.
  - This release requires Erlang/OTP 21.3 or later.
    22.x series is recommended.
  - RabbitMQ 3.8.3 is an RabbitMQ 3.8.0 update
* Mon Feb 24 2020 Gabriele Santomaggio <gsantomaggio@suse.de>
  - jsc#SLE-10913
* Mon Feb 03 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
    shortcut through the -mini flavors.
* Mon Jan 13 2020 Gabriele Santomaggio <g.santomaggio@suse.com>
  - Update to 3.8.2
  - RabbitMQ 3.8.2 is a maintenance release.
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.8.2
  - RabbitMQ 3.8.2 is a maintenance release.
  - This release requires Erlang/OTP 21.3 or later.
    22.x series is recommended.
  - RabbitMQ 3.8.2 is an RabbitMQ 3.8.0 update
  - RabbitMQ 3.8.0 is a feature release. It contains several major improvements
    in areas of data safety, replication, observability, and ease of upgrades.
    Some highlight features are:
    * Quorum Queues
    * Built-in Prometheus support with a set of Grafana dashboards to complement it
    * Feature Flags
    * Single Active Consumer
    * New authentication and authorisation backend that uses OAuth 2.0 (JWT)
      tokens and scopes
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.8.0
  - Read the upgrading guide before update: https://www.rabbitmq.com/upgrade.html
* Fri Dec 06 2019 Gabriele Santomaggio <gsantomaggio@suse.de>
  - Update to RabbitMQ version 3.7.23
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.23
  - RabbitMQ 3.7.23 is a maintenance release that focuses on bug fixes.
  - RabbitMQ 3.7.x series is supported through March 2020.
  - Per the new Erlang version support policy in effect starting with January 2019,
    this release no longer supports Erlang/OTP 20.3.
* Wed Nov 27 2019 Gabriele Santomaggio <gsantomaggio@suse.de>
  - Update to RabbitMQ version 3.7.22
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.22
  - RabbitMQ 3.7.22 is a maintenance release that focuses on bug fixes.
  - RabbitMQ 3.7.x series is supported through March 2020.
  - Per the new Erlang version support policy in effect starting with January 2019,
    this release no longer supports Erlang/OTP 20.3.
* Mon Nov 04 2019 Gabriele Santomaggio <gsantomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.21
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.21
  - RabbitMQ 3.7.21 is a maintenance release that focuses on bug fixes.
  - RabbitMQ 3.7.x series is supported through March 2020.
* Tue Oct 29 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - Update to RabbitMQ version 3.7.20
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.20
  - RabbitMQ 3.7.20 is a maintenance release that focuses on bug fixes.
  - RabbitMQ 3.7.x series is supported through March 2020.
* Mon Oct 14 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.19
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.19
  - RabbitMQ 3.7.19 is a maintenance release that focuses on bug fixes.
  - RabbitMQ 3.7.x series is supported through March 2020.
* Tue Sep 17 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.18
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.18
  - RabbitMQ 3.7.18 is a maintenance release. It focuses on bug fixes and internal
    API changes that refine the common plugin API with the upcoming 3.8.0 version.
* Mon Aug 19 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.17
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.17
  - RabbitMQ 3.7.17 is a maintenance release. It focuses on bug fixes and upgrades
    a JavaScript dependency in the management UI to patch three CVEs in that library.
* Mon Jul 15 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.16
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.16
  - RabbitMQ 3.7.16 is a maintenance release.
    It focuses on bug fixes and minor usability improvements. Erlang/OTP Compatibility Notes
    Per the new Erlang version support policy in effect starting with January 2019,
    this release no longer supports Erlang/OTP 19.3.
    Make sure a supported Erlang version is used before upgrading.
* Tue May 21 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.15
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.15
  - RabbitMQ 3.7.15 is a maintenance release. It focuses on bug fixes and
    minor usability improvements. This release requires Erlang/OTP 20.3 or later.
    It is also the first release to support Erlang 22.
* Fri Apr 26 2019 mvetter@suse.com
  - bsc#1130588: Require shadow instead of old pwdutils
* Fri Mar 29 2019 Gabriele Santomaggio <g.santomaggio@gmail.com>
  - Update to RabbitMQ version 3.7.14
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.14
  - RabbitMQ 3.7.14 is a maintenance release. It focuses on bug fixes and
    minor usability improvements. This release requires Erlang/OTP 20.3 or later.
* Sun Mar 10 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - Update to RabbitMQ version 3.7.13
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.13
  - RabbitMQ 3.7.13 is a maintenance release. It focuses on bug fixes and
    minor usability improvements. This release requires Erlang/OTP 20.3 or later.
* Fri Feb 15 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - Update to RabbitMQ version 3.7.12
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.12
  - RabbitMQ 3.7.12 is a maintenance release. It focuses on bug fixes and
    minor usability improvements. This is the first release to require Erlang/OTP 20.3+.
  - inet_dist_listen_min and inet_dist_listen_max were removed from new style configuration.
    They wouldn't have any effect due to how configuration translation is performed.
    Use advanced.config or the RABBITMQ_DIST_PORT env variable to configure inet_dist_listen_*
* Fri Feb 01 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - Update to RabbitMQ version 3.7.11
  - Full release notes: https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.11
  - RabbitMQ 3.7.11 is a maintenance release. It focuses on bug fixes and
    minor usability improvements. This is the first release to require Erlang/OTP 20.3+.
* Mon Jan 21 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - Update to RabbitMQ version 3.7.10
  - Requires erlang to 20.3, mandatory for RabbitMQ 3.7.10
    see: https://www.rabbitmq.com/which-erlang.html
* Tue Jan 08 2019 Jan Engelhardt <jengelh@inai.de>
  - Avoid name repetition in summary. Trim filler wording from
    descriptions.
* Wed Jan 02 2019 Gabriele Santomaggio <gsantomaggio@suse.com>
  - add the 3.7.x command line tools
* Mon Dec 17 2018 Dirk Mueller <dmueller@suse.com>
  - switch to 3.7.x style rabbitmq-server.conf
  - Remove sd_notify dependency and replace with socat as
    followup to upstream change in
    https://github.com/rabbitmq/rabbitmq-server/pull/666
* Sat Dec 15 2018 Dirk Mueller <dmueller@suse.com>
  - listen to localhost only by default to comply to the epmd.socket
    which also only listens to localhost (bsc#1087270)
* Tue Dec 04 2018 matwey.kornilov@gmail.com
  - Fix Source0 URL
* Fri Nov 16 2018 matwey.kornilov@gmail.com
  - BuildRequire elixir
  - Constrain required erlang versions:
    https://www.rabbitmq.com/which-erlang.html (boo#1115169)
  - Drop sysexists-in-ocf.patch: upstreamed
  - Update to 3.7.9 (fate#322425, bsc#1115466)
  - Changes for 3.7.9:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.8:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.7:
    * Erlang 21 compatibility
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.6:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.5:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.4:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.3:
    * Bug fixes
    * Usability improvements
  - Changes for 3.7.2:
    * Bug fix in the HTTP auth backend
  - Changes for 3.7.1:
    * Bug fixes
  - Changes for 3.7.0:
    * Minimum required Erlang version is now 19.3
    * Automation-friendly cluster formation
    * Distributed management plugin, including minor breaking HTTP API
    changes.
    * Simpler, ini-style configuration format
    * Per-vhost limits
    * Operator policies
    * Topic-based authorisation
    * Cross-protocol Shovel (currently supports AMQP 0.9.1 and AMQP 1.0)
    * Command-line tools are extensible via plugins
    * Message store multi-tenancy
    * Proxy protocol support
    * Web STOMP no longer supports WebSocket emulation
    * Java and .NET client releases no longer track RabbitMQ server
    releases
    * .NET client now supports .NET Core.
    * Management plugin extensions now must target Cowboy 2.0
    * Java client for RabbitMQ HTTP API
* Tue Sep 11 2018 dmueller@suse.com
  - update config.template to use channel_max to 0 (old default,
    mitigate breakage in 3.6.16 change)
* Mon Sep 10 2018 dmueller@suse.com
  - update to 3.6.16 (bsc#1109991):
    Bug fixes:
    + Queue master locator min-masters incorrectly calculated the number of masters.
    + Maximum supported number of queue priorities (255) is now enforced
    Enhancements:
    + queue.delete operations will now force delete queues that don't have a promotable master
    + Lock contention in internal database is now much lower when a node with a lot of exclusive queues
    shuts down or is otherwise considered to be unavailable by peers
    + Default max number of channels allowed on a connection (a.k.a. channel_max) has been lowered from 65535 to 2047.
    The new default is much safer and will reduce the effect application channel leaks have on node resource consumption. This is a potentially breaking change.
* Tue Jun 12 2018 jtomasiak@suse.com
  - Add sysexits-in-ocf.patch to handle new rabbitmqctl exit codes
    (bsc#1093046)
* Mon May 28 2018 bwiedemann@suse.com
  - Add TasksMax=8192 to start on large machines (bsc#1094896)
* Mon Jan 22 2018 vuntz@suse.com
  - Update to 3.6.15:
    + Bug fixes:
    - Avoid infinite loop when dropping entries in the GM.
    - Various changes to the OCF scripts.
    + Enhancements:
    - Internal authN backend will now prohibit logins with a blank
      passwords.
    + Bug fixes in plugins.
  - Remove ocf-pull-request-63.patch, ocf-pull-request-64.patch,
    ocf-pull-request-66.patch: merged upstream.
* Thu Jan 18 2018 vuntz@suse.com
  - Add TimeoutStartSec=300 to rabbitmq-server.service as enabling
    HiPE can make the startup take much longer (documentation says
    "a few minutes").
* Wed Dec 13 2017 vuntz@suse.com
  - Add ocf-pull-request-63.patch and ocf-pull-request-64.patch:
    fixes to avoid moving master unnecessarily, and to make start
    notification handler more reliable.
  - Add ocf-pull-request-66.patch: do not consider transient local
    failures as failures of remote nodes.
* Tue Dec 12 2017 ilausuch@suse.com
  - modified logrotate to use rabbitmqctl to force the creation of the
    log file after logrotation
* Thu Nov 23 2017 rbrown@suse.com
  - Replace references to /var/adm/fillup-templates with new
    %_fillupdir macro (boo#1069468)
* Thu Nov 16 2017 dmueller@suse.com
  - update to 3.6.14:
    * package/systemd bug fixes
    * Usability improvements
    * Bug fixes
* Wed Aug 23 2017 tbechtold@suse.com
  - update to 3.6.11:
    * packaging: package-rpm-suse is an alias for package-rpm-opensuse
    * Makefile: Move plugins list to `plugins.mk`
    * Include rabbitmq_web_mqtt into the distribution
    * Log rabbitmqctl's output on failure
    * Makefile: Set default `broker_version_requirements`
    * packaging/windows: Allow to override `PRODUCTVERSION`
    * debian/control: Revert the use of ${misc:Depends}
    * packaging: Add scripts for format RabbitMQ version to match package constarints
    * Commit Debian and RPM changelogs
    * debian/control: Use ${misc:Depends} instead of hard-coding dependencies
    * Fix HA OCF script
    * Makefile: Store the plugins list in the source archive
    * plugins.mk: The list is overriden by the server-release Concourse pipeline
    * Makefile: Use PROJECT_DESCRIPTION in git-revisions.txt
    * packaging/RPMS: Simplify the Makefile wrapping dpkg-buildpackage(1)
    * Makefile: Sync exclusion list with rabbitmq-erlang-client
    * OCF RA: accept 1 as valid exit code from "rabbitmqctl status"
    * Ignore .envrc files
    * upgrade/Makefile: Remove trailing space
    * standalone/src/rabbit_release.erl: Copy `escript` directory to the archive
    * packaging/standalone: Remove the source `rabbit.rel` file
    * Commit .deb and .rpm change logs
    * OCF RA: Don't hardcode primitive name in rabbitmq-server-ha.ocf
    * Makefile: Use $(PROJECT_VERSION) instead of $(VERSION)
    * debian/control: Add version restriction on erlang-dev and esl-erlang
    * Commit 3.6.9 package change logs
    * packaging/standalone: Fix path to the source `rabbit.rel` file
    * Configure shortcuts to run as admin.
    * Debian package: No need to pass $(VERSION) around in debian/rules
    * Makefile: Use a recursively expanded var for `RABBITMQ_VERSION`
    * Add Travis tests for Pacemaker OCF RA cluster
    * Makefile: Load rabbitmq-dist.mk before rabbitmq-run.mk
    * packaging/debs/Debian/Makefile: Display Erlang version *after* installing it
    * packaging/debs/Debian/scripts/udpate-changelog.sh: Show syntax
    * packaging/standalone: Do not use NUL-separated filenames in manifest
    * packaging/standalone: Copy `start_clean.boot` to bin driectory
    * packaging: rpms: Add systemd support for openSUSE
    * packaging/debs/Debian/Makefile: Install build dependencies
    * packaging/RPMS: Fix SAVE_CHANGELOG handling
    * Makefile: Call $(MAKE), not plain `make`
    * packaging/*/rabbitmq-server.service: Wait for RabbitMQ to stop in ExecStop
    * packaging/debs: Use make conditionals instead of Bourne shell ones
    * packaging/debs: Derive GNUPGHOME from KEYSDIR
    * Add chmod g+s to /etc/rabbitmq
    * packaging/standalone: Remove temporary `expand` directory
    * packaging/windows: Try to compute a valid default `PRODUCTVERSION`
    * Enlist OCF_RESKEY_limit_nofile_default on comment
    * Re-do #21
    * Makefile: Exclude `/rabbit{,mq_cli}/escript/` from the source archive
    * debian/control: Try with erlang-nox 1:16.b.3-3
    * packaging/standalone: Use an intermediate file to list files to archive
    * Makefile: Use an intermediate file to list files to put in the source archive
    * Makefile: Use echo instead of printf
    * debian/control: Depend on erlang-src
    * Change to 2750
    * Trigger a Travis build
    * packaging: Log the version of Erlang used to compile packages
    * Update erlang.mk
    * packaging/debs/apt-repository/distributions: Add `arm64` architecture
    * Require root or rabbitmq user for rabbitmq-plugins.
    * Makefile: Remove more unneeded files from the source archive
    * Update rabbitmq-components.mk
    * Placeholder, remove later.
    * packaging/windows: Bump copyright of the installer to 2017
    * Manually backport #20, #21, #24, #25 by @vuntz and @aplanas to stable
    * packaging/debs: Simplify the Makefile wrapping dpkg-buildpackage(1)
    * plugins.mk: Sort list alphabetically
    * Add write permissions to erl
    * OCF RA: Add new limit_nofile parameter to rabbitmq-server OCF RA
    * packaging/debs/Debian/Makefile: Use cp(1) instead of rsync(1)
    * scripts/rabbitmq-script-wrapper: Run rabbitmq-plugin as root only
    * Remove.
    * Add `standalone-linux-x86_64` and `standalone-freebsd-x86_64` package targets
    * Makefile: Remove all targets entering the `upgrade` subdir
    * OCF RA: Use rabbitmqctl_action wrapper for stop action
    * README.md: Document how to build the source archive and packages
    * README.md: Document how Windows' PRODUCTVERSION is computed by default
    * Add chmod g+s to rpm spec
  - Drop pull-request-20.patch . Applied upstream.
  - Drop pull-request-21.patch . Applied upstream.
  - Drop pull-request-24.patch . Applied upstream.
  - Drop pull-request-25.patch . Applied upstream.
* Wed Apr 05 2017 vuntz@suse.com
  - Stop shipping rabbitmq-server OCF resource agent as source file
    while it's included in the upstream tarball. Add patches for code
    that was specific to our variant; they now got upstreamed, but
    are not in this version of rabbitmq yet: pull-request-20.patch
    and pull-request-21.patch.
  - Also package the rabbitmq-server-ha OCF resource agent as it
    seems to be more appropriate for clustering. Add upstream fixes
    for making it more solid: pull-request-24.patch and
    pull-request-25.patch.
  - Ship an example of /etc/rabbitmq/rabbitmq-env.conf, as this is
    useful indication. It only contains commented examples, based on
    what the Debian package is doing.
* Wed Feb 15 2017 mrueckert@suse.de
  - Cleanup file list and prepare merging the plugins package into
    the main package:
    - No longer create parts of the filelist in %install
    - Only exclude the plugins starting with rabbitmq_* and not all
      files in the plugin dir. Some of the files are basic libraries
      needed to even launch rabbitmq. (boo#1025442)
  - in the tmpfiles.d file: make the directory group owned
  - own the run dir in the non systemd case
* Mon Feb 13 2017 mrueckert@suse.de
  - add buildrequires for xz to fix build on sle11
* Thu Feb 09 2017 mrueckert@suse.de
  - drop no-remove-common.patch and no-nmap.patch:
    no longer needed
* Thu Feb 09 2017 mrueckert@suse.de
  - add back default config from the 3.5.8 package as 3.6.6 doesn't
    ship one anymore
  - rabbitmq-script-wrapper now directly talks to the scripts in
    _rabbit_erllibdir instead of having another indirection.
  - moved tmpfiles.d support into the main systemd install block
  - extracted make cmdline options into a variable
* Mon Feb 06 2017 mrueckert@suse.de
  - update to 3.6.6
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_6
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_5
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_4
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_3
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_2
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_1
    https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_6_0
* Mon Feb 06 2017 mrueckert@suse.de
  - fix source url
* Mon Feb 06 2017 mrueckert@suse.de
  - IMPORTANT CHANGE
    Require the epmd service instead of running our own version as
    rabbitmq user.
    This requires that you configure epmd to listen on more
    interfaces than just 127.0.0.1.
    For non systemd based distributions you can set EPMD_ADDRESSES in
    /etc/sysconfing/erlang.
    For systemd based distributions please follow
    /usr/share/doc/packages/erlang/README.SUSE
    IMPORTANT CHANGE
    This change is also documented in
    /usr/share/doc/packages/rabbitmq-server/README.SUSE
* Tue Jan 17 2017 chris@intrbiz.com
  - Update to 3.5.8
    Fixes logging issues on erlang 17+
    Fixes MQTT password authentication error (CVE-2016-9877) (boo#1017642)
* Thu Apr 14 2016 aplanas@suse.com
  Fix bsc#973999
  - rabbitmq-server.service: increase NOFILE limit per documentation
  - rabbitqm-server.ocf: add OCF_RESKEY_limit_nofile parameter
    default as 65535
* Mon Sep 28 2015 dmueller@suse.com
  - rabbitmqctl: clear CMDLINE before appending
* Thu Sep 24 2015 dmueller@suse.com
  - update to 3.5.4:
    Runtime I/O thread pool size is now 64 instead of 30 by default.
    This reduces time spent waiting for file I/O operations to complete
    on machines with 8 or more cores.
    * https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_5_4
* Wed Jun 24 2015 dmueller@suse.com
  - rabbitmq-server.service: switch to type=Notify in order to
    avoid cookie creation race
* Tue Jun 23 2015 tbechtold@suse.com
  - update to 3.5.3:
    3.5.2 and 3.5.3 are bugfix releases. See:
    * https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_5_2
    * https://github.com/rabbitmq/rabbitmq-server/releases/tag/rabbitmq_v3_5_3
* Sun Apr 12 2015 mrueckert@suse.de
  - update to 3.5.1
    This release adds support for priority queues which were available
    as a plugin before. Performance is improved; in particular messages
    smaller than configurable size are embedded in the queue index to
    reduce I/O and memory consumption. Stability of clustering and
    autoheal partition handling is improved as well. A new
    pause_if_all_down partition handling mode is added. The management
    web UI now shows many more I/O statistics.
    This release also corrects a number of defects in the broker and
    plugins, as well as introducing many smaller new features and
    improvements.
    * see https://www.rabbitmq.com/release-notes/README-3.5.1.txt
    * see https://www.rabbitmq.com/release-notes/README-3.5.0.txt
    * see https://www.rabbitmq.com/release-notes/README-3.4.4.txt
  - instead of patching the ocf provider after copying: patch it
    right away and drop the ocf-fixes.patch.
  - refresh no-nmap.patch to apply cleanly again
  - create rcrabbitmq-server for the systemd case
* Wed Jan 21 2015 dmueller@suse.com
  - update to 3.4.3:
    * prevent XSS attack in table key names (since 2.4.0)
      (CVE-2015-0862)
    * prevent XSS attack in policy names (since 3.4.0)
      (CVE-2015-0862)
    * prevent XSS attack in client details in the connections list
      (CVE-2015-0862)
    * prevent XSS attack in user names in the vhosts list or the vhost names
      in the user list (since 2.4.0)
      (CVE-2015-0862)
    * prevent XSS attack in the cluster name (since 3.3.0)
      (CVE-2015-0862)
    * prevent /api/* from returning text/html error messages which could
      act as an XSS vector (since 2.1.0)
    * fix response-splitting vulnerability in /api/downloads (since 2.1.0)
    * do not trust X-Forwarded-For header when enforcing 'loopback_users'
      (CVE-2014-9494)
    * disable SSLv3 by default to prevent the POODLE attack
    * see https://www.rabbitmq.com/release-notes/README-3.4.3.txt
    * see https://www.rabbitmq.com/release-notes/README-3.4.2.txt
    * see https://www.rabbitmq.com/release-notes/README-3.4.1.txt
    * see https://www.rabbitmq.com/release-notes/README-3.4.0.txt
* Mon Nov 24 2014 dmueller@suse.com
  - ignore stop errors in %preun

Files

/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_amqp1_0-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_auth_backend_cache-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_auth_backend_http-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_auth_backend_ldap-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_auth_backend_oauth2-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_auth_mechanism_ssl-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_aws-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_consistent_hash_exchange-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_event_exchange-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_federation-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_federation_management-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_jms_topic_exchange-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_management-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_management_agent-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_mqtt-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_peer_discovery_aws-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_peer_discovery_common-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_peer_discovery_consul-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_peer_discovery_etcd-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_peer_discovery_k8s-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_prometheus-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_random_exchange-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_recent_history_exchange-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_sharding-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_shovel-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_shovel_management-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_stomp-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_top-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_tracing-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_trust_store-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_web_dispatch-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_web_mqtt-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_web_mqtt_examples-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_web_stomp-3.8.3.ez
/usr/lib64/rabbitmq/lib/rabbitmq_server-3.8.3/plugins/rabbitmq_web_stomp_examples-3.8.3.ez


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Dec 2 23:36:37 2021