Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

nautilus-deja-dup-40.6-lp152.2.3.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 updates for aarch64

Name: nautilus-deja-dup Distribution: openSUSE Leap 15.2
Version: 40.6 Vendor: openSUSE
Release: lp152.2.3.1 Build date: Fri Jul 9 18:13:25 2021
Group: Productivity/Archiving/Backup Build host: obs-arm-11
Size: 68056 Source RPM: deja-dup-40.6-lp152.2.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://wiki.gnome.org/Apps/DejaDup
Summary: Déjà Dup Plugin for Nautilus
Déjà  Dup is a simple backup tool. It hides the complexity of doing
backups the 'right way' (encrypted, off-site, and regular) and uses
duplicity as the backend.

Features:
 * Support for local or remote backup locations, including Amazon S3
 * Securely encrypts and compresses your data
 * Incrementally backs up, letting you restore from any particular backup
 * Schedules regular backups
 * Integrates well into your GNOME desktop

This package contains a plugin to integrate Déjà Dup into Nautilus.

Provides

Requires

License

GPL-3.0-or-later

Changelog

* Tue Jun 15 2021 Michael Gorse <mgorse@suse.com>
  - Up duplicity dependency to Requires: deja-dup cannot run without
    it (boo#1187256).
* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - No longer recommend -lang: supplements are in use
* Thu Jan 16 2020 Paolo Stivanin <info@paolostivanin.com>
  - Add meson version to spec file
  - Drop deja-dup-duplicity-Mark-GPGError-extern.patch: Fixed
    upstream.
* Thu Jan 16 2020 Paolo Stivanin <info@paolostivanin.com>
  - Update to 40.6:
    + Fixes a bug that prevented backing up to Google Drive accounts
      with unlimited quotas
    + Fix a bug that prevented backing up to Google Drive in some
      rare situations
    + Fix a bug that prevented the first login to Google Drive
    + Fix a bug that prevented resuming a full backup
    + Fix 2038 date problems by using 64-bit dates internally
    + Fix building against valac 0.45.2 and later
    + Add optional dependency on libgdk-x11-3.0 (only used in flatpak
      builds)
    + Make libgoa-1.0 an optional dependency (still recommended for a
      few years though)
    + Support autostarting via the new Background portal
    + Updated translations.
* Mon Sep 02 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Add deja-dup-duplicity-Mark-GPGError-extern.patch: Mark GPGError
    as extern and prevent GPG symbols to be public API. Also fixes
    building with new vala.
* Fri Jul 05 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 40.1:
    + Fix versioning to be correct.
  - Changes from version 40.0:
    + Fix tests when run under glib 2.60
    + Updated translations.
  - Changes from version 39.1:
    + Fix a bug that could have caused backups to be encrypted with
      two different passwords in some cases. This would result in
      difficulty backing up or restoring by not accepting the
      password you expected it to.
    + Fix a bug that caused duplicate save or exclude folders to
      appear in the preferences.
    + Delete a canary file that duplicity's pydrive puts in your
      Drive.
    + If you don't ask for your password to be saved, we now clear
      out any older saved password.
    + Finally delete the ancient Ubuntu One backend code.
  - Changes from version 39.0:
    + Switch away from GNOME Online Accounts to our own cloud keys:
    - It was brought to our attention that we shouldn't be using
      GNOME's keys, as they are intended for GNOME only.
    - Google accounts will have to be re-authenticated with our
      keys.
    - Nextcloud accounts will now appear as webdav network server
      accounts.
    - Adds new pydrive_pkgs option to list the package names needed
      for the pydrive duplicity backend (for now, the system
      package that provides the pydrive python2 package should
      suffice).
    - Adds new google_client_id option if you want to override our
      default account key and use your own. You likely won't want
      to do this.
    - Adds new dependencies on libjson-glib and libsoup.
    - Drops libgoa-backend dependency. The libgoa dependency will
      stay during a transition period from the old keys to the new
      keys.
    + Unmount a remote backup location when we are done with it, if
      we originally mounted it.
  - Add pkgconfig(json-glib-1.0) and pkgconfig(libsoup-2.4)
    BuildRequires: New dependencies.
  - Drop pkgconfig(goa-backend-1.0) BuildRequires: No longer needed,
    nor used.
  - Reenable meson_tests, upstream fixed the issues.
* Tue Feb 26 2019 bjorn.lie@gmail.com
  - Update to version 38.4:
    + Update app icon.
    + Don't run monitor when automatic backups are disabled.
    + Drop libpeas dependency.
    + Fix compilation with valac 0.43.
    + Be more forgiving if packagekit is unresponsive.
    + Updated translations.
  - Drop deja-dup-fix-build-vala043.patch: Fixed upstream.
  - Drop pkgconfig(libpeas-1.0) BuildRequires: No longer needed.
* Sun Feb 10 2019 bjorn.lie@gmail.com
  - Add deja-dup-fix-build-vala043.patch: Fix build with new vala
    0.43.x.
  - Disable meson_test, currently fails.
* Thu Jan 17 2019 bjorn.lie@gmail.com
  - Update to version 38.3:
    + Allow restoring from paths with symlinks in more situations
      (including a fix for a backup error when ~/.cache is a
      symlink).
    + Treat operation dialogs more like real dialogs (modal to
      preference window, with correct styling on default buttons).
    + Try harder to stop running duplicity commands when we are
      terminated.
    + Don't hide an error message when also running our bimonthly
      backup verification.
    + If there isn't enough space in the backup location, tell the
      user how much is needed.
    + Exclude flatpak cache directories by default.
* Mon Jan 07 2019 bjorn.lie@gmail.com
  - Update to version 38.2:
    + Fix not being able to find the backup files when restoring on
      a fresh install.
  - Changes from version 38.1:
    + Use a primary menu instead of an AppMenu, per current GNOME
      recommendations.
    + Drop support for the legacy desktop status icon.
    + Updated translations.
  - Drop meson version fix via sed in spec, no longer needed.
  - Stop exporting optflags and rpath before configure, no longer
    needed.
  - Renable meson test, tests are now ok.
* Fri Apr 13 2018 luc14n0@linuxmail.org
  - Update to version 38.0:
    + Drop ulimit for monitor process, it was causing crashes.
    + Fix autoscrolling in progress window.
    + Exclude snap cache directories by default.
    + Updated translations.
  - Add gio-2.0, gio-unix-2.0 and goa-backend-1.0 pkgconfig modules
    and glib2-tools package BuildRequires to avoid implicit
    dependencies.
  - Replace pkgconfig(appstream-builder), dbus-1-x11, update-desktop\
    - files and perl-gettext BuildRequires with appstream-glib, dbus-\
    1, desktop-file-utils and gettext-runtime respectively, what
    meson really looks for.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Wed Jan 17 2018 luc14n0@linuxmail.org
  - Update to version 37.1:
    + Add new Google Drive backend and make it the new default
      backend.
    + Updated translations.
  - Update Url to https://wiki.gnome.org/Apps/DejaDup: current Deja
    Dup's GNOME web page.
  - Point fdupes to the data directory instead of the build root,
    which is a practice that must be avoided.
  - Drop %glib2_gsettings_schema_requires macro: it's no longer
    needed since RPM File Triggers.
* Sun Nov 05 2017 badshah400@gmail.com
  - Update to version 36.3:
    + Fix the restore dialog sometimes being blank.
    + Updated translations.
* Fri Oct 20 2017 badshah400@gmail.com
  - Update to version 36.2:
    + Fix crash when trying to restore missing files.
    + Fix the UI from freezing for a second when mounting the
      backend location.
    + Updated translations.
* Sat Sep 30 2017 luc14n0@linuxmail.org
  - Update to version 36.1:
    + Fix backing up to external drives.
    + Updated translations.
  - Drop deja-dup-fix-setting-drive-volume.patch: Fixed upstream.
* Fri Sep 15 2017 zaitor@opensuse.org
  - Add deja-dup-fix-setting-drive-volume.patch: BackendDrive: Fix
    setting a drive volume (lp#1717230).
* Wed Sep 13 2017 zaitor@opensuse.org
  - Update to version 36.0:
    + data: Don't depend on bash.
    + BackendRemote:
    - Guard against returning a null GFile if we can't find mount.
    - Handle the user specifying a non-utf8 folder.
    + Updated translations.
* Thu Sep 07 2017 zaitor@opensuse.org
  - Update to version 35.6:
    + Fix a potential memory leak in the monitor daemon and few other
      bugs.
  - Changes from version 35.5:
    + Improve on-the-fly dependency installation and fixes a few
      other interaction bugs.
  - Changes from version 35.4:
    + Add support for GNOME Online Accounts and cleans up the
      interface a bit.
  - Changes from version 35.3:
    + Fix some bugs around unicode filenames and network access.
  - Changes from version 35.2:
    + Fix a crash we cause in nautilus with our extension.
  - Changes from version 35.1:
    + Fix a header-color bug introduced in the previous release and
      also try to fix a long-standing bug around backup/restore
      buttons being disabled too often.
  - Changes from version 35.0:
    + Modernize the code base in a few ways that make the experience
      better in GNOME 3.
  - Add meson BuildRequires and switch cmake macros cmake, make and
    cmake_install to meson, meson_build and meson_install following
    upstream switch to Meson build system.
  - Drop intltool BuildRequires: No longer needed.
  - Add libgpg-error-devel, pkgconfig(appstream-builder) and
    pkgconfig(goa-1.0) BuildRequires: New dependencies.
  - Drop deja-dup-vala-0.36.patch: Fixed upstream.
  - Drop deja-dup-help2man_stderr.patch: No longer needed after the
    port to meson.
  - Drop handling of localized man pages in install section, no
    longer needed.
  - Drop suse_update_desktop files macros, no longer needed.
  - Drop obsolete post(un) handling of following macros:
    glib2_gsettings_schema_post(un), desktop_database_post(un) and
    icon_theme_cache_post(un).
* Thu Jun 29 2017 tchvatal@suse.com
  - Fix obvious typo } instead of )
* Sat Jun 17 2017 dimstar@opensuse.org
  - Add deja-dup-vala-0.36.patch: Fix build with vala 0.36. Patch is
    only applied when vala version 0.36 or newer is found (since
    upstream is not yet clear if they just want to require a new vala
    version or possibly support older ones too).
* Thu Jan 26 2017 firebird209@gmail.com
  - Update to version 34.3:
    + Fix a bug that allowed an incorrect password when making a
      new full backup.
    + Updated translations.
* Thu Oct 13 2016 dimstar@opensuse.org
  - Fix deja-dup-help2man_stderr.patch: the introduction of
    - -no-discard-stderr actually only hid the underlying issue:
    deja-dup is being started from the 'build' directory and its
    libraries are not yet installed. As a consequence, the ld loader
    can't find them, resulting in broken man pages. Change the patch
    to no longer pass --no-discard-stderr (same as upstream) but
    inject LD_LIBRARY_PATH in order to find the two libs
    (boo#992499).
* Sun Apr 24 2016 zaitor@opensuse.org
  - Update to version 34.2:
    + This version fixes a bug that prevented restoring some files
      with unicode characters (boo#990937).
    + Updated translations.
* Thu Dec 31 2015 badshah400@gmail.com
  - Update to version 34.1:
    + Add experimental support for Google Cloud Storage, please test
      and file bugs.
    + Add experimental support for OpenStack Swift, please test and
      file bugs.
    + Fix a bug where the error dialog wasn't visible after a failed
      backup in GNOME.
    + Fix a bug where background backups were using smaller 'nice'
      values than they should have.
    + Drop support for building the GNOME Control Center plugin;
      upstream hasn't supported that for a while, and Ubuntu finally
      dropped their patch allowing it.
    + Install duplicity on demand if needed.
    + Support reproducible builds by using $SOURCE_DATE_EPOCH to set
      the man page timestamps, if present.
    + Updated translations.
  - Add BuildRequires: pkgconfig(packagekit-glib2), needed for the
    install duplicity on demand feature.
  - Due to above change, change duplicity Requires to Recommends.
* Sat Apr 11 2015 zaitor@opensuse.org
  - Update to version 34.0:
    + Support duplicity 0.6.25 and up.
    + Support latest versions of appstream-util.
    + Updated translations.

Files

/usr/lib64/nautilus/extensions-3.0/libdeja-dup.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Dec 2 23:36:37 2021