Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

fwupdate-devel-12-lp152.6.6.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 updates for aarch64

Name: fwupdate-devel Distribution: openSUSE Leap 15.2
Version: 12 Vendor: openSUSE
Release: lp152.6.6.1 Build date: Thu Apr 8 12:14:05 2021
Group: Development/Libraries/Other Build host: obs-arm-4
Size: 5394 Source RPM: fwupdate-12-lp152.6.6.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/rhinstaller/fwupdate
Summary: Development headers for libfwup
development headers required to use libfwup.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Tue Mar 30 2021 Gary Ching-Pang Lin <glin@suse.com>
  - Add fwupdate-bsc1182057-add-sbat-support.patch to add SBAT
    section to EFI images (bsc#1182057)
    + Also specify the vendor SBAT
* Wed Oct 16 2019 Gary Ching-Pang Lin <glin@suse.com>
  - Add fwupdate-bsc1152928-update-aarch64-linker-script.patch to
    update the linker script for AArch64 to match the one in
    gnu-efi (bsc#1152928)
* Mon Jan 28 2019 Gary Ching-Pang Lin <glin@suse.com>
  - Fix the destination of 'efi'-executables for i586 (FATE#326960)
* Thu Jan 17 2019 rw@suse.com
  - Move 'efi'-executables to '/usr/share/efi'  (FATE#326960)
* Tue Oct 23 2018 Gary Ching-Pang Lin <glin@suse.com>
  - Amend the spec file to avoid fwup*.efi from being removed
    mistakenly (bsc#1112832)
* Thu Jul 19 2018 bjorn.lie@gmail.com
  - Update to version 12 (FATE#326702)
    + Better CI.
    + Limit how large our WMI buffer can be.
    + Add fwup_version() because fwupd wants it.
    + Fix linking on (some) platforms that need libgcc_eh.a.
    + abicheck improvements.
    + Default to creating a UX capsule, whatever it may actually do.
  - Refresh fwupdate-suse-build.patch with quilt.
  - Use url for source tarball and license tag for COPYING.
* Thu Jun 28 2018 glin@suse.com
  - Correct the requirement of efivar-devel version
* Wed Jun 20 2018 oliver@getspam.de
  - Update to version 11
    + lots of fixes from cov-scan and clang analyzer
    + support for Lenovo machines
    + experimental support for UI Capsules
    + Dell WMI support
    + lots of bugfixes
    + configurable EFI ESP location by setting ESPMOUNTPOINT or the git
      config property fwupdate.espmountdir during the build.
    + Lots of coverity work
    + ABI compatibility checking during the release process
    + Make subdirectory builds work
  - removed fwupdate-list-firmware-types.patch
* Mon Apr 09 2018 glin@suse.com
  - Require shim only for x86_64 (bsc#1088434)
* Fri Feb 09 2018 glin@suse.com
  - Remove fwupdate-bsc988886-add-leading-space.patch and bump the
    shim version requirement since we got the new signature for shim
    (bsc#1054712)
* Mon Dec 18 2017 mls@suse.de
  - bring back accidental removed needssslcertforbuild
* Fri Dec 15 2017 stefan.bruens@rwth-aachen.de
  - EFI updates through fwupdate are also possible on Aarch64.
    smbios support is only relevant for some Dell machines, i.e.
    x86 only.
* Thu Dec 14 2017 mls@suse.de
  - disable _unique_debug_names fow now
    fwupdate wants to install it's own debug files, but doesn't know
    about this option yet
* Mon Nov 20 2017 glin@suse.com
  - Add back fwupdate-bsc988886-add-leading-space.patch due to the
    long pending shim signature request. Also drop the shim version
    requirement.
* Tue Aug 29 2017 glin@suse.com
  - Update to 9+git21.gcd8f7d7 (FATE#322805)
  - Add the new BuildRequires: libsmbios-devel
  - Update the so version of libfwup
  - Refresh fwupdate-suse-build.patch
  - Remove the upstream patches
    + fwupdate-fix-efivar-0.24-api.patch
    + fwupdate-bsc988000-set-a-mode-with-efi_set_variable.patch
    + fwupdate-unset-immutable-flag.patch
  - Drop fwupdate-bsc988886-add-leading-space.patch (Need shim >= 11)
  - Add fwupdate-list-firmware-types.patch to list the supported
    firmware types
* Thu Mar 30 2017 glin@suse.com
  - Remove the debug source and info of the EFI files when disabling
    the debug build (bsc#1031554)
    + Also remove the efi-debuginfo subpackage since the debug file
      is packaged correctly now.
* Thu Mar 09 2017 rw@suse.com
  - Enable efivar API patch based on pkg-config data and require
    at least gnu-efi-3.0.2.  (ramification of FATE#322108)
* Thu Jul 28 2016 glin@suse.com
  - Relax the requirement of efivar-devel and disable the efivar API
    patch for openSUSE Leap 42.x and SLE
* Thu Jul 21 2016 glin@suse.com
  - Amend the spec file to detect SLE/openSUSE (bsc#990228)
* Fri Jul 15 2016 glin@suse.com
  - Add fwupdate-fix-efivar-0.24-api.patch to fix the compilation
    errors due to the change of efivar APIs
  - Bump BuildRequires of efivar-devel to 0.24
  - Add fwupdate-unset-immutable-flag.patch to unset the immutable
    flag before clean the EFI variables (bsc#964726)
  - Amend fwupdate-suse-build.patch (FATE#319345)
    + omit the build-id and package fwudpate-efi-debuginfo in a less
      hacky way.
    + Use the RPM_OPT_FLAGS for the user space programs
  - Add fwupdate-bsc988886-add-leading-space.patch to add the leading
    space to the load option (bsc#988886)
* Thu Jul 07 2016 glin@suse.com
  - Correct the EFI dir for SLE-12-SP2 (FATE#319345)
  - Install fwup*.efi to the EFI system partition (FATE#319345)
  - Add fwupdate-bsc988000-set-a-mode-with-efi_set_variable.patch to
    fix the file mode (bsc#988000)
* Sun May 08 2016 jengelh@inai.de
  - Drop unnecessary specfile elements.
    fwupdate seems not required for libfwup, remove the requirement.
  - Correct requires of fwupdate-devel
  - Use source URLs
* Fri May 06 2016 coolo@suse.com
  - own bash-completion directory as no longer provided by
    util-linux (boo#977259)
* Mon Mar 28 2016 glin@suse.com
  - Add the missing Group
* Wed Mar 02 2016 glin@suse.com
  - initial import 0.5 (FATE#319345)
  - Add fwupdate-suse-build.patch to change the destination of the
    EFI files and remove the po files

Files

/usr/include/fwup-version.h
/usr/include/fwup.h
/usr/lib64/libfwup.so
/usr/lib64/pkgconfig/fwup.pc
/usr/share/man/man3/fwup_clear_status.3.gz
/usr/share/man/man3/fwup_get_fw_type.3.gz
/usr/share/man/man3/fwup_get_fw_version.3.gz
/usr/share/man/man3/fwup_get_guid.3.gz
/usr/share/man/man3/fwup_get_last_attempt_info.3.gz
/usr/share/man/man3/fwup_get_lowest_supported_version.3.gz
/usr/share/man/man3/fwup_get_ux_capsule_info.3.gz
/usr/share/man/man3/fwup_resource_free.3.gz
/usr/share/man/man3/fwup_resource_iter_create.3.gz
/usr/share/man/man3/fwup_resource_iter_destroy.3.gz
/usr/share/man/man3/fwup_resource_iter_next.3.gz
/usr/share/man/man3/fwup_set_guid.3.gz
/usr/share/man/man3/fwup_set_guid_forced.3.gz
/usr/share/man/man3/fwup_set_up_update.3.gz
/usr/share/man/man3/fwup_supported.3.gz
/usr/share/man/man3/libfwup.3.gz
/usr/share/man/man3/libfwup.h.3.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 29 23:59:34 2021