Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libwsman_client5-2.7.0-4.2 RPM for s390x

From OpenSuSE Ports Tumbleweed for s390x

Name: libwsman_client5 Distribution: openSUSE:Factory:zSystems
Version: 2.7.0 Vendor: obs://build.opensuse.org/openSUSE:Factory:zSystems
Release: 4.2 Build date: Wed Jun 15 18:30:11 2022
Group: System/Libraries Build host: s390zl28
Size: 49932 Source RPM: openwsman-2.7.0-4.2.src.rpm
Url: http://www.openwsman.org/
Summary: An implementation of the WS-MAN specification
OpenWSMAN is an implementation of the WS-Management protocol stack.
Web Services for Management (WS-MAN) is a specification for managing
computer systems using web services standards.

This subpackage provides the client libraries of OpenWSMAN.

Provides

Requires

License

BSD-3-Clause AND GPL-2.0-only

Changelog

* Thu Apr 28 2022 Jan Engelhardt <jengelh@inai.de>
  - Resolve rpmlint report "libwsman3.x86_64: E:
    shlib-policy-name-error SONAME: libwsman.so.1, expected package
    suffix: 1" (packaging bug introduced by the update to v2.6.1 on
    Aug 28 2015)
* Wed Oct 13 2021 Johannes Segitz <jsegitz@suse.com>
  - Added hardening to systemd service(s) (bsc#1181400). Added patch(es):
    * harden_openwsman.service.patch
    Modified:
    * openwsman.service
* Mon Aug 24 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Use more appropriate %{_prefix}/lib for firewalld service
    definitions (boo#1174075).
* Mon May 25 2020 Klaus Kämpf <kkaempf@suse.com>
  - Update to 2.7.0
    * API change:
      client_opt: expiry and hearbeat_interval are float (Alexander Usyskin)
      wsmc_set_sub_expiry() and wsmc_set_heartbeat_interval() change their
      first parameter from int to float
    * bump so version of libwsman_client from 4 to 5
    * split off client libraries from server libraries
      libwsman_client5 is separate from libwsman3 now.
  - Features
    * new functions for C++ bindings: OpenWsmanClient::GetWithFlags()
      and OpenWsmanClient::PutWithFlags to add a 'flags' parameter
      (Alexander Usyskin)
    * add FLAG_SUPRESS_100_CONTINUE to options, fixes #131 to workaround
      a curl problem. Reportedly curl 7.69.0 fixes this also in curl.
      (Alexander Usyskin)
  - Fixes
    * fixed several compiler warnings (Alexander Usyskin)
    * fixed spelling errors (Tomas Winkler)
* Fri Oct 04 2019 Klaus Kämpf <kkaempf@suse.com>
  - Update to 2.6.13
    * Bugfixes
    - fixed several compiler warnings (Alexander Usyskin)
    - code cleanup (Alexander Usyskin)
    - general code robustness (Alexander Usyskin)
* Tue Sep 17 2019 Klaus Kämpf <kkaempf@suse.com>
  - Update to 2.6.12
    * Bugfix release
    - fix regression from 2.5.0: __cimnamespace selector was not
      properly set in requests.
* Tue Sep 17 2019 Klaus Kämpf <kkaempf@suse.com>
  - Update to 2.6.11
    * Bugfix release
    - prevent double free in events error processing
* Wed Aug 07 2019 Klaus Kämpf <kkaempf@suse.com>
  - Update to 2.6.10
    * install firewalld configuration (Leap/SLE 15+, Fedora 15+)
    * Fix possible denial of service (bsc#1122623, CVE-2019-3816, CVE-2019-3833)
    * Pthread usage fixes (Alexander Usyskin)
    * Convert sprintf to snprintf and strcpy to strncpy (Tomas Winkler)
    * Many potential NULL dereferences fixed (Alexander Usyskin)
  - drop bsc1122623.patch and debug_fix.patch, upstreamed
* Wed Jun 12 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
    shortcut the build queues by allowing usage of systemd-mini
* Wed Apr 03 2019 Adam Majer <adam.majer@suse.de>
  - bsc1122623.patch: (bsc#1122623, CVE-2019-3816, CVE-2019-3833)
    + treat all non-registered by provider paths as invalid
    + fix possible denial of service in path parsing
  - debug_fix.patch: fix compilation in debug mode
  - use OBS specific BuildIgnore syntax that is rpm friendly. This is
    to prevent rpm parser from reporting errors.
* Tue Jan 08 2019 olaf@aepfle.de
  - Remove comment from postun scriptlet because it generates a
    script which is not understood by specified interpreter

Files

/etc/openwsman/openwsman_client.conf
/usr/lib64/libwsman_client.so.5
/usr/lib64/libwsman_client.so.5.0.0
/usr/share/doc/packages/libwsman_client5
/usr/share/doc/packages/libwsman_client5/AUTHORS
/usr/share/licenses/libwsman_client5
/usr/share/licenses/libwsman_client5/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jul 14 00:15:54 2022