Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ruby3.1-rubygem-sprockets-4.1.1-1.1 RPM for ppc64

From OpenSuSE Ports Tumbleweed for ppc64

Name: ruby3.1-rubygem-sprockets Distribution: openSUSE Tumbleweed
Version: 4.1.1 Vendor: openSUSE
Release: 1.1 Build date: Fri Jul 8 14:35:08 2022
Group: Development/Languages/Ruby Build host: obs-power9-07
Size: 385996 Source RPM: rubygem-sprockets-4.1.1-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/rails/sprockets
Summary: Rack-based asset packaging system
Sprockets is a Rack-based asset packaging system that concatenates and serves
JavaScript, CoffeeScript, CSS, Sass, and SCSS.

Provides

Requires

License

MIT

Changelog

* Fri Jul 08 2022 Manuel Schnitzer <mschnitzer@suse.com>
  - updated to version 4.1.1
    no changelog found
* Fri Mar 11 2022 Manuel Schnitzer <mschnitzer@suse.com>
  - updated to version 4.0.3
    * Fix `Manifest#find` yielding from a Promise causing issue on Ruby 3.1.0-dev. [#720](https://github.com/rails/sprockets/pull/720)
    * Better detect the ERB version to avoid deprecation warnings. [#719](https://github.com/rails/sprockets/pull/719)
    * Allow assets already fingerprinted to be served through `Sprockets::Server`
    * Do not fingerprint files that already contain a valid digest in their name
    * Remove remaining support for Ruby < 2.4.[#672](https://github.com/rails/sprockets/pull/672)
* Thu Jun 25 2020 Manuel Schnitzer <mschnitzer@suse.com>
  - updated to version 4.0.2
    * Fix `etag` and digest path compilation that were generating string with invalid digest since 4.0.1.
* Tue Nov 12 2019 Manuel Schnitzer <mschnitzer@suse.com>
  - updated to version 4.0.0
    * Fixes for Ruby 2.7 keyword arguments warnings #625
    * Manifest files are sorted alphabetically #626
* Tue Jun 19 2018 factory-auto@kulow.org
  - updated to version 3.7.2
    see installed CHANGELOG.md
    * *3.7.2** (June 19, 2018)
    * Security release for [CVE-2018-3760](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-3760).
    (bsc#1098369)
* Tue Dec 20 2016 coolo@suse.com
  - updated to version 3.7.1
    see installed CHANGELOG.md
* Sat Jul 23 2016 coolo@suse.com
  - updated to version 3.7.0
    see installed CHANGELOG.md
    * * 3.7.0** (July 21, 2016)
    * Deprecated interfaces now emit deprecation warnings #345
* Mon Jul 04 2016 coolo@suse.com
  - updated to version 3.6.3
    see installed CHANGELOG.md
    * *3.6.3** (July 1, 2016)
    * Faster asset lookup in large directories #336
    * Faster PathUtils.match_path_extname https://github.com/rails/sprockets/commit/697269cf81e5261fdd7072e32bd489403027fd7e
    * Fixed uglifier comment stripping #326
    * Error messages now show load path info #313
* Wed Jun 29 2016 coolo@suse.com
  - updated to version 3.6.2
    see installed CHANGELOG.md
    * *3.6.2** (June 21, 2016)
    * More performance improvements.
* Sat Jun 18 2016 coolo@suse.com
  - updated to version 3.6.1
    see installed CHANGELOG.md
    * *3.6.1** (June 17, 2016)
    * Some performance improvements.

Files

/etc/alternatives/sprockets
/etc/alternatives/sprockets-4.1.1
/etc/alternatives/sprockets.ruby3.1
/usr/bin/sprockets
/usr/bin/sprockets-4.1.1
/usr/bin/sprockets.ruby3.1
/usr/bin/sprockets.ruby3.1-4.1.1
/usr/lib64/ruby/gems/3.1.0/build_info
/usr/lib64/ruby/gems/3.1.0/cache/sprockets-4.1.1.gem
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/CHANGELOG.md
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/MIT-LICENSE
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/README.md
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/bin
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/bin/sprockets
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/rake
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/rake/sprocketstask.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/add_source_map_comment_to_asset_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/asset.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/babel.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/closure.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/coffee_script.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/eco.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/ejs.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/jsminc.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/sass.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/sassc.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/uglifier.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/yui.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/autoload/zopfli.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/babel_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/base.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/bower.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/bundle.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cache
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cache.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cache/file_store.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cache/memory_store.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cache/null_store.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/cached_environment.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/closure_compressor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/coffee_script_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/compressing.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/configuration.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/context.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/dependencies.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/digest_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/directive_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/eco_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/ejs_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/encoding_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/environment.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/erb_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/errors.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporters
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporters/base.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporters/file_exporter.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporters/zlib_exporter.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporters/zopfli_exporter.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/exporting.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/file_reader.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/http_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/jsminc_compressor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/jst_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/loader.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/manifest.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/manifest_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/mime.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/npm.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/path_dependency_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/path_digest_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/path_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/paths.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/preprocessors
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/preprocessors/default_source_map.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/processing.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/processor_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/resolve.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sass_cache_store.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sass_compressor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sass_functions.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sass_importer.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sass_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sassc_compressor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/sassc_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/server.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/source_map_processor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/source_map_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/transformers.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/uglifier_compressor.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/unloaded_asset.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/uri_tar.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/uri_utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/utils
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/utils.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/utils/gzip.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/version.rb
/usr/lib64/ruby/gems/3.1.0/gems/sprockets-4.1.1/lib/sprockets/yui_compressor.rb
/usr/lib64/ruby/gems/3.1.0/specifications/sprockets-4.1.1.gemspec
/usr/share/doc/packages/ruby3.1-rubygem-sprockets
/usr/share/doc/packages/ruby3.1-rubygem-sprockets/CHANGELOG.md
/usr/share/doc/packages/ruby3.1-rubygem-sprockets/MIT-LICENSE
/usr/share/doc/packages/ruby3.1-rubygem-sprockets/README.md


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Oct 9 10:32:30 2022