Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

obs-service-set_version-0.5.14-1.1 RPM for noarch

From OpenSuSE Ports Tumbleweed for noarch

Name: obs-service-set_version Distribution: openSUSE:Factory:zSystems
Version: 0.5.14 Vendor: obs://build.opensuse.org/openSUSE:Factory:zSystems
Release: 1.1 Build date: Sun Jul 18 23:51:45 2021
Group: Development/Tools/Building Build host: s390zp28
Size: 18725 Source RPM: obs-service-set_version-0.5.14-1.1.src.rpm
Url: https://github.com/openSUSE/obs-service-set_version
Summary: An OBS source service: Update spec file version
This is a source service for openSUSE Build Service.

Very simply script to update the version in .spec or .dsc files according to
a given version or to the existing files.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Wed Jul 14 2021 FSchreiner@suse.com
  - Update to version 0.5.14:
    * changed debugging output to logging module
    * Explicitely specifying --fromfile should win over .obsinfo
    * Add new switch --fromfile
    * Add zst to recognized suffixes (zstd support)
* Mon Feb 01 2021 FSchreiner@suse.com
  - Update to version 0.5.13:
    * add license file
    * fixing suffixes - remove backslashes
    * fix suffixes to begin with a dot
    * enhanced debug mode
    * tests for directory pristine-tar
* Wed Aug 07 2019 FSchreiner@suse.com
  - Update to version 0.5.12:
    * debian: set script shebang to python3
    * debian: add python3 as a runtime dependency
    * conditionally define PYTHON in Makefile
    * debian: use python3 for building
    * try to fix set_version:157:13: E117 over-indented (comment)
* Thu May 16 2019 John Whately <john+OpenSuse@whately.me>
  - Modified .spec file to better suit Fedora OS (let's just assume all Fedora versions has python 3)
* Thu May 16 2019 FSchreiner@suse.com
  - Update to version 0.5.11:
    * try to fix set_version:157:13: E117 over-indented (comment)
* Tue May 14 2019 Adrian Schröter <adrian@suse.de>
  - enable test suite by default
    * if it does not build, it can also not be executed on the distro
  - fix requires for SLE 12 distro
* Thu May 09 2019 John Whately <john+OpenSuse@whately.me>
  - Changed source files to support python 3
* Sat May 04 2019 John Whately <john+OpenSuse@whately.me>
  - fix for Fedora 30/Rawhide
* Mon Nov 26 2018 ro@suse.de
  - for now obs_scm_testsuite only for > 1315, needed python stuff
    not available otherwise
* Fri Nov 16 2018 opensuse-packaging@opensuse.org
  - Update to version 0.5.11:
    * fix code to pass flake8 tests for python3
    * fix zipfile crash also for python2.7
    * avoid error with latest flake8 about unused variable
    * allow running tests with python3
    * second place where zip file handling can crash
    * avoid crashes due to false is_zipfile() response
    * Add python-flake8 to test suite package list
    * Fix indentation of condition
    * Fix basename to match documentation (#54)
* Wed Sep 19 2018 adrian@suse.de
  - Update to version 0.5.10:
    * fix zipfile crash also for python2.7
* Mon Sep 17 2018 olaf@aepfle.de
  - Wrap make check in bcond obs_scm_testsuite
* Mon Sep 17 2018 adrian@suse.de
  - Update to version 0.5.9:
    * avoid crashes due to false is_zipfile() response
  - enable test suite

Files

/usr/lib/obs
/usr/lib/obs/service
/usr/lib/obs/service/set_version
/usr/lib/obs/service/set_version.service


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 14:53:45 2021