Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libtss2-tcti-tabrmd0-3.0.0-2.4 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libtss2-tcti-tabrmd0 Distribution: openSUSE Tumbleweed
Version: 3.0.0 Vendor: openSUSE
Release: 2.4 Build date: Sat Feb 10 00:52:08 2024
Group: System/Libraries Build host: i02-armsrv2
Size: 67596 Source RPM: tpm2.0-abrmd-3.0.0-2.4.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/tpm2-software/tpm2-abrmd
Summary: Client interface library for tpm2-abrmd
This library allows to interact with the tpm2-abrmd daemon. It is intended for
use with the SAPI library (libtss2-sys) like any other TCTI.

Provides

Requires

License

BSD-2-Clause

Changelog

* Tue May 23 2023 Alberto Planas Dominguez <aplanas@suse.com>
  - Cover ALP via the %{suse_version} macro
* Thu Dec 08 2022 Alberto Planas Dominguez <aplanas@suse.com>
  - Version 3.0.0
    + Fixed
    * A bug in special command processing in TPM2_GetCapability when
      an audit session is in use cuased tpm2-abrmd to abort.
    + Added
    * New SELinux interfaces for communication with keylime
    + Changed
    * DBUS permissions in tpm2-abrmd.conf to match the in-kernel RM,
      ie /dev/tpmrm0, permissions. Now users MUST be in the tss group
      to send to tpm2-abrmd over DBUS.
  - Drop dbus-access.patch (merged in PR#805)
* Fri Jul 08 2022 Alberto Planas Dominguez <aplanas@suse.com>
  - Version 2.4.1
    + Added
      Contributor Covenant Code of Conduct.
    + Fixed
    * superflous warning messages about tcti status.
      WARNING **: 11:00:56.205: tcti_conf before: "(null)"
      WARNING **: 11:00:56.205: tcti_conf after: "mssim"
    * GCC 11 build error: error: argument 2 of __atomic_load’ discards
      'volatile' qualifier
    * Initialize gerror pointer variable to NULL to fix use of
      unitialized memory and segfault.
    * Updated missing defaults in manpage.
    * Port CI to composite actions in tpm2-software/ci.
    + Removed
      Dependency on 'which' utility in configure.ac.
      ubuntu-16.04 from CI.
* Mon Apr 04 2022 Matthias Gerstner <matthias.gerstner@suse.com>
  - dbus-access.patch: restrict D-Bus access to tpm2-abrmd to members of the tss
    group (bsc#1197532). This prevents arbitrary users from meddling with TPM
    state and thus potential denial-of-service vectors.
* Wed Dec 08 2021 Alberto Planas Dominguez <aplanas@suse.com>
  - Version 2.4.0
    + remover syslog deprecation warning (bsc#1185154)
    + cover update to 2.3.3 (jsc#SLE-17366)
    + contains reload fix (bsc#1166936)
    + fix tcti loading using short / long names (bsc#1159176)
* Mon Nov 29 2021 Alberto Planas Dominguez <aplanas@suse.com>
  - Warp selinux into a bcond
* Thu Nov 25 2021 Johannes Segitz <jsegitz@suse.com>
  - Added hardening to systemd service(s) (bsc#1181400). Added patch(es):
    * harden_tpm2-abrmd.service.patch
* Sat Jul 17 2021 Callum Farmer <gmbr3@opensuse.org>
  - Move selinux devel file to devel subpackage
* Wed Jul 14 2021 Callum Farmer <gmbr3@opensuse.org>
  - Update to version 2.4.0:
    - Service start depends on systemd device unit: dev-tpm0.device.
    - Numerous memory leaks.
    - udev settle service deprecation warnings.
    - StandardOutput=syslog deprecation warnings.
  - Add selinux module files
  - Move dbus files out of /etc
* Wed Jun 09 2021 Alberto Planas Dominguez <aplanas@suse.com>
  - Requires libtss2-tcti-{device0,tabrmd0} (bsc#1187077).
    In MicroOS systems the recommendations are not installed, making the
    service fail to initialize: Failed to instantiate TCTI

Files

/usr/lib64/libtss2-tcti-tabrmd.so.0
/usr/lib64/libtss2-tcti-tabrmd.so.0.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue May 28 01:02:35 2024