Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

enblend-enfuse-4.2-6.2 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: enblend-enfuse Distribution: openSUSE Tumbleweed
Version: 4.2 Vendor: openSUSE
Release: 6.2 Build date: Fri May 28 03:45:27 2021
Group: Productivity/Graphics/Other Build host: obs-arm-9
Size: 7094816 Source RPM: enblend-enfuse-4.2-6.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://enblend.sourceforge.net/
Summary: Tool for Composing Images
Enblend is a tool for compositing images using a Burt & Adelson
multiresolution spline. This technique tries to make the seams between
the input images invisible. The basic idea is that image features
should be blended across a transition zone, proportional in size to the
spatial frequency of the features. For example, objects like trees and
window panes have rapid changes in color. By blending these features in
a narrow zone, you cannot see the seam because the eye already expects
to see color changes at the edge of these features. Clouds and sky are
the opposite. These features must be blended across a wide transition
zone because any sudden change in color is immediately noticeable.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Sat Mar 27 2021 Antoine Belvire <antoine.belvire@opensuse.org>
  - Add enblend-enfuse-4.2-gcc-10.patch: Fix build with GCC 10
    (picked from Gentoo, https://bugs.gentoo.org/723306).
* Tue Sep 17 2019 Bernhard Wiedemann <bwiedemann@suse.com>
  - Add reproducibledate.patch to override build date (boo#1047218)
  - Add reproducible.patch to override build hostname (boo#1084909)
* Fri Jul 27 2018 jengelh@inai.de
  - Update RPM groups.
* Tue Jun 19 2018 asn@cryptomilk.org
  - Switched to cmake build
    * Removed patch for autotools: enblend-latex-optional.patch
  - Added enblend-enfuse-4.2-add-missing-cmakelists.patch
  - Enabled support for OpenMP
  - Enabled support for SSE2
  - Turn on optimizations again
  - Info pages are no longer available
  - Added PDF documentation for enblend and enfuse
* Wed Feb 01 2017 adam.majer@suse.de
  - use individual libboost-*-devel packages instead of boost-devel
* Mon May 30 2016 astieger@suse.com
  - specify boost build dependendy version
* Thu May 26 2016 dimstar@opensuse.org
  - Update to version 4.2:
    + All deprecated options and features of version 4.1 have been
      removed.
    + Enblend and Enfuse support layer (aka "page", aka "frame")
      selection in of multi-layer image-files. This includes
      processing any layers in user-defined order.
    + Both Enblend and Enfuse can now perform all their pyramidal
      blending operations in CIELAB (aka L*a*b*, aka L-star) and
      CIELUV (aka L*u*v*) color spaces, too.
    + The new Graph-Cut algorithm is the default primary seam-line
      generator.
    + Avoid a division-by-zero in the Annealing Optimizer.
    + Fix a bug (sf#1356551) in the seam-line vectorization code that
      was there since 2004. The fix changes the position of almost
      any coarse-mask seam line vertex by one pixel.
    + Fix a longstanding quirk, which allowed to load masks into
      Enblend and Enfuse that were unsuitable for processing.
    + Fix a bug in the highlight-recovery that caused Enfuse to bail
      out with the uncaught exception "Minimizer1D::set_bracket:
      minimum not bracketed".
    + The OpenMP enabled versions of Enblend and Enfuse benefit from
      Google's TCMalloc library.
    + Several exposure weight functions were added to Enfuse. The
      choice is now up to the user. The default still is the Gauss
      function as in all Enfuse versions before.
  - Add texlive-latex-bin-bin BuildRequires: new dependency.
  - Drop use-default-gcc-inlining.diff: no longer needed.
  - Add enblend-latex-optional.patch: Allow building without
    documentation, that is, make latex optional.
  - Toggle _build_doc to 1: building documentation works again.
* Tue Dec 08 2015 p.drouand@gmail.com
  - Update to version 4.1.4
    * The introduction of additional blend color spaces in the Development
      Branch requires a new option to select them.    Here, in the Stable
      Branch, the new option `  *  * blend  * colorspace' just duplicates the
      functionality of `  *  * ciecam' and `  *  * no  * ciecam'.    The Stable Branch
      does *not* provide the additional blend colorspaces of the
      Development Branch.    The following equivalences hold
    * * ciecam         <=>      *  * blend  * colorspace=ciecam
    * * no  * ciecam    <=>      *  * blend  * colorspace=identity
      Both options `  *  * ciecam' and `  *  * no  * ciecam' are deprecated in 4.2 and
      will be withdrawn in 4.3.    Thus, users should prefer
      `  *  * blend  * colorspace'.
    * [Enblend and Enfuse] Fix the nesting  * depth counter for response
      files.    This bug prohibited to load more than 20 images in a single
      response file.
    * [Enblend and Enfuse] Allow grayscale images to bring their own
      (grayscale) profiles.    Previously grayscale images with ICC profiles
      were rejected.
    * [Enblend] Fix a possible domain error followed by a division  * by  * zero
      in the seam  * line optimizer.
    * [Enblend and Enfuse] Avoid an undeserved warning about incompatible
      colorspaces if they only disagree on their meta  * data (e.g. profile
      creation date/time).
    * [Enblend] Fix a bug in the Dijkstra Optimizer which could lead to
      undefined behavior in the placement of the (optimized) seam line.
    * [Enblend] Fix a non  * dereferencable vector iterator which led to a
      segfault.
    * [Enblend] Avoid a division  * by  * zero in the Annealing Optimizer.
    * [Enblend] Fix a bug (#1356551) in the seam  * line vectorization code
      that was there since 2004.    The fix changes the position of almost
      any coarse  * mask seam line vertex by one pixel.
  - Update use-default-gcc-inlining.diff
  - Add libICE-devel and pkg-config build dependencies
* Wed Feb 11 2015 dimstar@opensuse.org
  - Introduce _build_doc defines (currently set to 0): Allow to
    easily enable/disable the building of the documentation (incl.
    the reevant BuildRequires and file sections). Currently disabled,
    as enblend fails with texinfo 5.1; upstream is aware but there
    are multiple ways the texi files are broken (mainly using invalid
    characters for defintions).
* Sun Nov 16 2014 meissner@suse.com
  - no more upstream tarball signatures, no need for gpg offline

Files

/usr/bin/enblend
/usr/bin/enfuse
/usr/share/doc/packages/enblend-enfuse
/usr/share/doc/packages/enblend-enfuse/AUTHORS
/usr/share/doc/packages/enblend-enfuse/NEWS
/usr/share/doc/packages/enblend-enfuse/README
/usr/share/licenses/enblend-enfuse
/usr/share/licenses/enblend-enfuse/COPYING
/usr/share/man/man1/enblend.1.gz
/usr/share/man/man1/enfuse.1.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Oct 12 23:47:16 2021