Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

cabal-install-bash-completion-2.4.0.0-lp151.1.3 RPM for ppc64le

From OpenSuSE Ports Leap 15.1 for ppc64le

Name: cabal-install-bash-completion Distribution: openSUSE Leap 15.1
Version: 2.4.0.0 Vendor: openSUSE
Release: lp151.1.3 Build date: Thu Apr 11 22:39:21 2019
Group: System/Shells Build host: obs-power8-05
Size: 3082 Source RPM: cabal-install-2.4.0.0-lp151.1.3.src.rpm
Packager: https://bugs.opensuse.org
Url: https://hackage.haskell.org/package/cabal-install
Summary: Bash completion for cabal-install
Optional sub-package offering bash completion for cabal-install.

Provides

Requires

License

BSD-3-Clause

Changelog

* Sat Dec 08 2018 Peter Simons <psimons@suse.com>
  - Tweak Cabal build instructions to accept zip-archive 0.4.x.
* Sun Dec 02 2018 Peter Simons <psimons@suse.com>
  - Update Cabal build instructions to support network version 2.8.x.
* Thu Oct 04 2018 psimons@suse.com
  - Update cabal-install to version 2.4.0.0.
    * Bugfix: "cabal new-build --ghc-option '--bogus' --ghc-option '-O1'"
      no longer ignores all arguments except the last one (#5512).
    * Add the following option aliases for '-dir'-suffixed options:
      'storedir', 'logsdir', 'packagedir', 'sourcedir', 'outputdir' (#5484).
    * 'new-run' now allows the user to run scripts that use a special block
      to define their requirements (as in the executable stanza) in place
      of a target. This also allows the use of 'cabal' as an interpreter
      in a shebang line.
    * Add aliases for the "new-" commands that won't change when they
      lose their prefix or are eventually replaced by a third UI
      paradigm in the future. (#5429)
    * 'outdated' now accepts '--project-file FILE', which will look for bounds
      from the new-style freeze file named FILE.freeze. This is only
      available when `--new-freeze-file` has been passed.
    * 'new-repl' now accepts a '--build-depends' flag which accepts the
      same syntax as is used in .cabal files to add additional dependencies
      to the environment when developing in the REPL. It is now usable outside
      of projects. (#5425, #5454)
    * 'new-build' now treats Haddock errors non-fatally. In addition,
      it attempts to avoid trying to generate Haddocks when there is
      nothing to generate them from. (#5232, #5459)
    * 'new-run', 'new-test', and 'new-bench' now will attempt to resolve
      ambiguous selectors by filtering out selectors that would be invalid.
      (#4679, #5461)
    * 'new-install' now supports installing libraries and local
      components. (#5399)
    * Drop support for GHC 7.4, since it is out of our support window
      (and has been for over a year!).
    * 'new-update' now works outside of projects. (#5096)
    * Extend `plan.json` with `pkg-src` provenance information. (#5487)
    * Add 'new-sdist' command (#5389). Creates stable archives based on
      cabal projects in '.zip' and '.tar.gz' formats.
    * Add '--repl-options' flag to 'cabal repl' and 'cabal new-repl'
      commands. Passes its arguments to the invoked repl, bypassing the
      new-build's cached configurations. This assures they don't trigger
      useless rebuilds and are always applied within the repl. (#4247, #5287)
    * Add 'v1-' prefixes for the commands that will be replaced in the
      new-build universe, in preparation for it becoming the default.
      (#5358)
    * 'outdated' accepts '--v1-freeze-file' and '--v2-freeze-file'
      in the same spirit.
    * Completed the 'new-clean' command (#5357). The functionality is
      equivalent to old-style clean, but for nix-style builds.
    * Ensure that each package selected for a build-depends dependency
      contains a library (#5304).
    * Support packages from local tarballs in the cabal.project file.
    * Default changelog generated by 'cabal init' is now named
      'CHANGELOG.md' (#5441).
    * Align output of 'new-build' command phases (#4040).
* Wed Jul 18 2018 psimons@suse.com
  - Cosmetic: replace tabs with blanks, strip trailing white space,
    and update copyright headers with spec-cleaner.
* Mon May 14 2018 psimons@suse.com
  - Update cabal-install to version 2.2.0.0 revision 1.
    * '--with-PROG' and '--PROG-options' are applied to all packages
      and not local packages only (#5019).
    * Completed the 'new-update' command (#4809), which respects nix-style
      cabal.project(.local) files and allows to update from
      multiple repositories when using overlays.
    * Completed the 'new-run' command (#4477). The functionality is the
      same of the old 'run' command but using nix-style builds.
      Additionally, it can run executables across packages in a project.
      Tests and benchmarks are also treated as executables, providing a
      quick way to pass them arguments.
    * Completed the 'new-bench' command (#3638). Same as above.
    * Completed the 'new-exec' command (#3638). Same as above.
    * Added a preliminary 'new-install' command (#4558, nonlocal exes
      part) which allows to quickly install executables from Hackage.
    * Set symlink-bindir (used by new-install) to .cabal/bin by default on
      .cabal/config initialization (#5188).
    * 'cabal update' now supports '--index-state' which can be used to
      roll back the index to an earlier state.
    * '--allow-{newer,older}' syntax has been enhanced. Dependency
      relaxation can be now limited to a specific release of a package,
      plus there's a new syntax for relaxing only caret-style (i.e. '^>=')
      dependencies (#4575, #4669).
    * New config file field: 'cxx-options' to specify which options to be
      passed to the compiler when compiling C++ sources specified by the
      'cxx-sources' field. (#3700)
    * New config file field: 'cxx-sources' to specify C++ files to be
      compiled separately from C source files. Useful in conjunction with the
      'cxx-options' flag to pass different compiler options to C and C++
      source files. (#3700)
    * Use [lfxtb] letters to differentiate component kind instead of
      opaque "c" in dist-dir layout.
    * 'cabal configure' now supports '--enable-static', which can be
      used to build static libaries with GHC via GHC's `-staticlib`
      flag.
    * 'cabal user-config now supports '--augment' which can append
      additional lines to a new or updated cabal config file.
    * Added support for '--enable-tests' and '--enable-benchmarks' to
      'cabal fetch' (#4948).
    * Misspelled package-names on CLI will no longer be silently
      case-corrected (#4778).
    * 'cabal new-configure' now backs up the old 'cabal.project.local'
      file if it exists (#4460).
    * On macOS, `new-build` will now place dynamic libraries into
      `store/lib` and aggressively shorten their names in an effort to
      stay within the load command size limits of macOSs mach-o linker.
    * 'new-build' now checks for the existence of executables for
      build-tools and build-tool-depends dependencies in the solver
      (#4884).
    * Fixed a spurious warning telling the user to run 'cabal update'
      when it wasn't necessary (#4444).
    * Packages installed in sandboxes via 'add-source' now have
      their timestamps updated correctly and so will not be reinstalled
      unncecessarily if the main install command fails (#1375).
    * Add Windows device path support for copyFile, renameFile. Allows cabal
      new-build to use temporary store path of up to 32k length
      (#3972, #4914, #4515).
    * When a flag value is specified multiple times on the command
      line, the last one is now preferred, so e.g. '-f+dev -f-dev' is
      now equivalent to '-f-dev' (#4452).
    * Removed support for building cabal-install with GHC < 7.10 (#4870).
    * New 'package *' section in 'cabal.project' files that applies
      options to all packages, not just those local to the project.
    * Paths_ autogen modules now compile when `RebindableSyntax` or
      `OverloadedStrings` is used in `default-extensions`.
      [stack#3789](https://github.com/commercialhaskell/stack/issues/3789)
    * getDataDir` and other `Paths_autogen` functions now work
      correctly when compiling a custom `Setup.hs` script using
      `new-build` (#5164).
    * Support for GHC's numeric -g debug levels (#4673).
    * Demoted 'scope' field version check to a warning (#4714).
    * Fixed verbosity flags getting removed before being passed to
      'printPlan' (#4724).
    * Added a '--store-dir' option that can be used to configure the
      location of the build global build store (#4623).
    * Turned `allow-{newer,older}` in `cabal.project` files into an
      accumulating field to match CLI flag semantics (#4679).
    * Improve success message when `cabal upload`ing documentation
      (#4777).
    * Documentation fixes.
    * See http://coldwa.st/e/blog/2017-09-09-Cabal-2-0.html
      for more detailed release notes.
    * Removed the '--root-cmd' parameter of the 'install' command
      (#3356).
    * Deprecated 'cabal install --global' (#3356).
    * Changed 'cabal upload' to upload a package candidate by default
      (#3419). Same applies to uploading documentation.
    * Added a new 'cabal upload' flag '--publish' for publishing a
      package on Hackage instead of uploading a candidate (#3419).
    * Added optional solver output visualisation support via the
      tracetree package. Mainly intended for debugging (#3410).
    * Removed the '--check' option from 'cabal upload'
      (#1823). It was replaced by package candidates.
    * Fixed various behaviour differences between network transports
      (#3429).
    * The bootstrap script now works correctly when run from a Git
      clone (#3439).
    * Removed the top-down solver (#3598).
    * The '-v/--verbosity' option no longer affects GHC verbosity
      (except in the case of '-v0'). Use '--ghc-options=-v' to enable
      verbose GHC output (#3540, #3671).
    * Changed the default logfile template from
      '.../$pkgid.log' to '.../$compiler/$libname.log' (#3807).
    * Added a new command, 'cabal reconfigure', which re-runs 'configure'
      with the most recently used flags (#2214).
    * Added the '--index-state' flag for requesting a specific
      version of the package index (#3893, #4115).
    * Support for building Backpack packages.  See
      https://github.com/ezyang/ghc-proposals/blob/backpack/proposals/0000-backpack.rst
      for more details.
    * Support the Nix package manager (#3651).
    * Made the 'template-haskell' package non-upgradable again (#4185).
    * Fixed password echoing on MinTTY (#4128).
    * Added a new solver flag, '--allow-boot-library-installs', that allows
      any package to be installed or upgraded (#4209).
    * New 'cabal-install' command: 'outdated', for listing outdated
      version bounds in a .cabal file or a freeze file (#4207).
    * Added qualified constraints for setup dependencies. For example,
    - -constraint="setup.bar == 1.0" constrains all setup dependencies on
      bar, and --constraint="foo:setup.bar == 1.0" constrains foo's setup
      dependency on bar (part of #3502).
    * Non-qualified constraints, such as --constraint="bar == 1.0", now
      only apply to top-level dependencies. They don't constrain setup or
      build-tool dependencies. The new syntax --constraint="any.bar == 1.0"
      constrains all uses of bar.
    * Added a technical preview version of the 'cabal doctest' command
      (#4480).
* Thu Aug 03 2017 psimons@suse.com
  - Updated with latest spec-cleaner version 0.9.8-8-geadfbbf.
* Sat May 27 2017 psimons@suse.com
  - Update to version 1.24.0.2 revision 1.
* Wed Apr 26 2017 psimons@suse.com
  - Add bash-completion sub-package that provides the auto-completion
    instructions for bash.
* Sun Feb 12 2017 psimons@suse.com
  - Update to version 1.24.0.2 with cabal2obs.
* Mon Nov 21 2016 psimons@suse.com
  - Update to version 1.24.0.0 revision 2 with cabal2obs.
* Thu Sep 15 2016 psimons@suse.com
  - Update to version 1.24.0.0 revision 1 with cabal2obs.
* Sun Jul 10 2016 psimons@suse.com
  - Update to version 1.22.9.0 revision 0 with cabal2obs.
* Mon Mar 07 2016 mimi.vx@gmail.com
  - update to 1.22.9.0
    * Include Cabal-1.22.8.0
* Mon Feb 01 2016 mimi.vx@gmail.com
  - update to 1.22.8.0
    * Only Custom setup scripts should be compiled with '-i -i.'.
    * installedCabalVersion: Don't special-case Cabal anymore.
    * Bump the HTTP upper bound.
* Sun Jan 24 2016 mimi.vx@gmail.com
  - relax HTTP dep
* Mon Dec 28 2015 mimi.vx@gmail.com
  - update to 1.22.7.0
    * Remove GZipUtils tests
    * maybeDecompress: bail on all errors at the beginning of the stream with zlib < 0.6
    * Correct maybeDecompress
* Wed Jul 08 2015 peter.trommler@ohm-hochschule.de
  - update to 1.22.6.0
    * work with ghc 7.10
    * bug fixes
* Sun May 10 2015 mimi.vx@gmail.com
  - update to 1.18.1.0
    * Force cabal upload to always use digest auth and never basic auth.
    * Merge pull request #2367 from juhp/patch-2
    * Fix bootstrap.sh by bumping HTTP to 4000.2.16.1
* Fri Apr 10 2015 mimi.vx@gmail.com
  - update to 1.18.0.8
    * Support random 1.1.
    * Fix bootstrap script after network package split.
    * Support network-2.6 in test suite.

Files

/usr/share/bash-completion
/usr/share/bash-completion/completions
/usr/share/bash-completion/completions/cabal


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 12:13:44 2021