Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

hplip-sane-3.17.9-lp150.3.2 RPM for aarch64

From OpenSuSE Ports Leap 15.0 for aarch64

Name: hplip-sane Distribution: openSUSE Leap 15.0
Version: 3.17.9 Vendor: openSUSE
Release: lp150.3.2 Build date: Fri May 11 21:32:49 2018
Group: Hardware/Scanner Build host: obs-arm-2
Size: 199984 Source RPM: hplip-3.17.9-lp150.3.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://hplipopensource.com
Summary: Only plain scanning with HPLIP scan drivers
This sub-package includes only what is needed for plain scanning
with the scan drivers in HPLIP for standard HP all-in-one printers.

Provides

Requires

License

BSD-3-Clause and GPL-2.0+ and MIT

Changelog

* Thu Mar 22 2018 mwilck@suse.com
  - photocard.py: fixed broken import statement (bsc#1071255)
    * added photocard-fix-import-error-for-pcardext.patch
    * spec file: fixed dependency for dbus-1-python
* Wed Mar 21 2018 mwilck@suse.com
  - Use python3 on tumbleweed and SLE15/Leap15 (bsc#1071255)
    * add pcardext-python3-fixes.patch
    * add hplip-misc-missing-includes-and-definitions.patch
    * hp_ipp.h-add-missing-prototypes.patch
    * spec file: replace "/usr/bin/env python" and "/usr/bin/python" with
      desired interpreter
    * spec file: add py2/py3 selection macros
    * spec file: dropped python-openssl build dependency (not needed anymore)
* Thu Oct 12 2017 mgorse@suse.com
  - Add no-systray-failure-message.patch: don't display an error if
    unable to find a system tray (boo#1061211).
* Wed Oct 04 2017 mwilck@suse.com
  - Version update to 3.17.9:
    * Added support for the following new printers:
    - HP OfficeJet Pro 7720 Wide Format All-in-One
    - HP DeskJet AMP All-in-One Printer
    - HP OfficeJet 5220 All-in-One Printer
    - HP OfficeJet 5230 All-in-One Printer
    - HP OfficeJet 5232 All-in-One Printer
    - HP ENVY Photo 6220 All-in-One Printer
    - HP ENVY Photo 6232 All-in-One Printer
    - HP ENVY Photo 7120 All-in-One Printer
    - HP ENVY Photo 7134 All-in-One Printer
    - HP ENVY Photo 7820 All-in-One Printer
    - HP ENVY 5020 All-in-One Printer
    - HP ENVY 5032 All-in-One Printer
    - HP DeskJet Ink Advantage 3735 All-in-One
    - HP ENVY Photo 6234 All-in-One Printer
    - HP ENVY Photo 6230 All-in-One Printer
    - HP AMP 130 All-in-One Printer
    - HP OfficeJet Pro 7730 Wide Format All-in-One
    - HP ENVY Photo 7155 All-in-One Printer
    - HP ENVY Photo 7164 All-in-One Printer
    - HP ENVY Photo 7155 All-In-One Printer
    - HP ENVY Photo 7800 All-In-One Printer
    - HP ENVY Photo 6200 All-In-One Printer
    - HP ENVY Photo 7130 All-in-One Printer
    - HP ENVY Photo 7830 All-in-One Printer
    - HP ENVY Photo 7120 All-in-One Printer
    - HP ENVY Photo 7820 All-in-One Printer
    - HP ENVY Photo 7855 All-in-One Printer
    - HP DeskJet Ink Advantage 5075 All-in-One Printer
    - HP PageWide Enterprise Color 765dn
    - HP PageWide Managed Color E75160dn
    - HP PageWide Enterprise Color MFP 780dn
    - HP PageWide Enterprise Color Flow MFP 785f
    - HP PageWide Enterprise Color Flow MFP 785zs
    - HP PageWide Enterprise Color Flow MFP 785z+
    - HP PageWide Managed Color MFP E77650dn
    - HP PageWide Managed Color MFP E77650dns
    - HP PageWide Managed Color MFP E77660dn
    - HP PageWide Managed Color Flow MFP E77650z
    - HP PageWide Managed Color Flow MFP E77650zs
    - HP PageWide Managed Color Flow MFP E77650z+
    - HP PageWide Managed Color Flow MFP E77660z
    - HP PageWide Managed Color Flow MFP E77660zs
    - HP PageWide Managed Color Flow MFP E77660z+
    * from 3.17.7:
    - HP DeskJet Ink Advantage 2635 All-in-One
    - HP DeskJet Ink Advantage 2636 All-in-One
    - HP DeskJet Ink Advantage 2675 All-in-One
    - HP DeskJet Ink Advantage 2676 All-in-One
    - HP DeskJet Ink Advantage 2677 All-in-One
    - HP DeskJet Ink Advantage 2678 All-in-One
    - HP DeskJet 2620 All-in-One
    - HP DeskJet 2621 All-in-One
    - HP DeskJet 2622 All-in-One
    - HP DeskJet 2623 All-in-One
    - HP DeskJet Ink Advantage 2200 All-in-One
    - HP DeskJet 3722 All-in-One
    - HP DeskJet Ink Advantage 3789 All-in-One
    - HP DeskJet Ink Advantage 3790 All-in-One
* Fri Aug 25 2017 fvogt@suse.com
  - Default to Qt5 on SLE 15 as well to avoid Qt4 with dependency on
    openSSL 1.0
* Tue Jul 11 2017 mwilck@suse.com
  - Version Upgrade to 3.17.6:
    * Added support for the following new printers:
    - HP LaserJet Enterprise M607n
    - HP LaserJet Enterprise M607dn
    - HP LaserJet Enterprise M608n
    - HP LaserJet Enterprise M608dn
    - HP LaserJet Enterprise M608x
    - HP LaserJet Enterprise M608dh
    - HP LaserJet Enterprise M609dn
    - HP LaserJet Enterprise M609x
    - HP LaserJet Managed E60055dn
    - HP LaserJet Managed E60065dn
    - HP LaserJet Managed E60065x
    - HP LaserJet Managed E60075dn
    - HP LaserJet Managed E60075x
    - HP LaserJet Enterprise MFP M631dn
    - HP LaserJet Enterprise Flow MFP M631h
    - HP LaserJet Enterprise MFP M631z
    - HP LaserJet Enterprise Flow MFP M632z
    - HP LaserJet Enterprise MFP M632fht
    - HP LaserJet Enterprise MFP M632h
    - HP LaserJet Enterprise Flow MFP M633z
    - HP LaserJet Enterprise MFP M633fh
    - HP LaserJet Managed MFP E62555dn
    - HP LaserJet Managed Flow MFP E62565h
    - HP LaserJet Managed MFP E62565hs
    - HP LaserJet Managed Flow MFP E62565z
    - HP LaserJet Managed Flow MFP E62575z
    - HP Color LaserJet Enterprise M652dn
    - HP Color LaserJet Enterprise M652n
    - HP Color LaserJet Enterprise M653dn
    - HP Color LaserJet Enterprise M653dh
    - HP Color LaserJet Enterprise M653x
    - HP Color LaserJet Managed E65050dn
    - HP Color LaserJet Managed E65060dn
    - HP Color LaserJet Managed MFP E67550dh
    - HP Color LaserJet Managed Flow MFP E67560z
    - HP Color LaserJet Enterprise MFP M681dh
    - HP Color LaserJet Enterprise MFP M681f
    - HP Color LaserJet Enterprise Flow MFP M681z
    - HP Color LaserJet Enterprise Flow MFP M681f
    - HP Color LaserJet Enterprise Flow MFP M682z
    - HP PageWide Managed P77750z Multifunction Printer
    - HP Pagewide Pro 750dn
    - HP Pagewide Pro 750dw
    - HP PageWide Pro 772dw Multifunction Printer
    - HP PageWide Managed P77740zs Multifunction Printer
    - HP PageWide Managed P77750zs Multifunction Printer
    - HP PageWide Managed P75050dn Printer
    - HP LaserJet Pro MFP M25a
    - HP LaserJet Pro MFP M25nw
    - HP LaserJet Pro MFP M26a
    - HP LaserJet Pro MFP M26nw
    - HP LaserJet Pro MFP M27c
    - HP LaserJet Pro MFP M27cnw
    * Bug fixes (launchpad):
    - 1690515 - DeskJet 3775 - scanner not found
    - 1690516 - Head alignment dont work (HPLIP 3.17.4)
* Sun Apr 30 2017 bwiedemann@suse.com
  - call gzip -n to make build more reproducible
* Thu Apr 27 2017 dsterba@suse.cz
  - Version upgrade to 3.17.4:
    * Added Support for the Following New Printers:
    - HP LaserJet Managed Flow MFP E77822z Printer
    - HP LaserJet Managed MFP E77822dn Printer
    - HP LaserJet Managed Flow MFP E77825z Printer
    - HP LaserJet Managed MFP E77825dn Printer
    - HP LaserJet Managed Flow MFP E77830z Printer
    - HP LaserJet Managed MFP E77830dn Printer
    - HP LaserJet Managed Flow MFP E87640z Printer
    - HP LaserJet Managed MFP E87640dn Printer
    - HP LaserJet Managed Flow MFP E87650z Printer
    - HP LaserJet Managed MFP E87650dn Printer
    - HP LaserJet Managed Flow MFP E87660z Printer
    - HP LaserJet Managed MFP E87660dn Printer
    - HP LaserJet Managed Flow MFP E82540z Printer
    - HP LaserJet Managed MFP E82540dn Printer
    - HP LaserJet Managed Flow MFP E82550z Printer
    - HP LaserJet Managed MFP E82550dn Printer
    - HP LaserJet Managed Flow MFP E82560z Printer
    - HP LaserJet Managed MFP E82560dn Printer
    - HP LaserJet Managed Flow MFP E72525z Printer
    - HP LaserJet Managed MFP E72525dn Printer
    - HP LaserJet Managed Flow MFP E72530z Printer
    - HP LaserJet Managed MFP E72530dn Printer
    - HP LaserJet Managed Flow MFP E72535z Printer
    - HP LaserJet Managed MFP E72535dn Printer
    - HP LaserJet Pro  M203d Printer
    - HP LaserJet Pro  MFP M130a Printer
    - HP LaserJet Pro  MFP M130nw Printer
    - HP LaserJet Pro  MFP M130fn Printer
    - HP LaserJet Pro  MFP M130fw Printer
    - HP LaserJet Pro  MFP M227d Printer
    - HP LaserJet Pro  MFP M227fdn Printer
    - HP LaserJet Ultra MFP M230 sdn Printer
* Mon Mar 13 2017 fvogt@suse.com
  - Use Qt5 on Tumbleweed and Leap >= 42.2 (bsc#1018734)
* Thu Mar 02 2017 jsmeix@suse.de
  - Support most recent HP printing devices for SLE12 by upgrading
    HPLIP to the version that we have currently (as of this writing)
    in openSUSE Factory and this is in use on openSUSE Tumbleweed
    see https://fate.suse.com/322305 (fate#322305).
    In general regarding version upgrades for printer drivers
    see https://en.opensuse.org/SDB:Installing_a_Printer
* Thu Feb 09 2017 Mathias.Homann@opensuse.org
  - Version upgrade to 3.16.11:
    * Added Support for the Following New Printers:
    - HP LaserJet M101-M106 Printer
    - HP LaserJet Pro M203-M206 Printer
    - HP LaserJet Pro MFP M227-M231 Printer
    - HP LaserJet Pro MFP M129-M134
    * Added support for the following new Distro's:
    - OpenSuse 42.2
    - Fedora 25
* Wed Nov 23 2016 martin.wilck@suse.com
  - Fixed SLES12 SP2 build problem in
    %files section for /usr/lib/udev/rules.d
* Fri Nov 18 2016 jweberhofer@weberhofer.at
  - Version upgrade to 3.16.10:
    * Added Support for the Following New Printers:
    - HP officejetPro7740 wide  Format All in one
    - HP Office jet 6950 All-in-One printer
    - HP ScanJet Pro 3000 s3 Sheet-feed Scanner
    - HP ScanJet Enterprise Flow 5000 s4 Sheet-feed Scanner
    - HP Scanjet Entrprise Flow 7000 s3 sheetfeed Scanner
    - HP Color LaserJet Pro MFP M277c6
    * Notes to follow:
    - For scanjets scan using command "hp-scan --adf --size=size_name"
    - "hp-scan --help" for all size_name
* Tue Oct 18 2016 jweberhofer@weberhofer.at
  - Version upgrade to 3.16.9:
    * Added Support for the Following New Printers:
    - HP OfficeJet Pro 8732M All-in-One Printer
    - HP OfficeJet 8702 All-in-One Printer
    - HP OfficeJet 6960 All-in-One Printer
    - HP PageWide 377dw Multifunction Printer
    - HP PageWide 352dw Printer
    - HP PageWide Managed Color MFP E58650 series
    - HP PageWide Managed Color E55650 series
* Wed Sep 14 2016 fcastelli@suse.com
  - Version upgrade to 3.16.8:
    * Added Support for the Following New Printers:
    - HP OfficeJet Pro 6970 All-in-One Printer
    - HP OfficeJet Pro 6960 All-in-One Printer
    - HP OfficeJet 250 Mobile All-in-One
    - HP DeskJet 3700 All-in-One
    - HP DeskJet Ink Advantage 3700 All-in-One
    * Significant changes:
    - Modified the GUI representation of Secure PIN Printing
    * Added support for the following new Distro's:
    - Linux Mint 18
    - Fedora 24
    - Debian 8.5
  - Version upgrade to 3.16.7:
    * Added Support for the Following New Printers:
    - HP  Officejet Pro 8730
    - HP Officejet Pro 8210 Printer
    - HP Pagewide P55250
    - HP Pagewide MFP P57750
    - HP Pagewide Color 556
    - HP Pagewide Color MFP 586
    - HP Pagewide Color flow MFP 586
    - HP DeskJet Ink Advantage Ultra 5730 All-in-One Printer
    - HP Color Laserjet MFP M377 fnw
    * change-udev-rules.diff: the patch didn't apply because of some formatting
    issues. `quilt` fixed them automatically.
* Fri Aug 26 2016 martin.wilck@suse.com
  - Fixed device communication/detection problems with mdns/Bonjour
    * added hplip-mdns.patch (MDNS send/receive on every iterface)
    * added hplip-mdns-retry-query.patch (MDNS retry)
    See https://bugs.launchpad.net/hplip/+bug/1616861
* Mon Jun 06 2016 jweberhofer@weberhofer.at
  - rebased change-udev-rules.diff and
    add_missing_includes_and_define_GNU_SOURCE.patch
  - Version upgrade to 3.16.5
    * Added Support for the Following New Printers:
    - HP OfficeJet 200 Mobile Printer Series
    - HP OfficeJet Pro 8710 All-in-One Printer
    - HP OfficeJet Pro 8715 All-in-One Printer
    - HP OfficeJet Pro 8740 All-in-One Printer
    - HP OfficeJet Pro 8720 All-in-One Printer
    - HP OfficeJet Pro 8725 All-in-One Printer
    - HP LaserJet Pro M501n
    - HP LaserJet Pro M501dn
    * Qt5 support is available. For more information check the following link
      http://hplipopensource.com/node/376
  - Version upgrade to 3.16.3
    * Added Support for the Following New Printers:
    - HP PageWide Pro 577dw Multifunction Printer
    - HP PageWide Pro 577z Multifunction Printer
    - HP PageWide Pro 552dw Printer
    - HP PageWide Pro 452dw Printer
    - HP PageWide Pro 452dn Printer
    - HP PageWide Pro 477dw Multifunction Printer
    - HP PageWide Pro 477dn Multifunction Printer
    - HP DeskJet GT 5810 All-in-One Printer
    - HP DeskJet GT 5820 All-in-One Printer
    * fixed issue: Traceback error occurs when ESC button is hit upon the promt
      for root/superuser credentials while installing hp-plugin.
  - Version upgrade to 3.16.2
    * Significant Change: Queue configuration using 'hp-setup' command is no more
      supported for HP ScanJets. Scan frontends like xsane, hp-scan, scanimage,
      simplescan will automatically detect usb and network ScanJets.
    * Added Support for the Following New Printers:
    - HP ScanJet Pro 4500 fn1 Network scanner
    - HP LaserJet Pro MFP M127fs
    - HP DeskJet Ultra Ink Advantage 2029 Printer
    - HP DeskJet Ink Advantage Ultra 2529 All-in-One Printer
    * Issues fixed:
    - /usr/lib/sane/libsane-hpaio.so.1: undefined symbol: mdns_probe_nw_scanners
      (Launchpad #1521687)
    - udev: 56-hpmud.rules should not run usb_id for all USB devices out there
      (Launchpad #1537467)
    - Upgrade to HPLIP-3.15.11 fails (Launchpad: #1517494)
    - HPLIP installation fails with non-english locale (Launchpad: #1536762)
    - hp-plugin hangs on 'su' (Launchpad: #1483820)
    - hp-plugin infinite loop (Launchpad: #1484916)
    - hp-plugin not working - stuck on permission (Launchpad: #1510950)
    - HP plugin installation hangs after accepting license (Launchpad: #1502025)
    - Debian 8's hplip version is 3.14.6, not 3.15.2 (Launchpad: #1534404)
    - Laserjet Pro MFP M127fs is not supported (Launchpad: #1532451)
* Wed Dec 09 2015 tchvatal@suse.com
  - Fix build on SLE11 by removing not required and wrongly installed
    selinux support config
  - Remove another nested conditions that are the same
* Tue Dec 08 2015 tchvatal@suse.com
  - Do not bother with fsf address fix, if they move again or if the
    package update it we would needlessly fail
  - Do not bother with one condition that is equal to the following one
* Thu Nov 19 2015 ecsos@opensuse.org
  - Version upgrade to 3.15.11:
    Significant Changes:
    - Provided custom apparmor profiles and selinux policy for
      HPLIP.
    - Supported auto-discovery of network scanners.
    Added Support for the Following New Printers:
      HP Color LaserJet Pro MFP M274n
      HP LaserJet Enterprise M506 series
      HP Laserjet Enterprise M506n
      HP Laserjet Enterprise M506dn
      HP Laserjet Enterprise M506x
      HP Laserjet Enterprise M506dh
      HP Color Laserjet Pro M452dn
      HP Color Laserjet Pro M452dw
      HP Color Laserjet Pro M452nw
      HP Laserjet Pro MFP M426fdn
      HP Laserjet Pro MFP M426fdw
      HP Laserjet Pro MFP M427dn
      HP Laserjet Pro MFP M427fdw
      HP Laserjet Pro MFP M426dw
      HP Laserjet Pro MFP M427dw
      HP Laserjet Enterprise MFP M527dn
      HP Laserjet Enterprise MFP M527f
      HP Laserjet Enterprise Flow MFP M527c
      HP Laserjet Enterprise Flow MFP M527z
      HP Color LaserJet Enterprise MFP M577 Series
      HP Color LaserJet Enterprise MFP M577dn
      HP Color LaserJet Enterprise MFP M577f
      HP Color LaserJet Enterprise Flow MFP M577z
      HP Color LaserJet Enterprise Flow MFP M577c
      HP LaserJet Pro M402-M403 series
      HP LaserJet Pro M402-M403 n-dn series
      HP LaserJet Pro M402dw
      HP LaserJet Pro M402n
      HP LaserJet Pro M402dn
      HP LaserJet Pro M402d
      HP LaserJet Pro M403n
      HP LaserJet Pro M403dw
      HP LaserJet Pro M403dn
      HP LaserJet Pro M403d
      HP Color Laserjet Pro MFP M477fnw
      HP Color Laserjet Pro MFP M477fdn
      HP Color Laserjet Pro MFP M477fdw
      HP Envy 5543 All-in-One Printer
      HP Envy 5544 All-in-One Printer
      HP Envy 5546 All-in-One Printer
      HP Envy 5542 e-All-in-One Printer
      HP DeskJet 2134 All-in-One Printer
      HP DeskJet 3633 All-in-One Printer
      HP DeskJet 3634 All-in-One Printer
      HP OfficeJet 4654 All-in-One Printer
      HP ENVY 4524 All-in-One Printer
      HP ENVY 4523 All-in-One Printer
      HP ENVY 4520 All-in-One Printer
      HP DeskJet Ink Advantage Ultra 4720 All-in-One Printer series
      HP DeskJet Ink Advantage Ultra 4729 All-in-One Printer
      HP DeskJet Ink Advantage 5640 All-in-One Printer series
      HP DeskJet Ink Advantage 5645 All-in-One Printer
      HP DeskJet Ink Advantage 4675 All-in-One
      HP DeskJet Ink Advantage 4676 All-in-One
      HP DeskJet Ink Advantage 4535 All-in-One
      HP DeskJet Ink Advantage 4536 All-in-One
      HP DeskJet Ink Advantage 5570 All-in-One
      HP DeskJet Ink Advantage 5575 All-in-One
      HP Scanjet Pro 3500 f1 Flatbed Scanner
      HP ENVY 5531 e-All-in-One Printer
      HP ENVY 5532 e-All-in-One Printer
      HP ENVY 5534 e-All-in-One Printer
      HP ENVY 5536 e-All-in-One Printer
      HP ENVY 5539 e-All-in-One Printer
    Added support for the following new Distro's:
    - Ubuntu 15.10
    - Fedora 23
    - OpenSUSE 42.1
    Issues fixed:
    - Provided knowledge base article to unblock the ports and
      enable SLP and mDNS services using opensuse firewall utility
      at http://hplipopensource.com/node/375
  - remove patch104: do_not_open_mdns_port.diff, no more needed
    because since HPLIP 3.15.11 there is no longer "open_mdns_port=..."
    in distros.dat for any "SUSE" distribution
  - insert check for Leap so Leap can use his own cups
  - insert check for 13.2 and Leap for udev-dirs because of
    rpmlint-error: directory not owned by package
  - fix rpmlint-error: incorrect fsf-address
* Wed Oct 07 2015 jsmeix@suse.de
  - Dropped support for the outdated foomatic-rip-hplip via
    a symbolic link from /usr/lib/cups/filter/foomatic-rip-hplip
    to /usr/bin/foomatic-rip for foomatic-filters or to
    /usr/lib/cups/filter/foomatic-rip for cups-filters-foomatic-rip
    so that "BuildRequires cups-filters-foomatic-rip" can be dropped
    (cf. the entry dated "Thu Sep 18 10:31:14 CEST 2014" below)
    which makes it "just build" again if suse_version > 1310 without
    the need for more and more oversophisticated hacks.
* Tue Oct 06 2015 jsmeix@suse.de
  - Version upgrade to 3.15.9:
    Added Support for the Following New Printers:
      HP DeskJet Ink Advantage 2136 All-in_One Printer
      HP DeskJet Ink Advantage 3836 All-in_One
      HP Deskjet 2545 All-in-One Printer
      HP ENVY 4510 All-in-One Printer series
      HP ENVY 4512 All-in-One Printer
      HP ENVY 4516 All-in-One Printer
      HP ENVY 4520 All-in-One Printer series
      HP ENVY 4520 All-in-One Printer
      HP ENVY 4522 All-in-One Printer
      HP Envy 5540 All-in-One Printer series
      HP Envy 5540 All-in-One Printer
      HP Envy 5545 All-in-One Printer
      HP OfficeJet 4650 All-in-One Printer series
      HP OfficeJet 4650 All-in-One Printer
      HP OfficeJet 4652 All-in-One Printer
      HP OfficeJet 4655 All-in-One Printer
      HP OfficeJet 6820 e-All-in-One  Printer
    Some bug fixes - in particular:
      Fixed hplip plugin failure with hplip-3.15.7.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Version upgrade to 3.15.7:
    Added Support for the Following New Printers:
      HP Deskjet 1110 Printer
      HP Deskjet 1111 Printer
      HP Deskjet 1112 Printer
      HP DeskJet 2131 All-in-One Printer
      HP Deskjet Ink Advantage 1110 Printer
      HP Deskjet Ink Advantage 1115 Printer
      HP Deskjet Ink Advantage 1118 Printer
      HP DeskJet Ink Advantage 2130 All-in_One Printer
      HP DeskJet Ink Advantage 2135 All-in_One Printer
      HP DeskJet Ink Advantage 2138 All-in_One Printer
      HP DeskJet Ink Advantage 3630 All-in-One Printer
      HP DeskJet Ink Advantage 3635 All-in-One Printer
      HP DeskJet Ink Advantage 3636 All-in-One Printer
      HP DeskJet Ink Advantage 3638 All-in-One Printer
      HP DeskJet Ink Advantage 3830 All-in-One Printer
      HP DeskJet Ink Advantage 3835 All-in-One Printer
      HP OfficeJet 3830 All-in-One Printer
      HP OfficeJet 3832 All-in-One Printer
      HP OfficeJet 3834 All-in-One Printer
      HP Officejet 7510 Wide Format e-All-in-One Printer
    Some bug fixes - in particular:
      Fixed insecure binary driver verification (CVE-2015-0839).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - hplip-3.15.6.CVE-2015-0839.patch is obsolete since
    version 3.15.7 because it is fixed in the source.
* Wed Jun 24 2015 jsmeix@suse.de
  - hplip-3.15.6.CVE-2015-0839.patch uses 0xlong key ID
    (instead of the short key ID) for downloading the key
    see https://bugs.launchpad.net/hplip/+bug/1432516
    (CVE-2015-0839 bsc#933191).
  - Version upgrade to 3.15.6:
    Added Support for the Following New Printers:
      HP DeskJet 2130 All-in-One Printer series
      HP DeskJet 2132 All-in-One Printer
      HP Deskjet 2546B All-in-One Printer
      HP Deskjet 2546P All-in-One Printer
      HP Deskjet 2546R All-in-One Printer
      HP DeskJet 3630 All-in-One Printer series
      HP DeskJet 3632 All-in-One
      HP Officejet 5744 e-All-in-One
    Some bug fixes - in particular:
      udev rules wrongly match on monitor hub, wrong invocation
      of systemd unit, changes config files in udev rules
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - change-udev-rules.diff: Adapted for HPLIP 3.15.6.
* Tue May 19 2015 jsmeix@suse.de
  - Disabled build for parallel port because parallel port support
    was disabled by default by upstream HPLIP at least since 2011
    and is deprecated by upstream HPLIP since 2013,
    see https://bugs.launchpad.net/bugs/750796
    and http://hplipopensource.com/node/217
    furthermore parallel port support gets more or less abandoned
    by upstream projects in general, see "Parallel port printers"
    at https://en.opensuse.org/SDB:Installing_a_Printer
  - Version upgrade to 3.15.4:
    Significant Changes:
      HPLIP Plugin support for ARMv6,ARMv7 and aarch64 architectures
    Added Support for the Following New Printers:
      HP Color LaserJet Pro M252dw
      HP Color LaserJet Pro M252n
      HP Color LaserJet Pro MFP M277n
      HP Color LaserJet Pro MFP M277dw
      HP Color LaserJet Enterprise M553n
      HP Color LaserJet Enterprise M553dn
      HP Color LaserJet Enterprise M553x
      HP Color LaserJet Enterprise M553dh
      HP Color LaserJet Enterprise M552dn
      HP LaserJet Enterprise M604n
      HP LaserJet Enterprise M604dn
      HP LaserJet Enterprise M605dn
      HP LaserJet Enterprise M605n
      HP LaserJet Enterprise M605x
      HP LaserJet Enterprise M606x
      HP LaserJet Enterprise M606dn
    Some bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - add_missing_includes_and_define_GNU_SOURCE.patch adds
    missing '#include <...>' and missing '#define _GNU_SOURCE'
    see https://bugs.launchpad.net/hplip/+bug/1456590
  - Using again plain 'make' instead of 'make %{?_smp_mflags}'
    (cf. the entry below dated "Sun Apr 20 09:48:39 UTC 2014")
    and plain 'make ... install' instead of
    'make ... install %{?_smp_mflags}' to avoid random obscure
    build failures with errors like "libtool: install: error: relink
    `cupsext.la' with the above command before installing it", cf.
    http://lists.gnu.org/archive/html/automake/2010-03/msg00039.html
* Wed Mar 18 2015 jsmeix@suse.de
  - Make it build for SLE12 with traditional CUPS 1.5.4 to ensure
    it works on SLE12 both with CUPS 1.7.5 and CUPS 1.5.4 because
    for SLE12 by default CUPS 1.7.5 is provided and alternatively
    CUPS 1.5.4 is provided in the "legacy" module, cf.
    https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12/
* Fri Feb 27 2015 jsmeix@suse.de
  - HPLIP's Python module cupsext has a build-time dependancy on the
    CUPS version (see https://bugs.launchpad.net/hplip/+bug/1423220).
    Therefore it BuildRequires the CUPS version as provided in the
    openSUSE/SLE versions. When it was built with CUPS > 1.5 it must
    require CUPS > 1.5 during run-time. In contrast when it was built
    with CUPS < 1.6 then cupsext is built in a backward compatible
    way that works with any CUPS version.
    This replaces the "minimal version requirement on cups" from the
    entry below dated "Thu Feb 19 12:05:05 UTC 2015" and obsoletes
    the "Kill sle11 support" from the previous entry so that HPLIP
    should work again for SLE11 SLE12 and recent openSUSE versions
    (boo#918387).
  - Again BuildRequires sane-backends-devel if suse_version > 1130
    and BuildRequires sane-backends otherwise that was removed via
    one of the previous entries to make it again build for SLE11.
  - Run udev_rules_update that BuildRequires systemd-rpm-macros
    only if suse_version > 1130 to make it again build for SLE11.
  - For SLE11 redefine _libexecdir to be "/usr/lib" in any case
    because on SLE11 x86_64 it evaluates to "/usr/lib64" which
    is wrong in particular for CUPS filters and backends, cf.
    https://bugzilla.opensuse.org/show_bug.cgi?id=575544#c2
  - Again using the RPM scriplets as in previous versions with
    its various suse_version dependant stuff to make it again
    build for SLE11.
  - Using '-p /bin/bash' in RPM scriplets to enforce bash
    to be fail safe against issue with possible bashisms.
* Thu Feb 19 2015 tchvatal@suse.com
  - Cleanup-with spec-cleaner
  - Kill sle11 support as per min cups requirement
  - Add patch to put udev rules to usr as it is required:
    * hplip-udev-rules-in-usr.patch
  - Also run udev rules update in post for the above rules
* Thu Feb 19 2015 tchvatal@suse.com
  - Add minimal version requirement on cups (currently 1.7) bnc#918387
* Wed Feb 11 2015 tchvatal@suse.com
  - Drop gpg-offline usage as we do it as service on obs side if
    required files are present in the package
* Wed Feb 11 2015 tchvatal@suse.com
  - Version bump to 3.15.2:
    * python3 support (not enabled to work on older distros now)
    * Support for KF5 systemtray
    * Fixed issues:
      + 1388126 - Doesn't build against libjpeg-turbo 1.3.90
      + 1395676 - hpcups crashes if DEVICE_URI not set in environment
      + 1388007 - Incorrect call to hpmudext.device_open
      + 1187055 - plugin download fails if python links to python3
      + 802999  - Incorrect IEEE 1284 Device IDs for many models
    * For more info see http://hplipopensource.com/hplip-web/release_notes.html
* Mon Oct 27 2014 jsmeix@suse.de
  - change-udev-rules.diff: Adapted for HPLIP 3.14.10.
  - Version upgrade to 3.14.10:
    Added Support for the Following New Printers:
      HP Deskjet 2541 All-in-One Printer
      HP Envy 4501 e-All-in-One
      HP Envy 4503 e-All-in-One
      HP Envy 4505 e-All-in-One
      HP Envy 4507 e-All-in-One
      HP Envy 4508 e-All-in-One
      HP ENVY 5534 e-All-in-One Printer
      HP Envy 5640 e-All-in-One
      HP Envy 5642 e-All-in-One
      HP Envy 5643 e-All-in-One
      HP Envy 5644 e-All-in-One
      HP Envy 5660 e-All-in-One
      HP Envy 5665 e-All-in-One
      HP Envy 7640 e-All-in-One
      HP Envy 7645 e-All-in-One
      HP LaserJet Pro MFP M125r
      HP LaserJet Pro MFP M125ra
      HP LaserJet Pro M201n Printer
      HP LaserJet Pro M201dw Printer
      HP LaserJet Pro M202n Printer
      HP LaserJet Pro M202dw Printer
      HP LaserJet Pro MFP M225rdn
      HP LaserJet Pro MFP M225dw
      HP LaserJet Pro MFP M225dn
      HP LaserJet Pro MFP M226dw
      HP LaserJet Pro MFP M226dn
      HP LaserJet Enterprise MFP M630dn
      HP LaserJet Enterprise MFP M630f
      HP LaserJet Enterprise MFP M630h
      HP LaserJet Enterprise Flow MFP M630z
      HP Officejet 5740 e-All-in-One
      HP Officejet 5742 e-All-in-One
      HP Officejet 5745 e-All-in-One
      HP OfficeJet 8040 e-All-in-One
      HP OfficeJet 6810 e-All-in-One  Printer Series
      HP OfficeJet 6812 e-All-in-One  Printer
      HP OfficeJet 6815 e-All-in-One  Printer
      HP Officejet 7612 Wide Format e-All-in-One Printer
      HP OfficeJet Pro 6230 ePrinter
      HP OfficeJet Pro 6830 e-All-in-one
      HP OfficeJet Pro 6835 e-All-in-one
      HP OfficeJet Pro 8616 e-All-in-One Printer
    Some bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Thu Oct 16 2014 jsmeix@suse.de
  - Make and install Python compiled bytecode files
    (.pyc compiled python and .pyo optimized compiled python)
    because normal users do not have write permissions to the
    install location /usr/share/hplip/ so that for normal users
    Python would recompile the sources every time,
    see https://en.opensuse.org/openSUSE:Packaging_Python
  - Hardlink .pyc and .pyo when they have same content but
    do not run "fdupes buildroot/_datadir/hplip" because
    fdupes will link any files with same content there
    which can have unexpected side-effects (cf. bnc#784670).
  - Removed RPM preun script that had deleted leftover .pyc
    and .pyo files if made during run-time (see the entry below
    dated Fri Feb 16 11:52:28 CET 2007) because now those files
    are provided in the package.
  - Removed trailing whitespaces in RPM changelog file.
* Thu Sep 18 2014 jsmeix@suse.de
  - From openSUSE 13.2 on explicitly
    "BuildRequires cups-filters-foomatic-rip"
    to avoid that foomatic-filters is used for build
    in the "Printing" development project (where foomatic-filters
    intentionally exists also for openSUSE_13.2 and openSUSE_Factory)
    which would not match what is used for build in openSUSE:13.2 or
    openSUSE:Factory (where foomatic-filters is intentionally dropped
    and replaced by cups-filters-foomatic-rip). Using the matching
    package for build results that the backward compatibility link
    /usr/lib/cups/filter/foomatic-rip-hplip points to a foomatic-rip
    executable that is used by default on the runtime system.
* Mon Sep 15 2014 jsmeix@suse.de
  - PPDs that require a proprietary plugin from HP must be moved to
    the hplip main-package because the proprietary plugin from HP
    must be downloaded and installed by using HP's "hp-plugin" tool
    that belongs to the hplip main-package. Accordingly PPDs that
    require a proprietary plugin from HP are in a new directory
    /usr/share/cups/model/manufacturer-PPDs/hplip-plugin
    that belongs to the hplip main-package (bnc#876690).
* Tue Jun 10 2014 jsmeix@suse.de
  - Version upgrade to 3.14.6:
    Added Support for the Following New Printers:
      HP DesignJet Z6600 PostScript
      HP DesignJet Z6800PS Photo
      HP DesignJet D5800 60-in Production Printer
      HP DesignJet T3500 36-in Production eMFP
      HP Designjet T7200 42-in Production Printer
      HP Deskjet 2543 All-in-One Printer
      HP Deskjet 2549 All-in-One Printer
      HP OfficeJet Pro 8640 e-All-in-One Printer
      HP OfficeJet Pro 8660 e-All-in-One Printer
    Fixed Avahi discovery method in hp-toolbox.
    Some other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Wed May 07 2014 jsmeix@suse.de
  - Moved the hpcupsfax filter to the hplip-hpijs sub-package
    because the HP-Fax*hpcups PPDs in the hplip-hpijs sub-package
    that use that filter work technically correct when only the
    hplip-hpijs RPM is installed regardless that in practice
    queues with a HP-Fax*hpcups PPD usually use the hpfax backend
    Python script that belongs to the hplip main-package because
    it imports HPLIP Python modules.
  - Moved the hpps filter to the hplip main-package because the PPDs
    for various printers that use that filter do not work when only
    the hplip-hpijs RPM is installed because the hpps Python script
    imports HPLIP Python modules from the hplip main-package.
    Accordingly moved the PPDs that use the hpps filter
    to the hplip main-package (bnc#876690).
* Wed Apr 23 2014 jsmeix@suse.de
  - Fix how the link /usr/lib/cups/filter/foomatic-rip-hplip
    that points to foomatic-rip is installed depending on
    which package provides foomatic-rip. In foomatic-filters
    foomatic-rip is installed as /usr/bin/foomatic-rip
    but in cups-filters-foomatic-rip it is installed
    as /usr/lib/cups/filter/foomatic-rip.
* Sun Apr 20 2014 tchvatal@suse.com
  - Enable parallel build via "make %{?_smp_mflags}".
* Wed Apr 09 2014 jsmeix@suse.de
  - do_not_open_mdns_port.diff: Adapted for HPLIP 3.14.4.
  - Version upgrade to 3.14.4:
    Added Support for the Following New Printers:
      HP Color LaserJet Enterprise M651dn Printer
      HP Color LaserJet Enterprise M651n Printer
      HP Color LaserJet Enterprise M651xh Printer
      HP Color LaserJet Enterprise Multifunction M680dn Printer
      HP Color LaserJet Enterprise Multifunction M680f Printer
      HP Color LaserJet Enterprise Flow Multifunction M680z Printer
      HP Color Laserjet Pro MFP M476dw
      HP Color Laserjet Pro MFP M476nw
      HP Color Laserjet Pro MFP M476dn
      HP Designjet T795 44-in ePrinter
      HP DeskJet 1511 All-in-One Printer
      HP DeskJet 1011 Printer
      HP LaserJet Pro MFP M128fn
      HP LaserJet Pro MFP M128fp
      HP LaserJet Pro MFP M128fw
      HP LaserJet Pro M701a Printer
      HP LaserJet Pro M701n Printer
      HP LaserJet Pro M706n Printer
      HP Officejet Enterprise Color X555dn Printer
      HP Officejet Enterprise Color X555xh Printer
      HP Officejet Enterprise Color X585dn Multifunction Printer
      HP Officejet Enterprise Color X585f Multifunction Printer
      HP Officejet Enterprise Color Flow X585z Multifunction Printer
      HP OfficeJet Pro 8610 e-All-in-One Printer
      HP OfficeJet Pro 8615 e-All-in-One Printer
      HP OfficeJet Pro 8620 e-All-in-One Printer
      HP OfficeJet Pro 8625 e-All-in-One Printer
      HP OfficeJet Pro 8630 e-All-in-One Printer
      HP OfficeJet 4631 e-All-in-One Printer
      HP OfficeJet 4634 e-All-in-One printer
      HP OfficeJet 4636 e-All-in-One Printer
    Fixed hp-logcapture (captured personal information), see
    http://hplipopensource.com/hplip-web/release_notes.html
  - change-udev-rules.diff: Adapted for HPLIP 3.14.3.
  - Version upgrade to 3.14.3:
    Added Support for the Following New Printers:
      HP Deskjet Ink Advantage 4640 e-All-in-One Printer series
      HP Deskjet Ink Advantage 4645 e-All-in-One Printer
      HP Deskjet Ink Advantage 4646 e-All-in-One Printer
      HP Deskjet Ink Advantage 4648 e-All-in-One Printer
      HP LaserJet Pro MFP M125a
      HP LaserJet Pro MFP M125nw
      HP LaserJet Pro MFP M125rnw
      HP LaserJet Pro MFP M126a
      HP LaserJet Pro MFP M126nw
      HP LaserJet Pro MFP M127fp
    Fixed hpcups filter crash.
    Run hp-firmware from udev separately.
    Some other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Version upgrade to 3.14.1:
    Added digital signature validation in HPLIP upgrade feature.
    CVE-2013-6427: insecure auto update feature.
    CVE-2013-6402: insecure temporary file handling in pkit.py.
  - The whole HPLIP upgrade feature is still disabled, see the
    entry dated "Wed Dec  4 14:25:51 CET 2013" below.
* Wed Dec 04 2013 jsmeix@suse.de
  - disable_hp-upgrade.patch disables hp-upgrade/upgrade.py for
    security reasons (bnc#853405). To upgrade HPLIP an openSUSE
    software package manager like YaST or zypper should be used.
* Tue Nov 26 2013 mailaender@opensuse.org
  - Version upgrade to 3.13.11:
    Added Support for the Following New Printers:
      HP Color LaserJet Pro MPF M176 series
      HP Color LaserJet Pro MPF M176n
      HP Color LaserJet Pro MPF M177 series
      HP Color LaserJet Pro MPF M177fw
      HP Color LaserJet Enterprise M750 Printer series
      HP Color LaserJet Enterprise M750n
      HP Color LaserJet Enterprise M750dn
      HP Color LaserJet Enterprise M750xh
      HP Color LaserJet Enterprise M855 Printer series
      HP Color LaserJet Enterprise M855dn Printer
      HP Color LaserJet Enterprise M855xh Printer
      HP Color LaserJet Enterprise M855x+ Printer
      HP Color LaserJet Enterprise flow M880 Multifunction Printer series
      HP Color LaserJet Enterprise flow M880z Multifunction Printer
      HP Color LaserJet Enterprise flow M880z+ Multifunction Printer
      HP LaserJet Pro MFP M127 series
      HP LaserJet Pro MFP M127fn
      HP LaserJet Pro MFP M127fw
      HP Officejet 2620 All-in-One
      HP Officejet 2621 All-in-One
      HP Officejet 2622 All-in-One
    Added Pin Printing support for HP LaserJet m5035 MFP device
  - Added a devel package
  - Update the .desktop database on install/uninstall
  - Use .desktop files provided by upstream
* Wed Oct 16 2013 jsmeix@suse.de
  - Version upgrade to 3.13.10:
    Several more supported printers and all-in-one devices.
    Fix for CVE-2013-4325i (insecure Polkit use).
    Users will not be added to "lp" group, users will be prompted
    to provide necessary authentication (see the entry
    dated "Tue Jul  9 16:18:35 CEST 2013" below).
    Added firmware upload functionality during 'hp-setup'.
    Some other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - change-udev-rules.diff: Adapted for HPLIP 3.13.10.
  - disable-chgrp_lp.diff is obsolete since version 3.13.10
    because it is fixed in the source.
  - neither-add_user_to_group-nor-open_mdns_port.diff is replaced by
    do_not_open_mdns_port.diff because the "add_user_to_group" issue
    is fixed in the source since version 3.13.10 but the
    "open_mdns_port" issue still exists.
  - deactivate-add_group-function.diff is obsolete since 3.13.10
    because there is no longer that "chgrp" stuff in HPLIP.
* Thu Sep 12 2013 jsmeix@suse.de
  - Version upgrade to 3.13.9:
    Several more supported printers and all-in-one devices.
    Some bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - fix-uninitialized-variables.diff is obsolete since
    version 3.13.9 because it is fixed in the source.
* Tue Sep 10 2013 jsmeix@suse.de
  - change-udev-rules.diff: Added rule that only uploads firmware
    into printers that need it by calling only hp-firmware, see
    https://bugs.launchpad.net/bugs/1220628
* Wed Sep 04 2013 jsmeix@suse.de
  - Version upgrade to 3.13.8:
    Added support for Avahi network printer browsing.
    Using SLP protocol by default to browse printer in hp-setup.
    Some more supported printers and all-in-one devices.
    Some bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Jul 23 2013 jsmeix@suse.de
  - Version upgrade to 3.13.7:
    A few more supported printers and all-in-one devices.
    Some bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - hplip-3.9.8-CVE-2010-4267.patch is no longer needed because
    it is fixed in the upstream sources in HPLIP version 3.13.7
    (see the entry dated "Thu Jan 13 16:29:01 CET 2011" below).
* Tue Jul 09 2013 jsmeix@suse.de
  - deactivate-add_group-function.diff deactivates the add_group
    function that would add the groups ('lp') to user which would
    cause security issues see https://bugs.launchpad.net/bugs/1197416
    that would happen in any case via a fallback command in an "else"
    clause even if this functionality was explicitly disabled in
    distros.dat via neither-add_user_to_group-nor-open_mdns_port.diff
  - neither-add_user_to_group-nor-open_mdns_port.diff
    deactivates add_user_to_group and open_mdns_port
    in distros.dat for SUSE distros to avoid security issues
    when normal users get added to system groups 'lp' and 'sys'
    see https://bugs.launchpad.net/bugs/1197416
    and https://bugs.launchpad.net/bugs/1112306 and
    to avoid security issues when ports in the firewall get opened
    see https://bugs.launchpad.net/bugs/426161
  - Adapted change-udev-rules.diff so that it applies to
    the HPLIP 3.13.6 sources.
  - no-hplip_cron.diff is no longer needed because there is
    no longer any "cron" stuff in HPLIP version 3.13.6
  - Version upgrade to 3.13.6:
    A few more supported printers and all-in-one devices.
    Fix for firmware download during plug and play.
    Supported CUPS 1.6 IPP Private Structure changes.
    Some other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Version upgrade to 3.13.5:
    Several more supported printers and all-in-one devices.
    Added 56-hpmud.rules and removed 56-hpmud_support,
    86-hpmud_plugin, 56-hpmud_add_printer, 55-hpmud
    and 40-hplip rules.
    Added hplip-printer@.service to support systemd services
    in udev for OpenSUSE 12.3.
    Some other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Apr 16 2013 jsmeix@suse.de
  - Version upgrade to 3.13.4:
    Several more supported printers and all-in-one devices.
    Fixed toolbox.py crash (KeyError in is_auto_installer_support).
    Several other bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Thu Mar 14 2013 meissner@suse.com
  - use URLs in Source tags
  - added gpg signature checking to %prep.
* Tue Mar 12 2013 jsmeix@suse.de
  - Version upgrade to 3.13.3:
    Mainly a bugfix release.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Wed Mar 06 2013 jsmeix@suse.de
  - Removed hp-systray.wrapper because the reason for it
    is no longer in compliance with HPLIP upstream intentions
    (see SUSE Bugzilla bnc#649280 starting at comment#10).
* Fri Feb 15 2013 jsmeix@suse.de
  - Version upgrade to 3.13.2:
    Several more supported printers and all-in-one devices
    (in particular several "HP Officejet Pro X..." models).
    New self diagnose and healing utility "hp-doctor"
    but "hp-check-plugin" is no longer provided.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Adapted change-udev-rules.diff disable-chgrp_lp.diff
    and no-hplip_cron.diff for HPLIP 3.13.2.
* Thu Jan 24 2013 jsmeix@suse.de
  - Create /var/log/hp/tmp/ directory that is needed by hp-sendfax
    as a workaround until HPLIP upstream implemented it correctly
    see https://bugs.launchpad.net/bugs/1016507 (bnc#800312).
* Thu Nov 29 2012 jsmeix@suse.de
  - Version upgrade to 3.12.11:
    Several more supported printers and all-in-one devices
    (in particular several "HP LaserJet Enterprise" models).
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - fix-no-return-in-nonvoid-function.diff is no longer needed
    because it is now completely fixed in the upstream sources.
  - disable-chgrp_lp.diff replaces no-chgrp_lp_hplip_Logdir.diff
    and does basically the same but is adapted for HPLIP 3.12.11.
  - Adapted no-hplip_cron.diff for HPLIP 3.12.11.
* Wed Oct 10 2012 jsmeix@suse.de
  - Bugfix version upgrade to 3.12.10a:
    The 'a' does not mean 'alpha' but "first bugfix of 3.12.10".
    Fixed crash in HP Device Manager and System Tray due to
    ValueError exception in HPLIP upgrade functionality, see
    https://bugs.launchpad.net/hplip/+bug/1064889 (bnc#784173).
  - Added "chmod a+x ... usr/share/hplip/fax/pstotiff" because
    "make install" installs it only with -rw-r--r-- permissions
    so that when the CUPS filter usr/lib/cups/filter/pstotiff
    which is a link to usr/share/hplip/fax/pstotiff is called,
    it cannot execute usr/share/hplip/fax/pstotiff, see
    https://bugs.launchpad.net/hplip/+bug/1064247 (bnc#783810).
* Fri Oct 05 2012 jsmeix@suse.de
  - Version upgrade to 3.12.10:
    Perhaps HP binary plugin installation failure fixed upstream
    see https://bugs.launchpad.net/hplip/+bug/1048732
    A few more supported printers and all-in-one devices.
    A few bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Thu Oct 04 2012 jsmeix@suse.de
  - no-hplip_cron.diff deactivates the "cron" stuff in Makefile.am
    because it lets build fail on SLE11 products (possibly an
    autoconf issue) and we (SUSE) do not allow to install files
    like /etc/cron.daily/hplip_cron via RPMs. Instead hplip_cron
    is provided as /usr/share/doc/packages/hplip/hplip_cron
  - The /var/lib/hp directory is created everywhere except on
    openSUSE 12.2 and later versions (perhaps also an autoconf
    issue) so that it is created in the install section if it
    does not exist as a simple and fail-safe workaround
    see https://bugs.launchpad.net/bugs/1018303
    and (bnc#780413).
  - Adapted change-udev-rules.diff so that it applies to
    the HPLIP 3.12.9 sources.
* Fri Sep 28 2012 mmeister@suse.com
  - Adapted fix-no-return-in-nonvoid-function.diff because
    HP's upstream fix is insufficient (not 64-bit safe),
    see https://bugs.launchpad.net/hplip/+bug/1017496
  - Adapted no-chgrp_lp_hplip_Logdir.diff so that it
    applies to the HPLIP 3.12.9 sources.
* Fri Sep 28 2012 mmeister@suse.com
  - Version upgrade to 3.12.9:
    User can collect logs by running 'hp-logcapture' command
    for any issue in print/scan/fax functionality.
    Logs get stored in /var/log/hp/tmp.
    Several more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Thu Jun 28 2012 jsmeix@suse.de
  - Provide the /var/lib/hp directory that is required in particular
    by hp-plugin (see https://bugs.launchpad.net/hplip/+bug/1018303)
    in the hplip-hpijs package to be on the safe side because
    hplip-hpijs is the minimal (printing-only) way to use HPLIP.
* Mon Jun 25 2012 mail@philipp-wagner.com
  - Add libusb 1.0 as dependency. If necessary building with
    libusb 0.1 would be possible as well by setting a configure
    flag.
* Mon Jun 25 2012 mail@philipp-wagner.com
  - fix-no-return-in-nonvoid-function.diff fixes compiler warnings
    causing a no-return-in-nonvoid-function error during the build.
    An upstream bug report is open at
    https://bugs.launchpad.net/hplip/+bug/1017496
* Mon Jun 25 2012 mail@philipp-wagner.com
  - Upgraded to version 3.12.6:
    'hp-check' tool when run with "--fix" option resolves missing
    dependencies/groups/plugin and disable SELinux.
    Added PIN to PRINT support for HP Color LaserJet CM4540 MFP.
    libusb-1.0 support added.
    Several more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Apr 24 2012 jsmeix@suse.de
  -  hplip.SuSEfirewall2 is no longer provided
    (see SUSE Bugzilla bnc#757354 comment #10).
* Thu Apr 12 2012 jsmeix@suse.de
  - Upgraded to version 3.12.4:
    Uninstall Support: User can uninstall complete HPLIP package
    by running "hp-uninstall" command.
    Upgrade Support: Settings can be configured using
    "hp-systray -> settings -> Update settings" for notification
    of newer version of HPLIP release. User can also upgrade to
    latest version by running "hp-upgrade" command.
    Queue Analyzer: Print/Fax queues can be analyzed by
    running "hp-diagnose-queues" command or by clicking
    on "Diagnose Queues" from toolbox.
    Several more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Removed hp-toolbox.wrapper because the reason for it
    is no longer valid (see SUSE Bugzilla bnc#755820).
  - Added "BuildRequires: python-cups" to get special
    RPM Provides tags for the printers supported by
    this package (see SUSE Bugzilla bnc#735865).
* Wed Feb 08 2012 jsmeix@suse.de
  - Upgraded to version 3.12.2:
    Fixed digital signature mismatch issue for plugin download.
    Removed unsupported features (Water Mark overlay, Job Storage,
    PIN 2 Print) from the PS PPDs.
    Several more supported printers and all-in-one devices.
    A few bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Thu Jan 12 2012 jsmeix@suse.de
  - Upgraded to version 3.11.12:
    Auto-detection and installation of missing plug-ins.
    Designed tool to detect the missing plugin files and intimate
    user about it and giving the path forward to install it.
    SYSFS is replaced by ATTRS in udev rules.
    Uses D-Bus from separate threads without locking.
    Several more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - change-udev-rules.diff changes ATTRS to ATTR (bnc#436085).
  - no-chgrp_lp_hplip_Logdir.diff deactivates
    the "chgrp lp -R /var/log/hp" in Makefile.am because
    during install this results "Operation not permitted".
    This is done in the files section via attr(0774,root,lp)
    where mode 0774 matches to what is set in Makefile.am.
* Fri Oct 28 2011 badshah400@gmail.com
  - Install icons of various sizes in hicolor icon directory for
    better appearance in gnome-shell (bnc#713902).
  - Add hicolor-icon-theme BuildRequires to own the hicolor icon
    directory correctly and install icons in there
  - Use appropriate icon theme macros in post scripts
  - Modified hplip.desktop to use these hicolor icons
  - In hplip.desktop replace the category "Settings" by "System" to
    make it appear under the correct group "System Tools" rather
    than "Others" in desktop menus.
* Sat Oct 15 2011 coolo@suse.com
  - add libtool as buildrequire to make the spec file more reliable
* Thu Oct 13 2011 vuntz@opensuse.org
  - Split the sane driver in a hplip-sane subpackage, so that it's
    not necessary to install the full hplip tools to use an
    all-in-one HP printer. See bnc#723870.
* Tue Oct 04 2011 jsmeix@suse.de
  - Upgraded to version 3.11.10:
    Fixed insecure tmp file handling in hpcupsfax.cpp CVE-2011-2722
    see https://bugs.launchpad.net/hplip/+bug/809904 (bnc#704608).
    New tech classes for HP OfficeJet Pro 8100,
    HP Deskjet 3070 B611 series and HP Photosmart 7510 e-All-in-One.
    Added new subtech class for HP Photosmart 6510 e-All-in-one.
    Modified the error message which was displayed in case
    of missing .asc file for manual plug-in install.
    Several more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Fri Aug 12 2011 jsmeix@suse.de
  - Upgraded to version 3.11.7:
    A few more supported printers and all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Because foomatic-rip-hplip has CVE-2011-2697 (bnc#698451)
    plus a leftover in CVE-2004-0801 (bnc#59233)
    foomatic-rip-hplip is no longer installed and foomatic-rip
    from the foomatic-filters RPM is used instead and the
    "cupsFilter" entries in the PPDs are changed accordingly.
    To be backward compatible with PPDs in /etc/cups/ppd/
    for existing print queues a compatibility link
    /usr/lib/cups/filter/foomatic-rip-hplip
    which points to foomatic-rip is installed.
  - The DefaultPageSize in the PPDs is no longer set to A4
    if A4 is an available PageSize choice but left "as is"
    because the DefaultPageSize in the PPD templates in
    /usr/share/cups/model/ does not matter because the cupsd
    sets the DefaultPageSize for PPDs in /etc/cups/ppd/
    by default according to the locale that the cupsd runs in or
    according to a DefaultPaperSize entry in /etc/cups/cupsd.conf.
  - No longer "Correcting or removing non-working PPDs..."
    because none of those cases which were fixed still exist
    (i.e. all those cases are meanwhile fixed upstream).
* Fri May 13 2011 jsmeix@suse.de
  - Upgraded to version 3.11.5:
    Added LEDM ADF Scan support.
    Added LEDM Wireless support.
    Some more supported printers and all-in-one devices.
    It may fix the inverted/wrong color problem in HPCUPS
    (see Novell/openSUSE Bugzilla bnc #692905).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Mar 29 2011 jsmeix@suse.de
  - Upgraded to version 3.11.3a:
    Fixed hp-plugin plugin download error (no Suse bug), see
    http://hplipopensource.com/hplip-web/release_notes.html
* Fri Mar 18 2011 jsmeix@suse.de
  - Upgraded to version 3.11.3:
    New device class StingrayOJ for HP OfficeJet 100 Mobile L411.
    New filter hpps (HP PS filter for PostScript printers) currently
    only used via hp-officejet_pro_8000_enterprise_a811a-ps.ppd.gz
    Some more supported printers and all-in-one devices.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Feb 01 2011 jsmeix@suse.de
  - Updated to version 3.11.1:
    New encapsulation format for LJZJStream class.
    Alignment of cartridges over LEDM (Low End Data Model).
    LEDM dynamic scan resolution.
    New fax protocol (Low End Data Model) support.
    ADF and color scan for some HP LaserJet Pro and MFP devices.
    Some more supported all-in-one devices.
    Many bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Adapted change-udev-rules.diff for version 3.11.1
    because the "DesignJet product (0x03f0xx14)" was added.
* Thu Jan 13 2011 jsmeix@suse.de
  -  hplip-3.9.8-CVE-2010-4267.patch fixes a remote buffer overflow
    (CVE-2010-4267 and Novell/Suse Bugzilla bnc#336658).
* Wed Dec 29 2010 gber@opensuse.org
  - Use more appropriate categories for hplip.desktop
    'Settings HardwareSettings Printing' instead of 'System Monitor'
* Fri Dec 03 2010 jsmeix@suse.de
  - Removed explicite RPM requirement for pyxml. At least since
    openSUSE 11.1 and SLE11 pyxml is no longer required (pyxml was
    required e.g. for openSUSE 10.3 and SLE10, see the entry below
    dated "Wed Apr  2 14:40:57 CEST 2008") but meanwhile python-xml
    alone is sufficient for "import xml.parsers.expat"
    (see Novell/openSUSE Bugzilla bnc#656779 comment #3).
  - Added "Obsoletes: hplip-hpcups" because HPLIP does not work
    if the openSUSE packages hplip and hplip-hpijs are installed
    together with a leftover PackMan package hplip-hpcups
    (see Novell/openSUSE Bugzilla bnc#515005 comment #17).
  - Do not pollute the build log file with zillions of meaningless
    messages while "General tests and adjustments for all PPDs"
    (compare the OpenPrintingPPDs.spec file).
* Wed Oct 27 2010 jsmeix@suse.de
  - Added hp-systray.wrapper which is called
    via /etc/xdg/autostart/hplip-systray.desktop
    to increase desktop startup speed so that the purpose
    of this hp-systray.wrapper is different to the
    entry below dated "Tue Apr  8 14:56:53 CEST 2008".
    hp-systray.wrapper tests via "lpstat" if a 'hp:/...'
    print queue exists and exits otherwise.
    This avoids that hp-systray with all its Python stuff must be
    loaded when the desktop starts up only to let hp-systray do
    its built-in test and exit if there is no HPLIP print queue
    (see Novell/openSUSE Bugzilla bnc#649280).
  - Updated to version 3.10.9:
    New Scan protocol (Low End Data Model) support.
    Many more supported all-in-one devices.
    Many bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.10.6:
    New protocol support (LEDM) for device status over Network
    and USB.
    Some more supported all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.10.5:
    Fixed "libusb couldn't open USB device, Permission denied"
    error message in openSUSE.
    Several more supported all-in-one devices.
    Several bug fixes.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Wed Sep 15 2010 aj@suse.de
  - Change BuildRequires for sane-backends devel split.
* Thu Apr 01 2010 jsmeix@suse.de
  - Updated to version 3.10.2:
    The hpcups driver is again updated to better align with
    the product specifications for various printer models.
    Several more supported all-in-one devices.
    Several bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.9.12:
    The hpcups driver is updated to better align with the
    product specifications for various printer models.
    Several more supported printers.
    Several bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.9.10:
    The hpcups driver has been re-written. It does no longer do
    bi-directional IO. Printer specific settings are no longer
    hard coded, but are controlled by the PPD file.
    Many more supported printers and all-in-one devices.
    Several bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - hpcups.drv.in-3.9.8-reorder.patch and
    hpcups-ppds-3.9.8-reorder.tar.bz2 are obsolete
    because it is fixed in the source.
  - create_hal_global_fdi_from_hpmud_rules is obsolete
    because HAL is no longer used to manage ACLs
    (see Novell/Suse Bugzilla bnc#542473 comment#13).
  - change-udev-rules.diff fixes now also 56-hpmud_support.rules
    (see for example Novell/Suse Bugzilla bnc#577035) and
    it should trigger udev's generic ACL support for SANE
    via 'ENV{libsane_matched}="yes"' in 55-hpmud.rules
    (see Novell/Suse Bugzilla bnc#542473 comment#14).
    Perhaps the latter could be better achieved with the
    configure option --enable-udev-acl-rules (default=no)
    which installs 40-hplip.rules instead of 55-hpmud.rules
    but this was not at all tested up to now and it is
    likely not backward compatible (e.g. for openSUSE 11.2).
* Thu Oct 15 2009 jsmeix@suse.de
  - Also moved /usr/share/hplip/data/models/models.dat
    and /etc/hp/hplip.conf to the hplip-hpijs sub-package
    so that the "hp" backend can autodetect printers
    (see Novell/Suse Bugzilla bnc#546856 comment#10).
* Thu Oct 15 2009 jsmeix@suse.de
  - In the hplip-hpijs sub-package made weak package dependencies
    even weaker to avoid bloating of minimal installations. Now
    the hplip-hpijs sub-package only "Enhances: ghostscript_any"
    and "Suggests: hplip" (see Novell/Suse Bugzilla bnc#546893).
  - Enlarged hplip-hpijs to be useful for a CUPS print queue.
    Moved the following files from the hplip main package
    to the hplip-hpijs sub-package: cups/backend/hp,
    cups/filter/foomatic-rip-hplip, cups/filter/hpcac,
    cups/filter/hpcups, cups/filter/hplipjs,
    and all PPD files (see Novell/Suse Bugzilla bnc#546856).
* Wed Sep 16 2009 jsmeix@suse.de
  - hpcups.drv.in-3.9.8-reorder.patch addresses two issues
    in the 3.9.8 hpcups.drv.in file from which dynamic PPDs
    are generated.
    It re-orders common paper sizes so that normal, fullbleed
    and duplex papers sizes are grouped together in the PPD.
    It changes the LJColor device class from RGBW to RGB
    color space. The K band was not being printed by hpcups.
  - The hpcups-ppds-3.9.8-reorder.tar.bz2 source file contains
    the matching static PPDs which are fixed according to what
    hpcups.drv.in-3.9.8-reorder.patch fixes for dynamic PPDs.
* Thu Aug 06 2009 jsmeix@suse.de
  - The hplip.SuSEfirewall2 source file provides support
    to open UDP ports 5353(mdns) and 427(svrloc) for mDNS support
    according to the init-suse-firewall in the tar ball
    (see Novell/Suse Bugzilla bnc#528819).
  - Updated to version 3.9.8:
    Added mDNS/Bonjour support.
    Enabled mDNS as the default network search mechanism.
    Added front-end support for mDNS/Bonjour in setup.
    Added hpmud support for mDNS.
    The tar ball provides a init-suse-firewall init script
    for mDNS support which is not included in the RPM.
    Fixed wificonfig associate issue when called from hp-setup.
    Added 40-hplip.rules to the tar ball for distros with
    udev ACL support. Use configure option --enable-udev-acl-rules
    to install 40-hplip.rules instead of 55-hpmud.rules.
    Fixed Normal Grayscale on DJ8xx and DJ8x5 for HPCUPS.
    Added -lsane link option for libsane-hpaio in Makefile.
    Many more supported printers and all-in-one devices.
    Many bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Wed Jul 01 2009 jsmeix@suse.de
  - Fixed hp-toolbox.wrapper by adding "..." quotation when
    calling 'test -x "$( type -p whatever )"' because
    when 'type -p whatever' fails calling 'test -x' without
    an explicite empty argument would result true
    (see Novell/Suse Bugzilla bnc#503322 comment#6).
  - fix_gcc44_glib.diff is obsolete since version 3.9.6b
    because it is fixed in the source.
  - Updated to version 3.9.6b:
    The new native CUPS driver (HPCUPS) is now the default
    printer driver. HPCUPS provides new paper sizes for borderless
    and duplex so that there are now HPCUPS PPDs with exact
    printable regions for normal, borderless and duplex paper sizes
    which should fix https://bugs.launchpad.net/hplip/+bug/173857
    For now HPIJS (and its matching foomatic-rip-hplip PPDs)
    are still included (HPIJS can co-exist with HPCUPS).
    A new utility 'hp-wificonfig' can pre-configure wifi-capable
    printers on a wireless network. Once pre-configured, a queue
    for the printer can be set up as usual using hp-setup.
    Renamed hp-devicesetup to hp-devicesettings.
    Added CUPS filter hpcupsfax and new hpcups fax PPDs.
    Bumped libhpmud.so.0.0.4 to libhpmud.so.0.0.5.
    Integrated --enable-lite-build (default=no) into configure.in
    which can be used to get a minimal print/scan only build with
    limited Plugin support (Novell/Suse provides the "full" build).
    Many more supported printers and all-in-one devices.
    Many bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
* Tue Jun 02 2009 jsmeix@suse.de
  - fix_gcc44_glib.diff fixes GCC/glibc issues, here in particular
    "invalid conversion from 'const char*' to 'char*'" errors.
    The upstream bug report is
    https://bugs.launchpad.net/hplip/+bug/382720
* Tue May 05 2009 jsmeix@suse.de
  - force-qt4-for-hp-systray-desktop.diff is obsolete because
    configure uses --enable-qt4 by default now which obsoletes
    also "Recommends: python-qt" (only python-qt4 is required).
  - Updated to version 3.9.4b:
    A few bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.9.4:
    Added PolicyKit support. Command line tools like hp-setup,
    hp-plugin, etc. are now run as regular user.
    Added GPG digital signature support to the HPLIP plug-in
    to validate that the plug-in is not corrupted and authentic.
    Added native CUPS driver support (hpcups) currently for
    testing only and added static PPDs for hpcups.
    Some more supported printers and all-in-one devices
    (in particular a few Designjet PostScript printers).
    Many bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 3.9.2:
    Qt4 now default UI.
    Support policy change. End of support date is added to
    all HPLIP supported devices, for details see
    http://hplipopensource.com/node/314
    New file /var/lib/hp/hplip.state for runtime variable data.
    Removed any variable data from /etc/hp/hplip.conf.
    Some more supported printers and all-in-one devices.
    Major bug fixing on Qt4 solution (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 2.8.12:
    From this release forward, all PPD files - even for devices
    that require a binary plug-in - will reside in the tarball
    (the "plugin PPDs" are moved into hpijs.drv).
    Preview (alpha) release of the Qt4 version of HPLIP.
    Replaced "MODE 0666" udev device permissions with
    "console permissions via HAL".
    No new supported devices.
    Several bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 2.8.10:
    Bumped libhpmud version for new plugin attribute.
    Many more supported printers and all-in-one devices.
    Several bug fixes (no Suse bugs).
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html
  - Updated to version 2.8.9:
    Added Qt4 configure option but Qt3 is the default.
    Many bug fixes (no Suse bugs).
    Several more supported printers, in particular
    some Compact Photo (QuickConnect) printers.
    For details see
    http://hplipopensource.com/hplip-web/release_notes.html

Files

/usr/lib64/sane
/usr/lib64/sane/libsane-hpaio.so.1
/usr/lib64/sane/libsane-hpaio.so.1.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 10:42:46 2022