Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libSavitar0-4.13.1-bp154.1.21 RPM for s390x

From OpenSuSE Leap 15.4 for s390x

Name: libSavitar0 Distribution: SUSE Linux Enterprise 15 SP4
Version: 4.13.1 Vendor: openSUSE
Release: bp154.1.21 Build date: Mon May 9 20:04:57 2022
Group: System/Libraries Build host: s390zp21
Size: 194092 Source RPM: libSavitar-4.13.1-bp154.1.21.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/Ultimaker/libSavitar
Summary: 3D printer control software
libSavitar is a C++ implementation of 3mf loading with SIP python bindings.

Provides

Requires

License

LGPL-3.0-only

Changelog

* Sat Feb 26 2022 Max Lin <mlin@suse.com>
  - Use BuildRequires python3-qt5-sip for Leap 15.4
* Sun Feb 06 2022 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - update to 4.13.1
    Release notes:
    * https://github.com/Ultimaker/Cura/releases/tag/4.13.1
* Thu Jan 27 2022 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - update to 4.13.0
    Release notes:
    * https://github.com/Ultimaker/Cura/releases/tag/4.13.0
  - Drop upstreamed patch:
    * libSavitar-3.5.1-PyQt5.sip.patch
* Mon Apr 26 2021 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - update to 4.9.0
    Release notes:
    * https://github.com/Ultimaker/Cura/releases/tag/4.9
* Sun Nov 22 2020 Benjamin Greiner <code@bnavigator.de>
  - Depend on the PyQt5.sip module (see sr#849990 for libArcus)
  - Refresh libSavitar-3.5.1-PyQt5.sip.patch to query correct module
    for version
* Sat Nov 21 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Depend on python3-sip < 5, as libSavitar build is incompatible
    with SIP 5 and upstream currently has no intention to update,
    see gh#Ultimaker/libSavitar#26.
* Tue Nov 10 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - update to 4.8.0
    * no code changes, just some build system churn.
* Sun Jun 07 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - update to version 4.6.1
    * mostly internal changes
  - Fix Savitar python import error with current PyQt5, add
    libSavitar-3.5.1-PyQt5.sip.patch
* Thu Jan 02 2020 Adrian Schröter <adrian@suse.de>
  - update to version 4.4.1
    * mostly internal changes
* Wed Jun 26 2019 Adrian Schröter <adrian@suse.de>
  - update to version 4.1.0
    * https://ultimaker.com/en/products/ultimaker-cura-software/release-notes
  - enable test cases
* Fri Nov 23 2018 Adrian Schröter <adrian@suse.de>
  - update to version 3.6.0
    * version change only
* Wed Oct 17 2018 Adrian Schröter <adrian@suse.de>
  - update to version 3.5.1
    * version change only
* Wed Aug 08 2018 jengelh@inai.de
  - Rename %soname to %sover to better reflect its use.
  - Fix RPM groups for Factory.
* Mon Aug 06 2018 adrian@suse.de
  - update to version 3.4.1
* Mon May 14 2018 christophe@krop.fr
  - Initial package.

Files

/usr/lib64/libSavitar.so.0
/usr/lib64/libSavitar.so.0.1.2
/usr/lib64/python3.6/site-packages/Savitar.so
/usr/share/doc/packages/libSavitar0
/usr/share/doc/packages/libSavitar0/README.md
/usr/share/licenses/libSavitar0
/usr/share/licenses/libSavitar0/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 9 21:09:43 2022