Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

enchant-2-backend-hunspell-2.2.15-150400.1.9 RPM for ppc64le

From OpenSuSE Leap 15.4 for ppc64le

Name: enchant-2-backend-hunspell Distribution: SUSE Linux Enterprise 15
Version: 2.2.15 Vendor: SUSE LLC <https://www.suse.com/>
Release: 150400.1.9 Build date: Sun May 8 00:23:56 2022
Group: Unspecified Build host: cabernet
Size: 67984 Source RPM: enchant-2.2.15-150400.1.9.src.rpm
Packager: https://www.suse.com/
Url: https://abiword.github.io/enchant/
Summary: Hunspell backend for the Enchant spell checking library
Hunspell plugin for enchant, a library providing an efficient
extensible abstraction for dealing with different spell checking
libraries.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Tue Mar 16 2021 dmueller@suse.com
  - Update to version 2.2.15:
    + Specify that nuspell >= 4.1.0 is required.
    + Fix some space leaks in the tests.
    + The nuspell backend is updated for newer versions.
    + Make the enchant program output its version to standard output,
      not standard error. This may help some programs that use this
      output.
    + Fix a bug in the Voikko and Zemberek back-ends that could cause
      spell checking and suggestion to fail.
    + Make enchant silently ignore -B flag, for better Emacs
      compatibility.
    + Make enchant_broker_list_dicts sort the tags, so that
      enchant-lsmod’s output is sorted.
    + Minor build system improvement: don’t use -D_FORTIFY_SOURCE,
      which can cause problems on Windows, and should be configured
      by the compiler vendor if desired.
    + Fix Hunspell backend to treat apostrophes as Hunspell does: if
      either straight or curly apostrophe is a word character, allow
      both.
    + Fix a couple of space leaks in the Nuspell back end.
  - Drop Fix_back-ends_that_want_a_NUL-terminated_string.patch: fixed
    upstream.
* Thu Nov 05 2020 tjyrinki@suse.com
  - Backport from upstream git a Voikko backend fix (bsc#1178489)
    + Add Fix_back-ends_that_want_a_NUL-terminated_string.patch
* Tue Aug 18 2020 badshah400@gmail.com
  - Enable nuspell backend where it is available (openSUSE >= 1550):
    + Introduce BuildRequires: nuspell-devel and
      libboost_headers-devel.
    + Split out new package enchant-2-backend-nuspell providing the
      nuspell backend.
* Wed Aug 05 2020 elimat@opensuse.org
  - Update to version 2.2.8:
    + Add a provider back-end for Nuspell. Nuspell is a new
      spell-checker whose development has been supported by the
      Mozilla foundation. It is backwards-compatible with Hunspell
      and Myspell dictionaries, while supporting a wider range of
      language peculiarities, improved suggestions, and easier
      maintainability of the code-base.
    + Doxygen documentation generation is now supported for Enchant.
    + The command-line parsing of the “enchant” program has been made
      more friendly and reliable. The -L flag (show line numbers),
      which had not been working for some time, has been fixed.
    + A buffer overflow in personal wordlist handling has been fixed.
    + Minor improvements were made to the tests.
  - Changes in version 2.2.7:
    + Fix some memory leaks in the hunspell and aspell providers.
  - Changes in version 2.2.6:
    + Treat PWL as text, not binary.
  - Run spec-cleaner: Remove package groups.
* Mon Apr 13 2020 yfjiang@suse.com
  - Enable aspell support on SLE to synchronize with Leap.
* Mon Oct 21 2019 yfjiang@suse.com
  - Disable aspell support on SLE.
* Fri Oct 18 2019 yfjiang@suse.com
  - Redownload the 2.2.5 tarball to reflect the consistent upstream
    release provided in Source.
* Fri Jul 19 2019 alarrosa@suse.com
  - Update to version 2.2.5:
    + Fix a memory leak in the hunspell provider.
  - Changes from version 2.2.4:
    + Fix a bug in the enchant program, where words ending in non-ASCII
      characters were truncated during tokenization.
* Wed Apr 03 2019 mrostecki@opensuse.org
  - Add enchant-2-backend-aspell package which provides the aspell
    backend for enchant.
* Sun Jun 03 2018 dleuenberger@suse.com
  - Revert parts of last change: Still using supplementes instead of
    boolean rich deps: zypper dup from < CODE15 is impossible
    otherwise.
* Tue May 29 2018 badshah400@gmail.com
  - Fix installation of backends (bgo#1089433):
    + Drop Supplements entirely.
    + For the shared lib package, add conditional Requires on
      either/both the hunspell or voikko backends depending on
      whether the system has libhunspell and/or libvoikko installed.
    + Add a Suggests on -backend-hunspell for the case where neither
      libvoikko not libhunspell are installed.
* Sat Mar 10 2018 jengelh@inai.de
  - Update descriptions.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Update to version 2.2.3:
    + Brown paper bag: fix 2.2.2 as intended.
  - Changes from version 2.2.2:
    + Fix a bug in the build system where the test harness would try
      to delete files under root, typically the system libraries.
  - Changes from version 2.2.1:
    + Fix a crash on invalid input with the hspell backend.
    + Remove some bashisms from the build system.
    + updates the Free Software Foundation’s street address.
    + Stop running some tests that fail on recent macOS.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner.
* Wed Dec 13 2017 dimstar@opensuse.org
  - Update to version 2.2.0:
    + Improves support for parallel installation with other major
      versions of Enchant (specifically for man pages).
    + Fix relocation support.
    + Minor documentation improvements
    + Fix a potential crash in the hspell back-end.
  - Update URL to https://abiword.github.io/enchant/.
  - Adjust packaging, following the shared library packaging policy
    and allowing for coexistance of enchant-1 and enchant-2 (as
    foreseen by upstream):
    + Split enchant-1-data package (providing enchant-data, generic
      name) from libenchant1.
    + Split enchant-1-backends from libenchant1: the main backends.
    + Add conflict to libenchant1 < 1.6.1 to the split packages (and
      appropriate split provides).
    + Rename enchant-{voikko,zemberek} to
      enchant-2-backend-{voikko,zemberek}.
  - Drop enchant-hunspell-1.4.0.patch: no longer needed.
* Fri Aug 11 2017 pgajdos@suse.com
  - aspell to be removed from factory (bsc#1052949, FATE#323578).
* Mon May 02 2016 dimstar@opensuse.org
  - Add enchant-hunspell-1.4.0.patch: Fix build against
    hunspell 1.4.0, where MAXWORDLEN is no longer exported.

Files

/usr/lib64/enchant-2
/usr/lib64/enchant-2/enchant_hunspell.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 20:57:40 2022