Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ruby2.5-rubygem-sprockets-3.7.2-3.3.1 RPM for ppc64le

From OpenSuSE Leap 15.3 for ppc64le

Name: ruby2.5-rubygem-sprockets Distribution: SUSE Linux Enterprise 15
Version: 3.7.2 Vendor: SUSE LLC <https://www.suse.com/>
Release: 3.3.1 Build date: Fri Jun 22 10:50:42 2018
Group: Development/Languages/Ruby Build host: ananas
Size: 326859 Source RPM: rubygem-sprockets-3.7.2-3.3.1.src.rpm
Packager: https://www.suse.com/
Url: https://github.com/rails/sprockets
Summary: Rack-based asset packaging system
Sprockets is a Rack-based asset packaging system that concatenates and serves
JavaScript, CoffeeScript, CSS, LESS, Sass, and SCSS.

Provides

Requires

License

MIT

Changelog

* Tue Jun 19 2018 factory-auto@kulow.org
  - updated to version 3.7.2
    see installed CHANGELOG.md
    * *3.7.2** (June 19, 2018)
    * Security release for [CVE-2018-3760](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-3760).
    (bsc#1098369)
* Tue Dec 20 2016 coolo@suse.com
  - updated to version 3.7.1
    see installed CHANGELOG.md
* Sat Jul 23 2016 coolo@suse.com
  - updated to version 3.7.0
    see installed CHANGELOG.md
    * * 3.7.0** (July 21, 2016)
    * Deprecated interfaces now emit deprecation warnings #345
* Mon Jul 04 2016 coolo@suse.com
  - updated to version 3.6.3
    see installed CHANGELOG.md
    * *3.6.3** (July 1, 2016)
    * Faster asset lookup in large directories #336
    * Faster PathUtils.match_path_extname https://github.com/rails/sprockets/commit/697269cf81e5261fdd7072e32bd489403027fd7e
    * Fixed uglifier comment stripping #326
    * Error messages now show load path info #313
* Wed Jun 29 2016 coolo@suse.com
  - updated to version 3.6.2
    see installed CHANGELOG.md
    * *3.6.2** (June 21, 2016)
    * More performance improvements.
* Sat Jun 18 2016 coolo@suse.com
  - updated to version 3.6.1
    see installed CHANGELOG.md
    * *3.6.1** (June 17, 2016)
    * Some performance improvements.
* Thu Apr 07 2016 coolo@suse.com
  - updated to version 3.6.0
    see installed CHANGELOG.md
* Sat Dec 12 2015 coolo@suse.com
  - updated to version 3.5.2
    see installed CHANGELOG.md
    * *3.5.2** (December 8, 2015)
    * Fix JRuby bug with concurrent-ruby.
    * Fix disabling gzip generation in cached environments.
* Tue Dec 08 2015 coolo@suse.com
  - updated to version 3.5.1
    see installed CHANGELOG.md
    * *3.5.1** (December 5, 2015)
    * Fix gzip asset generation for assets already on disk.
* Fri Dec 04 2015 coolo@suse.com
  - updated to version 3.5.0
    see installed CHANGELOG.md
    * *Master**
    * *3.5.0** (December 3, 2015)
    * Reintroduce Gzip file generation for non-binary assets.
* Thu Nov 26 2015 coolo@suse.com
  - updated to version 3.4.1
    see installed CHANGELOG.md
    * *3.4.1** (November 25, 2015)
    * PathUtils::Entries will no longer error on an empty directory.
* Tue Oct 06 2015 coolo@suse.com
  - updated to version 3.4.0
    see installed CHANGELOG.md
    * *3.4.0** (October 5, 2015)
    * Expose method to override the sass cache in the SassProcessor.
* Sat Sep 26 2015 coolo@suse.com
  - updated to version 3.3.5
    see installed CHANGELOG.md
    * *3.3.5** (September 25, 2015)
    * Fix bug related to absolute path being reintroduced into history cache #141.
* Wed Sep 02 2015 coolo@suse.com
  - updated to version 3.3.4
    see installed CHANGELOG.md
    * *3.3.4** (September 1, 2015)
    * Relative cache contents now work with windows.
* Mon Aug 24 2015 coolo@suse.com
  - updated to version 3.3.3
    see installed CHANGELOG.md
    * *3.3.3** (August 21, 2015)
    * Remove more absolute paths from cache contents.
    * *3.3.2** (August 19, 2015)
    * Fix cache contents to use relative paths instead of absolute paths.
    * *3.3.1** (August 15, 2015)
    * Fix legacy Tilt integration when locals is required argument.
* Thu Aug 13 2015 coolo@suse.com
  - updated to version 3.3.0
    no changelog found
* Wed Jun 03 2015 coolo@suse.com
  - updated to version 3.2.0
    no changelog found
* Mon May 11 2015 coolo@suse.com
  - updated to version 3.1.0
    no changelog found
* Tue Apr 28 2015 coolo@suse.com
  - updated to version 3.0.3
    no changelog found
* Thu Apr 23 2015 coolo@suse.com
  - updated to version 3.0.2
    no changelog found
* Wed Apr 15 2015 coolo@suse.com
  - updated to version 3.0.1
* Mon Apr 13 2015 coolo@suse.com
  - updated to version 3.0.0
    * New processor API. Tilt interface is deprecated.
    * Improved file store caching backend.
    * MIME Types now accept charset custom charset detecters. Improves support for UTF-16/32 files.
    * Environment#version no longer affects asset digests. Only used for busting the asset cache.
    * Removed builtin support for LESS.
    * Removed `//= include` directive support.
    * Deprecated `BundledAsset#to_a`. Use `BundledAsset#included` to access debugging subcomponents.
    * Support circular dependencies. For parity with ES6 modules.
    * Manifest compilation will no longer generate .gz files by default. [Mixing
    Content-Encoding and ETags is just a bad
    idea](https://issues.apache.org/bugzilla/show_bug.cgi?id=39727)
    * Added linked or referenced assets. When an asset is compiled, any of its links will be compiled as well.
    * Introduce some limitations around enumerating all logical paths. 4.x will deprecate it and favor linked manifests for compliation.
    * Add Asset integrity attribute for Subresource Integrity
    * Default digest changed to SHA256. Configuring `digest_class` is deprecated.
    * Rename `Asset#digest` to `Asset#hexdigest`. `Asset#digest` is deprecated and will
    return a raw byte String in 4.x.
    * Added transitional compatibility flag to `Environment#resolve(path, compat: true)`. 2.x mode operates with `compat: true` and 4.x with `compat: false`
    * `manifest-abc123.json` renamed to `.sprockets-abc123.json`
* Tue Feb 10 2015 coolo@suse.com
  - updated to version 2.12.3
    * Security: Fix directory traversal bug in development mode server.
* Sun Oct 12 2014 coolo@suse.com
  - updated to version 2.12.2
    * Ensure internal asset lookups calls are still restricted to load paths within
    asset compiles. Though, you should not depend on internal asset resolves to be
    completely restricted for security reasons. Assets themselves should be
    considered full scripting environments with filesystem access.
  - adapt to new rubygem packaging
* Tue Apr 22 2014 coolo@suse.com
  - updated to version 2.12.1
    * Fix making manifest target directory when its different than the output directory.
* Fri Mar 21 2014 coolo@suse.com
  - updated to version 2.12.0
    * Avoid context reference in SassImporter hack so its Marshallable. Fixes
    issues with Sass 3.3.x.
* Sat Feb 22 2014 coolo@suse.com
  - updated to version 2.11.0
    * Support for `.bower.json`
* Sat Nov 23 2013 coolo@suse.com
  - updated to version 2.10.1
    `depend_on_asset` *path* works like `depend_on`, but operates
    recursively reading the file and following the directives found.
  - fix usage of update-alternatives
* Sat May 25 2013 coolo@suse.com
  - updated to version 2.10.0
    * Support for `bower.json`
* Wed Apr 24 2013 coolo@suse.com
  - updated to version 2.9.3
    * Fixed sass caching bug
* Fri Apr 12 2013 coolo@suse.com
  - updated to version 2.9.2
    * Improve file freshness check performance
    * Directive processor encoding fixes
    * Support for Uglifier 2.x
* Sun Mar 03 2013 coolo@suse.com
  - updated to version 2.9.0
    * Write out gzipped variants of bundled assets.
* Tue Dec 18 2012 coolo@suse.com
  - updated to version 2.8.2
    * Fixed top level Sass constant references
    * Fixed manifest logger when environment is disabled
* Thu Nov 01 2012 coolo@suse.com
  - updated to version 2.8.1
    * Fixed Sass importer bug
* Sun Oct 28 2012 coolo@suse.com
  - updated to version 2.8.0
    * Allow manifest location to be seperated from output directory
    * Pass logical path and absolute path to each_logical_path iterator
* Fri Oct 12 2012 coolo@suse.com
  - updated to version 2.7.0
    * Added --css-compressor and --js-compressor command line flags
    * Added css/js compressor shorthand
    * Change default manifest.json filename to be a randomized manifest-16HEXBYTES.json
    * Allow nil environment to be passed to manifest
    * Allow manifest instance to be set on rake task
* Sun Sep 23 2012 coolo@suse.com
  - updated to version 2.6.0
    Added bower component.json require support
* Tue Sep 04 2012 coolo@suse.com
  - updated to version 2.5.0
    * Fixed Ruby 2.0 RegExp warning
    * Provide stubbed implementation of context *_path helpers
    * Add SassCompressor
* Wed Aug 01 2012 cfarrell@suse.com
  - license update: MIT
    See data/LICENSE
* Wed Aug 01 2012 coolo@suse.com
  - no need for the extra suffix, renamed back to rubygem-sprockets
* Sun Jul 15 2012 coolo@suse.com
  - update to 2.4.5
    * Tweaked some logger levels
    * Canonicalize logical path extensions
    * Check absolute paths passed to depend_on
* Sun Jun 10 2012 coolo@suse.com
  - update to 2.4.3
    * Exposed :sprockets in sass options
    * Include dependency paths in asset mtime
* Tue May 08 2012 coolo@suse.com
  - update to 2.4.2
    * Fixed MultiJson feature detect
* Sat Apr 28 2012 coolo@suse.com
  - update to 2.4.1
    * Fixed MultiJson API change
    * Fixed gzip mtime
* Wed Apr 04 2012 coolo@suse.com
  - fork for 2.4 branch
* Fri Mar 23 2012 saschpe@suse.de
  - Spec file cleanup:
    * Factory preparation
* Thu Jan 26 2012 mrueckert@suse.de
  - initial package for the 2.1 branch

Files

/etc/alternatives/sprockets
/etc/alternatives/sprockets-3.7.2
/etc/alternatives/sprockets.ruby2.5
/usr/bin/sprockets
/usr/bin/sprockets-3.7.2
/usr/bin/sprockets.ruby2.5
/usr/bin/sprockets.ruby2.5-3.7.2
/usr/lib64/ruby/gems/2.5.0/build_info
/usr/lib64/ruby/gems/2.5.0/cache/sprockets-3.7.2.gem
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/CHANGELOG.md
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/LICENSE
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/README.md
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/bin
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/bin/sprockets
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/rake
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/rake/sprocketstask.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/asset.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/closure.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/coffee_script.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/eco.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/ejs.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/sass.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/uglifier.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/autoload/yui.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/base.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/bower.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/bundle.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cache
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cache.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cache/file_store.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cache/memory_store.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cache/null_store.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/cached_environment.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/closure_compressor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/coffee_script_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/coffee_script_template.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/compressing.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/configuration.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/context.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/dependencies.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/deprecation.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/digest_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/directive_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/eco_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/eco_template.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/ejs_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/ejs_template.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/encoding_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/engines.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/environment.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/erb_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/erb_template.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/errors.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/file_reader.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/http_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/jst_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/legacy.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/legacy_proc_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/legacy_tilt_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/manifest.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/manifest_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/mime.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/path_dependency_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/path_digest_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/path_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/paths.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/processing.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/resolve.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_cache_store.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_compressor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_functions.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_importer.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_processor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/sass_template.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/server.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/transformers.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/uglifier_compressor.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/unloaded_asset.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/uri_tar.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/uri_utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/utils
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/utils.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/utils/gzip.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/version.rb
/usr/lib64/ruby/gems/2.5.0/gems/sprockets-3.7.2/lib/sprockets/yui_compressor.rb
/usr/lib64/ruby/gems/2.5.0/specifications/sprockets-3.7.2.gemspec
/usr/share/doc/packages/ruby2.5-rubygem-sprockets
/usr/share/doc/packages/ruby2.5-rubygem-sprockets/CHANGELOG.md
/usr/share/doc/packages/ruby2.5-rubygem-sprockets/LICENSE
/usr/share/doc/packages/ruby2.5-rubygem-sprockets/README.md


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 15:55:55 2022