Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ruby-common-2.1-3.15 RPM for noarch

From OpenSuSE Leap 15.3 for noarch

Name: ruby-common Distribution: SUSE Linux Enterprise 15
Version: 2.1 Vendor: SUSE LLC <https://www.suse.com/>
Release: 3.15 Build date: Fri May 25 20:12:22 2018
Group: Development/Languages/Ruby Build host: sheep14
Size: 37828 Source RPM: ruby-common-2.1-3.15.src.rpm
Packager: https://www.suse.com/
Url: https://github.com/openSUSE/ruby-packaging/
Summary: Collection of scripts and macros for ruby packaging
This package is needed for (generated) ruby gems. It provides hooks for
automatic rpm provides and requires and macros that gem2rpm uses.

Provides

Requires

License

MIT

Changelog

* Wed Jan 24 2018 lnussel@suse.de
  - generate bundled(rubygem($name)) = $version provides for bundled
    gems in the vendor directory.
* Tue Dec 12 2017 mrueckert@suse.de
  - switch requires of the autogenerated subpackages from
    rb_suffix-rubygem-gemname = version to
    rubygem(rb_abi:gemname) = version
* Thu Nov 30 2017 mrueckert@suse.de
  - split our the rails part
* Thu Nov 30 2017 mrueckert@suse.de
  - we need bundler now. given ruby 2.5 will have it intree anyway,
    this soon wont be a big burden.
* Thu Nov 30 2017 mrueckert@suse.de
  - add support to generate requires from Gemfile.lock
* Mon Aug 07 2017 mrueckert@suse.de
  - package the buildinfo dir
  - allow passing options to extconf.rb
* Tue Jun 13 2017 bwiedemann@suse.com
  - Call fdupes -o name to make sure we always create symlinks
    in the same direction to make builds reproducible
* Tue Mar 01 2016 mrueckert@suse.de
  - Since rubygems 2.5.0 the default version in the gem bin stub
    changed from '>= 0' to '>= 0.a'. This was done to allow
    prerelease versions. Our patching script didn't take the '.a'
    into account and generated version fields like '= 0.10.1.a'
    instead of the expected '= 0.10.1'. This fix accounts for the
    '.a'.
* Thu Jun 11 2015 lnussel@suse.de
  - help the solver to pick the right gem2rpm for the default ruby
    version (bnc#934328)
* Sat May 02 2015 mrueckert@suse.de
  - Fix patching of the shebang line
* Thu Apr 16 2015 mrueckert@suse.de
  - The script sometimes returned from gem install already although
    the install wasn't finished yet. This broke e.g. the binary
    rename part.
* Fri Mar 13 2015 mrueckert@suse.de
  - Fail early if gem install fails
    This avoids confusing error messages at the end of the build.
* Fri Mar 13 2015 mrueckert@suse.de
  - More fixes for ruby 1.8
* Fri Mar 13 2015 mrueckert@suse.de
  - Ruby 1.8 insists on the () for the parameter
* Fri Mar 13 2015 mrueckert@suse.de
  - Cleaner solution for the extensions doc dir
    The other solution was also failing on 1.8
* Fri Mar 13 2015 mrueckert@suse.de
  - Forgot another option for forwarding
* Fri Mar 13 2015 mrueckert@suse.de
  - Do not overwrite options.otheropts
* Fri Mar 13 2015 mrueckert@suse.de
  - Fixed forwarding of options to gem install
* Fri Mar 13 2015 mrueckert@suse.de
  - Only use the extensions doc dir on MRI 2.1.x
* Fri Mar 13 2015 mrueckert@suse.de
  - Fix the ruby suffix for distributions before 13.2
  - Do not fail with --gem-binary
* Fri Mar 13 2015 mrueckert@suse.de
  - switch to ruby version of gem_install.sh
  - added ruby-find-versioned to make it easier to find versioned
    binaries.
    - all for loops in the shell scripts and macros are now using
      this script
* Thu Mar 12 2015 mrueckert@suse.de
  - call ruby with -x from shell wrappers otherwise we run into an
    endless loop
* Thu Jan 15 2015 dmueller@suse.com
  - rubygemsdeps.rb: add shell-launcher to avoid dependency on
    a fixed ruby version
* Tue Jan 13 2015 dmueller@suse.com
  - gem_install.sh: fix ruby shebang patching
* Sat Nov 15 2014 Led <ledest@gmail.com>
  - fix bashisms in generate_buildrequires.sh script
* Tue Oct 21 2014 mrueckert@suse.de
  - restore changes lost by the previous change
    - load rbconfigpackagingsupport if available and fail gracefully
      if not.
    - dont use not() it breaks the build on 1.8
    - remove requires onto the ruby version
* Sat Oct 18 2014 coolo@suse.com
  - update gem_packages template from git
* Mon Sep 29 2014 mrueckert@suse.de
  - ignore any files we find in */.gem/*. in some versions of
    rubygems, gems that are installed are also copied to ~/.gem/.
* Fri Sep 26 2014 mrueckert@suse.de
  - we dont always have /usr/bin/ruby, use perl for patching the
    version in the bin wrapper. also replaced the sed for patching
    the shebang line.
  - fixed a bad bug in the shebang line. we had an additional "."
    there.
* Fri Sep 26 2014 mrueckert@suse.de
  - install gemrc on all distros
* Fri Sep 26 2014 mrueckert@suse.de
  - dont delete .a files. there are actually gems where we need them
    like rubygem-libv8 for rubygem-therubyracer
* Tue Sep 23 2014 mrueckert@suse.de
  - fix the case where we dont symlink the binaries.
* Fri Sep 19 2014 mrueckert@suse.de
  - gem_cleanup macro was missed when updating for old ruby versions.
* Fri Sep 19 2014 mrueckert@suse.de
  - switch from "ruby -rrubygems -e
    'print Gem::Specification.new.base_dir'"
    to "gem env gemdir"
* Fri Sep 19 2014 mrueckert@suse.de
  - gem_build_cleanup: also delete static library files
* Wed Sep 17 2014 mrueckert@suse.de
  - ruby 1.8 support:
    - gem_packages.sh: change to /usr/src/packages when
      /home/abuild/rpmbuild doesn't exist.
    - gem_packages template:
    - require rbconfigpackagingsupport to fix the ruby_install_name
      dependent variables. we do that for all distros but catch the
      LoadError and continue.
    - and dont use not(), we need to use "!" instead.
* Wed Sep 17 2014 mrueckert@suse.de
  - our sle 11 sp3 rpm does provide the support for the automatic
    rubygems dependency but does not provide
    rpm-with-ruby-provide-hook. guard the requires with > 1110
* Wed Sep 17 2014 mrueckert@suse.de
  - remove the handling of spec.required_ruby_version here. this
    should be handled in rubygemsdeps.rb if at all. we already guard
    for this in the buildrequires and then have a requires via the
    $interpreter(abi) requires onto the newer version.
* Wed Sep 17 2014 mrueckert@suse.de
  - invert the logic. only stop shipping /etc/gemrc on 12.3 and 13.1
* Wed Sep 17 2014 mrueckert@suse.de
  - gem_packages template:
    Dont allow an suffix with just a plain number. prefix it with
    ruby.
* Wed Sep 17 2014 mrueckert@suse.de
  - gem_packages also need the rewrite that rewrites a number only
    suffix into .ruby<numbersuffix>
* Wed Sep 17 2014 mrueckert@suse.de
  - made the matcher for older versions more strict so we dont pick
    up gem2rpm.
* Wed Sep 17 2014 mrueckert@suse.de
  - also add support for older versioning in gem_packages.sh
* Wed Sep 17 2014 mrueckert@suse.de
  - added support for the versioning scheme in 13.1 and older
  - dont ship gemrc on 13.1
* Mon Sep 15 2014 mrueckert@suse.de
  - the ruby(abi) = $interpreter:$abiversion was not a good idea. rpm
    treats the $interpreter part as epoch. instead we use now:
    $interpreter(abi) = $abiversion
    For MRI it means we are basically back to ruby(abi).
    Examples for alternative ruby interpreters are rubinius(abi) and
    jruby(abi) (bnc#896658)
* Mon Sep 08 2014 mrueckert@suse.de
  - disable extensions doc dir on rubinius
* Mon Sep 08 2014 mrueckert@suse.de
  - workaround https://github.com/rubinius/rubinius/issues/2732
    for UTF8 locale in gem_packages.sh
* Thu Sep 04 2014 mrueckert@suse.de
  - we actually need the splitted version in any case. uncomment it
    again
* Wed Sep 03 2014 mrueckert@suse.de
  - pass the ruby abi as hash containing :interpreter, :version,
    :abi as keys. that way we have the full new string but also the
    version for the 1.8 support
* Wed Sep 03 2014 mrueckert@suse.de
  - rubygemsdeps.rb:
    - make the provides/requires also include the ruby interpreter
    - no longer emit the old package name style provides
  - rubygems.attr:
    - make the path a bit more relaxed so we can match other ruby
      interpreter too
* Wed Jul 16 2014 mrueckert@suse.de
  - added ruby-common.macros:
    Holds the common macros for the rpm macro based buildrequires.
  - merged ruby.macros into ruby.rpm-macros:
    the later file now carries the rb_* and gem_* macros
* Tue Jul 15 2014 mrueckert@suse.de
  - ruby.macros: drop the duplicate gem macros
* Tue Jul 15 2014 mrueckert@suse.de
  - fix small typo in opensuse.spec.erb which broke the formatting.
* Tue Jul 15 2014 mrueckert@suse.de
  - no longer require ruby(-devel). ruby-common is required by
    rubyX.Y so we should always be installed and this breaks a small
    loop
  - opensuse.spec.erb
    - no longer require the plain ruby package but the versioned
      named
    - handle disable_doc and no longer build subpackages for rdoc
      documentation in that case.
* Fri Jul 11 2014 mrueckert@suse.de
  - remove the set -x from gem_install
  - moved set -x in gem_packages to the interesting part only
  - the gem packages template only handles custom_pkgs_ruby_versioned
* Thu Jul 10 2014 mrueckert@suse.de
  - make use of config file support in gem2rpm (gem2rpm.yml)
    - gem_install.sh
    - drop gem-filelist-append and gem-custom-packages params
    - removed unneeded "-" when appending gem_version_suffix
    - gem_packages.sh
    - drop gem-suffix, gem-filelist-append and gem-custom-packages
      params
    - added gem2rpm-config param
    - added code to find gem2rpm.yml in RPM_SOURCE_DIR
    - opensuse.spec.erb
    - no longer get variables from the env. this is handled by the
      config file now
    - implemented all the gem2rpm.yml hooks
    - ruby.rpm-macros
    - removed usage of dropped cmdline arguments
    - pass mod_version_suffix to gem_install.sh
* Thu Jul 10 2014 mrueckert@suse.de
  - pass the output of gem_packages through %{expand} so macros and
    so on work.
* Wed Jun 25 2014 mrueckert@suse.de
  - in the past we had a few spec files were we manually patched the
    version in the binary wrapper from ">= 0" to "= %version"
    do this in gem install now.
* Wed Jun 25 2014 mrueckert@suse.de
  - do not have the expanded version of rubygem(gem2rpm) in the spec
    file. moved to project config.
* Wed Jun 25 2014 mrueckert@suse.de
  - adapt the symlink handling:
    We will us the versioned names in /etc/alternatives now instead of
    mapping everything to /etc/alternatives/$binaryname.
    That means we will get:
    /usr/bin/$binaryname$rubysuffix  /etc/alternatives/$binaryname$rubysuffix
    /usr/bin/$binaryname-$gemversion /etc/alternatives/$binaryname-$gemversion
    /usr/bin/$binaryname             /etc/alternatives/$binaryname
    The subpackage template and gem_install.sh script got adopted to
    this.
  - no longer patch files in $buildroot/usr/bin/.
    If we patch files there, we break the binaries for older ruby
    versions. we limit the search path to the gem dir.
  - loop over each gem directory in gem_cleanup macro. so far we only
    cleaned up the gems for the default ruby
  - add requires for fdupes. one of the macro is using it.
  - bump rpm_macros_version to 5
* Wed Jun 25 2014 mrueckert@suse.de
  - really make gem_install.sh work with more than one ruby version
    - use pushd/popd instead of cd when creating the symlinks
    - only create the generic symlinks if they dont exists already
* Mon Jun 23 2014 mrueckert@suse.de
  - added 2 new options to gem_packages.sh
    - --gem-filelist-append="arg"
      This can be either a string or a filename to a filelist that
      will be appended to the versioned main package
    - --gem-custom-packages="name|filelist[|preamble[|description]]"
      filelist, preamble and description can be either filenames or
      the actual value.
    to use both from the spec file you need to use
    %define gem_custome_packages ...
    %define gem_filelist_append ...
    important if you use the filename option, you need to call the
    tools to generate the files with %(....) so the files are
    actually available at the time when gem_packages is run. The tool
    is called at the very beginning of the build, even before %prep.
  - update the gem_packages template to handle those 2 options and
    also the --gem-suffix option.
    they are all passed via environment variables for now.
  - bumped the rpm_macro_version to 4
* Thu Jun 19 2014 mrueckert@suse.de
  - as it turns out gem_build_complete_path files are important.
    Do not delete them in the cleanup script.
* Wed Jun 18 2014 mrueckert@suse.de
  - added gem_packages macro and implementation
  - fix shebang patching in gem_install
* Wed Jun 18 2014 mrueckert@suse.de
  - if we dont use --symlink-binaries, let's undo the
    - -format-executable, that we we break less packages
* Wed Jun 18 2014 mrueckert@suse.de
  - added --symlink-binaries option to gem_install.sh:
    instead of breaking all the existing rubygem packages lets pass
    this option until we have all packages fixed and we can turn it
    on by default
* Wed Jun 18 2014 mrueckert@suse.de
  - a lot of additions to the gem_install.sh
    * --doc-files="..." - which files relatively to the installed gem
      directory should be symlinked to /usr/share/doc/packages/rpmname
    - > you can move the manual linking of documentation files to
      the --doc-files option
    * --gemsuffix="suffix" - if you need more than one version of the
      same gem.
    * all the symlinks for the different versioned files are not
      generated following the same rules that the template is using.
    - > you can remove the manual code from the spec file
  - enable format-executable again in the global gemrc
  - pass gem name and version from the %gem_install macro to the
    gem_install.sh, avoids parsing the gem file name in the shell
    script.
* Tue Jun 17 2014 mrueckert@suse.de
  - added opensuse.spec.erb this gem2rpm template should be later
    used by the gem_packages macro to create the needed file and
    package sections
  - make gem_install.sh loop over all /usr/bin/gem[1-9]*
* Tue Jun 17 2014 mrueckert@suse.de
  - added more patterns to the cleanup script for ruby 2.1
    - gem.build_complete
    - page\*.ri
* Sun Jun 15 2014 mrueckert@suse.de
  - installed the wrong file as gemrc
* Sat Jun 14 2014 mrueckert@suse.de
  - merge files from the ruby 2.1 package
  - moved gemrc from the ruby wrapper package
* Tue Apr 29 2014 aspiers@suse.com
  - eliminate "useless-provides rubygem-foo" rpmlint warning for
    every gem: "Provides: rubygem-foo = 1.2.3" is not required
    because rpm implicitly adds "Provides: rubygem-foo = 1.2.3-4"
* Tue Feb 04 2014 kkaempf@suse.com
  - make %gem_extensions and %gem_doc_ext not fail on Ruby < 2.1
* Sun Jan 12 2014 coolo@suse.com
  - remove 2.0 and 1.9 as binary suffix
* Sun Jan 12 2014 coolo@suse.com
  - increase the version and make gem_base generic
* Mon Jan 06 2014 coolo@suse.com
  - switch to 2.1 as default
* Thu Sep 12 2013 mrueckert@suse.de
  - fixed bootstrap problem by ignoring ruby-common at build time
* Sat Sep 07 2013 coolo@suse.com
  - do no longer buildrequire rubygems_with_buildroot_patch, that's
    history long enough - ruby-devel will do
* Thu Jun 06 2013 coolo@suse.com
  - fixed ~> 3.4 to actually require 3
* Mon Apr 29 2013 coolo@suse.com
  - switch to ruby 2.0 as default
* Sun Apr 14 2013 coolo@suse.com
  - fix permissions
* Tue Apr 09 2013 coolo@suse.com
  - do not remove ext completely, e.g. passenger extensions require
    some files from there
* Sat Mar 23 2013 coolo@suse.com
  - remove ext too, it only causes problems - as far as I can see
* Fri Mar 08 2013 rhafer@suse.com
  - Some enhancements to rubygemsdeps.rb:
    - Add --file-match option to rubygemsdeps.rb to allow
      specifying and alternate regex to match the input files
      against. This is useful to generate dependencies from gemspec
      files which do not endup being installed in the default
      locations
    - Default rubyabi to a non-nil value (basically the version of
      of the ruby interpreter that runs the script)
* Wed Jan 09 2013 aspiers@suse.com
  - Fix it to work even if all-good has just been created locally
    via mkpac and doesn't exist server-side yet.
  - Improve support for running within a branch of the original
    project.  This allows submitreqs which change all-good.spec.
* Tue Jan 08 2013 idonmez@suse.com
  - Bump version to 2.0 so we don't get a version downgrade when
    updating from 12.2
* Fri Dec 28 2012 coolo@suse.com
  - always provide the full version string as people use
    ~> 1.2 even if the version is 1.2
    The old logic assumed people would always require one digit
    less than the actual version
* Wed Dec 19 2012 aspiers@suse.com
  - Import an enhanced version of d:l:r:e/all-good/update-sources.sh
    which can be reused for any project, and allows more thorough
    handling of BuildRequires from different repository / arch
    combinations.
* Tue Dec 04 2012 nkrinner@suse.com
  - Bring back fix from submit request 140568 (Revision 23):
    Fix gemspec filtering on SLE_11_SP2:
      + Only gemspec files resulting of the built gem matter, not other
      gemspec found in-tree
      + Newer RPM uses rubygem.attr, which filters correctly
* Fri Nov 30 2012 coolo@suse.com
  - require rubygems for old ruby versions
  - strip trailing .0 for ~> operator
* Fri Nov 23 2012 aspiers@suse.com
  - Add -g option to rubygemsdeps.rb to allow preview / review
    of automatically generated dependencies from:
      + gemspecs in packages which have already been installed
      + gems/gemspecs which have not yet been packaged
    This is useful for learning / debugging the dependency generator.
* Wed Nov 07 2012 saschpe@suse.de
  - Fix gemspec filtering on SLE_11_SP2:
    + Only gemspec files resulting of the built gem matter, not other
      gemspec found in-tree
    + Newer RPM uses rubygem.attr, which filters correctly
* Mon Nov 05 2012 coolo@suse.com
  - fix build on fedora
* Thu Aug 02 2012 coolo@suse.com
  - "~> 2" doesn't have any meaning, but we still need to handle it
* Wed Aug 01 2012 coolo@suse.com
  - fixing the pessimistic operator
* Mon Jul 30 2012 coolo@suse.com
  - replace all */ruby with /usr/bin/ruby
* Fri Jul 27 2012 coolo@suse.com
  - replace /usr/local/bin/ruby with /usr/bin/ruby - a very often mistake
* Thu Jul 26 2012 coolo@suse.com
  - fix ruby provides/requires with ruby 1.8
* Thu Jul 26 2012 coolo@suse.com
  - old gems do not have a gem unpack --spec, so use gem specification
* Thu Jul 26 2012 coolo@suse.com
  - catch unspecified gem_binary
* Thu Jul 26 2012 coolo@suse.com
  - split from ruby package for easier backporting

Files

/etc/gemrc
/etc/rpm/macros.ruby-common
/etc/rpm/macros.suse-ruby
/usr/bin/g2r
/usr/bin/ruby-find-versioned
/usr/lib/rpm/fileattrs
/usr/lib/rpm/fileattrs/rubygems.attr
/usr/lib/rpm/fileattrs/rubygems_bundled.attr
/usr/lib/rpm/gem_build_cleanup.sh
/usr/lib/rpm/gem_install.sh
/usr/lib/rpm/gem_packages.sh
/usr/lib/rpm/gem_packages.template
/usr/lib/rpm/generate_buildrequires.sh
/usr/lib/rpm/rubygemsdeps.rb


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 9 17:53:32 2022