Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

yast2-ycp-ui-bindings-4.1.0-lp151.1.4 RPM for x86_64

From OpenSuSE Leap 15.1 for x86_64

Name: yast2-ycp-ui-bindings Distribution: openSUSE Leap 15.1
Version: 4.1.0 Vendor: openSUSE
Release: lp151.1.4 Build date: Thu Jan 31 16:54:22 2019
Group: System/YaST Build host: build36
Size: 601184 Source RPM: yast2-ycp-ui-bindings-4.1.0-lp151.1.4.src.rpm
Packager: https://bugs.opensuse.org
Summary: YaST2 - YCP Bindings for the YaST2 User Interface Engine
This package makes the generic YaST2 user interface engine available
for YCP applications (YCP is the scripting language in which most YaST2
modules are written).

Provides

Requires

License

GPL-2.0-only

Changelog

* Tue Oct 16 2018 schubi@suse.de
  - Added license file to spec.
* Tue Oct 09 2018 snwint@suse.com
  - increase version to correspond to the libyui version increase
    (related to bsc#991090)
  - 4.1.0
* Mon Aug 20 2018 schubi@suse.de
  - Switched license in spec file from SPDX2 to SPDX3 format.
* Wed Nov 15 2017 shundhammer@suse.de
  - Fixed segfault when comparing YCPValueWidgetIDs with
    YStringWidgetIDs (fate#324098)
  - 4.0.0
* Mon Apr 10 2017 jreidinger@suse.com
  - added built-in SetApplicationTitle for setting application title
    (bnc#1033161)
  - 3.2.0
* Wed Jul 08 2015 mvidner@suse.com
  - Added OpenUI, CloseUI (boo#937026).
  - 3.1.9
* Wed Jul 01 2015 jreidinger@suse.com
  - added built-in SetApplicationIcon for setting application icon
    only (bnc#894220)
  - 3.1.8
* Wed Feb 25 2015 gs@suse.de
  - Enhance example DateField1.rb
  - Add RELEASE-NOTES*.es.* files to examples (bnc#906936)
* Thu Apr 17 2014 jsrain@suse.cz
  - Added built-in for setting wizard logo (bnc#868722)
  - 3.1.7
* Wed Apr 09 2014 mvidner@suse.com
  - Enable wizard title on the left instead of on top (bnc#868859)
  - 3.1.6
* Wed Mar 12 2014 jsrain@suse.cz
  - more relaxed typeinfo to avoid errors when calling the builtin
  - 3.1.5
* Mon Dec 09 2013 lslezak@suse.cz
  - added missing locale directory initialization, fixes missing
    translations in Gtk package manager (bnc#801311)
  - 3.1.4
* Fri Dec 06 2013 jsrain@suse.cz
  - added handling of release notes button (fate#314695)
  - 3.1.3
* Thu Nov 14 2013 locilka@suse.com
  - Removed warning if checking for TextMode. It became a standard
    check so no warning is necessary anymore.
  - 3.1.2
* Mon Oct 14 2013 jreidinger@suse.com
  - Fix query for special widget DateField and TimeField resulting
    in bad widget in GUI (BNC#845623)
  - 3.1.1
* Thu Sep 19 2013 lslezak@suse.cz
  - do not use *.spec.in template, use *.spec file with RPM macros
    instead
  - 3.1.0
* Wed Jul 31 2013 yast-devel@opensuse.org
  - converted from YCP to Ruby by YCP Killer
    (https://github.com/yast/ycp-killer)
  - version 3.0.0
* Wed Jul 24 2013 jreidinger@suse.com
  - fix calling SetFunctionKeys as overloaded function (gh#yast/ycp-killer#556)
  - removed DemoBrowser.ycp and memtest.ycp examples (lslezak)
  - adapt example to changes in NCTable (gs)
  - 2.24.1
* Tue Jun 18 2013 jreidinger@suse.com
  - fix overloaded method matching (BNC#825263)
  - decrease log verbosity for cached component instances
  - 2.24.0
* Tue Jun 18 2013 tgoettlicher@suse.de
  - Fix for bnc#811842: segfault in ncurses because of
    uninitialized variable
* Tue May 14 2013 tgoettlicher@suse.de
  - Fixed libyui dependency
  - 2.21.8
* Tue Apr 30 2013 tgoettlicher@suse.de
  - Adapted setting prog dir in libyui
  - 2.21.7
* Wed Jan 09 2013 locilka@suse.com
  - Added references to ButtonBox into the generated documentation
* Mon Nov 12 2012 tgoettlicher@suse.de
  - confirmed license
  - 2.21.6
* Mon Sep 17 2012 fehr@suse.de
  - change Requires>=2.23 to Conflicts<2.23, to avoid build cycle
* Mon Aug 06 2012 tgoettlicher@suse.de
  - adapt bindings to work with yast independed standalone libyui package
  - 2.21.5
* Tue Jun 26 2012 aschnell@suse.de
  - adapted to namespace changes in yast2-core
  - 2.21.4
* Mon Mar 26 2012 jreidinger@suse.com
  - removed libxcrypt-devel from buildrequires (aschnell)
  - add more examples (gs)
  -  2.21.3
* Wed Dec 07 2011 coolo@suse.com
  - fix license to be in spdx.org format
* Fri Nov 25 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency
* Tue Aug 16 2011 tgoettlicher@suse.de
  - fixed bnc #711760: yast2 segfaults in second stage
  - V 2.21.2
* Tue Apr 19 2011 tgoettlicher@suse.de
  - version bump
  - V 2.21.1
* Fri Apr 15 2011 tgoettlicher@suse.de
  - Added support for recursive selection in tree widgets
  - V 2.20.4
* Fri Feb 11 2011 tgoettlicher@suse.de
  - fixed segfault when calling currentItem()
  - V 2.20.3
* Tue Feb 08 2011 tgoettlicher@suse.de
  - Added support for currentItem to tree widget
  - V 2.20.2
* Sun Feb 06 2011 coolo@novell.com
  - fix syntax error
* Fri Feb 04 2011 tgoettlicher@suse.de
  - Fixed selection of check boxes in tree widgets (bnc #669138)
  - V 2.20.1
* Thu Feb 03 2011 tgoettlicher@suse.de
  - V 2.20.0
* Mon Dec 20 2010 tgoettlicher@suse.de
  - Added support for check boxes in tree widgets
  - V 2.19.1
* Wed Feb 10 2010 tgoettlicher@suse.de
  - added license headers
* Wed Mar 11 2009 kmachalkova@suse.cz
  - Do not abort in DumpWidgetTree function if there is no dialog
    on the stack (log warning instead)
  - V 2.18.5
* Fri Mar 06 2009 tgoettlicher@suse.de
  - Added context menus
  - V 2.18.4

Files

/usr/lib64/YaST2
/usr/lib64/YaST2/plugin
/usr/lib64/YaST2/plugin/libpy2UI.so.2
/usr/lib64/YaST2/plugin/libpy2UI.so.2.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 10:04:26 2022