Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gnu-compilers-hpc-devel-1.3-lp150.4.2 RPM for noarch

From OpenSuSE Leap 15.0 for noarch

Name: gnu-compilers-hpc-devel Distribution: openSUSE Leap 15.0
Version: 1.3 Vendor: openSUSE
Release: lp150.4.2 Build date: Tue Jan 30 13:00:00 2018
Group: Development/Tools/Other Build host: lamb69
Size: 88 Source RPM: gnu-compilers-hpc-1.3-lp150.4.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/openhpc/ohpc
Summary: Devel package for HPC GNU compiler environment
Provides package dependencies for building with the GNU compiler toolchain.

Provides

Requires

License

BSD-3-Clause

Changelog

* Tue Jan 30 2018 eich@suse.com
  - Update to gcc v.7 for SLES-12 builds.
  - Set the 'granularity' for selection to the
    granularity of GNU toolchain versions we
    distinguish: For major versions until 4,
    this is 2 versions, for anything above it
    is just the major version.
  - On TW/Factory add explicit dependency to the
    compiler major version package. This is to make
    sure package gets rebuilt when this versions
    changes.
* Fri Nov 10 2017 eich@suse.com
  - Add Requires: for lua-lmod to base package.
  - Add Provides/Conflicts: to macro package:
    only one version of this macro package can
    can be installed at the same time.
* Thu Oct 05 2017 eich@suse.com
  - Make source files downloadable from git.
  - Remove some debugging code.
* Wed Oct 04 2017 eich@suse.com
  - Fix LICENSE and copyright statement in LICENSE.
* Tue Sep 12 2017 eich@suse.com
  - Rename: rpmlintrc -> gnu-compilers-hpc-rpmlintrc
* Tue Sep 12 2017 eich@suse.com
  - Remove spec_fix.pl, use multibuild instead.
  - Add RPM macros to be used together with macros.hpc from suse-hpc.
* Thu Jun 08 2017 eich@suse.com
  - Update spec_fix.pl: It is now able to produce multiple spec files
    from one replacement file.
* Tue May 02 2017 eich@suse.com
  - Remove ohpc-isms.
  - Add support for gcc update versions.
  - Pick correct compiler version.
* Wed Nov 30 2016 eich@suse.com
  - Fix group of devel package: Development/Languages
* Tue Nov 15 2016 pmladek@suse.com
  - Add gcc-c++ into requires of the devel package
  - Make the devel package to require the exact version of the main one
* Thu Oct 20 2016 eich@suse.com
  - Modified package to use a spec file template.
* Thu Oct 13 2016 eich@suse.com
  - Initial version of gnu compiler selection module
    FATE#321705.

Files

/usr/share/doc/packages/gnu-compilers-hpc-devel
/usr/share/doc/packages/gnu-compilers-hpc-devel/README.meta


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 11:46:08 2022