Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

pacemaker-libs-2.0.3-1.fc32 RPM for armv7hl

From Fedora 32 for armhfp / p

Name: pacemaker-libs Distribution: Fedora Project
Version: 2.0.3 Vendor: Fedora Project
Release: 1.fc32 Build date: Sat Jan 4 00:00:59 2020
Group: Unspecified Build host: buildvm-armv7-19.arm.fedoraproject.org
Size: 1719694 Source RPM: pacemaker-2.0.3-1.fc32.src.rpm
Packager: Fedora Project
Url: http://www.clusterlabs.org
Summary: Core Pacemaker libraries
Pacemaker is an advanced, scalable High-Availability cluster resource
manager.

The pacemaker-libs package contains shared libraries needed for cluster
nodes and those just running the CLI tools.

Provides

Requires

License

GPLv2+ and LGPLv2+

Changelog

* Tue Nov 26 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.3-1
  - Update for new upstream tarball: Pacemaker-2.0.3,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.3
    (functionally identical to 2.0.3-rc3, new build mostly to fix a memory
    leak & allow for easy glibc ~2.31+ friendly switch away from ftime(3))
  - Fix unability to build with Inkscape 1.0 beta (and possibly beyond)
* Thu Nov 14 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.3-0.1.rc3
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.3-rc3,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.3-rc3
  - Fix failure to build due to using obsolete ftime(3)
* Wed Nov 06 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.3-0.1.rc2
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.3-rc2,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.3-rc2
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 2.0.2-1.3
  - Rebuilt for Python 3.8.0rc1 (#1748018)
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.0.2-1.2
  - Rebuilt for Python 3.8
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.2-1.1
  - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Jun 07 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.2-1
  - Update for new upstream tarball: Pacemaker-2.0.2,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.2
    (functionally identical to 2.0.2-rc3, new build mostly to match expectations)
* Fri May 31 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.2-0.1.rc3
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.2-rc3,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.2-rc3
  - Adapt spec file more akin to upstream version including:
    . /usr/share/pacemaker now owned by -schemas, its "api" subdirectory
      is not carried redundantly in -cli anymore (f05eb7eec)
* Tue May 28 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.2-0.1.rc2
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.2-rc2,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.2-rc2
* Thu Apr 25 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.2-0.1.rc1
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.2-rc1,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.2-rc1
  - Customize (as allowed now) exhibited downstream-specific bug reporting URL
  - Adapt spec file more akin to upstream version including:
    . sbd ABI compatible version enforcement (37ad2bea1)
* Wed Apr 17 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-2
  - Apply fixes for security issues:
    . CVE-2019-3885 (use-after-free with potential information disclosure)
    . CVE-2018-16877 (insufficient local IPC client-server authentication)
    . CVE-2018-16878 (insufficient verification inflicted preference of
                      uncontrolled processes)
* Tue Mar 05 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-1
  - Update for new upstream tarball: Pacemaker-2.0.1,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.1
* Thu Feb 28 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-0.4.rc5
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.1-rc5,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.1-rc5
  - Reflect that cts-scheduler tests are fully compatible with whatever recent
    glib version that gets to be used in run-time (incl. buildroot tests) again
* Mon Feb 04 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-0.3.rc4
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.1-rc4,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.1-rc4
  - Conditionally disable "hash affected tests" in cts-scheduler (-cts package),
    since it is unlikely glib v2.59.0+ present in the buildroot will be
    artificially downgraded post-deployment
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-0.2.rc3.1
  - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Jan 22 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-0.2.rc3
  - Fix buildability with GCC 9 (PR #1681)
  - Apply minor crm_mon XML output fix (PR #1678)
* Sun Jan 20 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.1-0.1.rc3
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.1-rc3,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.1-rc3
  - Adapt spec file more akin to upstream version including:
    . split a dedicated, noarch -schemas package (c6a87bd86)
    . make static dependencies on inner libraries arch-specific (14bfff68e)
    . weak co-dependence of -cli with -remote & pacemaker proper (73e2c94a3)
    . declare bundled gnulib (d57aa84c1)
  - Move stonith_admin to -cli where it belongs, since it doesn't require
    -cluster-libs (considered by upstream)
  - Apply patches to restore basic buildability (still without much run-time
    reproducibility guarantees compared to what's been customary prior to glib
    v2.59.0+ that may now get run-time linked upon its fresh installation/update,
    but this applies also to whatever older version of pacemaker, and wasn't
    discovered until now; cf. https://github.com/ClusterLabs/pacemaker/pull/1677)
* Thu Aug 23 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-4
  - Sanitize/generalize approach to Python byte-compilation, so that also
    out-of-Python-path *.py files (%{_datadir}/pacemaker/tests/cts/CTSlab.py
    in particular) get the expected treatment now
* Wed Aug 15 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-3
  - Fix Python 3.7 incompatibility (otherwise missed in bytecompilation phase,
    see rhbz#1616219)
* Thu Aug 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-2
  - Include fix for "cibadmin --upgrade" related issues (rhbz#1611631)
  - Adapt spec file more akin to upstream version including:
    . assuredly skip servicelog-related binaries even when build-time
      prerequisites are present on suitable systems (9f24448d8)
* Mon Jul 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-1
  - Update for new upstream tarball: Pacemaker-2.0.0,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0
* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-0.1.rc6.1
  - Rebuilt for Python 3.7
* Thu Jun 28 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc6
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc6,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc6
  - Adapt spec file more akin to upstream version including:
    . new procps-ng and psmisc dependencies with -cli and -cts, for e.g.
      "ps/sysctl/uptime" and "killall" invocations, respectively (a4ad8183a)
    . move crm_node to -cli (a94a1ed58)
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-0.1.rc5.1
  - Rebuilt for Python 3.7
* Fri Jun 01 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc5
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc5,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc5
  - Adapt spec file more akin to upstream version including:
    . new coreutils dependency for "post" scriptlet of -cli,
      for "mv" invocation (c2b16165d)
* Wed May 16 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc4
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc4,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc4
    . as a special note, previous release candidate, rc3, had rolling upgrades
      broken, and if that is required, that particular release shall be
      skipped in the upgrade path altogether
  - Adapt spec file more akin to upstream version including:
    . as part of the update process, possibly move old log files as implicitly
      used prior to 2.0 so there's a (limited) continuity with the new implicit
      location, preventing clutter and confusion (ce2e74c99, c2b16165d)
    . move cts-exec-helper from -cli under main package (a2dc2a67e)
    . -cts backed with new helpers and, tangentially, dummy systemd service
      file transiently generated on-demand again (fa2d43445, d52b001b1)
* Wed May 02 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc3
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc3,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc3
    . IMPORTANT: this release candidate, rc3, has rolling upgrades broken,
                 and if that is required, this particular release shall be
                 skipped in the upgrade path altogether
  - Adapt spec file more akin to upstream version including:
    . new --without legacy_links conditional (c8a7e5225)
    . reflect name change of the auxiliary daemons
      (e4f4a0d64, db5536e40, e2fdc2bac + 9ecbfea1c, 038c465e2 + ed8ce4055a)
    . new dummy systemd service for -cts (bf0a22812)
    . honor system-wide crypto policies once for all, via package-build-time
      configurable "pcmk_gnutls_priorities" defaulting to @SYSTEM as prescribed
      in https://fedoraproject.org/wiki/Packaging:CryptoPolicies
      (based on b3dfce1d3)
  - Adapt spec file akin to current packaging guidelines including:
    . make -nagios-plugins-metadata package noarch
* Mon Apr 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc2
  - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc2,
    for full details, see included ChangeLog file or
    https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc2
  - Adapt spec file more akin to upstream version including:
    . out-of-tree change from 1.1.18-2 build got subsumed (508ad52e7)
    . %{_sysconfdir}/pacemaker path got properly owned
      (-cli package; f6e3ab98d)
    . -libs package started to properly declare Requires(pre): shadow-utils
      (293fcc1e8 + b3d49d210)
    . some build conditionals and dependencies dropped for no longer
      (snmp, esmtp; f24bdc6f2 and 1f7374884, respectively) or never
      being relevant (~bison, byacc, flex; 61aef8af4)
    . some dependencies were constrained with new or higher lower bounds:
      corosync needs to be of version 2+ unconditionally (ccd58fe29),
      ditto some others components (~GLib, 1ac2e7cbb), plus both 2 and 3
      versions of Python are now (comprehensively for the auxiliary
      functionality where used) supported upstream with the latter being
      a better fit (453355f8f)
    . package descriptions got to reflect the drop of legacy low-level
      cluster infrastructures (55ab749bf)
  - Adapt spec file akin to current packaging guidelines including:
    . drop some redundant/futile expressions (defattr, "-n %{name}-libs"
      instead of plain "libs", "timezone hack"), add some notes for future
    . make -cts and -doc packages noarch (former enabled with 088a5e7d4)
    . simplify "systemd_requires" macro invocation, and relax it to
      "systemd_ordering" for -remote package where possible so as not
      to drag systemd into a lightweight system setup (e.g. container)
      needlessly
    . adjust, in a compatible way, common ldconfig invocation with
      post{,un} scriptlets
      (https://fedoraproject.org/wiki/Changes/Removing_ldconfig_scriptlets)
    . drop some more unuseful conditionals (upstart_job)
  - Apply some regression fixes on top as patches (PR #1457, #1459)
* Wed Feb 21 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.1.18-2.2
  - Update Python 2 dependency declarations to new packaging standards
    (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.18-2.1
  - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Files

/usr/lib/.build-id
/usr/lib/.build-id/42
/usr/lib/.build-id/42/6a73ed8d26fe7f5c6917a20ab2c8d16abc5f1e
/usr/lib/.build-id/5b
/usr/lib/.build-id/5b/f57c57d4e56bd5723d650fe31eaa76fbbf0da7
/usr/lib/.build-id/98
/usr/lib/.build-id/98/62fc3a3899f9b6f06157a91b84347fa6801f36
/usr/lib/.build-id/9b/f5cf4ce679e9281bc3c3fd3eb5aac721020888
/usr/lib/.build-id/a7/b1b7072142d51a92766ee7579f94cef58739e3
/usr/lib/.build-id/a7/e43eaf654a700940ae04b3a25430014cf9ecc4
/usr/lib/.build-id/df
/usr/lib/.build-id/df/9080da40f93aa6d5daaf2b3bf59459c9f7c3df
/usr/lib/.build-id/e8
/usr/lib/.build-id/e8/bfcf45dbcf1486ee1689f62c43e4266538fa13
/usr/lib/libcib.so.27
/usr/lib/libcib.so.27.1.0
/usr/lib/libcrmcommon.so.34
/usr/lib/libcrmcommon.so.34.3.0
/usr/lib/libcrmservice.so.28
/usr/lib/libcrmservice.so.28.2.0
/usr/lib/liblrmd.so.28
/usr/lib/liblrmd.so.28.0.3
/usr/lib/libpacemaker.so.1
/usr/lib/libpacemaker.so.1.1.0
/usr/lib/libpe_rules.so.26
/usr/lib/libpe_rules.so.26.1.0
/usr/lib/libpe_status.so.28
/usr/lib/libpe_status.so.28.1.0
/usr/lib/libstonithd.so.26
/usr/lib/libstonithd.so.26.3.0
/usr/share/doc/pacemaker-libs
/usr/share/doc/pacemaker-libs/COPYING
/usr/share/doc/pacemaker-libs/ChangeLog
/usr/share/licenses/pacemaker-libs
/usr/share/licenses/pacemaker-libs/LGPLv2.1


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 16:28:36 2021