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QXmlEdit offers you the possibility to view, navigate and edit XML data as few other editors. It is

like a Swiss army knife. It is multi platform and, more, itis Libre Software; that means that it gives
to the user the freedom to adapt it to its needs and it comes with complete source code.

QXmlEdit is an XML editor and its main features are:

Hierarchical customizable view of XML elements.

Fast XML hierarchy navigation.

Handling of base 64 coded text and XML inserted as data.

Powerful search.

XML snippets.

XML compare utility.

XML Schema viewer.

Visual compare of XML schema.

Flex code generation from Balsamiq source.
Session handling.

XSL specialized mode.

Split of big XML files.

Data anonymizer.

QXmlEdit is an XML editor. To use it with proficiency you need to be accustomed with XML. Itis a
technical tool oriented toward software developers.

Following this manual you will learn to:

Examine XML data in details.

Applying different views to XML data to examining them under different points of view.

Customize QXmlEdit to ease your work.

Navigate and inspect XML data.
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On the @QXmLEdit Internet site you will find the up to date documentation and tutorials. The site
address is: http://gxmledit.org. The link for the source code is:

https://github.com/Ibellonda/qxmledit.
To get help while using the program you can use the menu Help > Help on QXmIEdit.

Generation of XML from XSD and vice-versa provided that Apache XMLBeans is installed. New
options in the tray menu.
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The user interface is very simple and consists of a main panel where all the functions of the
program can be controlled.

1 |
x . Qxﬂ‘nIEdit-Ihomellbell/devel/quled|t/manualqumIedlt-manualldata/sampIeAme v T( |

File Edit Preferences gookma‘ XML Specal Navigation View Sessions Tools Help |
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Sl .. Al v /. B =
“ - o ““
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v 1 <iconset resour "risorse.qrc”
1 <normaloff :/icon/images/icon.png
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- 1 <property - 'sizePolicy name="sizePolic

No schema mode: XML = Modifiable
° ¢
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This is a small abstract of the common operations grouped by purpose:
* Navigation:
© Go to parent element (menu Navigation, shortcut F12).
© Go to next sibling (Navigation, F10).
o Go to previous sibling (Navigation, F9).
* Data modification:
o Insert or append an element.
o Insert or append a comment.
o Insert or append a processing instruction.
o Change the position of a node.
o Paste a node as child or sibling.
o Copy or paste a set of attributes.
o Operation on containers:
= |nserta parent
= |nsert a child container that enclose all the current children
= Remove the parent of a node.
o Transform a node into a comment and vice versa.
o Insert prolog and namespace declarations.
o Edit base 64 coded text blocks.
o Edit base 64 coded attributes.
o Transform files into base 64 text blocks.
* View Data:
o Hide all the siblings of a node.
o Hide all the children of all the sibling of a node.
o Filter the visible attributes.
o Hide all the elements that have no children.
o Show the children count and the size of a node.
o Close all the siblings of a node.

For a complete description of each operation go to the specific section of this document. Here you
will find a small reminder of the commands.
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Startup

The first time QXmlEdit is started, it asks the user if a simplified user interface should be activated.
Through a panelit is possible to access the main features but there are no restrictions about what
QXmlEdit can perform. At any time, using the Preferences menu, the choice can be reverted.
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From above panel the following operations can be started:

Item Description

New Open a new editor.
Open Load an XML file.
Validate Validate XML using XSD.

Formatting

Formatting and indentation options.

Vision View Options.
Editing Editing options.
Configure Open the main preferences panel.

Expert User

Switch to “Expert User” mode.

Extract File Extract fragments from an XML.
View XSD View an XSD file as a diagram.
Compare Compare XML files.

Base 64 Open the Base64 operations panel.

View Data Map

View XML file statistics.

Anonymize

Anonymize a file using previously created profiles.

User Manual

Open the user manual.

Editing Shortcuts

Show the editing shortcuts.

Keyboard Info

Show the panel that list keyboard shortcuts.

QXmlEdit user manual, page 10 of 118.




Menus are divided in main functional groups; the most used commands are kept visible in main

dialog as a button on the right.

The menus are described here:

Menu Functionality

File XML document creation and saving

Edit clipboard handling; find command and configuration options
Tasks common tasks, grouping other menu commands
Bookmarks all about bookmarks

XML XML tree manipulation (insertion, deletion, etc)
Special special XML operations

Navigation XML tree navigation

View view commands and options

Sessions Session related commands

Tools plugins and tools

Help help

The QXmlEdit goal is to view and edit small XML files. It is not intended to handle data of hundred

of megabytes, since it works completely in memory.

1. Open files using the File > Open menu.

2. Inthe Open Files dialog choose the file type you are looking for.

This feature lets you override the settings by opening a file in a new window, if open new files in
same window is selected as a global option. If the configured behavior is to open files using new

windows, the option lets you reuse the current editor window.

* Use the menu File > Open in New Window if behavior is to open files reusing same

window.

* Use the menu File > Open in Same Window if behavior is to open files using new

windows.
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This setting can be configured in the preferences dialog.
* Menu Edit > Configure
* Select General tab

* Check “Open in new window" option.

You can save the file using this menu commands:
To save the file with the same name:
* Save the file using the File > Save menu.
To save the file with another name
* Save the file using the File > Save As... menu.
To save a copy of the file with another name, but continue to work in the original file:

* Openfiles using the File > Save a Copy As... menu.

Note: using this last option you make a copy of the file as it is in its current state. The original
file is not modified and the editor retains the current state.

Sometimes you can create a new file by pasting an XML text from the clipboard. For example you
can cut a block from a database client or a PDF or HTML page.

Use the menu File > New From Clipboard.

Using the File > New Specialized item, you can create new documents of a particular kind.
* XSL-FO
* XML Schema

e XSLT
«  Maven POM.xml
e SCXML

The documents are created with the predefined namespaces and declarations.
Creating Documents from Snippets

Using the File > New Specialized > New from Snippet item, you can create new documents from
a previously saved snippet.

Using the menu File > Reload the last saved version. The modifications to the current file will be
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lost.

Using the menu File > Load Sample. A sample of each tag and attribute will be loaded in a new
document.

The following export methods are available from the File > Export menu:
* Export Element to File
* Copyallto the clipboard
* Export as Java/JavaScript

*  Exportas C/C++

The document can be put in read only mode using the menu Edit > Read Only

Using the menu File > Recent Files you can load the last edited files.

Usually, working with files, there are some directories that are accessed often. QXmlEdit gives you
the possibility to remember these places and to quick recall them when opening files.

To add the directory of the current open file to the preferred ones:

* Use the menu File > Preferred Directories > Add Current Directory to Preferred Ones
To edit the directory list in a separate window:

* Use the menu File > Preferred Directories > Edit Preferred Directories...

A dialog will open
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£ Preferred directories

Preferred directories

homellbelll/develigemleditidata

Preferred
directories

¥ 0K

@ cancel

Remove

Remove a link

Insert a new link to
directory

To add a new link to a preferred directory
* Pushthe Add... button.

To remove a link to a directory
* Push the Remove button.

To confirm the directory list press OK.

To open afile into a preferred directory:

Use the menu File > Preferred Directories, then select the directory.

After having loaded XML data, there are many modes to view elements and attributes. The main
view uses a tree representation, mapped on XML data, however you can highlight some data

aspect:

To view one element attribute on a separate line (very readable if you are looking for attribute

values):

* Select the menu View > Show One Attribute per Line
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To show the attribute length near to their name:

* Select the menu View > Show Attributes Length.

To show attribute contents using a fixed size font, to better discover the presence of spaces:

* Select the menu View > Show Attributes Length.

To show in a separate column the text length of the elements:

* Select the menu View > Show Text Length.

To show the number and size of the children of each element:

e Select the menu View > Show Element Size.

To show the text contained into elements as base 64 encoded:

¢ Select the menu View > Show Text as Base 64 Coded.

Note: this option can have an impact on visualization speed.

To expand all the closed branches of the XML tree:

* Select the menu View > Expand

To enlarge or reduce the size of the character used to display the data:

¢ Select the menu View > Zoom In or View > Zoom Out.

or

* Use the Control key while scrolling with the mouse wheel.

To view only the structural components of the XML (the elements that have other elements as
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children):
* Select the menu View > Hide All the Leaf Children

To undo the effect of the previous command:
* Select the menu View > Show All the Leaf Children.

To show or hide on the basis of individual node, first select the node, then, to hide:
* Select the menu View > Hide Leaf Children.

To show:

¢ Select the menu View > Show Leaf Children.

It is possible to filter the display of the attributes. A profile can show only a set of attributes or hide
a given list of attributes. When an element has some hidden attributes, a filter icon appears.

It is possible to manage the attributes that can be shown or hidden in each element using the menu
View > Filter attributes > Manage Profiles...

In the management section it is possible to create delete or apply profiles.

profile

Description:

a new profile

Action: @ Show only the selected
Hide the selected

Attribute Names

attrl
attrz
attrEqual

New
Edit

Delete

To apply a temporary profile, based on the current element:
1. Select an element.

2. Use the menu View > Filter attributes > Apply a Temporary Profile.
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Attributes filter (fase profile)

Attributes
¥ elementFormDefault |« targetNamespace ¥ xmins

@ Cancel

¥ xmins:xs

Select all

2

Select none

It is possible to transform the temporary profile into a regular one using the menu Use the menu
View > Filter attributes > Save the current Profile.
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Namespaces and prefixes commands can be accessed from the XML > Namespaces menu item.
Both offer prefix manipulation, but only namespaces commands are aware of namespace concepts.
Prefix related items do not know about namespaces at all, they simply manipulate prefixes.

The operations that can be performed on prefixes are:
* Assign a prefix.
* Remove a prefix.

* Replace a prefix.

This operation sets the same prefix to all the elements on which it is applied. No considerations
about namespace declarations are made.

Panel:
» . Assign Prefix < : x V " )(
Prefix to set: Apply to: o OK
Lfo . Al
|‘ ‘I | Selection M
| Bookmarks
+| Include children
Items:
ltem Description
Prefix to set The prefix to apply
Apply to Elements involved.

The remove option removes the selected prefix from all the items, only from the selected item or

from the selected item and all its descendants, from tags and attributes. If there is a selection, the
prefixes found recursively in the selection are shown in the prefixes combo. No attention is payed

to the namespaces in this operation.
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Remowve Prefix

ltems:

All prefixes Choose to remove all the prefixes.
Choose a prefix Removes a single prefix.
Apply to Elements involved.

Replacing a prefix

This operation replaces one or all the prefixes with another one.

Replace Prefix

All prefixes Choose to replace all the prefixes.
Choose a prefix Replace a single prefix.

Replace with The prefix that will be inserted.
Apply to Elements involved.

Namespace operations

The operations that can be performed on namespaces are:
* Assign a namespace.
* Remove a namespace.
* Replace a namespace.

* Normalize a namespace.
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Assigning a namespace

This operation assigns a namespace to a tree or to all the document. The selected namespace will
be declared if not existent.

Aszign Mamespace

Items:
Namespace The namespace to set.
Prefix The prefix to set.
Apply to Elements involved.

Removing a namespace

Remove one or all the namepaces. The declarations of the removed namespace can be optionally
removed.

Remove Mamespaces

Items:
All namespaces If chosen, all the namespaces will be removed.
Choose a namespace Select only one namespace to remove.
Remove declarations With this option even the namespace declaration will be removed.
Apply to Elements involved.
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This operation replaces a selected namespace with another one. All the namespace elements will
be translated, even if declared with different prefixes.

x Replace Namespace & & 25
Namespace to replace: Apply to: o Ol
http:/fwww w3 org/1999/XSL/Format All
L
| Selection
Bookmarks
Replacement: - @ Cancel
Namespace: /| Include children | ———————
U v)
Prefix: |
W
Select...
ltems:
Item Description
Namespace to replace The namespace to be replaced.
Namespace The namespace that will be assigned.
Prefix Prefix of the new namespace.
Select Recalls the namespace selection panel.

This operation sets the same prefix on all the elements and attributes belonging to a namespace.
The prefixes of the namespace other than the selected one are lost and their declarations removed.

The normalization operation assumes that the XML is well formed and valid, so the chosen
namespace must be legally declared. This said, it will not be declared anew on the children if the
option “Declare namespace on root” is selected.

This option removes all the declaration from the inner of the selection tree and forces a declaration
on root of the selection tree. If the apply zone is only a part of the tree, only this part will be
checked. If there is no namespace declared, a declaration on root will be created if the option is
enabled.

Using this option it is possible to manage a namespace in only a branch of the XML tree.

Panel:
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Mormalize Namesapce

ltems:

Namespace The namespace to normalize.

Prefix The prefix to apply to normalized namespace.

Select Opens a namespace selection panel.

Apply to Elements involved.

Declare namespace on root | The declaration of the namespace is moved to the root element
only, any other inner declaration will be removed.
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Using the XML > XSLT Edit Mode menu item you can switch to XSLT edit mode. When loading a
file with "xsl" extension or containing a reference to XSLT namespace a panel will open.

x 0XmlEdit - thomellbellidevealigxmleditixsditest/datafxslttemplatefunctions.xslt

File Edit Bookmarks XML MNavigation View Sessions Tools Help

=~ R A o v s / K

encoding:UTF8

E

Elements . Size | Attributes/Text

B[ 3 —xsl:if 145  test="f" -0

1 —jpc ar
X XLST Made
2 —x

1

()
XSLT mode /

4 —xsl:c \Ql) It seems that you loaded an X5L document. Do you want to
switch to XSLT edit mode?

m Using the X5LT edit mode you will:

*® Use a specialized panel to edit elements.
* Use an enriched context menu.

No Use standard XML edit mode

Automatically enter XSLT mode when loading an XSLT

document.

Do not ask any more this question

Use the configuration panel to change the value of the options

6 -xsl:ig :
8 —xsl:template - 'cdbfgfg’ 1(3) 70 name="cdbfgfg"
1-a 1(2) 21

& 1-b 1(1) 14

[}]

No schema mode: XML

1. To activate the XSLT mode simply answer "Yes" or use the return key.
2. To have the mode always activated without answering the panel any more, select "Auto".

The settings can be also changed using the preferences.
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x 0XmlEdit - thomellbellideveligxmleditixsditestfdatalxslttemplatefunctions.xslt

File Edit Bookmarks XML Navigation View Sessions Tools Help
9HHW@ ﬁ@ o _/,E

Canfiguratian

b o L ; / .
f\:General ‘ ?5;“/ Style W Validation 4. Sessions | ( ¢ Edit Modes

XSLT mode
¥| Show the "Switch to XSLT" panel when opening files.

Automatically switch to X5LT edit mode when opening an X5LT file.

No schema mode: XML

1. From the Edit menu choose "Configure", then "Edit modes".
2. Setif the XSLT edit mode should automatically engage.

3. You can hide the panel if you do not care to enter this mode.
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A specific display style will be applied only to XSLT elements. The intermixed non XSLT elements

will not be touched, to reveal the XSL structure at a glance.

X

File Edit Bookmarks XML Navigation View Sessions Tools Help

A= = Y C & ® v e /|8

Elements #Ch. | Size| Attributes/Text
3 -xskif - T 2(3) 145 test=""
1-in-if 0() 15
B 2 -xshattribute - 'attr’ 1(1) 99 name="att"
1 -xskvalue-of = 0¢ 0(0) 51 select="yxe"
4 -xsl:choose 3(6) 185
B 1-xskwhen - ‘position(j=1' 1(1) 57 test="position()=1"
1 -one 0 11
B 2 -xskwhen - 'position(j=2" 1(1) 57 test="position()=2"
1-two 0 11
B 3 -xshotherwise 1(1) 46
1 ~other 00 15

5 -xsl:call-template - ‘one" 2(2) 195 name="one"

2 -xslwith-param - 'p2'$var3 0(0) 70

6 -xsl:apply-templates - * 0(0) 61 select="+"
8 -xsl:template - 'cdbfgfg’ 1(3) 70 name=‘cdbfgrg’
&0 1-a 120 21
B 1-b 11 14

1 -xskwith-param - 'p1'$varl 0(0) 70 *, select="$varl"

[+] encoding:UTF8

== No style ==

Noschema mod|  predefined

1- Double click an XSL element in the editor.

2- A special panel will open.

XSD
o XSLT

3- When you edit the "select" attribute, the auto-completion function will list the relevant

variables.

4- When invoking templates or parameters, you will see their names in the combo.

5- Toreturn to the usual property panel use CTRL-double click.

X

File Edit Bookmarks XML Navigation View Sessions Tools Help

PEHE XD & av e/ R

Elements Size| Attributes/Text
5 -out 30 attr="(varl)"

B 6 -xsktemplate - ‘one’ 319 name="one"

1 -xsl:param - ‘p1'‘def1’ 61 name="pl", select="def1"
2 -xsl:param - 'p2"‘def2’ 61 name="p2", select="def2"

3 ~xsl:choose

encoding:UTF8

K Delete
00

X

Path: /xsl:stylesheet/xsl:template

Element xsl:variable

Name [var3

(2o

select | 'var3'|

|©

Tip: a(s and attributes names for autocompletion using the main menu command.
var2 I

e Eye)
1 -xshvalue-of - “oo¢ 0(0) 51 select="xux"
E- - 4 -xslchoose 3(6) 185
B 1-xslkwhen - ‘position()=1' 1(1) 57 test="position()=1"
1 -one 0() 11
B 2 -xslkwhen - ‘position()=2" 1(1) 57 test="position()=2"
1-two 0() 11

No schema mode: XSLT 4

QXmlEdit user manual, page 26 of 118.



A new context menu appears on the editor elements. The menu propose to you the most used XSL
elements giving you the choice to append them to the current element as sibling, or to insert them

as a child.

The proposed elements are sync with the context, that is in a "call-template", the only "with-

parameter" element is proposed as a child.

X

File Edit Bookmarks XML Navigation View Sessions Tools Help

PEEADD &

Elements
5 -out

& 6 -xsktemplate - ‘one’

1 -xskparam - 'p1'‘def1’
2 -xstparam - 'p2 ‘def2’

3 -xsl:choose

4 -style - 'XSLT

% Cut
Copy

Copy Element Path in the Clipboard

" Paste
Edit Inner Text as One Node...
Editinner Base 64 Text...
Edit Inner XML,
Edit Inner XML Base 64 Coded...
Transform in Snippet..

3

¥ Move Down

& xsir >

Using names for auto-completion

L g

“apply~templates' insert as child =
oy [
“atibute! insert a5 chid
“attribute’ append as sibling
“call-template' insert as child i
=
{

“call-template' append as sibling

“choose' insert as child
“choose' append as sibling bowl

“comt
Ctrb+x

cui+C "

‘copy-of' append as sibling

iy

‘element’ append as sibling
“for-each’ insert as child
“for-each’ append as sibling
“for-each-group' insert as child
“for-each-group’ append as sibling
“function’ insert new

‘if* insert as child

Ctri+M

‘template’ insert new

‘comment’ append as sibling

‘element'insert as child

‘if* append as sibling

‘sequence' insert s child b [
D)

vz i |/

@

t insert as child

" insert as child

*sequence’ append s sibling

“value-of'insert as child

‘value-of' append as sibling

‘variable’

‘insert as child

© ppenc.

encoding:UTF8

/ Edit
¥ Delete

& Move Down

ha mode: XSLT

When XSTL mode is acting, you can scan the target XML file to extract names to be used with the
auto-completion feature of the edit panel.

Use the menu XML > Target XML

%

oxmlgdi

led

File Edit Bookmarks XML Navigation View Sessio

BN = |

Elements

H DL 4

8 ¥ 7

#Ch

ns  Tools Help

F= if= =

Al

Size Attributes/Text

5 —out
6 -xsl:template - ‘one’
1 -xsl:param - 'p1'‘defl’
2 —xsl:param - 'p2'‘def2'

3 -xsl:ichoose

0(0)
4(4)
0(0)
0(0)
0 (0)

attr="{varl)"
name="one"
", select="def1"

name="p2", select=""def2"™

4] encoding:UTF8

-

Path:  fxsl:stylesheet/xsl:template

Element xsl:

variable

XSIT Element

8 Delete
v X

Neme [var3

@

select [E.d

| @

—xsiatcrioute - ator
1 -xslvalue-of - “xod

sl:choose

1 -one

-xsl:when - ‘position()=1'

2 -xsl:when - ‘position()=2"

1 -two

name= atr

select="yxxx"

test="position()=1"

test="position()=2"

No schema mode: XSLT 4
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A XSL navigator for functions and templates will open automatically in the editor when choosing
XSL edit mode. The navigator can be shown or hidden using the menu Navigation > Show XSL
Navigator. A double click will lead you to the template or function definition in the editor.

» G QXmiEdit - --No file-- * <2= v o &
File Edit Tasks Bookmarks XML Special Navigation View Sessions Tools Help

:[Q%HKDF.E n v ¢ y=i=T- /7 B

A *Processing Instruction® <?xm|  xml(version="1.0' encoding="UTF-8") encoding:UTF-8

version="2.0°, xmins:|local="http://www.w3 org/2005/xquery-local-functions’ I‘_G Add Child...
xmins:xsl="http://wwww3.0rg/1999,/XSL/ Transform’
|@ Append...

¥ <xslstylesheet

| 1 <xsloutput  encoding="UTF8", indent="yes’, method="xml", omit-xml-declaration="no"

3 <xsl:function - 'myfunction’ name="myfunction’, select=" |x Delete

|
|
2 <xsltemplate - / match="/" |/§dit... |
|
|

4 MoveUp

W Move Down

View as XSD...

Functions and templates

¥ Templates (1)
match="/" mode="

¥ Functions (1)
myfunction

Show Edit...

(0 [

Noschema mode: XSLT I! Modifiable 12 n
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A specific display style will be applied only to SCXML elements. The intermixed non SCXML
elements will not be touched, to reveal the SCXML structure at a glance.

With SCXML edit mode enabled:

1- Double click an SCXML element in the editor.

2- A special panel will open.

3- When selecting a state name, a combo will reveal the list of states defined in the file..
5- To use to the usual element edit panel use CTRL or ALT while double clicking.

If the SCXML edit mode is not enabled, the double click modifiers are reversed.

A SCXML navigator for states will open automatically in the editor when choosing SCXML edit
mode. The navigator can be shown or hidden using the menu Navigation > Show SCXML
Navigator. A click will lead you to the state definition in the editor, a double click will open the edit
properties window.

The list of states can be flat or hierarchical.
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“X *Processing Instruction* <?xml  xml(yersion="1.0")

datamodel="ecrmascript’, initial="initial’, name="sample"

ok version="1.0", xmIns="hitp:/fwww.w3.org/2005/07/scxml’, xminsx

¥ 1 <datamodel
1 <data - 'someData' expr="5', id="someData"
¥ 2 <zparallel - ‘initial' id="initial’
¥ 1 <state - 'multi’ id="multi’
* 1 <initial
1 <transition target="one'
¥ 2<state- 'one' id="one"
1 <transition  event="eventtwo', target="two"
¥ 3J<state- 'two' id="two’
* 1 <initial
1 <transition target="multi2"
2 <transition  event="event.one’, target="one’
3 <transition cond="someData >= 0°, target="one"
¥ 2 <state - 'multi2' id="multi2’
* 1 <initial
1 <transition target="TwoOne’
¥ 2 <state- 'TwoOne' id="TwoOne"
1 <transition  event="eventtwo', target="TwoTwo"
¥ 3Je<state- 'TwoTwo' id="TwoTwo"

1 <transition event="event.one’, target="TwoOne'
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XML Schema management
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It is possible insert references to an XML Schema set of files. Using the menu XML > Schema
Instance > XML Schema References the “Insert Xml Schema References” dialog will appear.

® 06 XML Schema References
 Elements without namespace: http://www.w3.0rg/1999/XSL/Format © | Select.. | [ OK ]
Namespaces: . Annulla_|
Namespace Location
I8 http://www.w... | http://www.w3.org/MarkUp/SCHEMA /xhtmI11.xsd | Add |

| Modify |

| Delete |

In this dialog you caninsert
* aschema reference for elements without namespace
» for each namespace, a schema reference

The references will be inserted in the root element using the xsi namespace defined as
http://www.w3.0rg/2001/XMLSchema-instance namespace. If the namespace is already declared in
the root element, it will be used, else the namespace declaration will be inserted. If the prefix xsi is
already used, a new prefix will be created.

There is a facility for edit XML Schema documents in the editor a set of menu commands:

XML Schema > Insert No Namespace Schema Reference Attributes : insert a no namespace
attribute for the target schema to complete.

XML Schema > Insert Schema Reference Attributes : insert a namespace attribute for the target
schema to complete.

Using the XML Schema menu items it is possible to edit or insert XSD types.
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http://www.w3.org/2001/XMLSchema-instance

Operations in the dialog:
Choosing the type
* Reference: will set a reference to a type.
* Simple: inner simple type.
* Complex: inner complex type.
When choosing a complex type, it is possible to choose the content type.

If it is an update of existing data, the existent children that are not compatible with the selected
type will be deleted, but the children that are compatible will be preserved.

Edit an annotation

The annotation of XSD objects can be edited using the menu:
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XML > XML Schema > Edit XSD Annotation

If the element has no annotation one annotation is automatically created and the edit panel is
open. From this panelis it possible open the complete edit annotations panel where more than one
annotation can be inserted for the given element. If the element has already more than one
annotation item, the full annotation panel is open.

This panel configures a single annotation item.

» o ¥SD Annotation

Type: OK

@) documentation

(~
=z
&
(>

() applnfo

Source: | source ‘ - |

Language:|en v| | Cancel

Comment:

Text|)'NL|

simple comment<inner_iterm> a{ﬂ AREr_iterms

Advanced...

The panel can show the inner contents of the annotation when containing XML mixed to text.
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EEI 2 <inner_item a

Available options:

Type Switch the type of the annotation item between documentation
and appinfo.

Source Set the source of the item.

Language Valid only for documentation type.

Comment/text Edit field for the annotation item

Comment/XML XML view of the annotation item. This view is read only.

Advanced When the panel opens and the parent element has no items or only
one, this button opens the advanced edit panel.
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This panel shows a list of annotation items. Form here the items can be created, edited and
deleted.

‘ (] Manage annotations @y

Type Language Source Annotation 0K

1| documentation version 3.00+

2| documentation description | The &lt;code>&amp;ltproject&amp;gt;&lt;/code> element is the root of the descripto... |7|
Cancel

Move up

Move down

Available options:

Command Functionality

New Create a new item.

Modify Edit the selected item. This option can be triggered also by a
double click on the list.

Delete Delete the selected item.

Move Up Move the item one position up in the list.

Move Down Move the item one position down in the list.
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Editing Enumeration or Facets
The factes can be edited selecting the restriction element ad using the menu item:
XML > XML Schema > Edit Enumeration or Facet

The panel list all the facets. The items can be reorder, edited and annotated. Not legal elements are
discarded.

enumeration one comment 1 comment 2

enumeration due

Edit facet panel

This panel edits a single facet item.

e @ & 6 o & & o ¢ & 9 O
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Select an element and use the menu “XML>Schema Instance>Insert “nil” Attribute” to insert
the Schema Instance (XSI) “nil” attribute. If the namespace “xsi” is not present, it will be inserted in
the element, changing the prefix if the same prefix is already used; after that the attribute is
inserted.

Select an element containing the Schema Instance “nil” attribute and use the menu
“XML>Schema Instance>Remove “nil” Attribute” to remove the XSI “nil” attribute. If the XSI
namespace is declared in the elements and it is not used in the same element or its children, the
namespace is removed too.

Select an element and use the menu “"XML>Schema Instance>Insert “type” Attribute" to insert
the Schema Instance (XSI) “type” attribute. If the namespace “xsi” does not exist, it will be inserted
in the element, changing the prefix if the same prefix is already used; after that the attribute is
inserted. The type can be chosen by using a dialog.

Select an element containing the Schema Instance “nil” attribute and use the menu
“XML>Schema Instance>Remove “type” Attribute” to remove the XSI “type” attribute. If the
XSl namespace is declared in the elements and it is not used in the same element or its children,
the namespace is removed too.
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It is possible to generate a sample XML from a XSD or to create the XSD from XML. To enable this
feature Apache XMLBeans is required. This feature will only work if the tool is installed.

Open the Configuration panel, navigate to Validation panel and set the path of inst2xsd (part of
XMLBeans) and xsd2inst into the fields in the XSD Manipulation section.

X Conflguration & &) X

. .
aral P;-( Style Ph.'% Editor Colors ‘y Validation j, Sessions \._/ Edit Modes XML <€

XSD validation and Loading
Enable automaticloading of XML Schema associated to file edited

Enable disk cache (maximum size: 1 Mega)

XSD Viewer

XSD Report
Embed fonts in PDF report

Embed diagram image in HTML (instead of create a separate file)

& ES

Use Graphviz to generate diagram image in HTML report (experimental)

Override Graphviz path (system path will be used if empty)

XSD Manipulation

Path of inst2xsd = /home/lbell/devel/gxmledit/gxmledit/varie/xmlbeans/inst2xsd =

Path of xsd2inst | /home/lbell/devel/gxmledit/gxmledit/varie/xmlbeans/xsd2inst =

This feature generates XML/XSD and reguires Apache XMLBeans.

From now on it is possible to generate an XSD from data using the menu Special>Generate XSD
From Data. A new editor window will open with the generated XSD.

To generate XML from XSD, load an XSD file in the editor, then use the menu Special>Generate
XML from XSD. If the XSD contains more than one element that can be used as root, a panel will
open asking which element use as root.

x Choose Root Candidate Mol (X

Select the root item among the candidates

schema

@ Annulla
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There are some facilities to discover and search commands

With the toolbar button or the menu Help>Show Keyboard Shortcuts the shortcuts bound to the
current editor window can be visible listed by ket qualifier.

)_J©
A SRR |

Recent
sample.xml (2)

Most used
sample.xml (2)

Most recent folders

QxmiEdit - /home/lbell/develrgxmledit/manual/qxmledit-manual/datassample.xml

File Edit Preferences Bookmarks XML Special Navigation View Sessions Tools Help

% v g |vs | LY

7 fhome/lbell/devel.. ledit-manual/data

More...

N\ *Processing Instruction™ <?xml xml(version="1.0" encoding="UTF-8")

<ui

version:
1<class  MainWindow
2 <widget - 'MainWindow'  class="QMainWindow" name="MainWindow"
1 <property - 'geometry’ name="geometry"
v 1 <rect

4 Move up

2<y 0
3 <width 906
4 <height 725
2 <property - 'windowTitle' name="windowTitle"
1 <string  QXmlEdit
3 <property - ‘windowlIcon' name="windowlcon”
~ - 1<iconset resource="risorse.qrc”
1 <normaloff ficon/images/icon.png
*text® ficon/images/icon.png

4 <widget - 'centralwidget'  dass="QWidget" name="centralwidget"

- 1 <layout - 'horizontallayout'  class="QHBoxLayout” name="horizontalLayout”

- 1 <item

v 1 <widget - 'sessionTree' class="SessionDrawerWidget" name="sessionTree" native="true"

- 1 <property - 'sizePolicy’ name="sizePolicy”
- 1 <sizepolicy hsizetype="Fixed" vsizetype="Expanding"

1 <horstretch 0

F—
) XO)
Qualifier: Space
= AutoComplete

Keyboard Shortcuts List

New

T

New Window

T ——

4]
Open

%
“ encodingUTF-8
& Add child...
& Append.
/ Edit..
# Delete

¥ Move Down

View as XSD..

Replace  Save

Changing the qualifier key in the combo the shortcuts introduced by that qualified are reported.
The buttons can be pressed using the mouse.
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Tasks are operations than can be accomplished using different commands. They are a sort of
macro, The following tasks are predefined:

Task

Description

Adjust Display Detail

Set the editor view options.

With this task the level of detail of the editor is set. You can choose between some predefined
settings and have a preview of each one.

Options:

Command

Description

Use Predefined

Use the predefined settings.

Use (value)

Use the style shown in the selected tab.

Choose the level

Adjust editor's visualization |

of detail to suit your preferences  UseComeat |

@ G2 (o)
NN

The settings are available as separate options using the menu View.
This dialog can be recalled at any time using the menu "Tasks".

Use Predefined

Essential Compact

Extended Full Details

Preview:

X *Pro

¥ <server

cessing Instruction® <?xml
xmins="urn:abcdef"
1 <properties
/ *comment*®
w 3 <test
1 <test-interface - ‘value'
1 <test-binding - 'value'
*text* CDATA TEXT
w 2 <test-interface - 'value'
1 <test-binding - 'value'
2 <test-binding1
3 <test-binding2
3 <test2 - 'the name'

*text* text, atext second line

path="a.property”, relative-to="config.dir

Comment, this is a comment second line

test="value"

context="true", enabled="true", name="the name”, test-name="abc123

| Cancel | |

xmil(version="1.0" encoding="UTF-8') 1=

test="value", test]1="valuel", test2="value2", test3="valuel", test4:

test="value” text node second line

test="value"

Compact:
* One attribute per line
* Use child index
» Compact view
|- + Sort attributes
[» » Limit attributes

line length
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The preferences panel can be opened using the menu Edit > Configuration.

The panel allows the configuration of the following categories:

Information Description

General General options.

Style Management of display style in the editor.

Editor Colors The name says all.

Validation Option related to XML and XML Schema validation.
Sessions Management of sessions data.

Edit Modes Activation of special modes in the editor (e.g. XSLT).
XML XML management.

Here a detailed explanation of the options:
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Option

Description

Show welcome page

Shows the welcome page at program start up.

Enable experimental features for
test purpose

Enables experimental feature in development editions.

Default font bold

Use bold font weight for elements.

Override the font for elements
display

Use a user chosen family in the editor.

Override the font for fixed
spacing attributes

Use a custom font when rendering attributes with mono spaced
font.

Enable Logs

Enable logging.

Automatically expand editor tree
when loading data

Expands (open) the whole tree after loafing a new file.

Autoscroll in the elements tree

Enable autoscroll when dragging items

Open files in new window

A new window is used each time a file is loaded.

Limit attributes length

The maximum length of the attributes lines in XML visualization.

\,{""‘: General ??X Style ?’?X Editor Colors

Behavior

Show welcome page
V| Autoscroll in the elements tree

v | Enable experimental features for test purpose

Appearance

¥| Default font bold

Qg Validation

Configuration 2 oo &

Sessions x/ Edit Modes XML

Override the font for elements display <Not Set> change font...
Override the font for fixed spacing attributes Courier 10 Pitch size 9
| Enable Logs Level: | error -
v | Automatically expand editor tree when loading data
¥ | Open files in mew window
Warning: changes will be applied only after a program restart.
oK
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Style

This panel lets you choose the location for user defined styles files.

Use the program directory Use the installation folder

Use the standard Operating System |Use the default location for data.
location

Use the following directory Use a user defined folder.
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Editor colors

This dialog is described in details in the Style section. You can customize the colors of the editor.

tags

processing instruction
attribute names
attribute values
comments

info

text

anonymized element in preview
anonyrmized text in preview anonymized text in preview
anonymized attribute in preview anonymized attribute in preview

‘Q *Processing Instruction® <?xml  xml(version="1.0' ding="UTF-8")
<)

path="a property”
/1 <properties | e to="config.di”
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Validation

Option

Description

Enable automatic loading of XML Schema
associated to file edited

Automatically loads referenced XML schema files in the
background at the XML file loading.

Enable disk cache (maximum size: 1 Mega)

Enable cache for XML schema files to avoid unnecessary network
traffic.

Embed fonts in PDF report

Option to embed fonts in PDF report

Embed diagram image in HTML

If the diagram image in HTML report should be inlined or
generated as external file.

Use Graphviz to generate diagrams in HTML

Use GraphViz (not included in @XmlEdit) to generate the diagram
image. This option is experimental

Override GraphViz path

Custom path to dot executable.

| & validation H

Configuration @ @ @ @
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Sessions

Session options described in the Session section.
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This panel for the options related to specialized edit modes.

Option

Description

Automatically switch to XSLT edit
mode when opening an XSLT file.

When loading a new file, if it is recognized as a XSLT documents,
XSLT edit mode is automatically enabled.

Show the "Switch to XSLT" panel
when opening files.

When loading a new file, if it is recognized as a XSLT documents,
open the XSLT edit mode panel.

Use external Java engine with
Saxon command line syntax

If you want to use an external XSLT Java engine having the same
command line interface as Saxon, insert here the path of the jar.

Automatically switch to SCXML edit
mode when opening a SCXML file.

When loading a new file, if it is recognized as a SCXML
documents, SCXML edit mode is automatically enabled.

Show the "Switch to SCXML" panel
when opening files.

When loading a new file, if it is recognized as a SCXML
documents, open the SCXML edit mode panel.

) J©

.

_/\": General "';-X Style "gX Editor Colors

XSLT mode

Show the "Switch to XSLT" panel when opening files

*

Configuration

W Validation

?) () (o~
&/ & & &

Sessions | / Edit Modes XKML
o s

v| Automatically switch to XSLT edit mode when opening an X5LT file.

v| Use external Java engine with Saxon command line syntax

Saxon jar

SCXML mode

Show the "Switch to SCXML" panel when opening files

v| Automatically switch to SCXML edit mode when opening a SCXML file.

b

OK
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XML management options

Option

Description

Automatically -+insert prolog with
encoding

When creating new files, insert XML prolog with optional
encoding specification.

Automatically update metadata as
processing instruction if found
when saving data

Enable the update of @QXmlEdit specific metadata in the file when
saving.

Automatically -Hinsert formatting
metadata process instruction

When creating a new XML document insert a processing
instruction that holds formatting settings (indentation, ...)

XML -dndentation on save

Enable or disable XML indentation when saving. A value of O still
saves on element per row. You have to disable it explicitly if you
want only one output text line.

Save using stream instead of DOM

Enabled by default. Allow a finer control on input and output.
DTD declarations are not handled if this option is unchecked.

Sort alphabetically the attributes

On saving the attributes will be sorted alphabetically on their
name.

Attributes line length

It limits the start column of the attributes. If a limit is set, if the
attribute start at a column that is greater than the distance from
the tag end than the limit, a new line is started.

Limit attribute length to X
columns

Limits the length of the attribute zone when saving the file.

Process formatting metadata

When reading a document, if formatting metadata are fouund,
they will be applied.
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QXmlEdit can use a different display style, the font used, its dimensions and the color, to represent
different XML structures. The style description can be created by the user and applied on demand.
QXmlEdit comes with some predefined styles.

The style can display the value of some attribute near to the element tag to highlight the element
type.
To apply a style:

* Inthe main window, click the styles popup |5, (), then choose the desired style.
To remove a style:

* Inthe main window, click the styles popup ( £y, ), then choose the "== No Style ==" item
The style files location can be configured using the menu item Edit > Configure.
In the appendix there is the complete style reference.

An example of style applied to an XML Schema file is represented in the following screenshot:

== R |
Elements #Ch.
b itern 1(79)
v layout - werticallLayout' 2(78)
v itern 1(19)
v layout- ‘formLayout’ 6(18)
7 property - fizldGrowthPalicy' 101
Enum 00
2 item 1(3)
v widget- label’ 1(2)
o propery - ‘texd' 1(1)
string V()]
hd item 1(1)
widget- ‘editTag’ 00y
hd item 1(3)
v widget- label_2' 1(2)
v property - ‘texd' 1(1)
string 0(D)
7 itermn 101
widget- ‘editText 00
hd item 1(3)
v widget- label_3' 1(2)
g property - ‘texd' 1 (1)
string 00y
hd item 1(57)
v layout - ‘horizentalLayout_1' 2 (56)
hd item 1(33)
b layout- werticalLayout_2' 2(3)
v itern 1 (1)
widget- listWidget 0(D)
v itermn 1(29)
7 layout- layBox1' 4(28)
A4 itermn 1(5)
v widget- ‘lineEdil_2" 1(4)
v property- 'sizePolicy' 1 (3)
o sizepolicy 2({2)

The style can be used to highlight the elements.
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v kd 4 -event 2(2) 266 logger="loggerl", time
0(0) 28 <html><body bgcolor...
0(0) 122 file="Test.java", line='
v @ 5-evem 2(2) 265 logger="loggerl®, time

The Style can be based on rules, in the appendix there is the full detail.
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Basically you can use the tree view to insert child nodes or append nodes as brothers of the current
one. There is a separate input panel for each node type you can manipulate: elements, comments,
processing instructions.

To insert an element as a child of some other node:
* Select the XML > Add a Child Element menu.
or
* Click the button Add Child... on the main window.
To append a node as brother of the current selection:
* Select the XML > Append a Brother Element menu.
or
e Click the button Append... on the main window.
To work with attributes:
* open the element edit panel and start editing
To insert a processing instruction as a child of some other node:
* select the XML > Add Processing Instruction as a Child menu
To append a processing instruction as a brother of some other node:
* select the XML > Add Processing Instruction as Brother menu
To remove a node of any type (element, attribute, comment, processing instruction):

¢ click the button Delete on the main view

There are some shortcuts to move from one element to another one using the relationship
between the two. These shortcut are handful especially when the data tree is very tall, and avoid
you the necessity to continually scroll the window while examining data.

To rise from an element to its parent:
* select the element, then press F11

To jump to the next element at the same level of the current one:
* select the element, then press F10

To jump to the previous element at the same level of the current one:
* select the element, then press F9

To close all the children of an element and all the children of their brothers (it gives you a compact
view of the tree level in one operation):

* select the element, then press F12
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Editing Elements and Attributes
To edit the selected object:
* double click on the selected element
or
* press the Edit... button in the main window

When editing elements a panel will open. In the panel the current element path is shown; it is
possible to manage namespaces by recalling a library of user defined data. It is possible to manage
base 64 coded attributes.

. . Edit Element . . . . ‘

Path: /forroot/foilayout-master-set/fo:simple-page-master

Tag: [fo:simple—page—master

Text Nodes:

margin-bottom

margin-left

margin-right

margin-top

master-name

page-height

page-width

In the panel you can insert the following information:

Tag The tag of the element
Text Nodes You can insert or remove text nodes as element children
Attributes You can edit the element attributes
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To insert a text node:
* press the + button in the text nodes section
Toinsert a CDATA text node:

* press the + button in the text nodes section then activate the CDATA check box on the text
nodes table

To modify text node content:

* Select the text node, then press the Mod... button. A panel will open.

Note: you cannot edit child element nodes in this panel, only text nodes.

X - Edit Text Node @O0
] ¥ 0K
The selection can be always copied using usual shortcut keys or the Edit menu items, but when selecting an @ Cancel
elementthere is the possibility to copy only the element or the attribute name or value using the copy button
located in main window:|
V| Wrap text
Base 64 Text

From Base 64

To Base 64
Binary to Base 64

Load from file...

Saveto file..

Toinsert a base 64 coded text:
* Insert the text, then press To Base 64 button, then save the text.
To modify a base 64 coded text:

* Press the From Base 64 button, the text will be decoded, modify the text, then press To
Base 64 button, then save the text.

To view the text on more lines even it is a single line:

* Activate the Wrap text check box.
To load a binary file as base 64 coded text:

* Pressthe Load from file... button, then browse to the file in the file dialog.
To save current base 64 coded text into a binary file, decoding the values:

* Press the Save to file... button.
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In text panel there is a tool button at the top just over the text box; when pressed the search panel

appears.
The option for text search are:
* Search only whole words.

* Search with case sensitivity.

The menu XML>Siblings lets you
* Delete the siblings before the selected element.
* Delete the siblings after the selected element.

* Delete all the siblings of the selected element.

The selection can be always copied using usual shortcut keys or the Edit menu items, but when
selecting an element there is the possibility to copy only the element or the attribute name or value

using the copy button located in main window:

Copy Element Text xs:anyAttribute’
Copy Element Tag <xs:anyAttribute>
Copy Attribute Name 'namespace’

1 Copy Attribute Value='namespace'
Copy Attribute Name 'process Contents'

Copy Attribute Value ='process Contents'

to copy the selected element tag:

* clickthe Copy Element Tag item
to copy the selected element content:

* clickthe Copy Element Text item
For each attribute of the selected element:
to copy the attribute name:

* clickthe Copy Attribute Name item
to copy the selected attribute value:

* clickthe Copy Attribute Value item
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Namespaces

In the edit element window it is possible to recall the namespaces management dialog.

fo ]
http://www.w3.0org/1999/XSL/Format

http://www.w3... | XML Schema (xsd or xs)

Namespace management dialog

In this dialog it is possible insert namespace references recalling the namespace selection dialog.
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html http://www.w3... XHTML 1.1 (html)

xsi http:// h (xsi)

fo http://www.w3... XSL-FO 1.0 (fo)

xsl http://www.w3... | XSL 1.0 (xsl)

local http://www.w3... xquery local functions (local)
xsd
http://www.w3.0rg/2001/XMLSchema
http://www.w3.0rg/2001/XMLSchema

Namespace list dialog

I n this panel it is possible to select a system defined namespace or choose a user defined
namespace. The user defined namespaces are managed in a separate dialog, stored permanently
and are available to successive sessions of QXmlEdit.
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» Edit Namespace

Mame: | Userl W OK

Description: [ User2

(~
{«
G
x

@ cancel

Tags (comma separed): [ x,a,b,#{a a}

Created on: Tue Sep 22 15:25:42 2015
Last modified on: Thu Sep 24 09:57:36 2015

Default prefix: [ abc ]

XML Schema definition (X5D)

[ http:/ftest

Schema location

[ http://ftest

Other prefixes:

prefix
prefix
prefix Add

Modify

Delete

You can mark the elements with bookmarks for easy retrieval and navigation.
To set a bookmark:

* select an element, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)
To remove a bookmark:

* navigate to the bookmark, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)
To remove all the bookmarks:

* use the menu Bookmarks > Remove All Bookmarks
To move to the next bookmark:

* PressF2
or

* use the menu Bookmarks > Go to Next Bookmark

To move to the previous bookmark:
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or

Press Shift-F2

use the menu Bookmarks > Go to Previous Bookmark
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Basic information about the file can be shown using the menu Edit > Info
The information is relative to:

*  Encoding.

* XML Schema references embedded into the file.

* Declared name spaces.

« DTD.

* Fileinformation.

Here an “Info” panel:

e O 0 Information
Encoding: UTF-8
No file information. P,
. Annulla |
DTD —

XML Schema references
There are no XML Schema references

Namespaces

Prefix Namespace URI role

1 fo ‘ http://www.w3.0rg/1999/XSL/Format ‘ ‘

Please note that some namespace prefix can be used in more than one place with different
references.

The “role” column will list well known namespaces.

The DTD of the document can be edited in this panel if the file is not read only. The manually edited
DTD is not checked against syntax errors.
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Sometimes the data of an element are text nodes or binary data base 64 coded. QXmlEdit can
display decoded base 64 coded text near to the literal content in the main window, and permit you
to edit directly the content.

To edit directly the base 64 coded text of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner
base 64 Text.

2. Write directly the text into the edit box of the panel that appears.

The text will be automatically encoded and decoded as needed.

Sometimes the data of an element is an XML payload registered as text, or a base 64 coded XML.
QXmlEdit can edit directly both the types of contents.

To edit directly the XML data stored as payload of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner
XML.

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML.
The XML will be automatically encoded and decoded as needed.
To edit directly a base 64 coded XML used as element payload:

1. select the element, then right click to make the context menu appear and select Edit Inner
XML Base 64 Coded.

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML.

The XML will be automatically encoded and decoded as needed.

You can insert an XML prolog XML using the menu XML > Insert prolog. You can insert
automatically a prolog on document creation using an option in the configuration panel. In the
panel you can also select the encoding to be used.

QXmLEdit can use a processing instruction to store and retrieve formatting settings for indentation,
attributes display and so on.

If the processing of the instruction is enabled, the settings are read and applied at the next saving.
If some formatting options is changed and the instruction exists in data, the instruction is
automatically updated before saving.

The instruction processing can be enabled in preferences, XML section.

To insert a formatting processing instruction use the menu item Edit>Formatting>Add
Formatting Info. To remove it us the same menu, and the Remove Formatting Info item.
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To enable or disable the management for a single document, use the formatting panel with the
toolbar or the menu item Formatting>Formatting...

The preferences panel has an option to automatically insert the instruction at each document
creation.

The processing instruction is transparent to XML management, however should you want to avoid
it, you can disable it in preferences panel.

In the menu Edit>Formatting there are some common (hopefully) presets. The name of the items
gives a clue about its settings.

An XML Schema validation option is available, but it uses the Qt XML validation facility, that is
rather limited at the moment. The validation is made by default using schema references contained
in the XML document, if any. You can use an external XML Schema file; after this assignment the
validation is performed using the assigned file until an explicit command to use the document
references is given.

If an external schema file is used, its path is visible In the tool tip of the toolbar “Validate”
command.

To validate using the last assigned schema:

* select the menu XML > Validate
To validate a document using self referenced XSD, if any:

* select the menu XML > Validate Using Document References
To use a different an XML Schema file:

* select the menu XML > Validate Using New Schema File

N B: the validation option is available only if compiling at least with the Qt 4.4. It uses the Qt
XML validation facility, that is rather limited at the moment.

It is possible to display the sum of the number of elements children and the element total size,
calculated on the canonical element form (i. e. counting stating and ending tags). The size
calculated is only an approximation of the real value, given that there are many modes to write the
same XML data.

To activate the option:

¢ select the menu View > Show Element Size

It is possible to execute searches in the editor. To open the search panel:
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* use the Edit > Find menu
or

* press Control+F

File Edit Bookmarks XML MNavigation View Sessions Tools Help

] Tt — y J x50,
=1 = RS nv vz /Y R
Search
€ Text to Search | width| ~||al B~ @ Findau Prev Next Count XPath | Advanced
scope: « | Search in: | Element Tag - Match Exact Value Case Sensitive Only in Children
Found 1 occurrence. size: 0 | Wrap around || Close Unrelated || Selection to Bookmarks || Show Size
Elerments encoding:UTF-8
\. *Processing Instruction® <?xm xrml(version="'1.0' encoding="UTF-8') € Add Child...
* l<ui version="4.0" & Append...
| <class EditProcessing -
/ Edit...
- 2 <widget - 'EditProcessing’  class="QDialog", name="EditProcessing" =
» | <property - 'windowModality'  name="windowModality" # Delete
- 2 <property - 'geometry’  name="georetry” 4> Move Up
- | <rec
lex 0 G Mowve Down
2<y 0 View as XSD...
3 <width 610
4 <height 174
» 3 <property - 'sizePolicy’ name="sizePolicy"
» 4 <p ‘'windowTitle' name="windowTitle"
» 5 <property - 'autoFillBackground’  mame="autoFillBackground™
.4 6 <property - ‘'modal’  name="modal’
» 7 <layout - 'verticallayout_2'  class="QVBoxLayout’, name="verticalLayout_2"
’ i< [

Mo schema mode: XML B Modifiable

In the panel you can do the following operations:
To start a search:
* insert the text in the edit box and press Enter key or press the Find button
To limit the search to a particular kind of XML components, use the Search In option box:
* Allthe types of components
* Element tags only
* Attribute names only
* Attribute values only
* Text nodes
* Base 64 coded text

The elements that match the search rules will be highlighted, but you can act on the display in the
following manners:

Name of the Option Information

close unrelated close all the branches that does not contain any occurrence of the search text.
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selection to bookmarks adds all occurrences found to the bookmarks collection.

match exact value executes the search of the exact value of text (opposed to regard the text as a
substring)

case sensitive the search will be case sensitive

find all mark all the occurrences of the search pattern with a background pattern to
ease the reading, elsewhere the search will stop to first match.

only in children the search can be limited only to children of the selected item or to the whole
tree.

scope can limit the search to a set of elements or attributes. This field can contain a

path in XPath like syntax. For example to search a value in the “id" elements
children of “resource”, the field must contains “resource/id". If the search has
to be performed only on “name” attribute of the “window" element, write
“window/@name”. To include any elements between “window" and “widget”
tags, simply omit it as in “window//widget”

XPath Activates the XPath syntax (see below for details). If unchecked the text entered
in the search box is used as pure text.

The number of matches is reported in a box at the bottom of the search panel.

It is possible to find the next occurrence starting the search from the selected item. You can use the
command buttons in the panel or activate it using the following command:

e use the Edit > Find Next menu
or

* UsethekeyF3

The matching items are highlighted and, in combination with other options, non matching items
are closed.
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QXmIEdit - /nome/lbell

File Edit Bookmarks XML Navigation View Tools Help

IE=NT P

—search
0 Text to Search Ia\opinfo Ql Find I Searchin: IAII vl
scope: I

[V Close Unrelated |~ Selectionto Bookmarks |~ Match Exact Value | Case Sensitive [ Find Al [~ Only in Children [V Show Size

searchResults: Found 14 occurrences. Size: 0

Elements | AtributesText | encodngTF8
\ *Processing Instruction* <? ? xmi(version='1.0") Add Child... |
= xs:schema targetNamespace="http://www.example test/", version="1.0", xminstms
’ Append... I
xs:attribute - 'code’ use="required", name="code"
xs:complexType - 'someComplexType' name="someComplexType" Edi...
xs:attribute - 'code’ name="code"
=) Xs:annotation &I
xs:documentation documentation
= xs:appinfo appinfoappinfo — % Movelp I
1 a ’ appinfo
Xs:notation - ‘txt' ’/‘ | public="text/txt", name="txt", system="gedit" Ml
xs:import ;’ namespace="http:/'www.qxmledit.org/"
xs:group - ‘topLevelGroup' I minOccurs="1", maxOccurs="unbounded", name="topLevelGroup"
=] xs:element n
= Xs:annotation /]
xs:documentation / { sample annotation
B xs:appinfo / l-' sample annotationsample annotation
a ! appinfo
i xs:complexType /}
xs:complexType - ‘complexSimpl "‘es'!rictiorf:' name="complexSimpleRestriction"
xs:complexType - 'aComplexType' /| name="aComplexType"
xs:complexType - ‘typeWithGroup' ;‘“ name="typeWithGroup"
xs:complexType - ‘typeWithGroup' ‘f | name="typeWithGroup"
xs:element - ‘testElement2' ‘s’,-' minOccurs="4", maxOccurs="8", name="testElement2" -
« | Jf _»F' £y O
/:.

Matched items

In the panel you can do the following operations:
To start a search:
* select the “XPath” check box

* insert the text in the edit box using XPath syntax and press Enter key or press the Find
button

A small note will indicate the XPath mode activation.

If “Only in Children” check box is selected the root of the search is the current element, if not the
search starts at the document root.

Some of the options available to the text search are hidden because their operation can be carried
on using XQuery and XPath.

The elements that match the search rules will be highlighted, but you can act on the display in the
following manners:
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Name of the Option Information

close unrelated closes all the branches that does not contain any occurrence of the search text.

selection to bookmarks adds all occurrences found to the bookmarks collection.

the search can be limited only to children of the selected item or to the whole
tree.

only in children

can limit the search to a set of elements or attributes. This field can contain a
path in XPath like syntax. For example to search a value in the “id" elements
children of “resource”, the field must contains “resource/id”. If the search has
to be performed only on “name” attribute of the “window” element, write
"window/@name”. To include any elements between “window"” and “widget”
tags, simply omit it as in “window//widget”

scope

The number of matches is reported in a box at the bottom of the search panel.

The matching items are highlighted and, in combination with other options, non matching items
are closed.

The following screen shot shows a search using XPath:

View Sessions Tools Help

LI AR+ R IR

a search
o

searchResults: Found 1 occurrence. Size: 117

II*[/b/@attr4 eq 'four’] v l @[ Find H Count l ¥ XPath

¥ Close Unrelated ¥/ Selection to Bookmarks Only in Children ¥ Show Size

encoding:UTF&

Elements #Ch. | Size | Attributes Text
o Processing Instruction* <? 7> xml(version="1.0" encoding="UTF-8") [‘E Add Child..
-] root 1(2) 130 9 Append
attrl="one" =
= =g 1(1) 117 attr2="tweo"
attrEqual="equal"

4+ Move Up
€’ Move Down

View as X5D..

No schema |y

You can open a search results panel using the button “Open panel” in the find panel.

The new panel will show only the search results, giving the possibility to browse directly the XPath
queries elements or the text search results.
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Replace uses the search feature to find text that can match and replace it all at once or one at time.
Replace is triggered by the menu Edit > Replace.

Search
) Textto Search | xs:complexType -|a|[Zl @ Fedau Prev Next Count XPath | Advanced
scope: ~ | Searchin: | Element Tag ~ | [ Match Exact Value | | Case Sensitive | | Only in Children

size: - V| Wrap around  [v| Close Unrelated v Selection to Bookmarks [v/| Show Size

Replace with: | xs:simpleType] < ||| 4| P|| Replaceal

Elements encoding:UTF-8

The following commands are available:

Command Behavior

Replace All Replaces all the occurrences of the search pattern.

Replace and find next If there is a selection, a replacement is applied if there is a match; then the next
element that matches is selected. If no selection was existing, the next match is
selected.

Replace and find previous If there is a selection, a replacement is applied if there is a match; then the

previous element that matches is selected. If no selection was existing, the
previous match is selected.

Skip and find next If there is a selection then the next element that matches is selected. If no
selection was existing, the next match is selected.

Skip and find previous If there is a selection then the next element that matches is selected. If no
selection was existing, the previous match is selected.

Note: replace operation cannot use XQuery search.

The purpose of the comparison as implemented is to give a compact view of changes, comparing
the current editor content with another file. The sense of the comparison is to show what
transformations are needed to the chosen file to become the current loaded one.

To compare a file against the current:
1. select the menu File > Compare with...
2. choose afile
In the panel that opens you have the following information:

¢ The current file in XML format with elements and attributes that are different between the
files with highlighted colors (Synthetic View).

* Astructure comparison side by side of the two files (Analytical view).
* The list of the differences with the path of elements (Difference list).

The following options can be set:

Compare text Compare even the text nodes
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Compare comments Take into account the comments

Denormalize EOL
by specs.

In CDATA nodes do not transform the CR LF sequences into LF as stated

In the panel that opens you have the following options:

* Compare only elements or comments and mixed content too.

*  Copy the comparison result to the clipboard.

* Retry the comparison, after changing some option.

To start a comparison, load a recent file from the relative combo box or select another one using

the browse button.

User interface e s

Comparing Thameilbellidevel/qemleditixsditestidataicompare/refarance 1 xml’ with

Browse file

Compare with: | fhom¥g¥lell/devel/gqxmledit/xsd/test/data/compare/comparel.xml E l 0 [
Synthetic view | Analytical view Differences list
0 eneoding e o | Encoding
oot > indicator
<a attr2="two" a qual= attr21="two">
hree" attr4="four"
<c attr3="three" attr4="four"/>
Zoom Legend
- = Copy Text to Clipboard Equals
Status: |Files are different . ¥ Compare Text
options@ | Go to difference i
7 compare cfonts | Different
e[ =
Status
Compare options

Analytical view
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Compare with: [ihumeilbell.’devel.’qu\editixsditestldataiccmpare.’comparel.xml e l 6 l - ]
Synthetic view | Analytical view Differences list

Nodes | | Nodes 2

<? xml version="1.0' encoding="UTF-8' 7>

=l <root> <root>
=l <a> = <a»
=l Attributes: =t Attributes:
@ attr2 = "two"
,/ attrl = "one" ,/ attrl = "one_c"
attrEqual = "equal” attrEqual = "equal”
® attr2l = "two"
- @ <b> -
=" Attributes: E
@ attr3 = “three”
@ attrd = "four”
= H = ‘ <C> ]
= || =1~ Attributes: L
-1 ® attr3 = "three" E

T Options Legend

Copy Text to Clipboard Equals

¥ Compare Text

Status: |Files are different

Deleted
Sprans l:l Go to difference:
Dump on stdout ¥ Compare comments LfET=T:
Added

id]

Differences list

Compare with [lhomeﬂbel\ideve\qum\editlxsditestidata,’compareicomparel.xmI > I 6 l ]

Synthetic view | Analytical view | Differences list ‘

lcon Status Element XPath

: Added | Attribute /[<root>/<a>/Attributes://@attr2 = "two"
Modified| Attribute /<root=>/<a=/Attributes://@attrl = "one"
Deleted  Attribute /<root>/<a>/Attributes://@attr21l = "two"

Added |Element [<roots/<a=/<b>

Deleted Element /<root>/<a>/[2]<c>

Zoom: Options Legend

Copy Text to Clipboard Equals

4
Compare Text Deleted

Dump on stdout + Compare comments L
Added

Status: |Files are different.
Options: l:l Go to difference:

(i4] <
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The menu File > Load Sample allows to load only one copy of each tag and attribute of a filein a
new document. This feature is useful to set the rules for anonymization of a huge file or simply to
look into a file. Each tag, identified by its path is loaded only one time even if is is repeated. The
attributes of an element are collected over all the instances of the element; only the first
occurrence of the attribute is retained unless the attribute is empty, in this case the first following
instance that is not empty will replace the original one.

Note: there are some limitations, be sure to read the “Limitations” paragraph.

Occasionally the XML generated may be not valid if namespace declarations are different on
different instances of the same tag and have the same prefix; it is up to the user to manage this
case.

The menu Special > Anonymize recalls a dialog to anonymize the data contained in attributes and
text of the XML.

This feature can be useful if the XML file should be sent to technical staff for debugging purposes
avoiding the disclosure of personal information.

Using this feature the text and the attributes can be altered using a fixed character or using a
different letter for each input character by preserving the case of the original letters.

The original data structure is preserved replacing only letters and digits with altered text,
preserving the case of the letters and the reserved XML attributes. The tags and attribute names
are not changed.

Note: in order to set rules on a huge file, you can load only a sample of the file using the File >
Load Sample menu. Details on the specific paragraph.

Often the files contain not only personal information, but also data for business rules. Modifying all
the contained text or attributes will end in a useless file transporting no information at all.

To avoid that result, manipulating the parameters that belong to the business rules, two features
can be used:

* Afilter to avoid the anonymization of values consisting of less than 4 characters (the length
of many codes).

* The use of exceptions.

The exceptions can be bound to any element, attribute or text node and force the subject to be
anonymized or not; if anonymized, a user defined value can be used to replace the original one.

The exceptions can be hierarchical and extended to the children of the subject. It is possible to
isolate data from business rules from personal data. When applying more expressions, the more
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specific wins; for example if an element has been forced to be anonymized with children, and one
of its children has another exception of reverse meaning, the child exception is applied.

Each time an exception is modified, the anonymization operation results are shown in a preview
pane. The original values can be seen in the tooltips of the elements of the preview.

category=" "

‘regions/africafitern/incategary
Attributes:

category (anon. )="xo000001 1" org:" category12"

Since creating rules and exceptions is a time expensive process, it is possible to save them using a
profile and recall them later in other anonymization processes.
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® 006 Anonymize

Profile Name:

This feature will destroy your data | Cancel |

Options

() All text
(o) All text with more than 3 letters or numbers
@ Mask the text using a fixed pattern

h Save Profile
Preview
Elements
\ *Processing Instruction* <?xml  xml(version="1.0")
A *Processing Instruction® <?gxmledit  gxmledit(type="info" creationUse
M <rss  version="zzz", xmlns:atom="http://www.w3.0rg/2005 /Atom", x
v 1 <channel
1 <title  Xx00xxx XXX
| Edit Profile |
Add Exception: | Element... | Attribute... | | Text.. |
Exceptions
Rule | Transform Path
/rss/@version
| Profiles... |

Delete

The options are:
* Alltext: all the text will be changed.

* Text with more than 3 letters or digit: only the text that is composed by more than 3 letters
or digits will be changed. This to skip codes that usually have a limited length.

The check box “fixed pattern” determines how the text is transformed.
* If checked: letters are replaced by 'x' and numbers by '1'.

* If unchecked: the letters and the numbers are replaced by a succession of letters or
numbers in alphabetical order.

The exceptions can be entered selecting the element and using the contextual menu.
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Information in the panel:

Name

Information

Profile Name

Name of the profile (read only)

Options Options to anonymize data:
* anonymize all the text
* anonymize only the text with more than 3 letters or numbers
As an option it is possible to use a fixed pattern to replace the text.
Preview It shows the final result of the operation on the current data

Add Exception

You can add exceptions when an element is selected in the preview.

Exceptions

The list of the exceptions

Save Profile

Saves the current profile data. If the profile has not been created, a creation
panel will appear.

Edit Profile Edits the profile data.

Profiles Manages the profiles.

Import Import a list of exception in CSV format (see below for details)
Export Export the exception list to the clipboard in CSV format

To insert an exception:

1. Select an element in the preview pane

2. Use one of the buttons in the “Add exception” row

To remove an exception:

1. Select an exception in the exception list

2. Press “Delete” in the exception group.

To save the exception list in a profile:

* Press “Save profile”

If the profile has not be created, a profile creation panel will appear.

To mange profiles:

* press "Profiles..."”

A list of profiles, grouped by tags will appear. Selecting a profile and exiting with “Ok" will load the
profile in the caller dialog. It is possible also creating and deleting profiles.

The colors of anonymized items can be configured using the “Editor Colors” panel.
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e cotursen T eves
o[ e s [(f i
_Change.. |

tags tags

processing instruction processing instruction

attribute names attribute names

attribute values attribute values

comments comments

info info

text text

ancnymized element in preview anonymized element in preview
ancnyrnized text in preview anonymized text in preview

anonymized attribute in preview anonymized attribute in preview IS.

A\ *Frocessing Instruction® <7xml xmliversion="1.0" encoding="UTF-8")
V—B <server  xmins="urn:abcdef"
o 1T<properties  path="a property", relative-to="config.dir"

’M*commmt* Comment, this is a comment
second line

v— . 3 <test

test="value", test1="valuel", test2="value2", test3="value3", testd ="valued"

v—|«:| 1 <test-interface test5otyalues

Format of the CSV for importing and exporting the exceptions
The CSV fields used to exchange the exception list are:
1. The XPath of the exception.
2. Theinclusion criteria as integer:
I. 0:exclude (default)
[I. 1: exclude with children
[ll. 2:include
IV. 3:include with children
3. Type of data mask used:
I.  Use default.
[I. Use afixed value.
4. A string value if the fixed value replacement is chosen.
5. A numeric flag for processing namespaces.
[.  0:do not process namespaces

Il. 1: process namespaces
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When a profile has been created in the interactive anonymized dialog the profile can be used to
process a file without loading it into the editor.

To activate the function use the menu Tools > Anonymize File...

r
» o Anonymize a Fle @y e

Apply

Source file: |;'home.’lbelLr’de'vequxmladl'bfwlWdonﬂutorlah‘anam’daia.orlgml Browse... _

Close
Profile: |Anon Change...

Anonymized file: |.|'lmpﬂ xml | | Browse... _|

In the anonymize panel you have the following options:

Name Option

Source file Name of the source file to anonymize. Use the "Browse..."” button to
select it

Profile The name of the anonymizing profile. Use the “Change...” button to

select it among the previuosly saved profiles.

Anonymized file Name of the anonymized file. Use the “Browse..." button to select it.
Note that this function will overwrite the file.

At the end of the operation the destination folder can be opened by the panel.

) QXmiEdit o ®

Operation terminated.
Do you want to show the result folder in the browser?

Yes No
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It is possible to insert a progressive number or alphabetic sequence selecting an element and
triggering the menu “Tools > Fill Serie...". A dialog box will allow to choose the attribute name
that will contain the progression index.

This is the dialog and below each option is explained:

i“xh - I_ - Insert Index in Attribute & & _,:' X 1
i Attribute: |nar'n-e| - | | OK | l
I Start number: | 1 : 1
I Format: Unpadded number b 1

V| Ovenwrite existing values Cancel 1

Insert value at end of existing data

Separator:

= =

Replace existing value

Apply to the children too

[I—|
Options:
Name Information
Attribute Name Name of the attribute that will contain the progression index. If the attribute
does no exists in the element, it will be created.
Start number The index of the series fill. For the alphabetic enumeration '0' is equivalent
to'A'".
Format The format of the index. The possible predefined formats are:
Unpadded number (1,2,3)
Padded number ( 01, 02, 03)
Padded alpha (AA, AB, AC)
Unpadded Alpha (A, B, C)
Overwrite existing values This option allow the modification of an existing attribute. Without this
authorization, the existing attributes are left untouched.
Insert values at the end of existing If the attribute for the index is existing and overwrite is enabled, the index
data will be written before or after the current data.
Replace existing value Replaces an existing value of the attribute.
Separator This separator is used when inserting the index into existing data.
Apply to the children too. Apply recursively the index. Each series restarts from 0.
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Cloning Elements

Cloning or replicating elements in the editor using an existing sample is activated by using the
menu Tools > Clone Elements in the 0.9.2 version. Any element can be used as a sample except
the root one.

The only options available to this feature is if to clone only the selected element or even its children
recursively, the number of cloned objects and the use of a counter.

The counter that can be insert in an attribute, existing or created while cloning, is the same that can
be recalled by the “Fill Serie” dialog,

,‘ o/ Clone Element & e 2

MNumber of clones:

D Recursive Cancel ¢

Ihdd an index_..] | Rermove index|

This picture shows the result of the clone operation with the insert of an index using the “id”
attribute:

_i_\;/ : E - O)km\Edit o filed - & & Qy | _i_u : : - D)‘(m\Edit.-_--Nu file=¥ - & & Qy |
File Edit Bookmarks XML N: View  Sessi Tools  Help File Edit Bookmarks XML N: View  Sessi Tools  Help
o L A - X0, W A = x50,
DEEAUL d (e gy /% ] DEEHAUL d |8« gy /7 -
A *Frocessing Instruction® <fxml  xmifversion="10" encading="UTF-8") encoding:UTF-8 A #Frocessing Instruction® <xml  xmifversion="10" encading="UTF-8) encoding:UTF-8
v <wsdischema  xmlnsxsd="http://www.w3.0rg/2001/XMLSchema”, element| [9 Add Child... - <usdischema  xmlnsmxsd="http://www.w3.0rg/2001/XMLSchema”, elementl [0 Add Child...

- 1 <xsd:annotation & Append. h 1 <xsd:annotation &) Append.

1 <xsd:documentation Sample document. 1 <xsd:documentation  Sample document.

B 2 <xsd:element - 'sample’ name="sample” /Edi‘--- - 2 <xsd:element - 'sample’ name="sample" {/Ed“'—J
- 1 <xsd:complexType # Delete M MR e D w

- 1 <xsdall - 1 <xsd:all
1 <xsd:element - 'sample-inner' narme="sample-inner", -‘- Move Up | 1 <xsd:element - 'sample-inner' name="sample-inner", ‘ Move Up i
2 <xsd:attribute - ‘attribute’ name="attribute”, type="xsd:s |& PP — ‘ ] 2 <xsd:attribute - ‘'attribute’ name="attribute”, type="xsd:s’ ‘G R ‘ !
= | = [
—_— » 3 <xsd:element - 'sample’ name="sample", id="1" oEE——
View as XSD... o View as XSD...
M 3 4 =xsd:element - 'sample’ name="sample", id="2"

t b |5 <xsdelement - ‘sample’
B 6 <xsd:element - °

« I (&[0 « ] pl (£ (D)

No schema mode: XML E Modifiable 11 No schema mode: XML E Modifiable 11
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Snippets are pre-configured XML fragments that can be categorized and inserted in the main XML
text. A snippet example can be a resource reference in a J2EE component.

To create a snippet:

select an XML element, then:

or

select Transform in Snippet from the context menu

select the XML > Transform in Snippet menu

Toinsert a snippet in the XML you are editing:

select an XML element that will be the father of the snippet, then:

select the menu XML > Insert Snippet.

in the panel that will appear chose the snippet category from the left, then choose the snippet to

insert.

=

ame

Description

|

m

...... Context Parameters

b

E

web . xml
serviet
servlet mapping
resource-ref
servie@
isp fitter

O-BH-H®

Snippet - fitter mapping
- j2ee
category java

-

jboss-web xml
resource-ref-jposs
jhoss

[+

web xml Context Parameters

declares a serviet in web.xml
servlet mapping

declares a‘s_qurce-ref in web.xml
servlet definition —=__

jsp fitter T

JSP filter mapping

Snippet to insert

declares a resource-ref in jboss-web .xml

To edit the snippets and their categories:

1. Select the menu Edit > Configure Snippets

2.

In the panel that will open, insert, modify or delete a snippet at time.
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To assign snippets values:

In the edit snippet panel you can supply the following informations:

Name

Information

Name

The name of the snippet

Description

The description that will be shown when choosing a
snippet

Tags

Set of comma separated values that will be used as snippet
categories. A snippet can have more than one category

Edit XML Snippet

Mame:

Iservlet mapping

Description:

Iservlet mapping

Tags (comma separed:)

Ijzeejaua,web.xml

created on: FriSep 10 21.52:41 2010

Snippet

lzst modified on: Fri Sep 10 215355 2010

=seryviet-mapping=
=url-pattern='ADDRESS</zerviet-class:=
=servlet-name=SERVLET=/serviet-class=
=fzerviet-mapping=
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You have three options:
* Executing a XSLT using the current editor content as source.
* Use the menu Special > XSLT > Execute XSLT using this as source.
* Executing a XSLT using the current editor content as Style Sheet.
* Use the menu Special > XSLT > Execute XSLT using this as source.
* Using a panel to specify the source, the style sheet and the output.

¢ Usethe menu Tools > XSL Executor.

Using the menu Tools > XSL Executor brings a panel from which you can specify all the details of
the XSL execution.

x () X5LT Execution & Y O E

Source: |Edlt0r: /home/lbell/Desktop/test xml/standard_very_small.xml Browse.._| | APplica |
|
Chiudi
XsL: |Editor: <No file> Browse... |
Qutput: | <New Editor> Browse..._|
Parameters:
Value Add

Name

1|aParameter

Delete

Reset

In this panel you can specify:
* The source XML.
* The XSL template.
* The output.
When selecting the XSL template, the parameters, if any, are shown in the list.

If the internal engine has been selected as the XSL engine, you can choose the editors as source, if
the external engine has been configured, only files are allowed.
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Note: the support to XSL-T 2.0 in Qt is currently not complete.

You can use SAXON or another Java jar with same command line syntax (not part of QXmlEdit)
if you configure it in preferences.
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The metadata records carry information about the data in which it is located without modify the
data itself. QXmlEdit supports descriptive metadata implementing it using an XML processing
instruction whose target is “gxmledit”.

There are two types of metadata: updatable and static.

This kind of metadata carries information about the current state of the document and it can be
automatically updated at each document modification if the relative option is enabled. The data
that can be automatically updated consists of: document creation user and date and the document
revision.

The values contain semantic information and cannot be automatically updated without explicit user
intervention. Some data are predefined, others can be inserted by the user when needed.

The metadata lives on the root level of the XML document. Each metadata record consists of a
Processing Instruction composed by pseudo attributes. The first attribute is always “type”and
denotes the metadata role. The updatable metadata is composed by pseudo attributes that live all
together in a single “info” type. Other metadata uses a single processing instruction having the
attribute “value” for the real data. No entities will be resolved in a metadata pseudo-attribute

except the characters “double quote”, “single quote”, “greater than” and “minor than”, that are
escaped using usual XML entities notation.

The updatable metadata record is inserted manually via menu command. The editable ones are
inserted using a command that insert the updatables ones too.

No metadata is automatically inserted on read.
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When saving, if the option is active, the updatable data are modified. If the metadata record does
not exist in the XML document, it will be inserted if the user gives permission. If only partial
compiled metadata exists, QXmlEdit will complete it. Other unknown metadata information in the
same processing instruction will be preserved for future compatibility. If no creation data exists,
the data will be taken from the file data if available, else they will be created anew.

The metadata can be inserted in an XML document using a menu command or by using a dialog.
The user defined metadata can be handled using the dialog user interface. Malformed data inserted
by hand will be overwritten.

Name Value

creationUser The login name of the user
creationDate The date of the creation
updateUser The login name of the user
updateDate The date of the modification

A progressive value incremented at each

revision " .
writing operation

The values have no special meaning respect to the user defined metadata, however they can be
presented to the user in a configuration dialog.

Predefined data:

Name Value
project

name

copyright

domain

version

Using the menu Edit > Edit Metadata you can open the metadata edit panel. Only updatable
metadata whose check box is selected will be written into the document.
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L8 & 8 8 B B 3

When the file in editing declares itself as a XML Schema (XSD) through the root element and its

namespace, the button View as XSD in the main window is enabled. This button leads to a window

that display a graphic view of the file contents.

Alternatively you can display the current XSD file in this manner:

1. Load the XSD file as a normal XML file.

2. Use the menu Tools > Plugins > XsdPlugin

A window will open with the graphical representation of the data:

= Action

i ActionList

™ DefineGroup
" gui

" Menu

" Merge

= MergeLocal
™ Separator

caption
identifier
state

= Action {gui)
 DefineGroup (gui)
 MergeLocal (gui)

* Merge (gui)

= ActionList (gui)

™ Separator (gui)

* Action (gui)
 DefineGroup (gui)
™ Mergelocal (gui)
= Merge (gui)

= ActionList (gui)

= Action (gui)

™ Separator (gui)

= Menu (gui)

= Menu (gui)

= Menu (Menu)

* Separator (Menu)
= ActionList (Menu)
= Action (Menu)

= Action (state)

fhome/lbell/devel/qxmledit/doc/kxmlguixsd &)
& Targetnamespace:http://wwwhkde orgsstandards/kxmigui/1.0"
L 1..unbounded J
By T I
LE) TearOffHandle | A group, type: identifier
0. unbounded
e
© T ——
o 1..unboupded \E)DeﬁneGruup mplex | name, type: identifier
0. unbounded
O ; i
LE,'MergeLu:al i A, ﬂams‘type:\dsnnfler(upnona\)l
0 .. unbounded
\E i
;@IT'
] 0. unbounded
|
3]
0. unbounded
G|
- : (E) merge
0 .. unbounded
Root A | name, type: identifier
—é A/ append, type: identifier (np[mnal)l ié,ﬁ 7777777777777777777777777 §
P -1 i 0..unbounded
—i A) group, type: \dentif\er(upt\unal)l 3 .
T
R - :kE)Engie_mn;g_m}_um_:L
— A) icon, type: xsdistring (optmnal)l ‘E 0.1
*é A ncMerge,typs:xsd:hoc\ean(cp[mnal)l E(E)-l:l . ¥ b
- -y i 0..unbounded
—i A/ deleted, type: xsd:boolean (npnnna\)l b
= 10 - I B
I (E) i=/L¢ Reference to Actionlist
ShOWS or h|des the wkE’ER:i{L{nLLtD.M}.nL —
7 7 i 0.unbounded £ Yo mienmid
navigation bar cnsasssssssaed || mssssssssssssssssssse
\E I
:\EDERMJDM_
i 0..unbounded
]
L a a By < Legend: @ Choice = Sequence ® Type (E) Element @Attrmuts &2 [ (5)

Search box

C— |

Navigation bar

The symbols denote:

e E:element
* T:type

* A: attribute

Graphical view of XSD
types and elements
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The icons in the elements represent:

‘ Icon ‘ Description
6 There are annotations relative to the element that will be shown in the tooltip.
D The object is a reference to another one.

The visualization modes are two:

* reqgular: allows to view all the schema entities (low level view)

* outline: allows to view the resulting structure hiding details like restrictions and extensions

The selection of the view mode is done using the “Ouline” button.

In the tools button there is the menu command to open the diagram background inspector. The

settings are immediately applied and saved.
To open the inspector:

Tools button > Configure aspect...

Diagram background settings

Gradient type: [}

s B

alternate: |

Direction: |- Vertical

r

Repeat each: |lOO j |Pixe|s

Reset

r

W T WT—TTT

o B

Close

In the window there are buttons that permit to export the view as PDF, HTML or SVG file. The
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reports can be:
* physical: the children of the entities that refer to other entities are expanded inline,

* logical: (default) the references to other objects are kept.

Command Description

HTML Report | Open a panel where a report of the XSD diagram is shown.

Save as HTML | A HTML report of the XSD, with the diagram image, is saved to afile.

Save as PDF A PDF report of the XSD, with the diagram image, is saved to a file.

Exportas SVG | A SVGimage of diagram is exported.

The preferences panel in the “Validation” tab has some option to customize the report generation.
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QXmlEdit is targeted to files with dimensions not too big (< 100 MB). If you need to explore files
very big files, you can enter “Explore Mode” where only the element structure is loaded, without
data and attributes. In this mode, denoted by this icon in the status bar: Q . You cannot edit the

XML document, but you can search in it as usual.
To activate Explore Mode:

* Select the menu File > Explore Structure...
To exit from Explore Mode:

* Load another XML file or start a new document.

It is possible to search in external files the occurrences of a given pattern using a fast parser or
group and count elements.

The occurrence count will simply count how many of the elements stated in the search pattern
exist in the file. The grouping show the aggregation occurrences of the elements.

Let's do an example; if the input XML file is like that:

a

.
|

the number of elements 'a' will be 1, 'b' 2 and 'c' 3, but if we look at the groups they form, we will
have 1 group composed of one 'a' element (the root one), one group of 'b' elements (the children of
a ) and two groups of 'c' elements: one composed by one item (indicated by the green color), and
the other one composed by two items (red color).

To search in files:

¢ Select the menu Tools > Search in Files...

The search window will open:

QXmlEdit user manual, page 90 of 118.



- .
Search in files

Pattern to searchin files:
lalblc A
nim.w search is like this: /a/bic
Pattern to search B e e e ™
v/ Grouping .\ File to look into
Start
Item Occurrences
Aggregation TTa 1
2ITC b u
10
AT« Start the search
4 W Gr.0-/ahaving count: 1 b
5 W@ Cr1-/alb having cou :
6 W@ Gr.2-/albic having cgunt: 0 i
7|6 Gr2-/albie having tount: 1 i
8 Mg Gr2-/alblc having count: 3 2
Q Close
Results

In this window you can insert the following informations:

Information

Description

Pattern to search

The pattern as XPath (elements only) for example: /a/b/c

Path of the file to search into.

File Path
Grouping The scan operation will calculate element groups too.
Start Starts the search operation.

The icons in the result grid have these meanings:

Icon Description

The item is an occurrence count.

The item is an aggregation report.
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There is the possibility to split an XML file in smaller fragments and/or to examine the fragments
directly in the editor. This feature is handy mainly to explore very big files that does not even fit in
memory.

P . :
Welcome to QXm|Edit

Welcome to QXmIEdit

You can choose a task clicking the icon:
Examine a XML Schema [XSD) Splita XML file Choose arecent file L7

1 =

>z—-/

Wiz
Flune

lingiaty
Examine a XML Schema file showing itin a Split a XML file in smaller fragments or Select one of the recentfiles shown in the JB;:
graphical editor. You can printthe schema simply browse it, a fragment at time. list. o

or export it as an image.

Recentfiles list:

~lgxmleditksdiest/datatest split_badxml 1=
~/gxmleditDeskiop/pom.xml i)
~/gxmleditxsd/data/te stipom.xm|

~lgxmleditksd/data/te stimaven-4 0.0 xsd

+| Show this window nexttime { you can reactivate this option using the preferences dialog).

@ Close

When starting, the program will open a welcome dialog leading to the most common operations.
Choose "“Split a file". If you choose to hide the dialog next time the program restart and change
your mind, you can reactivate it in the configuration panel. You can access this feature also from
the menu Tools.

Extract Fragments from a XML File

|Z| Extract Documents (or scan the file and broswe the single documents)

If you want only navigate the data without creating any file, do not check 'Extract Documents'.
Even if you don't extract the XML fragments into smaller file, @XmlEdit scans the file and records
the information for an interactive review.

Parameters

Source file path: /home/lbell/Deskiop/test xmlistandard xml

Split documents using this path | /site/regions/africalitern/n e g /element/child

Browse to the file to examine, the insert the XPath that identifies a fragment. Insert a string of the
form /[/ROOT/DATA and so on.
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_ Extract all the documents

¢+, Extractarange from: |1 o to: 50000 o

Selecting a range permits to extract only a small subset of the original file. You are not obliged to
waste space on your disk if you want only a single fragment.

Extraction

Extract in the following directory: '.ftmp.iy

Wiew in browser

+'| Make subfolders

sach: |50 & files
Subfolder name pattern = %date% v '_ v | [ %timed% v '_ v | [ %numberd v
File name pafttern %date% v | [ %time% | v | [ %numberd v N

Enter the location where write the extracted fragments and decide if you want to create a folder
each N files. Decide also how to name the files and the folders. The combo boxes have some
predefined values to ease the task, like a timestamp, or a progressive counter.

i Help

encoding:UTF8

&
¥

Current fragment
% |[173 {]| Go &

1 \ 550

Clicking Advanced the advanced options dialog opens. In the dialog the following items can be
selected:

* Use namespaces (it is the default behavior) when reading and creating files.
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* Transform the input data using the following process:
o Trim attributes
= allthe attributes will be trimmed at the end
o Remove empty attributes

= allthe attributes that evaluate to empty string will be excluded form the resulting
file

The transformations can be chosen independently one from another.

Advanced options dialog:

x W) Extraction Advanced Options 2) ) ) (X
+ Use namespaces oK
Scripts
Cancel
il Trim Attributes Trim attributes
L Remove empty attributes |Remove empty attributes
Select All
Unselect All

Information in this panel:
Information Description
Use namespaces Default choice is ON. Manage namespaces.
Scripts List of scripts that can be executed.
Select All Select all the scripts.
Unselect All Unselect all the scripts
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After the start of the operation, in the main window a navigation box appears. The fragments found
in the input file are accessible directly with a random access using the information collected in the
previous phases. If you choose to split the file in fragments, you can examine them in the extraction

directory.

© Extract Fragments from a XML File

Parameters

Source file path: testxml

Split documents using this path  /site/items/item

e Extract all the documents

Extract a range from: to:

Extraction

Extract in the following directory: |/output

A
v

V| Make subfolders each: 100 files

Subfolder name pattern = %timestamp% v

File name pattern = %counter% v

v/| Extract documents (or scan the file and broswe the single documents)

Speed up the processing. No informations will be shown in the user interface.

e.g.: /element/child

View in browser

%counter% v

Elements enclosed between '%' characters are system fields

Folder names are like:'1320570825203_1', files like: 1" xml

¥ 0K @ cancel

lllustration 1: The Extraction Panel

Information in this panel:

Information

Description

Extract documents (or scan the file and browse
the single documents)

If selected the fragments found in the input file will be
written to files as XML documents, one per fragment

Speed up the processing. No information will be
shown in the user interface.

If selected, the extraction process will be faster, but after
the extraction, it will not possible to browse the input file
fragments in real time using the user interface.

Use it if you need the output files only.

Source file path

The path of the input file

Split documents using this path

The XPath used to find the XML fragments in the input file.
The path must be entered using a syntax like this:

/root/element/element

Split using the depth

Use the depth of the element as criterion. Root element
has depth one. Note: the elements will be extracted
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Information

Description

independently from their tag.

Extract all the documents

If selected causes the extraction of all the documents
found in the input file.

Extract a range

If selected, only the documents that fall in the specified
range will be extracted.

Extract in the following directory

The destination directory for the fragments.

Make subfolders

With this option the extracted files are created in a
subdirectory when their number exceeds the configured
threshold. Use it when the input file contains thousand of
fragments that will make impossible the browse of the
destination directory if all the files are in a single place.

Subfolder name pattern

The naming to assign to the subdirectories created in the
extraction process.

You can use a predefined token that will be expanded at
run time or any other thing you like.

File name pattern

The naming to assign to the files created in the extraction
process. The files will have a '.xml' suffix automatically
apposed.

You can use a predefined token that will be expanded at
run time or any other thing you like.

Advanced

Open the advanced options dialog.

Token that can be used in the name pattern section:

Information Description Example Output
%counter% The counter of the object created. This is an 1

unique number that can be used to identify the

object
"udate%" The current date in the YYYY_MM_DD format 2011_10_07
"%time%" The current time in HH_MM_SS_millis format 10_43_30_560
"%timestamp%" The current date and time in a numeric format 123456789
"%space%" A blank space used a separator wn

Since 0.6 version.

There is a plugin to generate Flex code from Balsamiq mockup program source. You can choose a
set of source files that will be transformed to a Flex application in the output directory.

Only a subset of Balsamiq controls are supported, controls not supported are converted to

mx:Label

List of supported controls:

e Button

* Label

* LinkBar
+ DataGrid
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e List

* TabBar

* Vrule

* Hrule

*  Textlnput

+ ComboBox
* TextArea

* Paragraph

* CheckBox

* RadioButton

e Tree

‘Warning: only a subset of Balsamig objects are supported

Files to translate

homelbelideveligxmledit fxmledt Ampimytube bmml
homelbelideveligxmleditfgxmledit Ampiownce bmml
homelbelideveligxmleditixmledit Ampiribbonla brmml
homelbelideveligxmleditigxmledt Amp/Comments_List bmml
homelbelideveligxmleditigxmledittmp/BlogEngine bmml
homelbelideveligxmleditigxmledittmptres_table bmml

| Dverwrite files
Qutput directory:

F.l'holnenbeIIIdexrel.l’qxmleditnna\ren-ﬂexJ‘provaI&rcnnainIﬂex

Open destination directory

Lo Apply 6 Close

Sessions are information about a set of files and access dates, related to a work or an activity than
can be recalled if needed. A file can be shared among different sessions, with different accesses.
The sessions can automatically collect information of the files that the program access. Only one
session can be active at time and there is no need to have a session active for QXmlEdit to work.

A session can be active (collecting information), paused or closed.

When sessions are active, there is the possibility to view the most used or recent files or folders in a
list in the main view.

In the main menu the following commands are available:
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Command Information

New Creates a new session. The current one, if existing, is closed.

Pause Pauses the current session when active. Paused sessions does not collect information.
Resume Resumes a paused session.

Close Closes the current session. No session is active, then.

Details Opens a dialog with information on the current session.

Manage Opens a dialog where have information about all the sessions.

The session panel can be shown or hidden using the toolbar button or the command in the View
menu.

The following lists are shown:

* Recent: the most recent files accessed in the session. Double clicking a file opens it in the
editor.

* Most used: the most used files of the session. Double clicking a file opens it in the editor.

* Most recent folders: the most recently used folders containing session related files.
Double clicking a folder entry shows the open file dialog on that folder.

_ QxmlEdit - thamellbellrdeve /qxm| editixs ditesud ataixsdroracle xml X [)
File Edit Bookmarks XML Navigation View Sessions Tools Help
? 7| & & i | /. B
S?]OV\[;O" hide search.. € Elements :#Ch. : Size © Attributes iText p| encoding:UTF8
the browser " )
% *Processing Instructi. xml{version="1.0")
Recents v~ . birthdate 3(3) 75 @
oracle.xml (1)
test_mixed.xml (1) month 0(0) 22 January v
day 0(0) 13 21 )
Most used year 0(0) 17 1983
oracle.xml (1)
sl () Clicking on the files

opens them in the editor
Most recent folders
" /home/lbell/devel/qxmledit/xs...

L L B LEHREERE] /home/Ibell/devel/qxmledit/xsd/test/data/xsd
last access: mercoledi 29 febbraio 2012 21:43:13 CEST

browser
e

— Clicking on the folder,
opens it in the open file dialog

More... | o B

N h
o schema o
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In this dialog you can view the sessions list. From here you can activate a session or manage
sessions, creating, deleting or editing them. When a session is selected, its accesses and files are
shown in the lower half of the dialog. The list of files can be copied in the clipboard. Double clicking
on afile loads it in the editor.

The following commands are available:

Command Information
Activate Activates the selected session, closing automatically the current one, if any.
New Creates a new session.
Edit Opens the session detail dialog of the currently selected session.
Delete Delete the currently selected session.
Edit file Loads in the editor the file selected in the lower pane.
Export file data Put in the clipboard the path of the files.
& - -SHERGERE o0 O
Session list
Id: Name ¢ Description Created ¢ Last Access Count | Activate

1 [ I I I 1o New...

2 4 |Session two 27/02/12 20:17 4] Edit...

3 3 |three 21/02/12 22:13 4] Delete

4 2 |uno 20/02/12 21:18 4]

Name: one Description: the first session

Files || Accesses

Path A~ Description Count
/home/Ibell/Desktop/test xml/test_mixed.xml| 1
[home/lbell/devel/gxmledit/xsd/test/data/xsd/oracle.xml 1

Edit file Export file data

@ Close

In this dialog you can set the session properties and examine its accesses to files. The name and the
description of a session can be changed and saved.
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e B Detal o0 o

Name: one

Description: | test on xsd

Last access: 29/02/12 21:42

Files | Accesses

Path Al Date

/home/lbell/devel/qxmledit/xsd/test/data/xsd/oracle.xml 29/02/12 21:43

Edit file Export file data

¥ 0K @ cancel

You can set or change the session name and description. The list of files can be copied in the
clipboard. Double clicking on a file loads it in the editor.

Sessions data are stored in the user data folder as indicated by the operating system using a sqlite
database file. To reduce sessions data file dimensions use the configuration dialog. The cleaning
procedure operates as follows:

* Completely erase the data.

¢ Erase sessions data on date criteria.

The following table explains in detail the options:

Option Operation
Delete all sessions data Completely erase the sessions data.
Delete data older than... Delete the data older than the specified date. The data are deleted as follows:

- all the accesses to a file registration older than the specified date.

- all the sessions that have last access date older than the specified date and
have no access data.

If the delete files information is selected, the files information without
access data are deleted. The file themselves are not altered, the operation is
done only on session registration inside QXmlEdit.
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Administraton
+'| Enable session management
Delete sessions data

*  Delete data older than one month
__ Delete data older than six months
_ Delete data older than the specified date | 01/01/00 v
__| Delete information on files (the files will not be touched)

Delete sessions data

Delete all sessions data

The session configuration panel allows to enable or disable session handling. There is the
possibility to clean session data as explained in details in the paragraph “Managing sessions data”.

Use the Visualization feature to graphically visualize the composition or the structure of an XML
file. The file can be view as a map; only the summary data are loaded in the program main memory,
so the consumed memory is of the order of magnitude of the data itself.

The data that can be shown are:
1. Size:size of the elements, attributes and text nodes.
2. Elements: number of children elements.
3. Attributes: number of attributes.
4. Structure:the data can be split on their depth from the root.

5. Payload:the size of the text nodes children of the elements.

The data values can be cumulative or relative. The cumulative measuring shows the sum of the

quantity associated with a given element and all its children. This kind of measurement gives an

idea of how the hierarchy is structured. The non cumulative measurement spots what elements
have the most relevant values.

The data relevance is underlined using a color map, shown in the dialog itself.
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User Interface

Load XML file Options for Calucation Measure type
» o XML Data visualization (IRt
File: |ﬁmmﬂbellmemomm xmlfstandard_smallxml Load... Loudness: | Nome v | Slice at level: 2 v || | Cumulative values  View as: M
|- Measure Data
1 Fragments 1
2 Size 7148
3 |Levels 1
4 Elements 9 |
Data Map 5 | Attributes 20 |
6 | Payload 6729 I
7 Max attributes 1
8 |Max children 16 :|
9  Max size 1140 |
10 MaxPayload | 1130
Zoom: 1 L= 100 Export Stats...| | Extract fragment..| [ ] 3D [¥] Grid [ ] Points Analyze relations | View Relations | Colormap: [l ][ change.
[ Close
Zoom . Color Map
Numeric values

To access to the Visualization use:
1. The welcome dialog.
2. The Tools > View Data menu.
The operation sequence is as follows:
1. Load afile using the Load file... button.
Choose the measurement type from the View as combo box.
Select the Cumulative values if you want to display cumulative values.
The data are now show.

Select the zoom level.

o v AW

Explore data hovering with the mouse on the interest points, a tool tip will appear.
7. Use the context menu (right mouse button) to export data.

Checking the “Analyze relations” button will give access to the relations explorer dialog.
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If @QXmlEdit is compiled with 3D support, a 3D view can be enabled using “3D" check box.

» o

Zoom: 1 L/ 10

File: | /home/lbell/Desktop/test xml/standard_very_small. xml

—

Load..

XML Data visualization

e
3 50 55
‘15%00 5 10 15 20 25 30 38 40 45 rnws?&)

|Export Stats...l Extract fragment... | /| 3D || Grid

Loudness: ‘None - | Slice at level: | 2 -

70 75 80 85 90 95 100

Points

The available options are:

-

+| Analyze relations | View Relations... | Color map: I

Cumulative values  View as:

Measure

@y
Size -

Data

Fragments
Size

Levels
Elements
Attributes
Payload

Max attributes
Max children
Max size

Max Payload

EEEFFFFEELDEF

32340

312

54

22653

2

16

1943

1799

Il Change.. ‘

| Close ‘

Command Information
Grid Show a grid in the back walls.
Points Show only points, do not draw surfaces.

The following measurement types are available:

The size is the size in bytes of the element, its attributes and its text nodes. The cumulative
measurement is the sum of the size of the element and allits children. The root element in the
cumulative mode has the maximum size of all the tree.

To activate the size measurement select Size in the View As combo box.

Note: the calculated size can differ from the physical file because when the data are loaded, the
formatting is discarded.

The payload size is the size in bytes of the text nodes children of an element. The cumulative
measurement is the sum of the payload size of the element and all its children. The root element in
the cumulative mode has the maximum size of all the tree.
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To activate the size measurement select Payload in the View As combo box.

The attributes counting is the number of the attributes of each element. The cumulative
measurement is the sum of the number of the attributes of the element and all its children. The
root element in the cumulative mode has the maximum total of all the tree.

To activate the attributes count measurement select Attributes in the View As combo box.

The children element counting is the number of the children of each element. The cumulative
measurement is the sum of the number of the children of the element and all its children. The root
element in the cumulative mode has the maximum total of all the tree.

To activate the elements count measurement select Elements in the View As combo box.

The structure view shows how the elements are divided in blocks using the depth from the root
information independently from the element tag. It shows the relative width of each element at a
given level. There is no cumulative option.

To activate the structure measurement select Structure in the View As combo box.

To change the depth level, use Slice At Level combo box.

The map exposes the following features in the contextual menu or with mouse hovering.

Command Information

Copy Data to Clipboard Copies the current measurement data, relative to the portion of the visible map to
the clipboard. The data consist of an header and the values ordered by row.

Extract this fragment Opens the extraction dialog with depth and fragment numbers information relative
to the current point.

Copy Path to the Clipboard Inserts into the clipboard the current element XML path.

Show current element Implemented as a tool tip that appears hovering with the mouse on a point of the

information map.

The relations panel shows in graphical form and using a table, the relationship between the nodes.

Graphic view: show the elements existing in the file and their relationships. The elements that
are in relation father-child are connected by a line.

The elements are disposed on the canvas in random position at each invocation. The nodes are
subject to a repulsive force and tend to be distribute evenly in the view.
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Data view: show a table of nodes and the number and the type of connected elements.

File: fhome/lbell/Desktop/test xml/standard_small.xml

Graphic view | Data view l

|| Center selected

Options:

Panel Option Description

Force Force The value of the repulsive force between the nodes.
Force Radius The effective radius of the force.

Spring Length The length of the spring.

Reset Reset the position of the nodes.

Zoom Zoom in Execute a zoom in

Zoom Zoom 1:1 Restore the view to the default size.

Zoom Zoom out Executes a zoom out

The relation panel can be accessed in the following modes:
* To show the data relative to the file loaded in the editor: View->View Relations...
* To show the data relative to a file: Tools->Relations...

* To show the data in the map view: check “Analyze relations”, load a file then "“View
relations”
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In the same panelin the “Attributes View” tab a detail of the attributes is shown. The allowed
options are:

Option Description

Load Whitelist Load a whitelist of attributes XPATH.
Load Blacklist Load a blacklist of attributes XPATH.
Reset Lists Clear whitelist and blacklist.

The behavior is as follows:
+ ifthereis no whitelist and no blacklist all the attributes are included in the same summary,

» ifthereis a whitelist only, the attributes in the whitelist are grouped together and the
remaining form another group,

» ifthereis a blacklist only, the attributes non in the blacklist are grouped,

» ifthereis a blacklist and a whitelist, the attributes in the whitelist form a group, then all the
other attributes non in the blacklist are added to the group.

This operation allows to test an XML file without opening it in the editor and can be used to test for
XML syntax errors in huge files.

To access this operation:
Menu > Tools > Test XML

A file choosing panel will let you select the file to be tested. At the end of the operation a
report will be shown.

This dialog permits to encode and decode text from and to base 64 coding, using one of the
common character encodings.

To access Base 64 Explorer:
Menu > Tools > Base 64 Tools...
* Toencode text in base 64:
o Write text into the “text” panel. The base 64 coding will appear in the base 64 panel.
* Todecode from base 64:
o Choose an encoding using the “encoding” combo box.

o Write or paste the base 64 coded text in the “Base 64" panel. The text will
automatically appear using the selected encoding.
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This dialog will permit to see how the text is transformed from unicode to different encodings.

To access the dialog:

Menu > Tools > Encoding Tools...

To explore how a string will be coded in different encodings:
1. Select the tab “String Explorer”.
2. Write the text into the Source Text box.

The encoded text will be displayed in the grid, character by character along its Unicode

value.

)i - Encoding Explorer

Sourcetext: | 4

String Explorer Character Explorer Chains Explorer Character Info

Show how the source text is encoded using different codecs. You can add or remove encodings
1 2 3 4
Source text a (LATIN SMALL LETTER A} | b (LATIN SMALL LETTER B ) | c (LATIN SMALL LETTER C ) | d (LATIN SMALL LETTER D )

Unicode value 0061 00062 00063 00064
150-8859-15 1: 061 1: 062 1: 0263 1: Ox64
windows-1250 1: 0x61 1: 0x62 1: 0x63 1: Ox6d
windows-1251 1: Ox61 1: 062 1: 0x63 1: Ox64
windows-1252 1: 061 1: 0m62 1: 0x63 1: Oxéd
UTF-8 1: 0x61 1: Ox62 1: 0x63 1: Ox64
Add an encoding: | Adobe-Standard-Encoding - Add
v| Hexadecimal numeric values || Show character names Code Pages Detail...

To add an encoding to the grid:

SN S

Paste here the text
to be examined

4

Remove

Add encodings to the table selecting an encoding from
the combo, then triggering "Add".

Close

* Select an encoding in the encoding combo box, then trigger add button.

To remove an encoding:
* Select the encoding row, then press Remove button.
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You can insert numeric values and examine how they are interpreted by different encoding.

To access this feature:

* Select the “Character Explorer” tab.

X -

Source text:

String Explorer Character Explorer

Insert numeric values and see how they are interpreted using different encodings.

Chains Explorer

Encoding Explorer

Character Info

&«

2l 2
LR e

Paste here the text
to be examined

Sample: Oxé1 98 99 (b4

Hexadecirmal values are prefixed by Ox, octals by 0, use a space as separator

Numeric values: |Oxa3 Oxad Oxad {Ix36|

| | Sequence 128.255

Textual representation in different encodings:

i

ISO-8B59-15

UTF-8

windows-1250
windows-1251

windows-1252

£2¥8
LoA]
=
Fo¥!

GOvw

This feature uses the encodings defined in the "String Explorer” tab.

V| Hexadecimal numeric values

v| Show character names

Code Pages Detail ..

Close %

Insert the numeric values in the input box, using the prefix “0x” for hexadecimal numbers, “0"” for

octal.

To add or remove encodings, use the “String Explorer” tab.

Use “Sequence” button to insert a sequence of 128-255 characters; if you press the Control key
with the “Sequence” button, the characters from range 32-127 will be inserted.
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Explore how a string will be translated when written in some encoding
and read in another one

Select the Chains Explorer tab, select an encoding (up to three are available), then write the string
into source text box.

The grid will show the string transformation up to three steps.

asdéé
0Ox61, 0x73, 0x64, Oxe8, Oxe8

asd@

0x61, 0x73, 0x64, Oxef, Oxbf, Oxbd

asddz™
0x61, 0x73, Ox64, Oxef, Oxbf, Oxbd
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Get information about a character

Select the Character Info tab, select a character using one of the methods:
* Literal character typed in a box.
* Unicode code point written in decimal or hexadecimal.
* Avalue of a given encoding.

You can change the character display using the “Change Font” button.

Ox20ac

Symbol_Currency ( informative Sc)

<unknown>

isPrint

is Symbol
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Using the menu “Tools"” > "Code Pages" you can open the code page explorer where you can
examine the code pages supported by QXmlEdit.

The possible operations are:

Change the encoding using the “Encoding” combo box.

Search a character using:

The literal value.

The Unicode code point.

The search result will be highlighted in the table and reported in a box.

Option for display of the characters:

Show the UTF-8 encoding.

Show the Unicode name of the character.

Show the value of the character.

» o Code Pages [ORONCIE]
&’ Encoding: | windows-1252 A4 ‘ { Close
0x01 002 0x03 0x04 005 [<]
1(0x1) 2 (0x2) 3 (0x3) 4 (0ed) 3 (0x5)
000 Uex1 Ux2 U3 Usxd U:x5
<control> START OF HEADING <control> START OF TEXT <control> END OF TEXT <control> END OF TRANSMISSION <control> ENQUIRY <cq
001 002 0x03 0x04 0x05
17 (0x11) 18 (0x12) 19 (0x13) 20 (0x14) 21 (0x15)
10 Uix11 Uix12 Ux13 Uix14 Uix15
<control> DEVICE CONTROL ONE | <control> DEVICE CONTROL TWO <control> DEVICE CONTROL <control> DEVICE CONTROL FOUR <control> NEGATIVE <cont|
011 0x12 THREE Ox14 ACKNOWLEDGE
! " oy 5 o
33 (0x21) 34(0x22) 35 (0x23) 36 (0x24) 37 (0x25)
0x20 Uzl 22 23 Ux24 Ux25
EXCLAMATION MARK QUOTATION MARK NUMBER SIGN DOLLAR SIGN PERCENT SIGN Options
0x21 22 023 0x24 0x25
1 2 3 4 5 (=]
49 (0x31) 50 (0x32) 51 (0x33) 52 (0x34) 53 (0x35) Value
030 Unx31 Ux32 Ux33 Ux34 U35
DIGIT ONE DIGIT TWO DIGIT THREE DIGIT FOUR DIGIT FIVE Name
0x31 32 033 34 035
A B C D E
65 (0x41) 66 (0x42) &7 (0x43) 68 (0x44) &9 (Dx45)
0x40 Unxdl Uxd2 Uxd3 Ux44 U:x45
LATIN CAPITAL LETTER A LATIN CAPITAL LETTER B LATIN CAPITAL LETTER € LATIN CAFITAL LETTER D LATIN CAFITAL LETTER E L4
0x41 42 0x43 Dxd4 0x45
R S T ]
81 (x51) 82 (0x52) 83 (0x53) 84 (0x54) 85 (0x55)
x50 Ux51 U:x52 Ux53 Ux54 U:x55 Seacha chasacier
LATIN CAFITAL LETTER @ LATIN CAPITAL LETTER R LATIN CAPITAL LETTER 5 LATIN CAPITAL LETTER T LATIN CAFITAL LETTER U L4
052 054 055 P
b [4 d e ’7|
98 (0x62) 99 (0x63) 100 (0x64) 101 (0x65) |
Un62 Un63 Ux64 U6 o e e ]
LATIN SMALL LETTER B LATIN SMALL LETTER C LATIN SMALL LETTER D LATIN SMALL LETTER E 13 -
062 0x63 Ox64 065 [ |
q r s t u Search result:
113 (0x71) 114 (0x72) 115 (0x73) 116 (0x74) 117 (0x75) 3
070 Ux71 72 Ux73 Ux74 Ux75
LATIN SMALL LETTER Q@ LATIN SMALL LETTER R LATIN SMALL LETTER 5 LATIN SMALL LETTERT LATIN SMALL LETTER U ¥ Position:97 (61)
071 0x72 073 074 075 Uni :M1
£ - Name:LATIN SMALL LETTER A
4] | I*
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The compare operation is started loading a XML Schema file, then selecting the menu operation.
After the compare a window will open, showing the elements with different colors depending on
their state. The comparison can be done taking into account the annotations or not. Even the single
items of restriction enumerators values are shown.

To start the compare operation:
Menu > File > Compare XSD...

Options available: exchange source and reference and compare annotations or not.

Roat w =
__|namespacePrefix="xs"

|_|Elements=qualified
Attributes=unqualified

hameilbellideveligxmleditxsditest/datalsd/difiitLxsd

e ©

namespace: test strmg)
namespace: http://www.w3.0org/2001/XMLSchema

Enumeration:

+ "four” (Deleted)

—‘@rsaa simpie '
—‘ﬂ Extension of 'xs:string'

£ 4 & & L & 4 & & L & & &8 L KA a L

Compare Summary

Reference: /home/lbell/devel/qxmledit/xsd/test/d:
Target: /home/lbell/devel/qxmledit/xsd/test/d:

\—‘ Extension of 'xs'string’
—‘@rsma simple '

Type |Name = \—i Extension of xs:string’
+ |Added
+ Modified @rsd, — '
restriction —‘ﬂl
extension
union
element xxx3
element X000 rsa
notation d =
3l s ‘ LIJ Simple type restriction (xs:string)

Double click on an item to select it in the diagram

Enumeration:

=l
Compare

Legend: Equals M Deleted  Different ¥ Added d B Close

W Compare annctations

EIRIESENENEN

Legend: . Choice 4= Sequence ® Type CE) Element & Attribute

Tools menu

Items, with different colors depending on state
Differences report
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Using the menu Tools > Binary files viewer you can view the raw data of a file. The data can be
decoded in text using one of the supported encoding, but each row of 16 bites is decoded
separately. The input file is divided in pages to not overloading the memory. In this panel you can:

* View the raw data using a text encoding.

* Search text using the selected encoding .

* Goto an offset into the file.

» G

Binary files viewar

| fmnt/ramdisk/nonamespace.xsd

- ||| chivi

File information

140 &0 70 &C 65 78 54 79 70 &5 3E

3C 3F 78 6D 6C 2@ 76 &5 72 73 69 6F &E 3D 22 31

1]
ZE 30 22 20 &5 &E 63 &F 64 69 6E 67 3D 22 75 74 |.0" encoding="ut
32 66 2D 38 22

144 30 22 61 22 3E OA 20 20 20 20 3C 78 73 3A 63 &F |="a">.

<?xmlL wersion="1

3F 3E @A 3C &8 65 6D | f-B"?>.<xs:schem

Raw value
48 &1 20 45 &6C &5 &D &5 44 A5 &4 |a elementFormDef
&4 &1 T5 &C 74 3D 22 71 75 &1 &C &9 &6 69 &5 &4 22 |ault="gualified"
80 20 78 4D &6C 6E 73 3A T8 T3 3D 22 68 74 T4 T0 3A xmlns:xs="http:
L 2F 2F 77 77 77 2E 77 33 2E &4F 72 &7 2F 32 30 30 S fwvwi.w3.org/f200

112 31 2F 5B 4D 4C 53 &3 &8 &5 &D &1 22 3E 0A 20 20 |[1/XMLSchema"=.

128 3C 78 73 3A 65 6C 65 6D 65 6E 74 20 6E 61 6D 65 |<xs:element name

=HSICO

lexType>.

Search box _

Size: 313 bytes Last updated on: 2:25:35 CET Encoding: | 150-8855-15 - |
Page L of 1 @\ P
Search: | | Previous Next
Offset Binary values Characters ]

Select encoding

Jump to offset

|

/

I Warning: the character representation
=

T

Go to address:

isleading if the selected encoding is not B bit.

V | ] Hexadecimal value
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QXmlEdit can be started with the following arguments:

Option Operation
-vis <file> Opens the data visualization panel
-anonymize <inputfile> <profile> <outputfile> Anonymizes a file and exit

-xslt [-saxon] -xsl=<xslFile> -output=<outputfile> Executes XSL transformation and exit.

{-p<name>=<value>}* <inputfile> Parameters can be supplied using the ‘-p’
options.

any other argument is used as a file to open.
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The single application mode is enabled by default, but can be disabled using an option in the
Options panel.

It consists in opening a local server when starting, After that, if a command line argument is used
by the shell (e.g. the “Open With"” in Windows Exlporer), the arguments are sent to the existing
instance via the local socket.

This section describes the structure of a style file.

A style file is an XML file with the following structure:

Tag name Attributes Child elements
style: *  “name” style name as shown in the *  "keywords”
user interface o styles”
*  "description”: a description o ids"
*  “namespace”: an optional namespace

This element is simply a collection of “style” elements plus one optional “default” that will be used
as default style, if existing.

It contains one “style” element.

Tag name Attributes Child elements
style *  "id" unique identifier of the style. It is
astring
*  "“color”: hexadecimal representation

of a color used to paint the text.
Example: “FFO000"

*  "backColor": optional, the background
color in hexadecimal format with
optional alpha at the end.

Example: FFOO0O or FFO00080
o “family”: font family if different from

default.

+  size":font size if different from
default.

e "bold"” set to 'true' or a numeric value

different from zero to force bold style
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on font
*  "jtalic": same of bold, but for italic
style
The only mandatory attribute is id, the others
are activated if set.

This element is simply a collection of “keyword” and “rule” elements

A keyword, with associated style. Each element tag in the data file that is enrolled in this section
will be printed with the indicated style

*  "idStyle": the identifier of the
associated style

Tag name Attributes Child elements
keyword o "keyword" the name of the element to
mark

Contains a set of “rule” and “ruleSet” using implicit AND connector

Tag name attributes Child elements
ruleSet *  “connector” the connector of the “rule”, “ruleSet”

children

o and (default)

o or

*  "idStyle": for a top level rule identify

the style to be used
Tag name attributes Child elements
rule *  "“entity”: denotes and attribute oran | none

element, default: attribute
o attribute
o element
e "name”: if attribute, the name of the
attribute or element
* "“op":denotes the comparison
operator
EQ: equals
NE: not equals
EX: value exists
NX: value non existent
GT: greater than
LT: less than
GE: greater or equal

O O O O O o O
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o LE:less orequal
o SS:substring (string only)
o ST:starts with (string only)

*  "type”: type of comparison, optional,
default: string
o s:string
©  n:number
°o  p:position

*  ‘“value”: the comparison value. If
position, the value should be:
©  numeric
o first (literal)

o last (literal)

* ‘“case”: if the comparisons take the
case of the strings into account,
default: true
©  true: case sensitive
o false: not case sensitive

This element is simply a collection of “id"” elements

This element contains the name of attributes whose content will be printed next to element tag

Tag name attributes Child elements
id *  "id" name of the attribute that is
considered as an identifier.
+  "alpha”: if true, force the enclosing of
the value between quotes.

This is a complete sample style file:

<?xml version="1.0" encoding="UTF-8"7?>
<!-- this is a sample QXmlEdit style file -->
<style name="Log" description="1log test style">

<keywords>
<keyword keyword="resource" idStyle="1"/>
<ruleSet idStyle="2">
<ruleSet connector="and">
<rule entity="element" op="eq" type="s" value="event"/>
<rule entity="attribute" name="level" op="eq" type="s" value="fatal" case="false" />
</ruleSet>
</ruleSet>
<ruleSet idStyle="3">
<ruleSet connector="or">
<rule name="level" op="eq" type="s" value="ERROR" />
<ruleSet connector="and">
<rule entity="attribute" name="level" op="eq" type="s" value="INF0" case="true" />
<rule name="pri" op="gt" type="n" value="12"/>
</ruleSet>
</ruleSet>
</ruleSet>
<ruleSet idStyle="4">
<rule name="level" op="eq" value="WARNING" case="true" />
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</ruleSet>
<ruleSet idStyle="5">
<rule name="level" op="eq" type="s" value="INF0" case="true" />
</ruleSet>
</keywords>

<styles>

<style id="1" color="2080FF" />

<!-- fatal -->

<style id="2" color="FFO000" size="12" family="Arial" bold="true" italic="false" icon=":E:" />
<!-- error -->

<style id="3" color="FF4080" size="10" family="Arial" bold="true" italic="false" icon=":E:"/>
<!-- warning -->

<style id="4" color="C0C080" size="10" family="Arial" bold="false" italic="false" icon=":W:"/>
<!-- info -->

<style id="5" color="000000" size="8" family="Arial" bold="false" italic="true" icon=":I:"/>
<default>

<style id="default" color="C0OCOCO" size="8" family="Arial" bold="false" italic="true"/>

</default>

</styles>

<ids>

<id id="name" alpha="true"/>

<id id="1id" alpha=""/>

</1ids>

</style>

Given that styles are so simple, they can be created by the user with a simple text editor. Styles are
searched in a directory configured via 'Configure...' menu.

QXmlEdit user manual, page 118 of 118.



	Contents
	Welcome to QXmlEdit
	View and Navigate XML Data in Unusual Modes
	Information About QXmlEdit
	Before You Begin
	What You Will Learn
	Finding Out More
	What's New in This Version

	Overview of QXmlEdit User Interface
	Operation with XML
	Startup
	Main Functionality
	Working with XML Files
	Opening Files
	Opening Files in New or Same Window
	Using only One Window or One Window per File
	Saving files
	Creating a File From Clipboard Contents
	Creating specialized files
	Reloading last saved version
	Loading a sample of a document
	Exporting the XML
	Avoiding modifications
	Loading the Last Edited Files
	Working With Preferred Directories
	Viewing Elements and Attributes
	Filtering Attributes

	Working with name spaces and prefixes
	Prefix operations
	Assigning a prefix
	Removing a prefix
	Replacing a prefix

	Namespace operations
	Assigning a namespace
	Removing a namespace
	Replacing a namespace
	Normalizing a namespace

	Choosing an Editing Mode
	Using XSLT Edit Mode
	Specific display style
	Specific edit panels
	A specific context menu
	Navigate templates and functions

	Using SCXML Edit Mode
	Specific display style
	Specific edit panels
	Navigate states


	XML Schema management
	Inserting XML Schema References
	Using the XSD Edit Mode
	Editing or inserting a type, attribute or element

	Edit an annotation
	Single annotation panel
	Annotation list edit panel

	Editing Enumeration or Facets
	Edit facet panel

	This panel edits a single facet item.
	Editing XML Schema Attributes
	Inserting the Schema Instance “nil” Attribute
	Removing the Schema Instance “nil” Attribute
	Inserting the Schema Instance “type” Attribute
	Removing the Schema Instance “type” Attribute

	XML From XSD and Vice-Versa
	One-time Configuration

	Help and information
	Show keyboard shortcuts

	Tasks
	Adjust Display Detail

	Preferences
	General
	Style
	Editor colors
	Validation
	Sessions
	Edit Modes
	XML

	Customization
	Choosing a Display Style

	Operations
	Editing Elements
	Navigating Elements
	Editing Elements and Attributes
	Searching text

	Deleting siblings
	Copying Selected Text Into the Clipboard
	Namespaces
	Using the Bookmarks
	Viewing and editing info and DTD
	Working with Base64 Coded Content
	Working With Inner XML Content
	Inserting an XML prolog on document creation
	Formatting a document
	Formatting Presets

	Validating an XML Document
	Counting Children Elements and Measuring Their Size
	Finding Text
	Search results

	XPath syntax
	Search results

	Browsing the search results
	Replacing text
	Replace panel

	Comparing Files
	Loading data sample
	Limitations

	Anonymizing data
	Data and business rules
	Options
	Configuring the anonymization
	Format of the CSV for importing and exporting the exceptions

	Anonymizing a file
	Filling data
	Cloning Elements
	This picture shows the result of the clone operation with the insert of an index using the “id” attribute:
	Working with Snippets


	Executing XSL style sheet
	XSLT Execution panel

	Metadata
	Introduction
	Metadata types
	Updatable Metadata
	Static metadata

	Metadata implementation
	Operation
	Creating a document
	Reading a document
	Saving a document
	Editing metadata

	Metadata summary
	Updatable Metadata
	Static Metadata

	Editing metadata

	Working With XML Schema Files (XSD)
	Visualization Types
	Changing the background color and pattern.
	Exporting XSD Graphical view
	Working With Big XML Files
	Searching in Files and counting elements
	Split an XML file
	Decide if you want to extract information or browse it
	Choose the file and how to fragment it
	Limit the extracted fragments number
	Decide the output folder and the naming
	Advanced Options
	Go and examine data

	Flex Code Generation From Balsamiq Source
	Life With Sessions
	The session user interface
	Sessions Management Dialog
	Session Properties
	Managing sessions data
	Sessions configuration

	Viewing data
	User Interface
	3D Visualization
	Measurement types
	Size
	Payload size
	Attributes count
	Children Elements count
	Structure

	Commands available in the contextual menu of the map

	Visualize Relationship
	Attributes summary

	Testing XML Files
	Base 64 Explorer
	Encoding tools
	Explore how a string will be coded in a specific encoding
	Explore how binary values are recognized by different encoding
	Explore how a string will be translated when written in some encoding and read in another one


	Get information about a character
	Code Pages explorer
	Visually Comparing XML Schema files
	Binary files viewer
	Command Line arguments
	Appendix
	Note on “Single Application” Mode
	Style file format
	Root Tag:
	Element “styles”
	Element “default”
	Element “style”
	Element “keywords”
	Element “keyword”
	Element “ruleSet”
	Element “rule” (inner)
	Element “ids”
	Element “id”
	Installation of new styles



