Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libqt4-x11-4.8.7-lp152.9.6 RPM for x86_64

From OpenSuSE Leap 15.2 for x86_64

Name: libqt4-x11 Distribution: openSUSE Leap 15.2
Version: 4.8.7 Vendor: openSUSE
Release: lp152.9.6 Build date: Thu Oct 24 06:29:24 2019
Group: Development/Libraries/C and C++ Build host: cloud103
Size: 32896172 Source RPM: libqt4-4.8.7-lp152.9.6.src.rpm
Packager: https://bugs.opensuse.org
Url: http://qt.digia.com
Summary: Qt 4 GUI related libraries
Qt 4 libraries which are used for drawing widgets and OpenGL items.

Provides

Requires

License

GPL-3.0-only OR SUSE-LGPL-2.1-with-digia-exception-1.1

Changelog

* Mon Feb 26 2018 fabian@ritter-vogt.de
  - Actually clean up openssl BuildReq: use pkgconfig(openssl)
* Wed Feb 21 2018 vcizek@suse.com
  - Clean up openssl BuildRequires
* Thu Feb 15 2018 crrodriguez@opensuse.org
  - Do not use xorg-x11-devel metapackage, instead use individual
    libraries.
  - libqt4-devel Requires have been adjusted to require all X11
    libs which were used for build, none of them are actually
    required but remain there in order not to break hundreds
    of packages that may have counted on xorg-x11-devel being
    pulled.
* Tue Dec 26 2017 fabian@ritter-vogt.de
  - Change fix-build-icu59.patch to build qlocale_icu.cpp with
    - std=c++11 to support ICU60 headers
* Wed Dec 06 2017 fabian@ritter-vogt.de
  - Add proper patch headers to:
    * no-ssl3.patch
    * qt4-openssl-1.1.0pre-3.patch
  - Remove patch, not needed:
    * qt-everywhere-opensource-src-4.8.7-gcc7.patch
* Tue Dec 05 2017 ro@suse.de
  - add patches from mageia to fix build with openssl-1.1
  - add no-ssl3.patch
  - add qt4-openssl-1.1.0pre-3.patch
  - add qt-everywhere-opensource-src-4.8.7-openssl.patch
  - add qt-everywhere-opensource-src-4.8.7-gcc7.patch
* Sun Sep 10 2017 dimstar@opensuse.org
  - BuildRequire libnsl-devel on current TW and CODE15 targets. The
    library has been deprecated in glibc and is now in an own
    package.
* Mon Sep 04 2017 cornelis@solcon.nl
  - Add fix-medium-font.diff (taken from ubuntu) to fix bolder font
    in Qt4 apps (boo#956357)
* Thu Aug 24 2017 fvogt@suse.com
  - Force building against openSSL 1.0 (boo#1042657)
  - Do not build the MySQL plugin on TW, it would cause an openSSL
    version conflict
  - Adjust fix-build-icu59.patch to also work if built with c++11
    support
* Wed May 10 2017 fabian@ritter-vogt.de
  - Add fix-build-icu59.patch to fix building with ICU4C >= 59
  - Invoke configure with sh to fix build on some older distros
* Fri Feb 10 2017 alarrosa@suse.com
  - Add fix-moc-parsing-with-glibc-2.25.patch to fix moc parsing
    system headers from glibc 2.25 correctly.
* Fri Jun 24 2016 lbeltrame@kde.org
  - Add fix-gcc6-detection.diff to fix GCC6 detection (boo#986350)
* Thu Jun 02 2016 matwey.kornilov@gmail.com
  - Enable libqt4-devel-32bit to fix boo#982826
* Thu Feb 11 2016 rguenther@suse.com
  - Explicitely build with -std=gnu++98.  [bnc#964458]
* Wed Feb 10 2016 alarrosa@suse.com
  - Added 0001-Fix-exclusion-of-anonymous-ciphers.patch from upstream
    to disable exp-adh and aecdh ciphers.
  - Added disable-rc4-ciphers-bnc865241.diff to disable <128 bits and
    RC4 based ciphers which are now considered insecure. This
    makes konqueror pass the https://www.howsmyssl.com test (bnc#865241)
* Thu May 28 2015 dmueller@suse.com
  - update to 4.8.7 (bsc#1039291):
    * see http://download.qt.io/official_releases/qt/4.8/4.8.7/changes-4.8.7
  - remove 0001-Don-t-crash-on-broken-GIF-images.patch,
    0001-Don-t-leak-RENDER-Pictures-in-QPixmap-paintEngine.patch,
    0001-Fix-DateTime-with-recent-versions-of-tzdata.patch,
    0001-Fix-crash-when-deleting-top-level-windows-embedded-i.patch,
    0001-Fixes-crash-in-gif-image-decoder.patch,
    0001-Ignore-expired-certificate-during-certificate-valida.patch,
    0001-Memory-and-file-descriptor-leak-in-QFontCache.patch,
    0001-QDbus-Fix-a-b-comparison.patch,
    0001-QDeclarativeTextEdit-fix-use-of-uninitialised-value.patch,
    0001-QPdf-addImage-avoid-a-QImage-detach-when-it-s-in-an-.patch,
    0001-QSslCertificate-blacklist-NIC-certificates-from-Indi.patch,
    0002-Fixes-crash-in-bmp-and-ico-image-decoding.patch,
    fix-a-division-by-zero.patch,
    fix-detection-of-GCC5.patch,
    fix-upload-corruptions-when-server-closes-connection.patch:
    * upstreamed
* Fri May 22 2015 tittiatcoke@gmail.com
  - Update patch fix-moc-from-choking-on-boost-headers.patch to
    include an additiona boost header due to the upgrade to
    Boost 1.58
* Thu May 07 2015 dmueller@suse.com
  - add 0001-Fixes-crash-in-gif-image-decoder.patch,
    0002-Fixes-crash-in-bmp-and-ico-image-decoding.patch
    (bnc#927806, bnc#927807, bnc#927808,
    CVE-2015-1858, CVE-2015-1859, CVE-2015-1860)
  - add 0001-Don-t-leak-RENDER-Pictures-in-QPixmap-paintEngine.patch
  - add 0001-Fix-DateTime-with-recent-versions-of-tzdata.patch
  - add 0001-Fix-crash-when-deleting-top-level-windows-embedded-i.patch
  - add 0001-Ignore-expired-certificate-during-certificate-valida.patch
  - add 0001-Memory-and-file-descriptor-leak-in-QFontCache.patch
  - add 0001-QDbus-Fix-a-b-comparison.patch
  - add 0001-QDeclarativeTextEdit-fix-use-of-uninitialised-value.patch
  - add 0001-QPdf-addImage-avoid-a-QImage-detach-when-it-s-in-an-.patch
  - add 0001-QSslCertificate-blacklist-NIC-certificates-from-Indi.patch
* Wed May 06 2015 hrvoje.senjan@gmail.com
  - Added fix-upload-corruptions-when-server-closes-connection.patch
    (boo#929688)
* Mon Mar 09 2015 hrvoje.senjan@gmail.com
  - Added fix-a-division-by-zero.patch (bnc#921999, CVE-2015-0295)
* Sun Feb 22 2015 hrvoje.senjan@gmail.com
  - Added fix-detection-of-GCC5.patch
* Wed Nov 19 2014 hrvoje.senjan@gmail.com
  - Update use-freetype-default.diff to use same method as with
    libqt5-qtbase package: Qt itself already does runtime check
    whether subpixel rendering is available, but only when
    FT_CONFIG_OPTION_SUBPIXEL_RENDERING is defined. Thus it is enough
    to only remove that condition
* Tue Nov 11 2014 alarrosa@suse.com
  - The -devel subpackage requires Mesa-devel, not only at build time
* Mon Nov 10 2014 alarrosa@suse.com
  - Fixed compilation on SLE_11_SP3 by making it build against
    Mesa-devel on that system

Files

/etc/rpm/macros.qt4
/usr/bin/qdbusviewer
/usr/bin/qmlplugindump
/usr/bin/qmlviewer
/usr/bin/qtconfig
/usr/lib64/libQtDeclarative.so.4
/usr/lib64/libQtDeclarative.so.4.8
/usr/lib64/libQtDeclarative.so.4.8.7
/usr/lib64/libQtDesigner.so.4
/usr/lib64/libQtDesigner.so.4.8
/usr/lib64/libQtDesigner.so.4.8.7
/usr/lib64/libQtDesignerComponents.so.4
/usr/lib64/libQtDesignerComponents.so.4.8
/usr/lib64/libQtDesignerComponents.so.4.8.7
/usr/lib64/libQtGui.so.4
/usr/lib64/libQtGui.so.4.8
/usr/lib64/libQtGui.so.4.8.7
/usr/lib64/libQtHelp.so.4
/usr/lib64/libQtHelp.so.4.8
/usr/lib64/libQtHelp.so.4.8.7
/usr/lib64/libQtMultimedia.so.4
/usr/lib64/libQtMultimedia.so.4.8
/usr/lib64/libQtMultimedia.so.4.8.7
/usr/lib64/libQtOpenGL.so.4
/usr/lib64/libQtOpenGL.so.4.8
/usr/lib64/libQtOpenGL.so.4.8.7
/usr/lib64/libQtScript.so.4
/usr/lib64/libQtScript.so.4.8
/usr/lib64/libQtScript.so.4.8.7
/usr/lib64/libQtScriptTools.so.4
/usr/lib64/libQtScriptTools.so.4.8
/usr/lib64/libQtScriptTools.so.4.8.7
/usr/lib64/libQtSvg.so.4
/usr/lib64/libQtSvg.so.4.8
/usr/lib64/libQtSvg.so.4.8.7
/usr/lib64/qt4/plugins/accessible
/usr/lib64/qt4/plugins/accessible/libqtaccessiblewidgets.so
/usr/lib64/qt4/plugins/bearer
/usr/lib64/qt4/plugins/bearer/libqconnmanbearer.so
/usr/lib64/qt4/plugins/bearer/libqgenericbearer.so
/usr/lib64/qt4/plugins/bearer/libqnmbearer.so
/usr/lib64/qt4/plugins/designer/libqdeclarativeview.so
/usr/lib64/qt4/plugins/graphicssystems
/usr/lib64/qt4/plugins/graphicssystems/libqglgraphicssystem.so
/usr/lib64/qt4/plugins/graphicssystems/libqtracegraphicssystem.so
/usr/lib64/qt4/plugins/iconengines
/usr/lib64/qt4/plugins/iconengines/libqsvgicon.so
/usr/lib64/qt4/plugins/imageformats
/usr/lib64/qt4/plugins/imageformats/libqgif.so
/usr/lib64/qt4/plugins/imageformats/libqico.so
/usr/lib64/qt4/plugins/imageformats/libqjpeg.so
/usr/lib64/qt4/plugins/imageformats/libqmng.so
/usr/lib64/qt4/plugins/imageformats/libqsvg.so
/usr/lib64/qt4/plugins/imageformats/libqtga.so
/usr/lib64/qt4/plugins/imageformats/libqtiff.so
/usr/lib64/qt4/plugins/imports
/usr/lib64/qt4/plugins/imports/Qt
/usr/lib64/qt4/plugins/imports/Qt/labs
/usr/lib64/qt4/plugins/imports/Qt/labs/folderlistmodel
/usr/lib64/qt4/plugins/imports/Qt/labs/folderlistmodel/libqmlfolderlistmodelplugin.so
/usr/lib64/qt4/plugins/imports/Qt/labs/folderlistmodel/qmldir
/usr/lib64/qt4/plugins/imports/Qt/labs/gestures
/usr/lib64/qt4/plugins/imports/Qt/labs/gestures/libqmlgesturesplugin.so
/usr/lib64/qt4/plugins/imports/Qt/labs/gestures/qmldir
/usr/lib64/qt4/plugins/imports/Qt/labs/particles
/usr/lib64/qt4/plugins/imports/Qt/labs/particles/libqmlparticlesplugin.so
/usr/lib64/qt4/plugins/imports/Qt/labs/particles/qmldir
/usr/lib64/qt4/plugins/imports/Qt/labs/shaders
/usr/lib64/qt4/plugins/imports/Qt/labs/shaders/libqmlshadersplugin.so
/usr/lib64/qt4/plugins/imports/Qt/labs/shaders/qmldir
/usr/lib64/qt4/plugins/inputmethods
/usr/lib64/qt4/plugins/inputmethods/libqimsw-multi.so
/usr/lib64/qt4/plugins/qmltooling
/usr/lib64/qt4/plugins/qmltooling/libqmldbg_inspector.so
/usr/lib64/qt4/plugins/qmltooling/libqmldbg_tcp.so
/usr/lib64/qt4/plugins/script/libqtscriptdbus.so
/usr/share/applications/qt4config.desktop
/usr/share/pixmaps/designer.png
/usr/share/qt4/phrasebooks
/usr/share/qt4/phrasebooks/danish.qph
/usr/share/qt4/phrasebooks/dutch.qph
/usr/share/qt4/phrasebooks/finnish.qph
/usr/share/qt4/phrasebooks/french.qph
/usr/share/qt4/phrasebooks/german.qph
/usr/share/qt4/phrasebooks/hungarian.qph
/usr/share/qt4/phrasebooks/italian.qph
/usr/share/qt4/phrasebooks/japanese.qph
/usr/share/qt4/phrasebooks/norwegian.qph
/usr/share/qt4/phrasebooks/polish.qph
/usr/share/qt4/phrasebooks/russian.qph
/usr/share/qt4/phrasebooks/spanish.qph
/usr/share/qt4/phrasebooks/swedish.qph
/usr/share/qt4/translations/qtconfig_eu.qm
/usr/share/qt4/translations/qtconfig_he.qm
/usr/share/qt4/translations/qtconfig_hu.qm
/usr/share/qt4/translations/qtconfig_ja.qm
/usr/share/qt4/translations/qtconfig_ko.qm
/usr/share/qt4/translations/qtconfig_pl.qm
/usr/share/qt4/translations/qtconfig_ru.qm
/usr/share/qt4/translations/qtconfig_sl.qm
/usr/share/qt4/translations/qtconfig_uk.qm
/usr/share/qt4/translations/qtconfig_zh_CN.qm
/usr/share/qt4/translations/qtconfig_zh_TW.qm


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Dec 1 23:07:19 2019